Subject: [nemo] IPv6 prefix delegation

From: "Pekka Pääkkönen" <[email-masked]>
Date: Tue, 29 Oct 2002 14:36:38 +0200

CN
                    |
               ---------------
             (  Internet    )--HA 
               ---------------
                   |
                  AR                           linkX/prefix X                 
                   |                        MR2-------------------MN2 
                   | link1/prefix1
                   | 
                  MR1               
                   |
                   | link2/prefix 2
                   |
                  MN1
                
Hi all.                               
Please consider the above picture. MR2 and MN2 on linkX want to establish a NEMO-network (consists of MR2 and MN2). 
It is assumed that MR2 needs to dynamically get a IPv6 prefix X for the NEMO, because the NEMO-network is created in an ad-hoc way.
When this new NEMO is created and attached to Internet via AR or MR1 the following questions arise: 

1.) Where will the IPv6 prefix for the NEMO be received from? From AR, HA or MR1 or some other network entity?

2.) What are the protocol requirements for IPv6 prefix delegation in a NEMO environment? 

3.) Do we need IPv6 prefix delegation for NEMO environment? The picture suggests yes, because no IPv6 prefix has been initially allocated for the NEMO.

Should these issues be concerned with in the requirements related to NEMO?

Pekka Pääkkönen

---

From: Alexandru Petrescu<[email-masked]>
Date: 29 Oct 2002 18:04:05 +0100

>                    CN

Good picture.

> Hi all.                               
> Please consider the above picture. MR2 and MN2 on linkX want to
> establish a NEMO-network (consists of MR2 and MN2).  It is assumed
> that MR2 needs to dynamically get a IPv6 prefix X for the NEMO,
> because the NEMO-network is created in an ad-hoc way.

That's a nice statement, but if it is done in an ad-hoc way, then I
believe it's a manet problem, not a NEMO problem.  I think we can see
it as a NEMO problem only if we want MN2 to get a new CoA once MR2 had
attached under MR1, but I thought this will not happen and MN2 will
not have to deal with any form of mobility (I assume that's why you
attached MN2 to MR2, presumably like an LFN).

> 1.) Where will the IPv6 prefix for the NEMO be received from? From
> AR, HA or MR1 or some other network entity?

So it's assumed that a mobile network will receive a new prefix
(instead of a CoA), let's say a CoP (Care-of Prefix) when it moves.
This might be very useful for RO.  This might be done with Router
Renumbering as well.  This might be done with other routing protocols
as well.

> 2.) What are the protocol requirements for IPv6 prefix delegation in

Off the top of my head: security requirements.

> 3.) Do we need IPv6 prefix delegation for NEMO environment? The
> picture suggests yes, because no IPv6 prefix has been initially
> allocated for the NEMO.

Initially, there's a prefix allocated to the mobile network when the
mobile network is at home.  Let's call it MNP (mobile network prefix).
The mobile network can continue to use this MNP wherever it moves, and
only the MR will obtain a CoA (not a CoP).  The MR maintains a
bidirectional tunnel with the HA through which all communication of
LFNs goes.  This has obvious inconvenients like multiple tunnels when
nested nets (for which RRH is a solution), or lack of RO with the CN
and so on.  These drawbacks should be described somewhere.  But
inspite of these obvious drawbacks it still offers a solution for
mobile networks, nested nets, with minimal modifications to Mobile
IPv6.  Looks like a good first step.

> Should these issues be concerned with in the requirements related to

I think yes, in the NEMO RO requirements case.

Alex

---

From: "JinHyeock Choi" <[email-masked]>
Date: Wed, 30 Oct 2002 20:28:09 +0900

Hi

> >                    |                        MR2-------------------MN2 

Yes. It's difficult for me to draw a picture for mailing list. 

> attached MN2 to MR2, presumably like an LFN).

I agree. MN2 even may not recognize that it has moved at all. 

> Renumbering as well.  This might be done with other routing protocols

In basic support, only Mobile Router have to receive CoA in foreign network. 
Mobile Network doesn't have to receive prefix (Care-of Prefix). But I agree 
that it will be useful for RO if Mobile Network get a CoP in foreign network.

> IPv6.  Looks like a good first step.

Exactly. MNP is configured to the ingress interface of MR and remains same
regardless of MR's movement. 

> I think yes, in the NEMO RO requirements case.

JinHyeock