Subject: RE: [nemo] IPv6 prefix delegation

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 28 Oct 2002 16:52:35 -0000

There are basically 3 ways for the HA to establish routes to the mobile
networks via the MR:

1) static model: routes are statically configured at the HA, and the
networks are pre-configured on the MR interfaces as well.

2) Dynamic model: A protocol is used by the MR to advertise its networks
to the HA so the HA does not need prior config. The protocol could be a
traditional IGP over the home tunnel, or a MIP extension such as
proposed by Thierry's draft.

3) Delegation - there we are -: The MR learns the prefixes on its
network from the HA. This could be done using DHCPv6 when it's an RFC,
or other (still debated at IPv6 without even MIP in the picture !!!)

Pascal

> -----Original Message-----
> From: Alexandru Petrescu [mailto:[email-masked]] 
> Sent: lundi 28 octobre 2002 15:50
> To: Brian Haberman
> Cc: [email-masked]
> Subject: Re: [nemo] IPv6 prefix delegation
> 
> 
> Brian Haberman <[email-masked]> writes:
> >       The original discussion of prefix delegation occurred on the 
> > IPv6 WG mailing list.  The zerouter BoF being held in 
> Atlanta is also 
> > going be interested in the subject.  I can see where NEMO 
> needs to be 
> > involved as well.
> 
> Brian, where does NEMO need to be involved with prefix delegation?
> 
> Thanks,
> 
> Alex
> 
>

---

From: Alexandru Petrescu<[email-masked]>
Date: 28 Oct 2002 18:00:27 +0100

> proposed by Thierry's draft.

2.5) Dynamic model with ICMP redirects instead of IGP.

> or other (still debated at IPv6 without even MIP in the picture !!!)

The MR learns its MNPs from the HA when MR is not at home, through the
MRHA tunnel?

I thought Brian was referring to MR learns new prefixes from the
visited network, something like Care-of Prefixes instead of CoA.
Which, in my very humble oppinion, is very much about RO?

Alex