Subject: [nemo] Some questions about the basic of NEMO ...

From: Patrick Lam <[email-masked]>
Date: Mon, 18 Jul 2005 10:22:11 -0700 (PDT)

Hi,

As I thought about NEMO more, more questions I have
... :)

1.  For the MNNs inside a MR, can they be NAT'ed?  Or
do they have to be addressed according to the MR's
prefix?
2.  Under the definition of NEMO, can a MNN be handed
off from one MR to another?  If so, the MNN will have
to have a globally unique IPv6 address (i.e., can't
use NAT), right?
3.  If the MNNs can be handed off from one MR to
another, it seems like they will have to be addressed
by a CoA as well, right?

Thanks very much in advance.

Regards,

Patrick

____________________________________________________
Start your day with Yahoo! - make it your home page 
http://www.yahoo.com/r/hs

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 18 Jul 2005 12:03:32 -0700

> do they have to be addressed according to the MR's

first of all, there is no NAT in IPv6.

> to have a globally unique IPv6 address (i.e., can't

the MNN will have a globally unique IPv6 address from
the mobile network prefix advertised by the mobile
router. it is possible that the mobile network prefix
is of the type described in
draft-ietf-ipv6-unique-local-addr-09.txt. in this case,
the MNN's IPv6 address will not be globally routable,
only inside the home network. this is not explicity
addressed in RFC 3963. as long the MNN stays put in
the mobile network, it will work.

> another, it seems like they will have to be addressed

yes.

Vijay

---

From: Patrick Lam <[email-masked]>
Date: Mon, 18 Jul 2005 18:56:51 -0700 (PDT)

Hi Vijay,

Thanks for your reply.  You are right that IPv6
doesn't have NAT.  I was thinking NAT64 when I was
typing, but I guess that won't be applicable to NEMO
scenarios ... or should it be?

Regarding MNN getting a CoA, I am just wondering the
following scenario.  

Say, a MNN is associated with MR1 at the home network
and moved together with MR1, then I guess it won't
need a CoA in this case (because MR1 is handling all
the handoff duties), right?  But then when it is
handed off to a new MR2, it will need to get a CoA.  

As a result, as long as the MNN is associated with an
appropriate MR (i.e., MR1), it will "feel" like at
home, no matter where MR1 is.  On the other hand,
whenever the MNN is not associated with the right MR
(say, moved to MR2), it will "feel" like at a foreign
network even MR2 is actually inside the home network
of the MNN.

It doesn't seem to be a correct interpretation.  Where
did I misunderstand?

Thanks again.

Regards,

Patrick

---

From: Ryuji Wakikawa <[email-masked]>
Date: Tue, 19 Jul 2005 11:04:30 +0900

Hello Patrick

Try to read  draft-ietf-nemo-home-network-models-03.
Similar scenario is described in Section8.

ryuji

On 2005/07/19, at 10:56, Patrick Lam wrote:

>>> As I thought about NEMO more, more questions I
>>>
>> have
>>
>>> ... :)
>>>
>>> 1.  For the MNNs inside a MR, can they be NAT'ed?
>>>
>> Or
>>
>>> 2.  Under the definition of NEMO, can a MNN be
>>>
>> handed
>>
>>> off from one MR to another?  If so, the MNN will
>>>
>> have
>>
>>> to have a globally unique IPv6 address (i.e.,
>>>
>> can't
>>
>>> use NAT), right?
>>>
>>
>>> another, it seems like they will have to be
>>>
>> addressed
>>
>>> by a CoA as well, right?
>>>
>>
>> yes.
>>
>> Vijay
>>
>>
>
>
>
>

---

From: Thierry Ernst <[email-masked]>
Date: Tue, 19 Jul 2005 15:28:49 +0900

Dear Patrick,

1st, I recommend to read draft-ietf-nemo-terminology where the terms VMN
and LFNs are defined. What you are talking about may be either a VMN or
a LFN or a VMN.

I would like to better understand your scenario: are MR1 and MR2 moving
together ? 

- If yes, MR1 and MR2 may form the same NEMO. Say it is the cruise ship 
"Norway". In such a case, you may deploy a HA inside the NEMO. A MNP is
advertised within the NEMO. Your MNN is a LMN, and it operates Mobile
IPv6, or another mobility protoco (e.g. a MANET protocol)l. If operating
Mobile IPv6, it has a HoA configured from the MNP advertised on the link
where it is attached to (i.e. where the HA is located). It can move
within the NEMO, and then would configure a CoA on another link inside
the NEMO. 

- if not, then MR1 and MR2 are 2 distincts NEMOs. Your MNN is a VMN, and
it is operating Mobile IPv6 to manage mobility from NEMO-MR1 to
NEMO-MR2.

Thierry

 On Mon, 18 Jul 2005 18:56:51 -0700 (PDT)

-- 
Thierry Ernst, PhD
WIDE, Jun Murai Lab., Keio University, Japan
Nautilus6 Chair: http://www.nautilus6.org
Web: http://www.sfc.wide.ad.jp/~ernst/
T:+81-44-580-1600 F:+81-44-580-1437
--

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 19 Jul 2005 12:17:20 +0200

Patrick Lam wrote:
> You are right that IPv6 doesn't have NAT.  I was thinking NAT64 when
> I was typing, but I guess that won't be applicable to NEMO scenarios
> ... or should it be?

What is NAT64?  Is it about draft-durand-ngtrans-dns-issues-00.txt of
2002?  As I read the abstract I deduce NAT64 is about transitioning and
DNS.  The NEMO base protocol does not deal at all with names, only with
addresses.

> Regarding MNN getting a CoA, I am just wondering the following 
> scenario.
> 
> Say, a MNN is associated with MR1 at the home network and moved 
> together with MR1, then I guess it won't need a CoA in this case 
> (because MR1 is handling all the handoff duties), right?

Yes.

> But then when it is handed off to a new MR2, it will need to get a 
> CoA.
> 
> As a result, as long as the MNN is associated with an appropriate MR 
> (i.e., MR1), it will "feel" like at home, no matter where MR1 is.

Yes.

> On the other hand, whenever the MNN is not associated with the right
>  MR (say, moved to MR2), it will "feel" like at a foreign network
> even MR2 is actually inside the home network of the MNN.

Yes.

> It doesn't seem to be a correct interpretation.  Where did I 
> misunderstand?

I don't think there's any misunderstanding above, all looks right to me.

Alex

>>> do they have to be addressed according to the MR's prefix?
>> 
>> the MNN will have a globally unique IPv6 address from the mobile 
>> network prefix advertised by the mobile router. it is possible that
>>  the mobile network prefix is of the type described in 
>> draft-ietf-ipv6-unique-local-addr-09.txt. in this case, the MNN's 
>> IPv6 address will not be globally routable, only inside the home 
>> network. this is not explicity addressed in RFC 3963. as long the 
>> MNN stays put in the mobile network, it will work.
>> 
>> 
>>> 3.  If the MNNs can be handed off from one MR to another, it 
>>> seems like they will have to be
>> 
>> addressed
>> 
>>> by a CoA as well, right?
>> 
>> yes.
>> 
>> Vijay
>> 
> 
> 
> 
> 
> ____________________________________________________ Start your day 
> with Yahoo! - make it your home page http://www.yahoo.com/r/hs
>

---

From: Patrick Lam <[email-masked]>
Date: Tue, 19 Jul 2005 09:39:00 -0700 (PDT)

Hi Thierry,

Thanks for your reply.  You have actually triggered me
to think a little more about my question.... :)

I did not even think about whether MR1 and MR2 are
moving together.  To make it simpler, let's assume
they are not moving together, and have different MNPs
(belong to different networks).

I think what I meant was, based on the terms given in
draft-ietf-nemo-terminology, when a LMN (denoted by
MNN1) of MR1  moves to MR2 (and the MNN1 now becomes a
VMN of MR2), but then MR2 moves to the home link of
MNN1 (MR2 will therefore be a VMN of the home link I
guess) together with all its VMNs including MNN1.

Now, MNN1 is physically inside the home link. 
However, it is "feeling" like "visiting" because it is
currently the VMN of MR2.

It seems to me that, this scenario is causing some
extra tunneling overhead between the home link
(represented by the HA) and MNN1.  But then I guess
the extra tunneling is inevitable?

Regards,

Patrick

--- Thierry Ernst <[email-masked]> wrote:

> > > draft-ietf-ipv6-unique-local-addr-09.txt. in
> this
> > > case,

---

From: Thierry Ernst <[email-masked]>
Date: Wed, 20 Jul 2005 14:56:55 +0900

hi Patrick,

> guess) together with all its VMNs including MNN1.

Correct, from a terminology point of view.

> currently the VMN of MR2.

MNN1 is topologicaly located on a different link and is therefore using
a tunnel between the HA on its home link behind MR1. MNP1 and MNP2 may
be from very distant part of the Internet topology. So, it's normal to
consider it is vitising, so "feeling" the mobility is the right thing to
do from a topological point of view.

> the extra tunneling is inevitable?

Yes, it does cause some overhead, but no, it's not inevitable. The
current standards do not avoid the tunneling overhead, but this why the
NEMO WG has publised the NEMO RO Problem Statement draft:
http://www.ietf.org/internet-drafts/draft-ietf-nemo-ro-problem-statement-00.txt

Thierry