Subject: RE: [nemo] status of draft-ietf-nemo-dhcpv6-pd-01.txt

From: "Tsirtsis, George" <[email-masked]>
Date: Mon, 13 Nov 2006 10:10:13 -0800

Thanks Vijay,

I also have the following question. The draft allows a MIPv6 home agent
to act as a DHCPv6 relay agent for the mobile node so that the node can
get IPv6 prefixes from the DHCPv6 server at home.

The draft does not seem to place any requirements on MIPv6/NEMO with
respect to the prefixes allocated via this mechanism. Is the mobile
supposed to register the prefixes using NEMO explicit registration
support or is it assumed that implicit registration is used in this
case?

George

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]]
> Sent: Monday, November 13, 2006 11:47 AM
> To: Tsirtsis, George
> Cc: [email-masked]
> Subject: Re: [nemo] status of draft-ietf-nemo-dhcpv6-pd-01.txt
> 
> it is supposed to go for a WG last call soon.
> it has been stable for a while.
> 
> Vijay
> 
> Tsirtsis, George wrote:
> > Hi everyone,
> >
> > Could someone let me know what the status of
> > draft-ietf-nemo-dhcpv6-pd-01.txt is? Was it discussed during the
IETF
> > meeting last week?
> > Thanks
> > George

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 13 Nov 2006 18:24:43 -0800

> support or is it assumed that implicit registration is used in this

the implicit/explicit mode is independent of how
the mobile router gets the prefixes. the mobile
router and the home agent need to know before the
BU is sent, whether the mobile router is using
the implicit or explicit mode.

if the MR gets more than prefix through
DHCPv6-based prefix delegation and sends a BU in
the implicit mode, the home agent sets up
forwarding for all prefixes. if explicit mode is
used, forwarding is setup for only the prefixes
that appear in the BU.

Vijay