Subject: RE: Q: No max/ minMax length of anything?

From: "Sharon Chisholm" <[email-masked]>
Date: Fri, 13 Jan 2006 08:21:40 -0500

-----Original Message-----
From: Andy Bierman [mailto:[email-masked]] 
Sent: Thursday, January 12, 2006 4:51 PM
To: Chisholm, Sharon [CAR:ZZ00:EXCH]
Cc: Netconf (E-mail)
Subject: Re: Q: No max/ minMax length of anything?
hi

<Andy>
We decided (and nobody objected) that the message-id attribute is 
maxLength="4095".
Other than that, all data types are constrained AFAIK.  We don't control

the URL limits.
</Andy>

Did we? It isn't in -10

<xs:attribute name="message-id" type="xs:string" use="required"/>

Sharon

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Rob Enns" <[email-masked]>
Date: Fri, 13 Jan 2006 11:31:56 -0800

> <xs:attribute name="message-id" type="xs:string" use="required"/>

It will be in -11 (hey, NETCONF goes to 11!)

  <!--
    message-id attribute
    -->
  <xs:simpleType name="messageIdType">
    <xs:restriction base="xs:string">
      <xs:maxLength value="4095"/>
    </xs:restriction>
  </xs:simpleType>

Rob