Subject: how people implement <filter> in netconf over SOAP?

From: Zihong Lu <[email-masked]>
Date: Fri, 27 Jan 2006 11:07:12 -0800

> I am looking into the implementation detail of netconf over SOAP.  Wonder
> how people implement <filter> in SOAP.  Can any one please shed some
> light?  
> 
> 
> In general, SOAP is a service function based protocol.  It should be
> possible to be message-based, but it will not be as easy to implement, and
> the SOAP benefit will mostly be lost.  For example, the <get-config> part,
> we have a message looks like this:
> 
> <soapenc:Body>
>   <rpc>
>       <get-config>
>            <fource/>
>                <filter>
>                    <users/>
>                </filter>
>        </get-config>
>   </rpc>
> </soapenc:Body>
> 
> 
> Currently, most SOAP toolkit will automatically convert this message to a
> function call 
> 
>    RpcReply rpc(GetConfig g);
> 
> When it gets to the filter part, you are on your own, since the netconf
> schema passes in the <anyType> under the filter.  The agent code will have
> to parse the xml document! 
> 
> If there is such a netconf module (toolkit) that can be put behind SOAP
> toolkits like gSoap, or Axis for Java, etc, which converts the
> <get-config> part (or GetConfig object, returned from normal SOAP toolkit)
> into a function for getting the detail data, so that all agent codes need
> to to is to provide functions like
> 
>   RpcReply  GetConfigFilter(TargetData d, Source s);
>   RpcReply EditConfig( ... );
> 
> it will become much easier to implement in SOAP paradigm.  Not sure if
> this kind of netconf toolkit exists.
> 
> 
> -Zihong
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "王罕" <[email-masked]>
Date: Mon, 30 Jan 2006 14:58:02 +0800

I guess it should be the vedors' job.

�����������������ᵽ:
>From: Zihong Lu <[email-masked]>
>Reply-To: 
>To: "[email-masked]'" <[email-masked]>
>Subject: how people implement <filter> in netconf over SOAP?
>Date:Fri, 27 Jan 2006 11:07:12 -0800
>
>
> 
>