Subject: kill-session schema

From: Martin Bjorklund <[email-masked]>
Date: Wed, 18 Jan 2006 20:30:53 +0100 (CET)

Hi,

The parameter session-id to kill-session is defined as:

             <xs:element name="session-id"
                         type="SessionId" minOccurs="0"/>

Should this parameter really be optional?  Since you're not allowed to
your own session, this seems strange.

/martin

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Wed, 18 Jan 2006 20:38:52 -0800

>your own session, this seems strange.

This is a bug in the schema. It should be minOccurs="1".
The normative text in sec. 7.9 does not say
this is optional, so that means it is mandatory.

>/martin

Andy