Subject: every message only can have one operation?

From: "王罕" <[email-masked]>
Date: Thu, 19 Jan 2006 11:03:25 +0800

dear all:

   how many operations can be assembled in the same message? I read the netconf
propose, and I find every message have only one operation in itself.

   can I generate such a message:
<rpc message-id="101"
          xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">
       <get-config>             //the 1th operation get
         <source>
           <running/>
         </source>
       </get-config>
       <copy-config>          // the 2th operation copy
         <source>
           <url>https://[email-masked]:passphrase/cfg/new.txt</url>
         </source>
         <target>
           <running/>
         </target>
       </copy-config>
     </rpc>

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Wed, 18 Jan 2006 20:32:45 -0800

>           <url>https://[email-masked]:passphrase/cfg/new.txt</url>

no -- only 1 RPC method per <rpc> request is allowed

Andy