Subject: Re: [Netconf] continue-on-error

From: Andy Bierman <[email-masked]>
Date: Fri, 24 Oct 2008 08:35:04 -0700

Johan Rydberg wrote:
> 
>> The original intent was to support the 'load startup config'
>> operation found in CLI.  Config file commands that cause errors
>> don't automatically crash a router.  This is not always the
>> case in other applications, such as Apache -- if httpd.conf
>> has unknown or invalid commands the WEB server will not start.
> 
> I'm trying to implement c-o-e for general use throughout our
> agent.  Currently we're modeling the "load config" operation
> as an editing operation on the current configuration, with
> the new configuration as source.  In other words, we do inline
> editing to the existing configuration tree while we're applying
> the new configuration.  The reason behind this is that you can
> in case of error do a simple rollback by re-applying the old
> configuration to the somewhat edited tree.
> 
> The problem is what to do when you want to continue on an error.
> 
> Is it OK to leave the edited configuration in state where it
> does not validate?  Must the running configuration always
> be valid according to the schema?
> 

yes -- it makes implementation much harder if you leave
known-to-be-bad subtrees in the config.

> As example, say that the agent fails to remove an leaf from
> a list entry, when it tries to remove the list entry.  Should
> the list entry be left in place with the failing leaf, possible
> without key leafs.  Or should the list entry be removed in
> either case?
> 

Good question.
Short answer: it depends on the data model.
If you are trying to automate the operations in the central stack,
then it is difficult to use a generalized algorithm.

Even if you let the error ripple up to the root
(top-level ancestor in the same namespace), you can
still leave the config invalid due to 'must' restrictions
that reference the sub-tree you just deleted.

> ~jr

Andy

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Andy Bierman <[email-masked]>
Date: Fri, 24 Oct 2008 08:35:04 -0700

Good question.

Andy