Subject: [Netconf] [partial-lock] privilege of partial-lock

From: fanhuaxiang 90002624 <[email-masked]>
Date: Tue, 14 Oct 2008 12:52:10 +0800

Hi,
   partial-lock only allow a user on a session to operate in the same time, how about the same user with many sessions?
   since the scope of patial-lock cover some nodes and their subnodes, how about I lock and delete one node, and another people add it. the spec allow this to happen, does it lead to inconsistency?

Regards,
Washam
******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained here in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this email in error, please notify the sender by phone or email immediately and delete it!
 *****************************************************************************************
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Balazs Lengyel <[email-masked]>
Date: Wed, 15 Oct 2008 17:15:46 +0200

Hello Washam,
I am not sure I understood your question correctly, but still see my reply below:
regards Balazs

>    partial-lock only allow a user on a session to operate in the same time, how about the same user with many sessions?
BALAZS: A user can have multiple sessions, but partial-locks are connected to one specific 
session, the same way as global (RFC4741) locks. We wanted to follow the design of the global 
locks. Also this ensures that a lock is always released when a session terminates. If we 
connected the lock to a user, it would be harder to ensure that the lock is always released 
correctly, that a lock doesn't stay hanging.
>    since the scope of patial-lock cover some nodes and their subnodes, how about I lock and delete one node, and 
another people add it. the spec allow this to happen, does it lead to inconsistency?
BAFrom [email-masked]  Wed Oct 15 08:15:08 2008
Date: Wed, 15 Oct 2008 17:15:46 +0200
From: Balazs Lengyel <[email-masked]>
To: fanhuaxiang 90002624 <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netconf] [partial-lock] privilege of partial-lock
Sender: [email-masked]

Hello Washam,
I am not sure I understood your question correctly, but still see my reply below:
regards Balazs

>    partial-lock only allow a user on a session to operate in the same time, how about the same user with many sessions?
BALAZS: A user can have multiple sessions, but partial-locks are connected to one specific 
session, the same way as global (RFC4741) locks. We wanted to follow the design of the global 
locks. Also this ensures that a lock is always released when a session terminates. If we 
connected the lock to a user, it would be harder to ensure that the lock is always released 
correctly, that a lock doesn't stay hanging.
>    since the scope of patial-lock cover some nodes and their subnodes, how about I lock and delete one node, and 
another people add it. the spec allow this to happen, does it lead to inconsistenLAZS: Yes this can happen, and no we don't consider this as inconsistent. As described in the 
draft the user should lock the parent node of the object he wants to delete/create to avoid the 
situation you mention.
We could have allowed locking not existing nodes, however that is also a somewhat surprising 
behavior.

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

cy?
BALAZS: Yes this can happen, and no we don't consider this as inconsistent. As described in the 
draft the user should lock the parent node of the object he wants to delete/create to avoid the 
situation you mention.
We could have allowed locking not existing nodes, however that is also a somewhat surprising 
behavior.

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf