Subject: [Netconf] Draft Agenda for IETF #73 NETCONF Session

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 27 Oct 2008 21:49:37 +0100

> Dear NETCONF WG, 
> below is the draft agenda for the NETCONF WG session 
at the IETF #73. Our session will be on Monday after 
the afternoon beverage and snack break II at 1740-1930.
> Please send us your comments and requests concerning 
the agenda. Our main focus in the session will be as usual 
on open issue discussion but we have a few additional 
topics this time.
> We need to summarize the 4741bis relevant issues as 
starter for discussion. Please let us know if there is 
anybody who wants to jump in for this. 
> BTW: We need to organize the scribes and minute takers 
> before the meeting. Please help us to start the session 
> timely and send us a note if you volunteer. 
> Bert & Mehmet 
> ________________________________________From [email-masked]  Mon Oct 27 13:50:09 2008
Content-class: urn:content-classes:message
Date: Mon, 27 Oct 2008 21:49:37 +0100
From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
To: <[email-masked]>
Subject: [Netconf] Draft Agenda for IETF #73 NETCONF Session
Sender: [email-masked]

> Dear NETCONF WG, 
> below is the draft agenda for the NETCONF WG session 
at the IETF #73. Our session will be on Monday after 
the afternoon beverage and snack break II at 1740-1930.
> Please send us your comments and requests concerning 
the agenda. Our main focus in the session will be as usual 
on open issue discussion but we have a few additional 
topics this time.
> We need to summarize the 4741bis relevant issues as 
starter for discussion. Please let us know if there is 
anybody who wants to jump in for this. 
> BTW: We need to organize the scribes and minute takers 
> before the meeting. Please help us to start the session 
> timely and send us a note if you volunteer. 
> Bert & Mehmet 
> _____________________________________________ _____ 
> NETCONF WG 
> IETF 73, Minneapolis, MN, USA
> 
> MONDAY, November 17, 2008, 1740-1950 
> 
>    WG Chairs:
>    Bert Wijnen <[email-masked]>
>    Mehmet Ersue <[email-masked]>
> 
>    Scribes (IF no_volunteers THEN wait_forever) 
>    Agenda bashing (2 minutes) 
>    WG status review (5 minutes) 
> 
>    Charter items:
> 
>       1. NETCONF Monitoring Schema - Mark Scott (20 minutes)  
>           draft-ietf-netconf-monitoring
>       2. Partial Lock RPC for NETCONF - Balazs Lengyel (10 minutes) 
>          draft-ietf-netconf-partial-lock 
>       3. NETCONF over TLS - Mohamad Badra (5 minutes)
>          draft-ietf-netconf-monitoring
> 
>    Not-chartered document(s): 
> 
>       1. New charter text for Notification Content - Bert Wijnen (15
> minutes)
> 
>       2. Issues for 4741bis-draft - ?? (30 minutes)
> 
>    Open mike (15 minutes)
>       Any other topics to discuss? 
> 
>    AOB (5 minutes)
> 
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

> NETCONF WG 
> IETF 73, Minneapolis, MN, USA
> 
> MONDAY, November 17, 2008, 1740-1950 
> 
>    WG Chairs:
>    Bert Wijnen <[email-masked]>
>    Mehmet Ersue <[email-masked]>
> 
>    Scribes (IF no_volunteers THEN wait_forever) 
>    Agenda bashing (2 minutes) 
>    WG status review (5 minutes) 
> 
>    Charter items:
> 
>       1. NETCONF Monitoring Schema - Mark Scott (20 minutes)  
>           draft-ietf-netconf-monitoring
>       2. Partial Lock RPC for NETCONF - Balazs Lengyel (10 minutes) 
>          draft-ietf-netconf-partial-lock 
>       3. NETCONF over TLS - Mohamad Badra (5 minutes)
>          draft-ietf-netconf-monitoring
> 
>    Not-chartered document(s): 
> 
>       1. New charter text for Notification Content - Bert Wijnen (15
> minutes)
> 
>       2. Issues for 4741bis-draft - ?? (30 minutes)
> 
>    Open mike (15 minutes)
>       Any other topics to discuss? 
> 
>    AOB (5 minutes)
> 
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 28 Oct 2008 11:10:08 +0100

Hello Mehmet, Bert,
I would like to have our with-defaults draft on the agenda as a proposed new work item for the WG.

http://tools.ietf.org/html/draft-bierman-netconf-with-defaults-01

Balazs

Ersue, Mehmet (NSN - DE/Munich) wrote:
>> BTW: WeFrom [email-masked]  Tue Oct 28 03:11:59 2008
Date: Tue, 28 Oct 2008 11:10:08 +0100
From: Balazs Lengyel <[email-masked]>
To: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>, 
	Bert Wijnen - IETF <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netconf] Draft Agenda for IETF #73 NETCONF Session
Sender: [email-masked]

Hello Mehmet, Bert,
I would like to have our with-defaults draft on the agenda as a proposed new work item for the WG.

http://tools.ietf.org/html/draft-bierman-netconf-with-defaults-01

Balazs

Ersue, Mehmet (NSN - DE/Munich) wrote:
>> B need to organize the scribes and minute takers 
>> _____________________________________________ 
>> NETCONF WG 

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

TW: We need to organize the scribes and minute takers 
>> _____________________________________________ 
>> NETCONF WG 

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 28 Oct 2008 12:02:27 +0100

Hello Johan,
Because the NETCONF XSD allows any attribute on the RPC, but not on the operation.  On the 
other hand I would agree with you that it would be more logical on the 
get/get-congig/copy-config operation.

Anyway once we get the draft into the workgroup we can debate and change this if needed.
Balazs

Johan Rydberg wrote:
> Balazs Lengyel skrev:
> May I ask why the attribute is on the <rpc> element and not on the
> operation element (get, copy-config, ..) ?  It seems that it is an
> attribute to the protocol and not to the transport/rpc layer.
>

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 28 Oct 2008 12:02:27 +0100

Hello Johan,

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 28 Oct 2008 13:29:13 +0100

Hi Balazs,

we need for sure a discussion on this. How much time 
do you need for discussion?

Does this going to become a part of 4741bis or do you 
see it rather as a standalone RFC?

Cheers, 
Mehmet

> -----Original Message-----
> From: ext Balazs Lengyel [mailto:[email-masked]] 
> Sent: Tuesday, October 28, 2008 11:10 AM
> To: Ersue, Mehmet (NSN - DE/Munich); Bert Wijnen - IETF
> Cc: [email-masked]

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 28 Oct 2008 13:29:13 +0100

Hi Balazs,

Cheers, 
Mehmet

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 28 Oct 2008 14:27:54 +0100

Hello Mehmet,
I would rather see it as a standalone that can later be folded into a 4741bis. Putting it into 
the bis right now might delay it for too long. I think this is urgent stuff.

I think 20 minutes would be good: My presentation would be something like:

- What is the problem?
- 3 ways of handling defaults
- Why is this needed for interoperability? Because it effects ...
- Solution basics
- Open issues
	need to force suppressing defaults
	need to force presenting defaults
	need to advertise default handling
	encoding issues

Balazs

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 28 Oct 2008 14:27:54 +0100

Hello Mehmet,

- What is the problem?

Balazs

---

From: Johan Rydberg <[email-masked]>
Date: Tue, 28 Oct 2008 11:54:06 +0100

---

From: Johan Rydberg <[email-masked]>
Date: Tue, 28 Oct 2008 11:54:06 +0100