Subject: Re: [Netconf] Reeminder: Action required before May 5th 2010: WG LAST ***CALL for draft-ietf-netconf-with-defaults-07.txt

From: Phil Shafer <[email-masked]>
Date: Wed, 5 May 2010 10:51:58 -0400

Andy Bierman writes:
>We have no requirement to maintain backward compatibility
>with RFC 4741.  We are cycling at Proposed Standard.

I don't think so.  The WG charter limits changes to bug fixes and
clarifications.  See attached.

Thanks,
 Phil

----

https://datatracker.ietf.org/wg/netconf/charter/

6. NETCONF implementations have shown that the specification in
RFC4741 is not 100% clear and has lead to different interpretations
and implementations.  Also some errors have been uncovered. So the
WG will do an rfc4741bis with following constraints:

- bug fixes are to be done
- clarifications can be done
- extensions can be done only when needed to fix bugs
or inconsistencies (i.e. we are not doing a NETCONF V2)
- The work can be started based on the discussion in IETF #73 (see
http://www.ietf.org/proceedings/08nov/slides/netconf-3.pdf).

---

From: Andy Bierman <[email-masked]>
Date: Wed, 05 May 2010 08:14:01 -0700

> clarifications.  See attached.

That is what we are doing.
All of the changes have been bug fixes.
Even the new confirmed-commit stuff is to address
problems with the existing operation.

This is irrelevant to the standards process in RFC 2026.
We already decided to cycle at PS.  RFC 2026 does not require
this type of update to be backward compatible.

>  Phil

Andy

---

From: Phil Shafer <[email-masked]>
Date: Wed, 5 May 2010 10:58:45 -0400

>All of the changes have been bug fixes.

I don't think "with-defaults" fits this charter.

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Wed, 05 May 2010 08:22:17 -0700

> I don't think "with-defaults" fits this charter.

But this document has a different charter.
IMO, starting over on with-defaults is a non-starter.
That draft has been reviewed by many people, up to 8 times already.
It is an insult to these reviewers, not to mention a complete
disregard for the schedule (and way overdue milestones),
to start over on this work.

Andy

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 05 May 2010 17:42:37 +0200

> to start over on this work.

I believe that integrating with-defaults into 4741bis does not mean
starting over and that the authors' and reviewers' work won't be lost at
all. The eight iterations helped improve the text and the whole concept
considerably.

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Wed, 05 May 2010 08:57:14 -0700

> all. The eight iterations helped improve the text and the whole concept

I think it does mean starting over.
It means rechartering 4741bis, which is a bad idea.
It means taking even longer to finish work that is already late.

I don't see the problem.
The with-defaults draft provides additional functionality
to the base protocol -- the ability to detect the defaults
behavior of the server and the ability to retrieve data
using a specific style.

Normally (90% ?) the YANG or XSD schema will provide
the defaults so the operator can just 'trust' the server basic mode.
(Just use explicit -- it works ;-)

When an operator is debugging a server that is not behaving
as expected, or when installing a new SW version from a vendor who
has been known to change defaults in the past, it is useful
to verify the defaults are in fact implemented correctly.
When YANG deviations and import-by-revision become factors,
retrieving 'report-all' can be even more important for
debugging purposes.

Whether this is critical, useful, nice-to-have, or useless
is a subjective decision.  Packaging technical specifications
in multiple RFCs is a reality in the IETF.  Some people even prefer
multiple documents over 1 giant document.

Andy