Subject: Re: [Netconf] WG Last Call on one more change to RFC4742bis

From: Phil Shafer <[email-masked]>
Date: Wed, 1 Dec 2010 07:50:57 -0500

Martin Bjorklund writes:
>>      C:
>>      C: #271
>>      C: <?xml version="1.0" encoding="UTF-8"?>
>Yes this is correct.

I find the leading LF somewhat odd.  Should we consider changing
this to be:

       chunk           = "#" chunk-size LF chunk-data LF

Not a big dea, but....

Thanks,
 Phil

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 1 Dec 2010 15:11:53 +0100

>        chunk           = "#" chunk-size LF chunk-data LF

I prefer if the # mark is always in column 0. Since there is no need
to end the XML with a LF (or is there?), there does not need to be an
empty line.

/js

PS: I think we are taking the examples too literally.

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Phil Shafer <[email-masked]>
Date: Wed, 1 Dec 2010 10:34:40 -0500

>to end the XML with a LF (or is there?), there does not need to be an

My suggestion does not alter "# mark is always in column 0".  I'm
suggesting moving the LF from the start to the end of the production:

                    vv---- Move this LF  ...
- chunk           = LF "#" chunk-size LF chunk-data
+ chunk           = "#" chunk-size LF chunk-data LF
                     ... to the end over here ---^^

In both rules, the "#" will always be in column 0.  The only real
difference is that the first message starts with a "#" not with a
LF.

old:   LF # len LF msg LF # len LF msg LF # len LF msg LF # len LF msg ...
new:   # len LF msg LF # len LF msg LF # len LF msg LF # len LF msg LF ...

So the message sending code will change like:

-    printf("\n#%u\n%s", strlen(msg), msg);
+    printf("#%u\n%s\n", strlen(msg), msg);

IMHO this is cleaner (trailing LF is more normal than a leading
one) and makes the initial message (which we'll have in our examples)
less odd.

>PS: I think we are taking the examples too literally.

If the examples are not literally correct, then they are broken
and will mislead implementors.

Thanks,
 Phil

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 01 Dec 2010 17:39:24 +0100 (CET)

Hi,

Phil Shafer <[email-masked]> wrote:
> My suggestion does not alter "# mark is always in column 0".

But it does.  Consider the hello + first rpc from the client:

   C: <?xml version="1.0" encoding="UTF-8"?>
   C: <hello xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">
   C:   <capabilities>
   C:     <capability>
   C:       urn:ietf:params:xml:ns:netconf:base:1.0
   C:     </capability>
   C:   </capabilities>
   C: </hello>
   C: ]]>]]>
   C: #271
   C: <?xml version="1.0" encoding="UTF-8"?>
   C: <rpc message-id="105"
   C:      xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">
   C:   <get-config>
   ...

The client sends ]]>]]>, and that marks the end of the hello msg.  If
the LF is not present before the first chunk we would get

   ...
   C: </hello>
   C: ]]>]]>#271
   ...

since the sequence is "]]>]]>", not "]]>]]>\n".

Same issue after each message, since an XML message doesn't have to
end with a LF.

> and will mislead implementors.

Then we'd have to say that in the examples each line is ended with a
single LF, except the line with ]]>]]>.

/martin

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 1 Dec 2010 17:54:04 +0100

> difference is that the first message starts with a "#" not with a

Sorry, now I understand. I fully agree.
 
> and will mislead implementors.

My fear is that people will believe there must be an empty line
between the closing XML tag and the # mark while this is really just
an artefact of translating the whitespace literally. I would rather
remove the empty lines (and maybe add a clarifying sentence that the
translation is not necessaryly preserving all whitespace).

/js

---

From: Andy Bierman <[email-masked]>
Date: Wed, 1 Dec 2010 09:03:17 -0800

Hi,

It is very important to get the examples correct.
People read the normative text, but check their code against
the examples. I agree with Martin that a sentence explaining
the newline details would help.  The examples should be exactly
correct -- not altered in any way for readability or RFC Editor
formatting.

Andy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Wednesday, December 01, 2010 8:54 AM
To: Phil Shafer
Cc: [email-masked]
Subject: Re: [Netconf] WG Last Call on one more change to RFC4742bis

 

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Phil Shafer <[email-masked]>
Date: Wed, 1 Dec 2010 11:49:58 -0500

>But it does.  Consider the hello + first rpc from the client:

Rats.  Hadn't thought about the hello.  Could you please add text
to explain this, since the normal reader (me ;^) will miss it
completely?  I guess adding a special LF for the first message would
not be slick.

Thanks,
 Phil

---

From: Kent Watsen <[email-masked]>
Date: Wed, 1 Dec 2010 09:32:27 -0800

If we move the LF to the end of "chunk", should we also remove the LF at the beginning of "end-of-chunks", so that there won't be a blank/empty line before the "##"?

Regarding Martin's concern for "]]>]]>#271", I don't think it's a problem, being a streaming protocol, but we could let an LF show up at the beginning of a chunked message:

  Chunked-Message = 0*1LF 1*chunk end-of-chunks

Though as Phil points out, this wouldn't be slick...

Thanks,
Kent

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Phil Shafer
Sent: Wednesday, December 01, 2010 10:35 AM
To: Juergen Schoenwaelder
Cc: [email-masked]
Subject: Re: [Netconf] WG Last Call on one more change to RFC4742bis

                    vv---- Move this LF  ...

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Wed, 1 Dec 2010 09:35:32 -0800

Hi,

I prefer a deterministic algorithm.
Letting the sender choose multiple forms is not a feature.
IMO, a line that starts with a NL is not a bug.
Let's not solve a non-problem by introducing flexibility.

Andy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Kent Watsen
Sent: Wednesday, December 01, 2010 9:32 AM
To: Phil Shafer; Juergen Schoenwaelder
Cc: [email-masked]
Subject: Re: [Netconf] WG Last Call on one more change to RFC4742bis

Thanks,
Kent

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Phil Shafer
Sent: Wednesday, December 01, 2010 10:35 AM
To: Juergen Schoenwaelder
Cc: [email-masked]
Subject: Re: [Netconf] WG Last Call on one more change to RFC4742bis

                    vv---- Move this LF  ...

Thanks,
 Phil

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 1 Dec 2010 23:58:23 +0100

> correct -- not altered in any way for readability or RFC Editor

He? I want them correct, but not misguiding.

/js

---

From: Andy Bierman <[email-masked]>
Date: Wed, 1 Dec 2010 23:52:39 -0800

We all want them correct and not misguiding.
Some note is needed so it is obvious why 1 example looks
different than the rest.

IMO, this document needs another WGLC.
I think we should all re-read the entire 4742bis (and 4741bis
related sections) to make sure we didn't break anything
at the last minute.  Sort of a regression test for an I-D.

Andy

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Wednesday, December 01, 2010 2:58 PM
To: Andy Bierman
Cc: Phil Shafer; [email-masked]
Subject: Re: [Netconf] WG Last Call on one more change to RFC4742bis

/js