Subject: Re: [Netconf] list of 4741bis edits

From: "Bert (IETF) Wijnen" <[email-masked]>
Date: Wed, 15 Dec 2010 10:17:06 +0100

We have seen (during the rfc4742bis discussion) some remarks about this
piece of text in RFC4741bis:

    All NETCONF messages MUST be well-formed XML, encoded in
UTF-8. If a peer receives a message that is not well-formedXML,
    it MUST reply with an 'operation-failed' error.

We (still) believe this is what we have consensus for. This text is stronger now
that we have proper framing, since valid messages that contain the
]]>]]> can no longer be chopped and end up as invalid.

Does anybody have strong objections to leaving that as is?

Thanks,
Bert and Mehmet

---

From: Andy Bierman <[email-masked]>
Date: Wed, 15 Dec 2010 08:48:59 -0800

Hi,

I object to the 'MUST send an <rpc-error>' text.
It needs to be spelled out that:
   - the server may not have the <rpc> start tag available
     so the <rpc-reply> may not have the original <rpc> attributes,
     including message-id
   - the client is assumed to be expecting an <rpc-reply> but this is not
     true if the message was a data injection attack
   - the client may not be able to do anything useful with an <rpc-reply>
     with no message-id
   - if the malformed XML is due to the client or server dropping the TCP
     connection, then the server cannot send an <rpc-reply>
   - there is no requirement that a server parse XML tags in sequence
     or that each XML tag be made available to the operations layer.
     A server may implement a DOM design.  In either case, the server will
     get valid XML or get nothing from the XML parser (e.g., libxml2 EOF)
   - if the server does not have the message-id available, then MUST send is not
     appropriate, since the client cannot reliably correlate the reply with a request.

Andy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bert (IETF) Wijnen
Sent: Wednesday, December 15, 2010 1:17 AM
To: netconf
Subject: Re: [Netconf] list of 4741bis edits

Thanks,
Bert and Mehmet

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf