Subject: [Netconf] list of 4741bis edits

From: Martin Bjorklund <[email-masked]>
Date: Fri, 10 Dec 2010 14:40:16 +0100 (CET)

Hi,

As requested by the chairs, this is a list of proposed edits for
4741bis.  There are a few editorial changes, and two technical
changes.  One is a fix for the XML Schema bug reported by Kent, and
one is a fix for the 'data' response element in the YANG module.

/martin

Section 4.2., paragraph 1:
OLD:

    The <rpc-reply> message is sent in response to an <rpc> operation.

NEW:

    The <rpc-reply> message is sent in response to an <rpc> message.

Section 7.5., paragraph 6:
OLD:

       A lock MUST not be granted if either of the following conditions
       is true:

NEW:

       A lock MUST NOT be granted if either of the following conditions
       is true:

Appendix B., paragraph 4:
OLD:

          This schema defines the syntax for the NETCONF Message layer

NEW:

          This schema defines the syntax for the NETCONF Messages layer

Appendix B., paragraph 6:
OLD:

      <xs:complexType name="rpcReplyType">
        <xs:choice>
          <xs:element name="ok"/>
          <xs:group ref="rpcResponse"/>
        </xs:choice>
        <xs:attribute name="message-id" type="messageIdType"
          use="optional"/>
        <!--
          Any attributes supplied with <rpc> element must be returned
          on <rpc-reply>.
        -->
        <xs:anyAttribute processContents="lax"/>
      </xs:complexType>
      <xs:group name="rpcResponse">
        <xs:sequence>
          <xs:element ref="rpc-error"
                      minOccurs="0" maxOccurs="unbounded"/>
          <xs:any namespace="##any" processContents="lax"
                  minOccurs="0" maxOccurs="unbounded"/>
        </xs:sequence>
 
      </xs:group>
  
NEW:
      <xs:complexType name="rpcReplyType">
        <xs:choice>
          <xs:element name="ok"/>
          <xs:sequence>
            <xs:element ref="rpc-error"
                        minOccurs="0" maxOccurs="unbounded"/>
            <xs:element ref="rpcResponse"
                        minOccurs="0" maxOccurs="unbounded"/>
          </xs:sequence>
        </xs:choice>
        <xs:attribute name="message-id" type="messageIdType"
          use="optional"/>
        <!--
          Any attributes supplied with <rpc> element must be returned
          on <rpc-reply>.
        -->
        <xs:anyAttribute processContents="lax"/>
      </xs:complexType>

      <!--
        rpcResponseType: used as a base type for all
        NETCONF responses
        -->
      <xs:complexType name="rpcResponseType"/>
      <xs:element name="rpcResponse"
                  type="rpcResponseType" abstract="true"/>

Appendix C., paragraph 46:
OLD:

      output {
        container data {
          presence
            "An empty data container indicates that the
             request did not produce any results.";
          description
            "Copy of the source datastore subset which matched
             the filter criteria (if any).";
        }
       }
    }

NEW:

      output {
        anyxml data {
          description
            "Copy of the source datastore subset which matched
             the filter criteria (if any).  An empty data container
             indicates that the request did not produce any results.";
        }
       }
    }

Appendix C., paragraph 84:
OLD:

      output {
        container data {
          presence
            "An empty data container indicates that the filter
             request did not match any results.";
          description
            "Copy of the running datastore subset and/or state
             data which matched the filter criteria (if any).";
        }
      }
    }

NEW:

      output {
        anyxml data {
          description
            "Copy of the running datastore subset and/or state
             data which matched the filter criteria (if any).
             An empty data container indicates that the request did not
             produce any results.";
        }
      }
    }

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Wed, 15 Dec 2010 08:55:15 +0100

Not having heard any objections to this, we suggest that Martin
puts a new revision out for this document later this week.

If you DO HAVE objections, PLEASE SPEAK up ASAP.

Bert and Mehmet

----- Original Message ----- 
From: "Martin Bjorklund" <[email-masked]>
To: <[email-masked]>
Sent: Friday, December 10, 2010 2:40 PM
Subject: [Netconf] list of 4741bis edits

Hi,

/martin

NEW:

NEW:

NEW:

 
      </xs:group>
  
NEW:

      <!--

      output {
        container data {
          presence

NEW:

      output {
        anyxml data {
          description

      output {
        container data {
          presence

NEW:

      output {
        anyxml data {
          description
            "Copy of the running datastore subset and/or state
             data which matched the filter criteria (if any).
             An empty data container indicates that the request did not
             produce any results.";
        }
      }
    }
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf