Subject: [Netconf] New "-00": draft-voit-i2rs-pub-sub-requirements

From: "Eric Voit (evoit)" <[email-masked]>
Date: Thu, 11 Dec 2014 16:11:57 +0000

I2RS has a number of YANG datastore subscription requirements.  We have just published a new draft assembling some of these requirements, and articulating what functions would be need to be supported by the subscribed YANG Datastore.

Hopefully we can discuss this draft during one of the interims in January.

Thanks!
Eric, Alex, & Alberto

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Eric Voit (evoit)
Sent: Thursday, December 11, 2014 10:22 AM
To: [email-masked]
Cc: Alexander Clemm (alex); Alberto Gonzalez Prieto (albertgo)
Subject: [i2rs] New "-00": draft-voit-i2rs-pub-sub-requirements

A number of I2RS WG documents ask for Pub/Sub capabilities.  Other WG have addressed or are looking for similar mechanisms.  The document 
http://tools.ietf.org/html/draft-voit-i2rs-pub-sub-requirements-00 
assembles a view of requirements for a YANG Datastore from an I2RS perspective, and makes comparisons with capabilities in standards in and beyond the IETF. 

This document is a good companion document for
https://tools.ietf.org/html/draft-netmod-clemm-datastore-push-00 

Thanks,
Eric , Alex, & Alberto

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, December 11, 2014 10:03 AM
To: Alberto Gonzalez Prieto (albertgo); Alberto Gonzalez Prieto (albertgo); Alexander Clemm (alex); Eric Voit (evoit); Alexander Clemm (alex); Eric Voit (evoit)
Subject: New Version Notification for draft-voit-i2rs-pub-sub-requirements-00.txt

A new version of I-D, draft-voit-i2rs-pub-sub-requirements-00.txt
has been successfully submitted by Eric Voit and posted to the IETF repository.

Name:		draft-voit-i2rs-pub-sub-requirements
Revision:	00
Title:		Requirements for Subscription to YANG Datastores
Document date:	2014-12-10
Group:		Individual Submission
Pages:		13
URL:            http://www.ietf.org/internet-drafts/draft-voit-i2rs-pub-sub-requirements-00.txt
Status:         https://datatracker.ietf.org/doc/draft-voit-i2rs-pub-sub-requirements/
Htmlized:       http://tools.ietf.org/html/draft-voit-i2rs-pub-sub-requirements-00

Abstract:
   This document provides requirements for a service that allows client
   applications to subscribe to updates of a YANG datastore.  Based on
   criteria negotiated as part of a subscription, updates will be pushed
   to targeted recipients.  Such a capability eliminates the need for
   periodic polling of YANG datastores by applications and fills a
   functional gap in existing YANG transports (i.e.  Netconf and
   Restconf).  Such a service can be summarized as a "pub/sub" service
   for YANG datastore updates.  Beyond a set of basic requirements for
   the service, various refinements are addressed.  These refinements
   include: periodicity of object updates, filtering out of objects
   underneath a requested a subtree, and delivery QoS guarantees.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 11 Dec 2014 19:17:25 +0000

Hi Eric,

can any of you attend the NETCONF interim meeting on Dec 15 and explain shortly the focus of the draft?

Cheers, 
Mehmet 

> From: Netconf [mailto:[email-masked]] On Behalf Of ext Eric Voit (evoit)
> Sent: Thursday, December 11, 2014 5:12 PM
> To: [email-masked]
> Subject: [Netconf] New "-00": draft-voit-i2rs-pub-sub-requirements
> 
> I2RS has a number of YANG datastore subscription requirements.  We have just
> published a new draft assembling some of these requirements, and articulating what
> functions would be need to be supported by the subscribed YANG Datastore.
> 
> A number of I2RS WG documents ask for Pub/Sub capabilities.  Other WG have
> addressed or are looking for similar mechanisms.  The document
> assembles a view of requirements for a YANG Datastore from an I2RS perspective,
> and makes comparisons with capabilities in standards in and beyond the IETF.
> 
> To: Alberto Gonzalez Prieto (albertgo); Alberto Gonzalez Prieto (albertgo); Alexander
> Clemm (alex); Eric Voit (evoit); Alexander Clemm (alex); Eric Voit (evoit)
> Please note that it may take a couple of minutes from the time of submission until the
> htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

---

From: "Alberto Gonzalez Prieto (albertgo)" <[email-masked]>
Date: Thu, 11 Dec 2014 20:32:56 +0000

Thanks Mehmet,
I can do it.

Please provide me with the details for the slot we would have for this
draft.

Thanks,

Alberto

On 12/11/14, 11:17 AM, "Ersue, Mehmet (NSN - DE/Munich)"
<[email-masked]> wrote:

>> Subject: New Version Notification for
>>draft-voit-i2rs-pub-sub-requirements-00.txt
>> 
>> 
>> URL:            
>>http://www.ietf.org/internet-drafts/draft-voit-i2rs-pub-sub-
>> requirements-00.txt
>> Status:         
>>https://datatracker.ietf.org/doc/draft-voit-i2rs-pub-sub-requirements/
>> Htmlized:

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 11 Dec 2014 20:35:54 +0000

The agenda is unfortunately pretty full.
You can get a few min. at the beginning of the I2RS slot, which is planned to start approx. at 1925 CET.
See attached invitation.

Cheers, 
Mehmet 

> From: ext Alberto Gonzalez Prieto (albertgo) [mailto:[email-masked]]
> Sent: Thursday, December 11, 2014 9:33 PM
> To: Ersue, Mehmet (NSN - DE/Munich); Eric Voit (evoit); [email-masked]
> Subject: Re: [Netconf] New "-00": draft-voit-i2rs-pub-sub-requirements
> 
> Thanks Mehmet,
> I can do it.
> 

Subject: [Netconf] Agenda of the virtual interim meeting on December 15, 2014 1700-1900 UTC WAS:FW: NETCONF WG Virtual Interim Meetings December 15, 2014, and bi-weekly starting January 5, 2015
From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
To: Netconf <[email-masked]>
Cc: 'Jeff Haas' <[email-masked]>
Date: Tue, 9 Dec 2014 18:37:37 +0000
List-Id: Network Configuration WG mailing list <netconf.ietf.org>

Dear NETCONF WG,

please find below the Agenda of the virtual interim meeting on December 15, 2014 1700-1900 UTC.
The access information for the virtual meeting is provided in the mail below.

I would like to invite all key players in the WG to participate in the meeting and the discussion we are going to have.
Based on the discussion result and preparation, we aim to start the WGLC for some of the WG items soon.

There is a special time slot in the agenda on the I2RS Ephemeral State we discussed in IETF #91 and I2RS key player are invited to attend.
Susan, Jeff: Please forward as appropriate. Thanks.

Agenda of the virtual interim meeting on December 15, 2014 1700-1900 UTC
-------------------------------------------------------------------------------------

Agenda is also available at:
http://www.ietf.org/proceedings/interim/2014/12/15/netconf/agenda/agenda-interim-2014-netconf-5

- 5 min chair intro, scribe, agenda bashing
  The note taking will be done on: http://beta.etherpad.org/p/netconf-z

Issue discussion and status check per WG item:

- Call Home (Kent) (5min)
  Currently no open issues.
  See https://github.com/netconf-wg/call-home/issues

- Server Model (Kent) (20min)
  Currently 5 open issues.
  See https://github.com/netconf-wg/server-model/issues

- rfc5539bis (Juergen) (5min)
  The two issues decided in IETF 91 are in preparation.

- Restconf (Andy) (30min)
  Currently 4 open issues.
  See https://github.com/netconf-wg/restconf/issues

- Zerotouch (Kent) (20min)
  Currently 1 open issues.
  https://github.com/netconf-wg/yang-patch/issues

- I2RS Ephemeral state (Susan, Jeff) (30min)
  Please provide slides before the meeting.

- 5 min AOB other topics

Best Regards,
Mehmet  & Mahesh

-----Original Message-----
From: Netconf [mailto:[email-masked]] On Behalf Of ext IESG Secretary
Sent: Monday, December 01, 2014 10:05 PM
To: IETF Announcement List
Cc: [email-masked]
Subject: [Netconf] NETCONF WG Virtual Interim Meetings December 15, 2014, and bi-weekly starting January 5, 2015

The NETCONF WG will hold a series of virtual interim meetings beginning Monday, December 15, 2014.

Meeting day: Mondays
Time: 1800 CET
Duration: 2 hours

Dates: December 15, 2014 1-time
and starting with: January 5, 2015 bi-weekly
End date: March 16, 2015

WebEx information:

Meeting number: 640 672 878
Meeting password: nc2015
Audio connection:
1-877-668-4493 Call-in toll free number (US/Canada)
1-650-479-3208 Call-in toll number (US/Canada)

Access code: 640 672 878
Meeting link: https://ietf.webex.com/ietf/j.php?MTID=m2580594e0bc14b4b94f869a415ce437c

---

From: "Alberto Gonzalez Prieto (albertgo)" <[email-masked]>
Date: Thu, 11 Dec 2014 20:40:08 +0000

Thanks Mehmet,

Alberto

On 12/11/14, 12:35 PM, "Ersue, Mehmet (NSN - DE/Munich)"
<[email-masked]> wrote:

>> >> I2RS has a number of YANG datastore subscription requirements.  We
>>have
>> >>just
>> >> and makes comparisons with capabilities in standards in and beyond
>>the
>> >>IETF.
>> >>

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 11 Dec 2014 20:55:33 +0000

Hi Alberto,

you get only a few minutes which basically eats from the I2RS discussion time concerning the Ephemeral State.
I expect that you explain _shortly_ what it is and where in the future it will be developed.

You should be also aware that based on the original agreement between NETCONF and I2RS co-chairs,
requirements from I2RS WG directed to NETCONF WG should be first agreed in I2RS WG.
However, as I see NETMOD WG might be also involved.

Cheers, 
Mehmet 

> Sent: Thursday, December 11, 2014 9:40 PM

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Thu, 11 Dec 2014 21:25:10 +0000

Absolutely agree that the requirements must be first agreed in I2RS.  But we provided notice to the NETCONF mailer as there likely are people who care about this topic here.

I think it is great that Alberto can give a brief intro.  We will pass along details as this proceeds in I2RS.

Eric

> From: Ersue, Mehmet, December 11, 2014 3:56 PM
> 
> Hi Alberto,
> 
> You should be also aware that based on the original agreement between
> NETCONF and I2RS co-chairs, requirements from I2RS WG directed to NETCONF
> WG should be first agreed in I2RS WG.
> > >> >can any of you attend the NETCONF interim meeting on Dec 15 and
> explain
> > >> >shortly the focus of the draft?
> > >> >
> > >> >Cheers,
> > >> >Mehmet
> > >> >
> > >> >> A number of I2RS WG documents ask for Pub/Sub capabilities.  Other
> WG
> > >> >>have

---

From: "Alberto Gonzalez Prieto (albertgo)" <[email-masked]>
Date: Mon, 15 Dec 2014 18:39:32 +0000

Thanks for the opportunity to present today and your comments.
I attach the slides.

Thanks,

Alberto