Subject: [Netconf] RESTCONF #4: defaults handling

From: Andy Bierman <[email-masked]>
Date: Sun, 7 Dec 2014 09:58:43 -0800

Hi,

This is the proposal for draft-04 for defaults handling.
The text is in the github version of the draft.

1) server MUST include the "defaults" protocol capability in
the "capability" list with parameter "basic-mode" set.
Example:

    urn:ietf:params:restconf:capability:defaults:1.0?basic-mode=explicit

2) server MAY support the "with-defaults" query parameter
(works the same as <with-defaults> parameter for get or get-config)

Andy

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Sun, 14 Dec 2014 15:39:09 +0000

Dear All,

please comment on the solution proposal of issue #4 below.
If there is no objection the author is going to implement as proposed.
The issue will be closed in the virtual meeting on Dec 15.

Cheers, 
Mehmet 

> -----Original Message-----
> From: Netconf [mailto:[email-masked]] On Behalf Of ext Andy Bierman
> Sent: Sunday, December 07, 2014 6:59 PM
> To: Netconf
> Subject: [Netconf] RESTCONF #4: defaults handling
> 
> Hi,
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf