Subject: [Netconf] RESTCONF #3: collections

From: Andy Bierman <[email-masked]>
Date: Mon, 15 Dec 2014 11:28:45 -0800

Hi,

The collections resource is more complicated than originally
anticipated.  There are additional XPath parameters for
sorting, filtering, pagination, etc. that should be addressed.
Since this an optional feature, not applicable to all
server implementations, it should be in a separate document.

The proposed solution for collections is to move the collection
resource plus the "limit" and "offset" parameters to a new draft
(could be called "Collection Resource for RESTCONF").

This will keep the base RESTCONF protocol simpler and allow
WGLC to start sooner on the base document.

Unless there are any objections by 12/19/14, this change
will be made in the next RESTCONF draft. A new draft will
be submitted for the collection resource.

Andy

---

From: Alan Luchuk <[email-masked]>
Date: Mon, 15 Dec 2014 15:36:33 -0500 (EST)

Hello,

>be submitted for the collection resource.

I support moving the collection resource and related parameters
to a new draft.

Regards,
--Alan

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 15 Dec 2014 21:50:48 +0100

> On 15 Dec 2014, at 21:36, Alan Luchuk <[email-masked]> wrote:
> 
> Hello,
> 

+1

Lada

> 
> 
> Regards,
> --Alan
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C