Subject: Re: [netconf] Create IANA-defined modules?

From: Qin Wu <[email-masked]>
Date: Thu, 10 Jun 2021 01:47:32 +0000

>>-----邮件原件-----
>>发件人: tom petch [mailto:[email-masked]] 
>>发送时间: 2021年6月10日 0:38
>>收件人: Qin Wu <[email-masked]>; Kent Watsen <[email-masked]>; [email-masked]
>>主题: Re: [netconf] Create IANA-defined modules?

>>Apologies for the noise.

 >>mmm the wonders of webmail,  I inserted comments and then was told that my e-mail could not be sent.   I saved it - well, no, it could not be saved.  Returned later, there was a draft in the folder so I sent it.  Bad idea, my comments have  been excised.

>>Ah well, try again later.

[Qin Wu]
 :-)
I think I should indent original message text or mark the comment in different color. By default, my outlook client disable this feature.

>>Tom Petch 

________________________________________
> From: netconf <[email-masked]> on behalf of tom petch <[email-masked]>
> Sent: 09 June 2021 17:32
> To: Qin Wu; Kent Watsen; [email-masked]
> Subject: Re: [netconf] Create IANA-defined modules?

________________________________________
> From: netconf <[email-masked]> on behalf of Qin Wu <[email-masked]>
> Sent: 09 June 2021 14:07
> To: Kent Watsen; [email-masked]
> Subject: Re: [netconf] Create IANA-defined modules?

-----邮件原件-----
> 发件人: netconf [mailto:[email-masked]] 代表 Kent Watsen
> 发送时间: 2021年5月27日 3:06
> 收件人: [email-masked]
> 主题: [netconf] Create IANA-defined modules?

>  [CC-ing Gary, who contributed the “ietf-[tls/ssh]-common" modules originally]

---

From: Qin Wu <[email-masked]>
Date: Tue, 15 Jun 2021 11:53:04 +0000

-----邮件原件-----
>>发送时间: 2021年6月15日 19:32
>>收件人: Qin Wu <[email-masked]>; Kent Watsen <[email-masked]>; Per Andersson (perander) <[email-masked]>
>>抄送: [email-masked]

>>From: Qin Wu <[email-masked]>
>>Sent: 15 June 2021 06:54

>> Kent Watsen [mailto:[email-masked]]
 2021 6 5 0:22

>>Thank you Qin, Tom, and Per for the responses to my last post…this message addresses them all.

>>Since the discussion has been mostly about *how* to create the IANA-defined module (not *if* we should, e.g., dropping the work for some future effort to pickup), I take it that folks believe having the ability for configure supported-algorithms is needed now.  
>>no one offered to help (:sigh:, and people wonder why this work takes so long), I wrote the attached script that creates the attached module directly from the data obtained from the IANA-maintained "TLS Cipher Suites" sub-registry of the "Transport Layer 
>>Security (TLS) Parameters” registry here: https://www.iana.org/assignments/tls-parameters/tls-parameters.xhtml.  The resulting module is also attached.

>[Qin Wu]  The proposed module looks good to me, I assume these cipher-suite identities are not specific to particular version of TLS, e.g., TLS1.3.

><tp>
>No, the exact opposite.  AFAIK there is no recommended ciphersuite that is common to TLS1.2 and TLS1.3 (or indeed one that is not recommended).  TLS1.3 is very different!

[Qin Wu] Thanks for your clarification, this aligns with what I understand.