Subject: Re: [netconf] Should Partial Lock be deprecated?

From: Kent Watsen <[email-masked]>
Date: Tue, 1 Jun 2021 12:53:17 +0000

Hi Andy,

> I bet some do not remember we have this RFC
> https://datatracker.ietf.org/doc/html/rfc5717 <https://datatracker.ietf.org/doc/html/rfc5717>
> (So old there is a normative XSD and non-normative YANG module).
> 
> I have not seen this RFC used in several years.
> Is anyone using it? 
> Should it be deprecated?
> Just curious.

As a contributor, I have never been a fan of this RFC.  Significant complexity for a weak use case.

Regarding the use case, my limited perspective is that rarely does more than one client access a server at a time (esp. when an NMS/orchestrator is in play) and, when it does occur, the access is typically for a brief amount of time, such that having a second client wait doesn’t seem a big deal.

Applications vary, of course, with some (multi-tenant app, socials, etc.) being all about simultaneous access.  To the extent these apps desire YANG-driven interfaces, I much prefer RESTCONF’s If-Match mechanism and would recommend porting it to NETCONF.

> Andy

K.

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 4 Jun 2021 17:14:39 +0000

Hi guys,

I've always been a bit doubtful about this RFC as well (complexity and issues vs benefits and likely use cases).

Jason

From: netconf <[email-masked]> On Behalf Of Kent Watsen
Sent: Tuesday, June 1, 2021 8:53 AM
To: Andy Bierman <[email-masked]>
Cc: [email-masked]
Subject: Re: [netconf] Should Partial Lock be deprecated?

Hi Andy,

I bet some do not remember we have this RFC
https://datatracker.ietf.org/doc/html/rfc5717
(So old there is a normative XSD and non-normative YANG module).

Andy

K.

---

From: "Per Andersson (perander)" <[email-masked]>
Date: Mon, 7 Jun 2021 13:14:29 +0000

Hi!

Both NSO (orchestrator) and ConfD implement partial-lock. I do not know
from the top of my head if/how it is used though. Use cases for both NSO
and ConfD involve simultaneous access from multiple users and/or systems.

However, what would the alternative be if partial-lock is deprecated?
Only using global lock, an RFC 5717 bis, or something else?

Porting RESTCONF's If-Match to NETCONF, as Kent suggests, looks
interesting. Have you seen Jan's draft for transaction-id [0], I believe this
would be such a mechanism.

[0] https://datatracker.ietf.org/doc/html/draft-lindblad-netconf-transaction-id-00

--
Per

________________________________________
From: netconf <[email-masked]> on behalf of Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>
Sent: Friday, June 4, 2021 19:14
To: Kent Watsen; Andy Bierman
Cc: [email-masked]
Subject: Re: [netconf] Should Partial Lock be deprecated?

Hi guys,

Jason

Hi Andy,

Andy

K.