Subject: Re: [netconf] Create IANA-defined modules?

From: Qin Wu <[email-masked]>
Date: Wed, 9 Jun 2021 13:07:28 +0000

-----邮件原件-----
发件人: netconf [mailto:[email-masked]] 代表 Kent Watsen
发送时间: 2021年5月27日 3:06
收件人: [email-masked]
主题: [netconf] Create IANA-defined modules?

[CC-ing Gary, who contributed the “ietf-[tls/ssh]-common" modules originally]

NETCONF WG,

The “tls-client-server” draft just received the following GitHub “issue”:

=====start=====
This is rather a question than an issue, maybe.

Given that IANA maintains the TLS parameters at   https://www.iana.org/assignments/tls-parameters/tls-parameters.xhtml, would it not be better for that content to come from something like iana-tls[-parameters].yang rather than an IETF maintained YANG module?
=====stop=====

This is a good point.  Perhaps we should move all the identities for the algorithms defined in the “ietf-tls-common” module to an IANA-maintained “iana-tls-parameters” module.  Thoughts?

[Qin]: I agree this seems straightforward to me. The module name could be "iana-tls-types" like.

By extension, the same statement applies to the “ssh-client-server” draft and the IANA maintained SSH parameters page: https://www.iana.org/assignments/ssh-parameters/ssh-parameters.xhtml.

One potential issue with doing this is that the existing identities have “if-feature” statements that constrain them to specific TLS-versions and algorithm-families, and are sometimes marked as “deprecated".  By example:

    identity ecdhe-ecdsa-with-aes-128-cbc-sha256 {
       if-feature "tls-1_2";
       if-feature "tls-ecc and tls-sha2";
       base cipher-suite-base;
       status "deprecated";
       description
           "Cipher suite TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256.";
       reference
          "RFC 5289: TLS Elliptic Curve Cipher Suites with
                             SHA-256/384 and AES Galois Counter Mode (GCM)";
    }

But that information is NOT captured in the IANA-maintained page.   What to do?

[Qin]: Why not bind tls version with cipher-suite in the ecdhe-ecdsa-with-aes-128-cbc-sha256 identity definition. Also I feel identity name is too long.

One option would be to drop all the feature statements.  All they do is limit the totality of algorithms presented to an administrator, when configuring which algorithms the client/server should support.  Worst case, all algorithms (of a given type) are presented, regardless if supported by the, e.g., TLS protocol version.  When configuring clients/servers using, e.g., text-based configuration files, such filters are never available.  Does anyone know what Cisco/Juniper/etc. devices do in their command-line and/or web interfaces?

[Qin]: See above, do we need to introduce if-feature "tls-1_2" and why not tie the tls version in the cipher-suite name such as "tls12-ecdhe-ecdsa-with-aes-128-cbc-sha256". 

Another option, which I like because it’s less work for me (unless someone can volunteer a GitHub pull request), is to remove the ietf-[tls/ssh]-common modules altogether.  They’re currently optional-to-configure and, when not configured, it’s an implementation-specific decision what, e.g., algorithms to list as being supported during the protocol handshake.  Personally, I’ve never used them (or implemented support for them), happily deferring to internal code and underlying libraries.  In lieu of us not defining these modules now, applications could augment-in their own configuration nodes and, of course, a future WG effort could add them.  Thoughts on this approach?

K.

_______________________________________________
netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: tom petch <[email-masked]>
Date: Wed, 9 Jun 2021 16:32:44 +0000

________________________________________
From: netconf <[email-masked]> on behalf of Qin Wu <[email-masked]>
Sent: 09 June 2021 14:07
To: Kent Watsen; [email-masked]
Subject: Re: [netconf] Create IANA-defined modules?

-----邮件原件-----
发件人: netconf [mailto:[email-masked]] 代表 Kent Watsen
发送时间: 2021年5月27日 3:06
收件人: [email-masked]
主题: [netconf] Create IANA-defined modules?

NETCONF WG,

=====start=====

K.

---

From: tom petch <[email-masked]>
Date: Wed, 9 Jun 2021 16:37:55 +0000

Apologies for the noise.

mmm the wonders of webmail,  I inserted comments and then was told that my e-mail could not be sent.   I saved it - well, no, it could not be saved.  Returned later, there was a draft in the folder so I sent it.  Bad idea, my comments have  been excised.

Ah well, try again later.

Tom Petch 

________________________________________
From: netconf <[email-masked]> on behalf of tom petch <[email-masked]>
Sent: 09 June 2021 17:32
To: Qin Wu; Kent Watsen; [email-masked]
Subject: Re: [netconf] Create IANA-defined modules?