Subject: [netconf] Draft minutes for NETMOD 112 session uploaded

From: Kent Watsen <[email-masked]>
Date: Mon, 15 Nov 2021 22:53:12 +0000

The draft minutes for our session today are both below and uploaded here:

  https://datatracker.ietf.org/meeting/112/materials/minutes-112-netconf

Please review and send any corrections to the chairs alias (CC-ed).

Thanks!
Kent (and Mahesh)

# Meeting Minutes for the NETCONF 112 WG Session

# Introduction

## Chair slides (10 minutes)
  - Session Intro & WG Status

Rob: re: the IEEE liaison on the keystore draft, says that he'll setup a meeting.

Kent: requests all authors to bring discussions to the WG list.

# Chartered items:

## UDP-based Transport for Configured Subscriptions (10 min)
  - https://datatracker.ietf.org/doc/html/draft-ietf-netconf-udp-notif-04
  - Discussion Leader: Pierre Francois

Rob: Need to check with Sec Area.  From a quick discussion with the ADs they may not be happy with allowing unencrypted UDP in a standards track doc.  (2) We should also check that we cover transport issues such as congestion.

Pierre: XXX

Kent: I have sympathy for implementations that want to send notifications unencrypted in a private network.

Pierre: Do you think that having this traffic over a secure network would not be good enough?

Rob: Yes, I have sympathy for the the deployment scenario, but I'm still not sure whether this will be sufficient for the security ADs, they may think that the cost of encrypting all of the traffic is low enough to justify

Mahesh: Draft talks about a transmission timeout value to be set, but there is no configuration in the YANG module for that timer?  Is the draft asking for a  well known UDP port?

Pierre: I need to check for the timeout.  We might need to have this configured, but a default value may be sufficient.  Re 2nd question.  We had this in, but we decided that having a single default value is not really needed and nobody was caring.

# Non-Chartered items:

## Adaptive Subscription to YANG Notification (10 mins)
  - https://datatracker.ietf.org/doc/html/draft-wang-netconf-adaptive-subscription-07
  - Discussion Leader: Qiufang Ma
  
Rob: Thank you for Qin's comments.  I think that you are on the right track.  Okay to allow more complex expressions as long as all implementions support a minimum level of complexity.  Should have a well defined error code if the expression is too complex.

Kent: Arbitrary XPaths may also turn up in list pagination.  This may be a problem if the backend is supported by a simple database.  How does the server indicate to the client what level of complexity is supported.  I see the same problem turning up here and in the list pagination work.

## Transaction ID Mechanism for NETCONF (10 min)
  - https://datatracker.ietf.org/doc/html/draft-lindblad-netconf-transaction-id-01
  - Discussion Leader: Jan Lindblad

Kent: You had some open issues, there is no time for discussion.  I do think that we should take issues to the list.  Please take the open issues there.

Benoit: I really support the id being issued by the client, or at least having a way to label the required.  Particularly helpful if there are multiple clients configuring a server, and we want to keep track of the service request Id.

Kent: I do also think that there is value there.  Just need to decide the best way to introduce it.

# List Pagination for YANG-driven Protocols (20 mins)
  - https://datatracker.ietf.org/doc/html/draft-wwlh-netconf-list-pagination-00
  - https://datatracker.ietf.org/doc/html/draft-wwlh-netconf-list-pagination-nc-02
  - https://datatracker.ietf.org/doc/html/draft-wwlh-netconf-list-pagination-rc-02
  - Discussion Leader: Qin Wu

Mahesh: Out of time, so please take these questions to the list.

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 15 Nov 2021 16:09:42 -0800

Just a minor correction to the subject line. 

Mahesh (and Kent)

> On Nov 15, 2021, at 2:53 PM, Kent Watsen <[email-masked]> wrote:
> 
>