Subject: Re: [netconf] Question to draft-ietf-netconf-sztp-csr-13

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 1 Mar 2022 21:50:31 +0000

Hi Kent, authors,

Given that I haven’t get approved this draft from the IESG review yet, then even though it is late, these changes look useful but relatively minor.  If the authors think that these changes are appropriate then I am happy for you to post an updated draft revision with these changes then ping me and I’ll check it before sending it on its way to the RFC editor.
Regards,
Rob

From: netconf <[email-masked]> On Behalf Of Brockhaus, Hendrik
Sent: 23 February 2022 08:44
To: Kent Watsen <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [netconf] Question to draft-ietf-netconf-sztp-csr-13

Kent

I understood that this change request comes very late, but to male the change request more concrete I looked into the document and identified four places where p10cr is referenced. In all theses places “p10cr” would need to be replaced with “ir, cr, kur, or p10cr”.

Finally this is the proposed change:

** Section 3.2.

In identity cmp-csr:

s/PKIBody containing only the p10cr structure/PKIBody containing only the ir, cr, kur, or p10cr structure/

And three times in grouping csr-grouping:

s/The body element contains a p10cr CHOICE of type CertificationRequest./The body element contains a ir, cr, kur, or p10cr CHOICE of type CertificationRequest./

But I understood that such change can only be processed if there is a DISCUSS.

Hendrik

Von: netconf <[email-masked]<mailto:[email-masked]>> Im Auftrag von Fries, Steffen
Gesendet: Dienstag, 22. Februar 2022 17:52
An: Kent Watsen <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Betreff: Re: [netconf] Question to draft-ietf-netconf-sztp-csr-13

Hi Kent,

Thank you for your answer.
I agree, it is very late in the process for such a comment. I should have realized it earlier. Nevertheless, I wanted to raise that point as it would allow for more functionality. If there is no DISCUSS, the proposal with an additional definition is probably the easiest way forward.

Best regards
Steffen

From: Kent Watsen <[email-masked]<mailto:[email-masked]>>
Sent: Dienstag, 22. Februar 2022 16:33
To: Fries, Steffen (T CST) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: Question to draft-ietf-netconf-sztp-csr-13

Hi Steffen,

Yes, the CMP-CSR is bound to P10.

This draft is currently in the final stage of IESG Last Call review.  Comments such as these should have been received during WG Last Call.  Unless an IESG member throws a DISCUSS, the draft will proceed as is.  In such case, a future work may define something like a "cmp-csr-2” leaf to contain an expanded definition.

Kent // contributor

On Feb 15, 2022, at 1:46 PM, Fries, Steffen <[email-masked]<mailto:[email-masked]>> wrote:

Hello Kent,

I’ve got a short clarification question regarding the latest draft. I realized in the description of the YANG modules that there is a difference in section 3.2 between CMC and CMP in the description what can be contained in the respective CSR. Based on the description of the YANG module, CMC seems to be open for different types of certification requests, while CMP is bound to a wrapped P10 not leaving any further choice (like ir, cr, kur). Did I got this right or did I misinterpret the description for the cmc-csr? Sorry for realizing this so late.

Best regards
Steffen

---

From: Kent Watsen <[email-masked]>
Date: Thu, 3 Mar 2022 01:38:09 +0000

Rob et. al., 

An -14 update was posted with the changes proposed by Hendrik.
Thank you Hendrik for providing simple to apply edits!

Kent (on behalf of the authors)

> On Mar 1, 2022, at 4:50 PM, Rob Wilton (rwilton) <[email-masked]> wrote:
> 
> Hi Kent, authors,
>  
> From: netconf <[email-masked] <mailto:[email-masked]>> On Behalf Of Brockhaus, Hendrik
> To: Kent Watsen <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> Von: netconf <[email-masked] <mailto:[email-masked]>> Im Auftrag von Fries, Steffen
> An: Kent Watsen <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> From: Kent Watsen <[email-masked] <mailto:[email-masked]>> 
> To: Fries, Steffen (T CST) <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> On Feb 15, 2022, at 1:46 PM, Fries, Steffen <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Hello Kent,
>

---

From: "Fries, Steffen" <[email-masked]>
Date: Thu, 3 Mar 2022 10:51:56 +0000

Hi Kent,

Thank you for the prompt reaction. This definitely ensures broader applicability of the CMP features.

Best regards
Steffen

From: netconf <[email-masked]> On Behalf Of Kent Watsen
Sent: Donnerstag, 3. März 2022 02:38
To: Rob Wilton (rwilton) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [netconf] Question to draft-ietf-netconf-sztp-csr-13

Rob et. al.,

On Mar 1, 2022, at 4:50 PM, Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Kent, authors,

From: netconf <[email-masked]<mailto:[email-masked]>> On Behalf Of Brockhaus, Hendrik
Sent: 23 February 2022 08:44
To: Kent Watsen <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [netconf] Question to draft-ietf-netconf-sztp-csr-13

Kent

Hendrik

Hi Kent,

Best regards
Steffen

Hi Steffen,

Kent // contributor

Hello Kent,

Best regards
Steffen

---

From: Sean Turner <[email-masked]>
Date: Thu, 3 Mar 2022 09:04:55 -0500

Thanks all ‘round!

spt

> On Mar 3, 2022, at 05:51, Fries, Steffen <[email-masked]> wrote:
> 
> Hi Kent,
>  
> Von: netconf <[email-masked]> Im Auftrag von Fries, Steffen
> An: Kent Watsen <[email-masked]>
> From: Kent Watsen <[email-masked]> 
> To: Fries, Steffen (T CST) <[email-masked]>
> On Feb 15, 2022, at 1:46 PM, Fries, Steffen <[email-masked]> wrote:
>  
> Hello Kent,
>

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 3 Mar 2022 17:20:53 +0000

Thank you authors, WGs, and contributors for their work on this document.  This is now approved and will shortly go into the RFC editor queue.

Regards,
Rob

-----Original Message-----
From: Sean Turner <[email-masked]> 
Sent: 03 March 2022 14:05
To: Fries, Steffen <[email-masked]>
Cc: Kent Watsen <[email-masked]>; Rob Wilton (rwilton) <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [netconf] Question to draft-ietf-netconf-sztp-csr-13

Thanks all ‘round!

spt