Subject: [netconf] comments on draft-lindblad-netconf-transaction-id-01

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 22 Mar 2022 14:19:24 +0000

Hi Jan,

I read the draft and found both the problem statement and the proposed solution compelling. My only comment/suggestion is that I found sections 3 and 4 to be rather repetitive. I suspect this is somewhat intentional as section 3 is states requirements and section 4 outlines an implementation that addresses those requirements; however, I think it would be better to simplify section 3 and keep the details and normative language for section 4.

Cheers,
Charles

---

From: "Jan Lindblad (jlindbla)" <[email-masked]>
Date: Thu, 24 Mar 2022 11:03:26 +0000

Charles,

> I read the draft and found both the problem statement and the proposed solution compelling.

Excellent.

> My only comment/suggestion is that I found sections 3 and 4 to be rather repetitive. I suspect this is somewhat intentional as section 3 is states requirements and section 4 outlines an implementation that addresses those requirements; however, I think it would be better to simplify section 3 and keep the details and normative language for section 4.

Thanks for the feedback. I must confess I have struggled a bit with the organization of the document, going back and forth between different structures. Your point is well taken, and I'll have that in mind for the next version.

Best Regards,
/Jan