Subject: RE: Design teams (Was: Re: [netlmm] Reviewof draft-giaretta-netlmm-dt-protocol-00)

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Mon, 10 Jul 2006 11:51:40 -0700

On the "tutorial" comment, let me rationalize that.  Since the DT's
draft was the cumulation of the multiple NetLMM authors' contributions
which were based on numerous approaches, I believe it would be valuable
to explain the protocol that was proposed to the WG.  Hopefully, the
control message flows will provide some better understanding to
stimulate more discussions.

Kent

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Monday, July 10, 2006 6:53 AM
> To: Jari Arkko
> Cc: [email-masked]
> Subject: Re: Design teams (Was: Re: [netlmm] Reviewof 
> draft-giaretta-netlmm-dt-protocol-00)
> 
> I am fine with design teams in the IETF. I have participated 
> in a number of them. you can made good progress in a very 
> short time compared to the mailing list. but I have always 
> seen design teams formed ad hoc when there a number of 
> solutions and it is hard getting consensus on the solution.
> 
> but the NETLMM case is bizarre. the first charter proposal 
> explicitly spoke above a forming a design team and doing the 
> work in the design team even before there was a problem 
> statement. even before there were multiple solutions. I had 
> protested about this when the NETLMM WG was being chartered.
> but folks didnt seem to care.
> 
> I hope NETLMM is an exception and we won't form design teams 
> like this again.
> 
> Vijay
> 
> ps: I am setting in the NETLMM WG meeting and it appears to 
> me that one of the design team members is giving a NETLMM 
> tutorial to the rest of the WG. :(
> 
> Jari Arkko wrote:
> > Folks,
> > 
> > Design teams are one of the tools that we use in the IETF. They are 
> > not a perfect tool, but they can often bring together sufficient 
> > cycles to work on a major specification, create interest in 
> > individuals working together, etc.
> > 
> > However, the results of the design teams are always subject 
> to the WG 
> > process. The situation is not very different from an individual 
> > submission. Also, like individual drafts, design team 
> drafts can too 
> > be early, initial versions. Do not treat the result as the final 
> > output from the WG, treat it as an input to the WG.
> > If the input has a problem, bring up an issue. If the input is not 
> > ready in some aspects, I hope the design team makes clear 
> where this 
> > is the case. Or others may point it to them.
> > 
> > And like all inputs to the working group, its often useful 
> to discuss 
> > the background and rationale for design decisions.
> > I would be very surprised if such discussion in the WG 
> doesn't change 
> > some of the decisions, in fact. Design decisions that can not be 
> > backed up by rational explanations can rightfully be challenged.
> > 
> > In short, I would urge everyone to focus on the technical 
> evaluation 
> > of the design team draft.
> > 
> > --Jari
> > 
> > 
> > _______________________________________________
> > netlmm mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/netlmm
> 
> 
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/netlmm
> 

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 10 Jul 2006 13:32:44 -0700

hi Kent,

> stimulate more discussions.

I was pointing out we (the working group members) 
actually needed a tutorial to understand the protocol. 
you just reiterated that. I started reading the 
protocol document, realized it was too complicated and 
need to set aside a substantial amount of my time to 
understand the protocol. :(

Vijay