Subject: RE: [netlmm] Which Addressing Model to Choose?

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Tue, 18 Jul 2006 08:36:05 -0700

Hi Fred.

> -----Original Message-----
> From: Templin, Fred L [mailto:[email-masked]] 
> Sent: Monday, July 17, 2006 4:57 PM
> To: James Kempf; Alexandru Petrescu
> Cc: [email-masked]
> Subject: RE: [netlmm] Which Addressing Model to Choose?
> 
> James,
> 
> w/o going through exhausing detail, I'll grant your point 
> that multilink subnet is responsible for requiring the 
> proxied NS(DAD) in the SLAAC case. If not for the SEND 
> requirements, the procedure would be simple ND proxying, but 
> with SEND things get a bit more complex. As you say, this 
> would not be a problem for the DHCP case but if SLAAC is the 
> base case then we have to take the added complexity into account.
> 

Yes, per-MN prefix will simplify SLAAC.  DHCP doesn't gain or lose
complexity with this scheme.

> One thing I will challenge, though, is the assumptiom that 
> the ARs (MAGs) and/or LMAs need to be either just routers or 
> just bridges; there might be some operational advantage to 
> having them function as hybrid routing-bridges instead.
> 

Just wanted to clarify a bit.

Are you saying some packets for a MN can be bridged and other packets to
the same MN are routed?  This means access gateway treat the packets for
a MN selectively, either bridging or routing based on the protocol type.

Or that all packets for one MN are bridged and all packets for another
MN are routed?  This means the access gateway can operate in either
bridging or routing mode depending on the authorized service of the MN.

Kent

> Fred
> [email-masked]
> 
><snip>

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 18 Jul 2006 09:14:14 -0700

Hi Kent,

> bridging or routing mode depending on the authorized service of the
MN.

Not really either one. I was more or less hinting at the RBridge
work being done in the TRILL wg, where they are designing a hybrid
routing-bridge. MAGs acting as RBriges could be used to create
rather large shared links within a NETLMM domain. (There might
even be multiple such rather large shared links within a NETLMM
domain.) For that matter, it seems like a NETLMM domain could be,
well, rather large.

Fred