Subject: [netlmm] #98: Need definition of WLAN switch

From: netlmm <[email-masked]>
Date: Thu, 27 Jul 2006 21:29:15 -0000

#98: Need definition of WLAN switch
-----------------------------------------+----------------------------------
 Reporter:  [email-masked]     |       Owner:  [email-masked]
     Type:  defect                       |      Status:  new                     
 Priority:  minor                        |   Milestone:  milestone3              
Component:  draft-ietf-netlmm-nohost-ps  |     Version:  2.0                     
 Keywords:  PS draft                     |  
-----------------------------------------+----------------------------------
 Dan Romanascanu, OPS AD, has rasied the following DISCUSS comment:

 1. The document uses the teem 'WLAN switch' which is neither standard
 (afaik) nor explained - I suggest that a short definition be added

-- 
Ticket URL: <http://www1.tools.ietf.org/wg/netlmm/trac/ticket/98>
netlmm <http://tools.ietf.org/wg/netlmm/>
_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: netlmm <[email-masked]>
Date: Thu, 27 Jul 2006 21:54:38 -0000

#98: Need definition of WLAN switch
------------------------------------------+---------------------------------
  Reporter:  [email-masked]     |       Owner:  [email-masked]
      Type:  defect                       |      Status:  closed                  
  Priority:  minor                        |   Milestone:  milestone3              
 Component:  draft-ietf-netlmm-nohost-ps  |     Version:  2.0                     
Resolution:  fixed                        |    Keywords:  PS draft                
------------------------------------------+---------------------------------
Changes (by [email-masked]):

  * resolution:  => fixed
  * status:  new => closed

Comment:

 Added the following definition:

 WLAN Switch

 A Wireless LAN (WLAN) switch is an Ethernet switch - that is a multiport
 bridge that connects network segments but allows a physical and logical
 star topology - which also runs a protocol to control a collection of
 802.11 [17] access points. The access point control protocol allows the
 switch to perform radio resource management functions such as power
 control and terminal load balancing between the access points. Most WLAN
 switches also support a proprietary protocol for inter-subnet IP mobility,
 which provides session continuity when a terminal moves between subnets.

 Marked as fixed pending Dan's comments.

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 27 Jul 2006 16:16:49 -0700

netlmm wrote:

> Most WLAN

are we talking about deployments here or what vendors
claim to support? if its the former, I think this
statement is wrong.

Vijay

---

From: Jim Murphy <[email-masked]>
Date: Thu, 27 Jul 2006 17:28:20 -0700

This technology is deployed widely. The way it works is that
when a station associates on a switch that does not contain the
station's assigned VLAN, that switch will establish a tunnel to
another switch that does contain the VLAN, effectively extending
the VLAN to the switch to which the station is now associated.
Hopefully that is what you mean by inter-subnet IP mobility.

Thanks,

Jim

---

From: "James Kempf" <[email-masked]>
Date: Fri, 28 Jul 2006 08:48:39 -0700

Vijay,

Could you provide more detail here?

            jak

---

From: "James Kempf" <[email-masked]>
Date: Fri, 28 Jul 2006 08:50:11 -0700

Right. Perhaps I should edit the definition to describe the actual 
mechanism.

            jak

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 28 Jul 2006 18:02:12 +0200

Jim Murphy wrote:
> This technology is deployed widely.

What is its name?

> The way it works is that when a station associates on a switch that 
> does not contain the station's assigned VLAN, that switch will 
> establish a tunnel to another switch that does contain the VLAN, 
> effectively extending the VLAN to the switch to which the station is
>  now associated.

This sounds to me like Fast Handovers for Mobile IPv6 (RFC4068)
or Mobile IPv6 Fast Handovers for 802.11 (RFC 4260).  Is this what you mean?

Alex

> 
> Thanks,
> 
> Jim
> 
> Vijay Devarapalli wrote:
>> netlmm wrote:
>> 
>>> Most WLAN switches also support a proprietary protocol for 
>>> inter-subnet IP mobility, which provides session continuity when
>>>  a terminal moves between subnets.
>> 
>> are we talking about deployments here or what vendors claim to 
>> support? if its the former, I think this statement is wrong.
>> 
>> Vijay
>> 
>> _______________________________________________ netlmm mailing list
>>  [email-masked] https://www1.ietf.org/mailman/listinfo/netlmm
> 
> 
> _______________________________________________ netlmm mailing list 
> [email-masked] https://www1.ietf.org/mailman/listinfo/netlmm
>

---

From: "James Kempf" <[email-masked]>
Date: Fri, 28 Jul 2006 09:46:13 -0700

No, the protocols are proprietary. Every WLAN switch vendor has their own 
way of doing this, and there is no host involvement. It is entirely handled 
by the WLAN switches.

            jak

----- Original Message ----- 
From: "Alexandru Petrescu" <[email-masked]>
To: "Jim Murphy" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Friday, July 28, 2006 9:02 AM
Subject: Re: [netlmm] #98: Need definition of WLAN switch

>> The way it works is that when a station associates on a switch that does 
>> not contain the station's assigned VLAN, that switch will establish a 
>> tunnel to another switch that does contain the VLAN, effectively 
>> extending the VLAN to the switch to which the station is
>>  now associated.
>
>>>> Most WLAN switches also support a proprietary protocol for inter-subnet 
>>>> IP mobility, which provides session continuity when
>>> are we talking about deployments here or what vendors claim to support? 
>>> if its the former, I think this statement is wrong.
>>>
>>> Vijay
>>>

---

From: Jim Murphy <[email-masked]>
Date: Fri, 28 Jul 2006 13:05:48 -0700

>> This technology is deployed widely.

We call it subnet roaming. I'm not 100% certain that subnet roaming is
an accepted market term.

> or Mobile IPv6 Fast Handovers for 802.11 (RFC 4260).  Is this what you 

They don't sound similar. Subnet roaming is about bringing the
station's subnet to any AP they happen to associate with. The idea
is to avoid any L3 mobility protocols on the station. You should also
be aware of the fact that wireless switches assume a layer 1 connection
between the AP and the switch through a direct wired connection or
a tunnel. This implies that the access network between the access
point and the wireless switch never sees packets from this roamed
subnet. This is not the case with 4260 as far as I can tell.

Thanks,

Jim