Subject: RE: [netlmm] Which Addressing Model to Choose?

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Tue, 18 Jul 2006 11:02:04 -0700

OK, I understand what you mean now.  But Rbridge is solving the bridging
problems by adopting some routing features.  This doesn't really match
the problem statements of NetLMM, IMHO.

Kent 

<snip>
> 
> Not really either one. I was more or less hinting at the 
> RBridge work being done in the TRILL wg, where they are 
> designing a hybrid routing-bridge. MAGs acting as RBriges 
> could be used to create rather large shared links within a 
> NETLMM domain. (There might even be multiple such rather 
> large shared links within a NETLMM
> domain.) For that matter, it seems like a NETLMM domain could 
> be, well, rather large.
> 
> Fred
> [email-masked] 
> 

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 20 Jul 2006 09:43:03 -0700

> That being said, if all links in the domain are pt-2-pt, then we do 
> not need to enforce domain wide link-local address uniqueness because 
> the above scenario will never happen (two MN's can't be on the same 
> link if the link is pt-2-pt; there would be only a MN and its MAG on 
> any link.)

As I said in my previous message, this just isn't right. If
the link-local address is to be treated as an ID for the MN,
a duplicated link-local address is a problem whether the link
is pt-2-pt or shared; it is a MNs affiliation with a MAG that
matters - not what kind of link it is attached to.

If the link-local address is *not* to be treated as an ID for
the MN then DAD doesn't matter in either link case. The MAG
would have to do something non-standard like couple the
link-local address with a unique identifier for the MN in
its neighbor cache so that it could service two different
MNs with the same link-local address. But again, this would
work the same way whether the link was pt-2-pt or shared.

Fred