Subject: [netlmm] #104: Claim of location privacy shortcoming for dynamic home agent is not accurate

From: netlmm <[email-masked]>
Date: Mon, 31 Jul 2006 17:13:41 -0000

#104: Claim of location privacy shortcoming for dynamic home agent is not
accurate
------------------------------------------+---------------------------------
 Reporter:  [email-masked]      |       Owner:  [email-masked]
     Type:  defect                        |      Status:  new                     
 Priority:  minor                         |   Milestone:  milestone3              
Component:  draft-ietf-netlmm-nohost-req  |     Version:  2.0                     
 Keywords:  REQ draft                     |  
------------------------------------------+---------------------------------
 Jari Arkko, INT AD, submitted this comment during AD Review:

 >      Goal  #3  Location  privacy:  Location  privacy  is  preserved  for
 >      external correspondents, but the mobile node itself still maintains
 >      a  local  care-of  address.  If  the  mobile  node  performs  route
 >      optimization,  location  privacy  may  be  compromised,    but
 > not
 >      performing route optimization is no better than having a remote
 >      home agent.

 1) The privacy compromise argument rests on the mobile node
 knowingly doing something that harms itself. Surely mobile
 nodes that care about location privacy would avoid RO. I would
 suggest cutting the entire text to "Location privacy is preserved
 for external correspondents, assuming the mobile node itself
 does not disclose its care-of address in other ways."

 2) I have trouble parsing the last part about RO. But the way that
 I read it, it seems to claim that local HA with bidir tunneling
 is not any more efficient than a remote HA. This seems incorrect;
 a local HA ensures that that routing is in general fairly efficient.
 Without RO, some unnecessary paths may need to be taken, but
 at least they will not take you to the other side of the world and
 back.

-- 
Ticket URL: <http://www1.tools.ietf.org/wg/netlmm/trac/ticket/104>
netlmm <http://tools.ietf.org/wg/netlmm/>
_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: netlmm <[email-masked]>
Date: Mon, 31 Jul 2006 17:14:41 -0000

#104: Claim of location privacy shortcoming for dynamic home agent is not
accurate
-------------------------------------------+--------------------------------
  Reporter:  [email-masked]      |       Owner:  [email-masked]
      Type:  defect                        |      Status:  closed                  
  Priority:  minor                         |   Milestone:  milestone3              
 Component:  draft-ietf-netlmm-nohost-req  |     Version:  2.0                     
Resolution:  fixed                         |    Keywords:  REQ draft               
-------------------------------------------+--------------------------------
Changes (by [email-masked]):

  * resolution:  => fixed
  * status:  new => closed

Comment:

 Changed the text to the following:

 Goal #3 Location privacy: Location privacy is preserved for external
 correspondents as long as all of the mobile node's traffic is routed
 through the local HA.