Subject: [netlmm] Replay of RS in draft-ietf-netlmm-mn-ar-if

From: Christian Vogt <[email-masked]>
Date: Fri, 14 Jul 2006 23:06:28 +0200

According to the MN-AR Interface draft, a MN is registered by its MAG at
the LMA when the MN sends a SEND-authenticated RS (cf. section 4.2.2).

SEND uses a nonce in the RS to protect against replay of the RA.  But
the RS can still be replayed.

Proposed solution:  When the MAG receives an RS, it first sends an
authenticated NS, soliciting an authenticated NA from the MN.  When the
 NA is received, the MAG can authenticate the MN and securely register
it with the LMA.  (The NS-NA exchange, too, uses a nonce for replay
protection.  But in this case it is the MAG which can choose the nonce.)

A good place to put this new rule would be section 4.3.1, first bullet.
 Section 4.2.2 would require some slight modification.

Kind regards,
- Christian

-- 
Christian Vogt, Institute of Telematics, Universitaet Karlsruhe (TH)
www.tm.uka.de/~chvogt/pubkey/

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Christian Vogt <[email-masked]>
Date: Sat, 15 Jul 2006 00:30:09 +0200

Just noticed that an RS gets both a nonce /and/ a timestamp in SEND.  I
was assuming that it would only get a nonce.  Sorry, my mistake; there
is no replay threat (unless the replay takes place within the allowed
synchronization window, of course).

- Christian

Wassim Haddad wrote:
> On Fri, 14 Jul 2006, Christian Vogt wrote:
> 
> 
> => you're suggesting to solve a replay problem by adding two messages?
> Is it possible to use for example the synchronization (or pseudo-sync)
> with the AR to prevent replay?
> 
> 
> Regards,
> 
> Wassim H.

---

From: Wassim Haddad <[email-masked]>
Date: Sat, 15 Jul 2006 01:35:13 +0300 (EEST)

> synchronization window, of course).

=> Thanks for the info. That was my assumption in my previous email.

Cheers,
Wassim H.

---

From: Wassim Haddad <[email-masked]>
Date: Sat, 15 Jul 2006 00:59:39 +0300 (EEST)

Regards,

Wassim H.

---

From: Julien Laganier <[email-masked]>
Date: Sat, 15 Jul 2006 00:53:26 +0200

Christian,

On Friday 14 July 2006 23:06, Christian Vogt wrote:
> According to the MN-AR Interface draft, a MN is registered by its
> MAG at the LMA when the MN sends a SEND-authenticated RS (cf.
> section 4.2.2).
>
> SEND uses a nonce in the RS to protect against replay of the RA. 
> But the RS can still be replayed.

Anti-replay protections of RS is provided by the Timestamp option.

--julien

---

From: Christian Vogt <[email-masked]>
Date: Mon, 17 Jul 2006 09:57:00 +0200

Yes, see the email exchange between Wassim and me.

- Christian