Subject: Re: [netlmm] I-D Submission: draft-sgundave-mip6-proxymip6-01.txt

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 15 Jan 2007 13:09:58 -0800 (PST)

Hi Gerardo,

----- Original Message ----
From: Gerardo Giaretta <[email-masked]>
To: Sri Gundavelli <[email-masked]>
Cc: netlmm <[email-masked]>; Basavaraj Patil <[email-masked]>
Sent: Monday, January 15, 2007 11:47:53 AM
Subject: Re: [netlmm] I-D Submission: draft-sgundave-mip6-proxymip6-01.txt

Hi Sri,

actually this is something being discussed and proposed by some
companies in 3GPP SAE. So I think there are deployments looking at it,
this is why I raised the issue.

Are they proposing PMIP as the next generation 4G mobility technology from IETF?

--Gerardo

--behcet

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 15 Jan 2007 13:16:25 -0800 (PST)

I don't think Mobile IPv6 was originally designed to make the mobile
"feel itself home",
it was designed to have an HA-less mobility to the extent possible.

Regards,

--behcet

----- Original Message ----
From: "Tsirtsis, George" <[email-masked]>
To: "Chowdhury, Kuntal" <[email-masked]>; Haris Zisimopoulos <[email-masked]>; Sri Gundavelli <[email-masked]>; netlmm <[email-masked]>
Sent: Monday, January 15, 2007 10:31:54 AM
Subject: RE: [netlmm] I-D Submission: draft-sgundave-mip6-proxymip6-01.txt

Hi Harri/Kuntal,

Configuration is always possible, but I hope that, if implementations
behave :-), such configuration should not be necessary. Here is how I
view PMIP/CMIP interactions:

Mobiles that support client-mobility i.e., they support a MobileIP
client, need to be able to function in the presence of PMIP domains.

Assuming I understand draft-sgundave, network mobility domains are
supposed to appear to the Client-MobileIP stack as single links. Indeed,
while in a PMIP domain, a mobile node should believe that it is directly
connected to its home link. Note that "home link" here refers to the
link to which the IP address assigned by the PMIP domain to the mobile
belongs to. 

>From the mobile node perspective, an interface connected to a PMIP
domain looks like a single link i.e., Link Layer attachment changes are
not visible and the IP address assigned to the interface does not change
while the interface is connected to the same PMIP domain.

Now, if the PMIP domain is truly the mobile node's "home", in the Mobile
IP sense of the word then, while the mobile node is connected in the
PMIP domain, the MobileIP client is not registered to the HA i.e., the
mobile should behave according to RFC 2473 for mobiles connected to home
link.

If the PMIP domain is not the mobile node's "home" then, the Mobile IP
client can use the address assigned to the interface by the PMIP domain
as a CoA and thus, it should be able to perform a MIP registration to
its HA.

Also note, that mobiles that do not support client-mobility, work
exactly as above but, since they do not have a MobileIP client, they can
not use the address assigned by the PMIP domain as a CoA. In other words
if such a mobile moves out of the range of the PMIP domain, the "link"
will change and a new IP address will be assigned.

Does this make sense or did I miss something?

Best regards
George

> -----Original Message-----
> From: Chowdhury, Kuntal [mailto:[email-masked]]
> Sent: Monday, January 15, 2007 10:32 AM
> To: Haris Zisimopoulos; Sri Gundavelli; netlmm
> Subject: RE: [netlmm] I-D Submission:
draft-sgundave-mip6-proxymip6-01.txt
> 
> In PMIP6, there is no indication sent to the MN that the network is
> actually running a mobility management protocol to provide IP service
to
> the MN.
> 
> The choice of CMIP vs. PMIP can be a provisioned policy in the MN's
> network dialer software if there is any and if the MN has CMIP
> capability. This seems to be an implementation detail.
> 
> -Kuntal
> 
> 
> > -----Original Message-----
> > From: Haris Zisimopoulos [mailto:[email-masked]]
> > Sent: Monday, January 15, 2007 12:13 PM
> > To: Sri Gundavelli; netlmm
> > Subject: RE: [netlmm] I-D Submission:
> draft-sgundave-mip6-proxymip6-01.txt
> >
> > Hello,
> >
> > I have read this I-D it is really well written and comprehensive.
> >
> > I have one basic question that I could not answer by reading the
> draft.
> > Given that co-existence of host and proxy modes is one of the goals,
> > what are the procedures of handling MN roaming to domains that the
AR
> > does not support the PMA function? IOW section 6.9 handles the
> > procedures from PMA's point of view but is nowhere stated how the MN
> > will "understand" when it moves to a domain where the PMA function
is
> > not supported (ie PMIP not supported)? Maybe some flag in RA is
> required
> > to indicate that PMIP is enabled?  Is this simply implementation
> > specific maybe even such a statement would help.
> >
> > Any ideas?
> >
> > Best regards,
> > Haris
> >
> > > -----Original Message-----
> > > From: Sri Gundavelli [mailto:[email-masked]]
> > > Sent: 09 January 2007 17:14
> > > To: netlmm
> > > Subject: [netlmm] I-D Submission:
> draft-sgundave-mip6-proxymip6-01.txt
> > >
> > > FYI.
> > >
> > >
> > >
> > >
> > >
> > > A New Internet-Draft is available from the on-line
> > > Internet-Drafts directories.
> > >
> > >
> > >          Title : Proxy Mobile IPv6
> > >          Author(s) : S. Gundavelli, et al.
> > >          Filename : draft-sgundave-mip6-proxymip6-01.txt
> > >          Pages : 39
> > >          Date : 2007-1-5
> > >
> > > This specification describes a network-based mobility management
> > >     protocol.  It is called Proxy Mobile IPv6 (PMIPv6) and is
based
> on
> > >     Mobile IPv6.  This protocol is for providing mobility
> > > support to any
> > >     IPv6 host within a restricted and topologically localized
> > > portion of
> > >     the network and with out requiring the participation of
> > > the host in
> > >     any mobility related signaling.
> > >
> > > A URL for this Internet-Draft is:
> > > http://www.ietf.org/internet-drafts/draft-sgundave-mip6-proxym
> > > ip6-01.txt
> > >
> > > To remove yourself from the I-D Announcement list, send a
> > > message to i-d-announce-request@... with the word unsubscribe
> > > in the body of the message.
> > > You can also visit
> https://www1.ietf.org/mailman/listinfo/I-D-announce
> > > to change your subscription settings.
> > >
> > > Internet-Drafts are also available by anonymous FTP. Login
> > > with the username "anonymous" and a password of your e-mail
> > > address. After logging in, type "cd internet-drafts" and then
> > > "get draft-sgundave-mip6-proxymip6-01.txt".
> > >
> > > A list of Internet-Drafts directories can be found in
> > > http://www.ietf.org/shadow.html or
> > > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> > >
> > > Internet-Drafts can also be obtained by e-mail.
> > >
> > >