Subject: Re: [netlmm] I-D Submission: draft-sgundave-mip6-proxymip6-01.txt

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 11 Jan 2007 16:16:50 -0800 (PST)

----- Original Message ----
From: Sri Gundavelli <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: netlmm <[email-masked]>
Sent: Tuesday, January 9, 2007 11:58:31 AM
Subject: Re: [netlmm] I-D Submission: draft-sgundave-mip6-proxymip6-01.txt

Hi Behcet,

The draft has support for both the addressing models
and with the corresponding node configuration procedures.

1. Per-MN-Prefix: DHCP, Stateless Auto Address Config

2. Shared-Prefix: DHCP

There is a section on the interaction of the DHCP Relay
Agent and the Proxy Mobile Agent. In that section, we
have covered on the specifics of how the link-address
option (DHCPv6) or the giaddr field (DHCPv4) needs to
be set. That has to be set to the mobile's home prefix
and the DHCP server will allocate an addres from that
prefix block.

Sri

Sri I think you can have giaddr specified in Sec. 5.6 of your draft.
On p. 31 
A Binding Acknowledgment message that is sent by proxy mobile agent
   is also referred to as "Proxy Binding Acknowledgement"
PMA does not send PBack, right?

On Tue, 9 Jan 2007, Behcet Sarikaya wrote:

> Hi Sri,
> Nobody is commenting, let me comment.
> -What happened to giaddr?
> -I think that per-MN prefix is not an option on the home link as per draft-iab-multilink-subnet-issues-02.txt?
>
Regards,
--behcet

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 11 Jan 2007 16:22:14 -0800 (PST)

> Sri I think you can have giaddr specified in Sec. 5.6 of your draft.

Right. We support IPv4 HoA mobility. If the mobile sends a DHCPv4
request and if the network policy permits IPv4 roaming support,
the relay agent needs to set the giaddr field in the DHCPv4 requests.
PMA sends the Proxy Binding Update with the IPv4 HoA option and
the HA responds with the Proxy Binding Ack.

Sri