Subject: RE: [netlmm] I-D Submission: draft-sgundave-mip6-proxymip6-01.txt

From: "Haris Zisimopoulos" <[email-masked]>
Date: Mon, 15 Jan 2007 11:13:07 -0000

Hello,

I have read this I-D it is really well written and comprehensive.

I have one basic question that I could not answer by reading the draft.
Given that co-existence of host and proxy modes is one of the goals,
what are the procedures of handling MN roaming to domains that the AR
does not support the PMA function? IOW section 6.9 handles the
procedures from PMA's point of view but is nowhere stated how the MN
will "understand" when it moves to a domain where the PMA function is
not supported (ie PMIP not supported)? Maybe some flag in RA is required
to indicate that PMIP is enabled?  Is this simply implementation
specific maybe even such a statement would help.

Any ideas?

Best regards,
Haris

> -----Original Message-----
> From: Sri Gundavelli [mailto:[email-masked]] 
> Sent: 09 January 2007 17:14
> To: netlmm
> Subject: [netlmm] I-D Submission: draft-sgundave-mip6-proxymip6-01.txt
> 
> FYI.
> 
> 
> 
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> 
> 
>          Title : Proxy Mobile IPv6
>          Author(s) : S. Gundavelli, et al.
>          Filename : draft-sgundave-mip6-proxymip6-01.txt
>          Pages : 39
>          Date : 2007-1-5
> 
> This specification describes a network-based mobility management
>     protocol.  It is called Proxy Mobile IPv6 (PMIPv6) and is based on
>     Mobile IPv6.  This protocol is for providing mobility 
> support to any
>     IPv6 host within a restricted and topologically localized 
> portion of
>     the network and with out requiring the participation of 
> the host in
>     any mobility related signaling.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-sgundave-mip6-proxym
> ip6-01.txt
> 
> To remove yourself from the I-D Announcement list, send a 
> message to i-d-announce-request@... with the word unsubscribe 
> in the body of the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username "anonymous" and a password of your e-mail 
> address. After logging in, type "cd internet-drafts" and then 
> "get draft-sgundave-mip6-proxymip6-01.txt".
> 
> A list of Internet-Drafts directories can be found in 
> http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> 
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/netlmm
> 

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Sri Gundavelli <[email-masked]>
Date: Mon, 15 Jan 2007 08:26:31 -0800 (PST)

Hi Haris,

> specific maybe even such a statement would help.

The presence of the Home Prefix in the Router Advertisement is an
indication about the availability of the proxy service on the link.
Typically, the PMIP nodes are configured to be on a virtual link on
the home agent and so the presence of the home prefix implies it is
on a link supported by a proxy mobile agent. If the mobile moves to
a link that has no proxy mobile agent service on that link, the
advertised prefix it would see is that of a local prefix from the
visitor network and not its home prefix. This is more implied and
there is no explicit way. Probably, as in Mobile IPv4, having a bit 
advertising the proxy mobile agent service, makes sense. We will
discuss about this.

Regards
Sri