Subject: [netlmm] Terminology confusion in draft-sgundave-mip6-proxymip6-01

From: "Narayanan, Vidya" <[email-masked]>
Date: Tue, 16 Jan 2007 14:15:48 -0800

All,
Having followed all the discussion, I think there is some confusion due
to the re-use of MIP6 terminology in this draft. I suggest that we
really focus on the PMIP6 functionality and design, and use terminology
that can clearly distinguish it from MIP6. So, I suggest the following
terms: 

1. PMA (Proxy Mobility Agent) or MAG (Mobility Access Gateway)
2. LMA (Local Mobility Agent) 
3. PMIP IP Address (PIA) (Address assigned to the MN in the PMIP domain)
4. PMIP Tunnel Address (PTA) (Address of the PMA to which packets are to
be sent)

Particularly, since there are several possible realizations of MIP6 and
PMIP6 feasible in a system, using the same terminology leads to
confusion. As far as this protocol is concerned, it should have its own
functional entities. Depending on architecture choices, the functional
elements of MIP6 and PMIP6 may be collocated. 

Vidya

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Julien Laganier <[email-masked]>
Date: Wed, 17 Jan 2007 09:55:37 +0100

Hi Vidya,

As I said earlier, I support using the NETLMM 
terminology we've been using since the WG started. I 
agree with you that re-use of MIP6 terminology is 
confusing (That was one reason why we defined LMA in 
the first place, to avoid confusion with the HMIPv6 
MAP entity.)

Best,

--julien

On Tuesday 16 January 2007 23:15, Narayanan, Vidya 
wrote:
> All,
> Having followed all the discussion, I think there is
> some confusion due to the re-use of MIP6 terminology
> in this draft. I suggest that we really focus on the
> PMIP6 functionality and design, and use terminology
> that can clearly distinguish it from MIP6. So, I
> suggest the following terms:
>
> 1. PMA (Proxy Mobility Agent) or MAG (Mobility
> Access Gateway) 2. LMA (Local Mobility Agent)
> 3. PMIP IP Address (PIA) (Address assigned to the MN
> in the PMIP domain) 4. PMIP Tunnel Address (PTA)
> (Address of the PMA to which packets are to be sent)
>
> Particularly, since there are several possible
> realizations of MIP6 and PMIP6 feasible in a system,
> using the same terminology leads to confusion. As
> far as this protocol is concerned, it should have
> its own functional entities. Depending on
> architecture choices, the functional elements of
> MIP6 and PMIP6 may be collocated.
>
> Vidya
>