Subject: [netlmm] some comments on Sri's draft

From: "Sangjin Jeong" <[email-masked]>
Date: Sun, 18 Mar 2007 06:58:33 +0100

Hi Sri,

I think the draft is well-written, however, there exist some issues
related to IPv4 support that are not clear and need to be considered.

The draft describes data tunneling in order to transport IPv6 or IPv4
packet over IPv4-UDP encapsulation in the IPv4 network supporting
NAT. However, the way about MN's IPv4 home link emulation under
NAT does not seem to be clearly explained, IMHO.

Let me consider IPv4-only network between LMA and MAG.
According to the draft, MAG can support IPv4 NAT.

1) When IPv4-only MN boots up in the access network supporting
NAT, the MN will be assigned IPv4 private address. Then, MAG
will perform Proxy BU including MN's IPv4 HoA (private address)
according to DS-MIPv6.

LMA will create binding cache and routing entry containing IPv4
private address. Thus, the following routing table entry will be
created for the MN's IPv4 HoA.
=========
IPv4-MN HoA(priv addr)/32 via tunnel ID, next hop IPv4 Proxy CoA
=========

Therefore, I am wondering how IPv4 CN can send packets destined
to MN's HoA.

2) Let me assume that there are two MAGs, namely MAG#1 and
MAG#2. MAG#1 has public IPv4 address prefix and MAG#2 has
private IPv4 address prefix (i.e., MAG#2 supports NAT).

When IPv4-only MN boots up in MAG#2's access network, the MN
will be assigned IPv4 MN-HoA in private address prefix. Later, if
the MN moves into MAG#1's access network, then MAG#1 will
detects the MN's attachment and perform Proxy BU with MN's IPv4
MN-HoA (private IPv4 address)

In that case, does the Proxy BU sent to LMA include MN's IPv4
MN HoA? Also, does the MN keep its previously assigned private IP
address in the access network supporting public IPv4 address?

If so, binding cache and routing entry in LMA will include private
IPv4 address. MN's roaming from MAG#1 to MAG#2 causes similar
issues.

IMHO, in order to apply the NAT traversal scheme proposed in
DS-MIPv6 to PMIPv6, more consideration may be needed.

Regards,
Sangjin

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Sri Gundavelli" <[email-masked]>
Date: Tue, 20 Mar 2007 02:34:01 -0700

Hi Sangjin,

Please see inline.

Sri

> -----Original Message-----
> From: Sangjin Jeong [mailto:[email-masked]] 
> Sent: Monday, March 19, 2007 5:01 PM
> To: Sri Gundavelli
> Cc: [email-masked]
> Subject: Re: FW: some comments on Sri's draft
> 
> Hi Sri,
> 
> Thanks for kind explanation.
> Please see inline.
> 
> Regards,
> Sangjin
> 
> > >
> >
> > The NAT support in DSMIP6 or even in MIPv4 NAT Traversal is for
> > supporting the scenario where the IPv4-CoA address or one 
> end-point of
> > the tunnel is a private IPv4 translated address. The 
> scenario you are
> > referring to is about a private home address i.e Private 
> IPv4-MN-HoA.
> > Just to emphasize, the address the mobile node is assigned 
> in the access
> > network is from the mobile node's IPv4 Home Network Prefix 
> and not from
> > a prefix on the access link.
> 
> Let me assume that an access router supports MAG function and NAT.
> In that case, the access router would have DHCP server 
> function so as to
> assign private IP address to hosts in the access network 
> (private net).
> 
> Also, the access router would require DHCP relay function in order to
> relay DHCP message from mobile node to DHCP sever that will assign
> IPv4 Home Network Prefix to the mobile node.
> 
> Therefore, when a mobile node powers up in a private access network
> and initiates DHCP procedure by sending DHCPDISCOVER message,
> I am wondering how the access router will decide whether to relay the
> DHCP message to DHCP server that has IPv4 Home Network Prefix or
> to assign a private IP address to the mobile node by DHCP server in
> the access router.
> I am not sure if DHCP specification supports such function.
> 

This was discussed in the mailing list before and also explained in
Section 6.12 and 6.10 of the document.

When a mobile node attaches to an access link in the Proxy Mobile IPv6
domain, after the access authentication, the network knows the mobile
by its MN-Identifier and it has access to the configuration or policy
data, on if the network needs to offer network-based mobility. Please
see the doc ...

Sri