Subject: [netlmm] comments on draft-singh-

From: "JinHyeock Choi" <[email-masked]>
Date: Tue, 13 Mar 2007 21:00:08 +0900

Dear Singh

I have a question.

Trigger message ordering.
- How can a PMIP client correctly order Trigger messages when it
receives multiple of them?

Thanks for your kind consideration.

Best Regards

JinHyeock

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Singh Ajoy-ASINGH1" <[email-masked]>
Date: Tue, 13 Mar 2007 18:34:14 -0400

Hi, JinHyeock, 

Thanks for reviewing the draft. TRIGGER message has transaction ID 
which is similar to sequence number.  Transaction ID can be used to
order 
TRIGGER message. Please let me know if this is not clear. 

Regards,
Ajoy 

-----Original Message-----
From: JinHyeock Choi [mailto:[email-masked]] 
Sent: Tuesday, March 13, 2007 7:00 AM
To: Singh Ajoy-ASINGH1
Cc: Narayanan, Vidya; [email-masked]
Subject: comments on draft-singh-

Dear Singh

I have a question.

Best Regards

JinHyeock

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 13 Mar 2007 23:59:41 +0100

Singh Ajoy-ASINGH1 wrote:
> order TRIGGER message. Please let me know if this is not clear.

A related question isn't clear in draft-sgundave.  For example it's not
known by what means can AR (PMIPv6) know which NAI correspond to which
homenetwork-prefix (to put in giaddr or link-address).  This is needed 
when there are more mobiles connecting to an AR, and different 
homenetwork-prefixes.  This mapping is referred to some interaction:

draft-sgundave:
> However, on the shared links supporting multiple mobile nodes with
> different home prefixes, there is some interaction required between
> the relay agent and the mobile access gateway, for setting the
> link-address field to the requesting mobile node's home network
> prefix.

Alex

> 
> Regards, Ajoy
> 
> 
> -----Original Message----- From: JinHyeock Choi
> [mailto:[email-masked]] Sent: Tuesday, March 13, 2007 7:00 AM To:
> Singh Ajoy-ASINGH1 Cc: Narayanan, Vidya; [email-masked] Subject:
> comments on draft-singh-
> 
> Dear Singh
> 
> I have a question.
> 
> Trigger message ordering. - How can a PMIP client correctly order
> Trigger messages when it receives multiple of them?
> 
> _______________________________________________ netlmm mailing list 
> [email-masked] https://www1.ietf.org/mailman/listinfo/netlmm
> 

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________

---

From: "JinHyeock Choi" <[email-masked]>
Date: Wed, 14 Mar 2007 09:47:22 +0900

Ajoy

Thanks for the prompt reply.

> TRIGGER message. Please let me know if this is not clear.

What if two TRIGGER messages come from different MAGs? Can Transaction
ID work in that case? (Seq number in Binding Update message can't
order BUs arriving from different MAGs.)

Best Regards

JinHyeock

---

From: "Singh Ajoy-ASINGH1" <[email-masked]>
Date: Wed, 14 Mar 2007 11:05:33 -0400

Hi,  JinHyeock, 

Correct! Probably we need to clarify this that transaction ID along with
MAG source IP address will be used 
to re-sequence TRIGGER messages. Also, since SCTP is used as transport
between MAG and PMIP client 
so perhaps we should clarify that TRANSACTION ID will be used to order
TRIGGER messages received on 
a given SCTP connection. Please let me know if you see any issue with
approach or I am missing your comment 
all together.  

Regards,
Ajoy  

-----Original Message-----
From: JinHyeock Choi [mailto:[email-masked]] 
Sent: Tuesday, March 13, 2007 7:47 PM
To: Singh Ajoy-ASINGH1
Cc: Narayanan, Vidya; [email-masked]
Subject: Re: comments on draft-singh-

Ajoy

What if two TRIGGER messages come from different MAGs? Can Transaction
ID work in that case? (Seq number in Binding Update message can't order
BUs arriving from different MAGs.)

Best Regards

JinHyeock

---

From: "JinHyeock Choi" <[email-masked]>
Date: Thu, 15 Mar 2007 10:30:15 +0900

Hi Ajoy

> approach or I am missing your comment

Thanks for your kind elaboration but I still can't understand how
TRIGGER messages from different MAGs can be ordered with TRANSACTION
ID.

Or TRANSACTION ID is only for ordering TRIGGER messages from the same MAG?

Best Regards

JinHyeock

---

From: "Singh Ajoy-ASINGH1" <[email-masked]>
Date: Thu, 15 Mar 2007 12:58:00 -0400

Hi, JinHyeock,

Thanks for your review again. Please find inline response. 

Regards,
Ajoy 

-----Original Message-----
From: JinHyeock Choi [mailto:[email-masked]] 
Sent: Wednesday, March 14, 2007 8:30 PM
To: Singh Ajoy-ASINGH1
Cc: Narayanan, Vidya; [email-masked]
Subject: Re: comments on draft-singh-

Hi Ajoy

> Correct! Probably we need to clarify this that transaction ID along 
> with MAG source IP address will be used to re-sequence TRIGGER 
> messages. Also, since SCTP is used as transport between MAG and PMIP 
> client so perhaps we should clarify that TRANSACTION ID will be used 
> to order TRIGGER messages received on a given SCTP connection. Please 
> let me know if you see any issue with approach or I am missing your 
> comment all together.

Thanks for your kind elaboration but I still can't understand how
TRIGGER messages from different MAGs can be ordered with TRANSACTION ID.

Or TRANSACTION ID is only for ordering TRIGGER messages from the same
MAG?

Ajoy-> I see your point now. I guess we need to extend TRIGGER message
to support timestamp options. 
The timestamp option can be used by PMIP client to order TRIGGER
messages received from various MAGs. 
We will make this change in next update. This will also require time
synchronization between 
PMIP client and MAG which is ok because both will be part of same
domain. Hope this clarifies your point. 

Best Regards

JinHyeock

---

From: "JinHyeock Choi" <[email-masked]>
Date: Fri, 16 Mar 2007 11:15:54 +0900

Dear Ajoy

> domain. Hope this clarifies your point.

yes. With timestamp option, I guess PMIP client can order the TRIGGER
messages. Thanks for your clarification.

Best Regards

JinHyeock

---

From: "Singh Ajoy-ASINGH1" <[email-masked]>
Date: Fri, 16 Mar 2007 01:30:26 -0400

Dear  JinHyeock,

Thanks for your review. We will make this change in next update. 

Regards,
Ajoy 

-----Original Message-----
From: JinHyeock Choi [mailto:[email-masked]] 
Sent: Thursday, March 15, 2007 9:16 PM
To: Singh Ajoy-ASINGH1
Cc: Narayanan, Vidya; [email-masked]
Subject: Re: comments on draft-singh-

Dear Ajoy

ID.
> synchronization between PMIP client and MAG which is ok because both 
> will be part of same domain. Hope this clarifies your point.

Best Regards

JinHyeock