Subject: RE: [netlmm] Re: SDOs and NETLMM WG

From: "Singh Ajoy-ASINGH1" <[email-masked]>
Date: Fri, 9 Mar 2007 10:51:06 -0500

Hi, Lalit, 
 
Thanks for your comments. Sure,  I believe that we are on track with
respect to timeline. 
We should be able to meet the quality as well as timeline. We just need
some more 
co-ordination between two drafts. I myself is very interested to get the

work done in timely manner. But let us make the solution good enough so
that various SDOs
will find it both usable and compelling.  One way to focus on this
solution will be to standardize 
IPv6 only support and focus on IPv4 support in seperate document. 
 
Regards,
Ajoy 

________________________________

From: [email-masked]
[mailto:[email-masked]] 
Sent: Friday, March 09, 2007 8:59 AM
To: Singh Ajoy-ASINGH1; Basavaraj Patil; Chowdhury, Kuntal; Alexandru
Petrescu; Hidetoshi Yokota
Cc: [email-masked]
Subject: RE: [netlmm] Re: SDOs and NETLMM WG

Ajoy and others
 
Timeline for availability of IETF PMIP protocol is extremely important.
Your comment about quality of protocol is agreed as long as it meets the
timeline. Group could agree on base protocol and come up enhancement
list to be worked on as part of the netLMM WG item. If IETF PMIP
protocol is not available at the right time, some SDOs may choose other
non-IETF protocol, instead
 
Regards
Lalit

________________________________

From: Singh Ajoy-ASINGH1 [mailto:[email-masked]]
Sent: Thu 3/8/2007 2:17 PM
To: Basavaraj Patil; Chowdhury, Kuntal; Alexandru Petrescu; Hidetoshi
Yokota
Cc: [email-masked]
Subject: RE: [netlmm] Re: SDOs and NETLMM WG

Hi, Raj,

Thanks for your response. Please find my inline responses.

Regards,
Ajoy 

-----Original Message-----
From: Basavaraj Patil [mailto:[email-masked]]
Sent: Thursday, March 08, 2007 3:22 PM
To: Singh Ajoy-ASINGH1; Chowdhury, Kuntal; Alexandru Petrescu; Hidetoshi
Yokota
Cc: [email-masked]
Subject: Re: [netlmm] Re: SDOs and NETLMM WG

Ajoy et al,

This discussion on which SDOs have expressed interest in PMIP6 and what
is the timeline for it being available is not really productive.

Ajoy-> Agreed. I was trying to clarify this because there was some
confusion on the list.

If the same energies were spent on analysing the I-Ds and discussing
technical content we would be making forward progress (instead of the
current state where we debate endlessly on issues that do not result in
the work moving forward).

Ajoy-> Absolutely. We need to review technical contents of various docs
and make objective assessment. 
I think we have been making good progress. We have been updating draft
based upon mailing list consensus and discussion.

IMO, we in the IETF are responsible for specifying a protocol for
Netlmm.
How the SDOs use the specification is not our concern. If the SDOs have
some specific requirements for a netlmm protocol, they can just as well
make them known in the netlmm WG. There really is no value in finding
out what any of the SDOs opinion is about any of these drafts, because
the netlmm WG is not going to make a choice based on what another
external SDO prefers or thinks.

Ajoy-> I am not sure if I agree with this. If the customer of our
protocol is various SDOs, we will have to care about their requirements.

Also, we will also have to know how a given protocol will be used by
various SDOs. If we do not make such assumption, we will end-up defining
incompatible protocol.
Incompatible protocol is not going to help anyone.

People from the SDOs are just as welcome to express their views in the
netlmm WG where the discussion is open.

Ajoy-> Sure

Regarding the timeline for when this work can be completed, I think we
can stop speculating about it and instead let the chairs make a
determination.
The charters goals will no doubt need to be revised because the current
milestones are not aligned with the changes that have occurred since
IETF67.

Ajoy-> Sure, I care about quality of protocol. We should not compromise
quality for timeline.

-Raj

On 3/8/07 1:56 PM, "ext Singh Ajoy-ASINGH1" <[email-masked]>
wrote:

> I agree that SDOs are interested in PMIPv6 protocol.
> However, it is not clear to me that enough discussion has taken place
> in SDOs about details of both proposals being discussed in IETF.
> As far as I am aware, WIMAX Forum is targeting to discuss both drafts
> in
>
> next planery call.
>
> Regards,
> Ajoy
> 
>
> -----Original Message-----
> From: Chowdhury, Kuntal [mailto:[email-masked]]
> Sent: Thursday, March 08, 2007 10:13 AM
> To: Alexandru Petrescu; Hidetoshi Yokota
> Cc: Singh Ajoy-ASINGH1; [email-masked]
> Subject: RE: [netlmm] Re: SDOs and NETLMM WG
>
> All three wireless SDOs have expressed interest in PMIP6 based
solution.
> Besides 3GPP2, WiMAX Forum also sent a communication to IETF regarding

> this requirement. 3GPP SAE (TS 23.402/TR 23.882) has dependencies on
> PMIP6. See 3GPP dependency list for more info.
>
> This is certainly not a 1-3 year project. If PMIP6 spec does not come
> out of IETF in 2007, every SDOs publication schedule will be impacted.
> So, moving fast on the base draft is the most important task for the
> netlmm WG, IMHO.
>
> -Kuntal
>
>
>> -----Original Message-----
>> From: Alexandru Petrescu [mailto:[email-masked]]
>> Sent: Thursday, March 08, 2007 8:26 AM
>> To: Hidetoshi Yokota
>> Cc: Singh Ajoy-ASINGH1; [email-masked]
>> Subject: [netlmm] Re: SDOs and NETLMM WG
>>
>> Hidetoshi Yokota wrote:
>>>> Currently, only 3GPP2 TSG-X has made a statement relayed through
>>>> our liaison.  That statement talks about need to do proxy mobile ip
>
>>>> based solution.  It says nothing about the timeliness needed.  See
>>>> the PostScriptum with the relevant mail.
>>>
>>> If liaison statements from other SDOs could speed up the IETF
> process
>>> by stating the timeline, then they would probably do so. But I don't
>
>>> think IETF works that way... (I may be wrong, though)
>>
>> Right.  So what is the timeline you think these SDOs expect?  3years
> is
>> fine?  1year is necessary?
>>
>> Just saying SDO needs this quick gives no hint about how we could
> plan.
>>
>>>> At the same time, the NETLMM WG has not made any statement back to
>
>>>> 3GPP through our liaison.
>>>>
>>>> If I'm to interpret the request from 3GPP technically I consider
>>>> the draft-singh much more appropriated to 3GPP needs (has PMIP
>>>> client relocation) than draft-sgundave (has not).
>>>
>>> This type of relocation would also be beneficial for 3GPP2, but my
>>> take is that this can be regarded as an extension to the base
>>> protocol.
>>
>> It can.  The minimal conditions between the two is to refer to each
>> other.  HEre's one example:
>>
>> draft-sgundave:
>>> When the mobile node attaches to an access link connected to the
>>> mobile access gateway, the mobile node presents its identity, MN-
>>> Identifier, as part of the access access authentication procedure.
>>> After a successful access authentication, the mobile access gateway
>>> obtains the mobile node's profile from the policy store, such as
> from
>>>  a AAA infrastructure.  The mobile access gatway would have all the
>>> information for it to emulate the mobile node's home network on the
>>> access link.  The mobile access gateway also starts sending periodic
>
>>> Router Advertisements to the mobile node advertising its home
> network
>>>  prefix.
>>
>>
>> draft-singh:
>>> 2. After receiving the prefix as part of the router advertisement
>>> from MAG1, the MN attempts to acquire another IP address, called the
>
>>> Proxy Home Address (pHoA) associated with the advertised prefix. The
>
>>> MN issues a DHCP request and a DHCP server assigns a pHoA consistent
>
>>> with the advertised prefix.
>>
>> One uses DHCP the other uses RA.  For one the other is in Appendix.
> So
>> should these be combined?
>>
>> Alex
>>
>>
>> _____________________________________________________________________
>> _ This email has been scanned by the MessageLabs Email Security
>> System.
>> For more information please visit http://www.messagelabs.com/email
>> _____________________________________________________________________
>> _
>>
>> _______________________________________________
>> netlmm mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/netlmm
>
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

The information contained in this message and any attachment may be
proprietary, confidential, and privileged or subject to the work
product doctrine and thus protected from disclosure.  If the reader
of this message is not the intended recipient, or an employee or
agent responsible for delivering this message to the intended
recipient, you are hereby notified that any dissemination,
distribution or copying of this communication is strictly prohibited.
If you have received this communication in error, please notify me
immediately by replying to this message and deleting it and all
copies and backups thereof.  Thank you.

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Fri, 9 Mar 2007 10:57:34 -0500

________________________________________
From: Singh Ajoy-ASINGH1 [mailto:[email-masked]] 
Sent: Friday, March 09, 2007 10:51 AM
To: [email-masked]; Basavaraj Patil; Chowdhury, Kuntal; Alexandru Petrescu; Hidetoshi Yokota
Cc: [email-masked]
Subject: RE: [netlmm] Re: SDOs and NETLMM WG

Hi, Lalit, 
 
Thanks for your comments. Sure,  I believe that we are on track with respect to timeline. 
We should be able to meet the quality as well as timeline. We just need some more 
co-ordination between two drafts. I myself is very interested to get the 
work done in timely manner. But let us make the solution good enough so that various SDOs
will find it both usable and compelling.  One way to focus on this solution will be to standardize 
IPv6 only support and focus on IPv4 support in seperate document. 
 
KC> I don't think we should take the IPv4 support out of the base spec. It is very important that the base spec supports IPv4 and IPv6 (addressing and transport) so that a comprehensive solution is available ASAP. The draft-sgundave has this support, and I don't believe we need to take this out.

-Kuntal

Regards,
Ajoy 

________________________________________
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, March 09, 2007 8:59 AM
To: Singh Ajoy-ASINGH1; Basavaraj Patil; Chowdhury, Kuntal; Alexandru Petrescu; Hidetoshi Yokota
Cc: [email-masked]
Subject: RE: [netlmm] Re: SDOs and NETLMM WG
Ajoy and others
 
Timeline for availability of IETF PMIP protocol is extremely important. Your comment about quality of protocol is agreed as long as it meets the timeline. Group could agree on base protocol and come up enhancement list to be worked on as part of the netLMM WG item. If IETF PMIP protocol is not available at the right time, some SDOs may choose other non-IETF protocol, instead
 
Regards
Lalit
________________________________________
From: Singh Ajoy-ASINGH1 [mailto:[email-masked]]
Sent: Thu 3/8/2007 2:17 PM
To: Basavaraj Patil; Chowdhury, Kuntal; Alexandru Petrescu; Hidetoshi Yokota
Cc: [email-masked]
Subject: RE: [netlmm] Re: SDOs and NETLMM WG
Hi, Raj,

Regards,
Ajoy 

-----Original Message-----
From: Basavaraj Patil [mailto:[email-masked]]
Sent: Thursday, March 08, 2007 3:22 PM
To: Singh Ajoy-ASINGH1; Chowdhury, Kuntal; Alexandru Petrescu; Hidetoshi
Yokota
Cc: [email-masked]

Ajoy et al,

Ajoy-> Sure

-Raj

solution.

---

From: "Singh Ajoy-ASINGH1" <[email-masked]>
Date: Fri, 9 Mar 2007 11:02:30 -0500

Kuntal,

Even draft-singh has IPv4 support as well. The point is not about which draft has what kind of support. 
Rather does transition scenario should belong to base draft. If we can learn anything from past 
IETF work, we should know that traditionally IETF has not included transition scenario in base draft. 
Let us look at base MIPv6 spec. It does not define transition scenario. Dual stack support is defined as extension. 

Regards,
Ajoy  

-----Original Message-----
From: Chowdhury, Kuntal [mailto:[email-masked]] 
Sent: Friday, March 09, 2007 9:58 AM
To: Singh Ajoy-ASINGH1; [email-masked]; Basavaraj Patil; Alexandru Petrescu; Hidetoshi Yokota
Cc: [email-masked]
Subject: RE: [elm] Re: SDOs and NETLMM WG

Hi, Lalit, 
 
Thanks for your comments. Sure,  I believe that we are on track with respect to timeline. 
We should be able to meet the quality as well as timeline. We just need some more co-ordination between two drafts. I myself is very interested to get the work done in timely manner. But let us make the solution good enough so that various SDOs will find it both usable and compelling.  One way to focus on this solution will be to standardize
IPv6 only support and focus on IPv4 support in seperate document. 

-Kuntal

Regards,
Ajoy 

Subject: RE: [netlmm] Re: SDOs and NETLMM WG Ajoy and others

Regards
Lalit
Subject: RE: [netlmm] Re: SDOs and NETLMM WG Hi, Raj,

Regards,
Ajoy 

-----Original Message-----
From: Basavaraj Patil [mailto:[email-masked]]
Sent: Thursday, March 08, 2007 3:22 PM
To: Singh Ajoy-ASINGH1; Chowdhury, Kuntal; Alexandru Petrescu; Hidetoshi Yokota
Cc: [email-masked]
Subject: Re: [netlmm] Re: SDOs and NETLMM WG

Ajoy et al,

This discussion on which SDOs have expressed interest in PMIP6 and what is the timeline for it being available is not really productive.

If the same energies were spent on analysing the I-Ds and discussing technical content we would be making forward progress (instead of the current state where we debate endlessly on issues that do not result in the work moving forward).

Ajoy-> Absolutely. We need to review technical contents of various docs
and make objective assessment.
I think we have been making good progress. We have been updating draft based upon mailing list consensus and discussion.

IMO, we in the IETF are responsible for specifying a protocol for Netlmm.
How the SDOs use the specification is not our concern. If the SDOs have some specific requirements for a netlmm protocol, they can just as well make them known in the netlmm WG. There really is no value in finding out what any of the SDOs opinion is about any of these drafts, because the netlmm WG is not going to make a choice based on what another external SDO prefers or thinks.

Also, we will also have to know how a given protocol will be used by various SDOs. If we do not make such assumption, we will end-up defining incompatible protocol.
Incompatible protocol is not going to help anyone.

People from the SDOs are just as welcome to express their views in the netlmm WG where the discussion is open.

Ajoy-> Sure

Regarding the timeline for when this work can be completed, I think we can stop speculating about it and instead let the chairs make a determination.
The charters goals will no doubt need to be revised because the current milestones are not aligned with the changes that have occurred since IETF67.

-Raj

solution.

The information contained in this message and any attachment may be proprietary, confidential, and privileged or subject to the work product doctrine and thus protected from disclosure.  If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited.
If you have received this communication in error, please notify me immediately by replying to this message and deleting it and all copies and backups thereof.  Thank you.

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Fri, 9 Mar 2007 11:07:37 -0500

Ajoy,

The point I am making is that, we don't have to define IPv4 support in a separate draft simply because similar approach was taken in the past. DSMIP6 extensions are available for us to use in the PMIP6 base protocol so that it becomes a comprehensive solution document. I do not believe taking out IPv4 support from the base PMIP6 spec is going to speed up the process.

-Kuntal

-----Original Message-----
From: Singh Ajoy-ASINGH1 [mailto:[email-masked]] 
Sent: Friday, March 09, 2007 11:03 AM
To: Chowdhury, Kuntal; [email-masked]; Basavaraj Patil; Alexandru Petrescu; Hidetoshi Yokota
Cc: [email-masked]
Subject: RE: [elm] Re: SDOs and NETLMM WG

Kuntal,

Regards,
Ajoy  

-----Original Message-----
From: Chowdhury, Kuntal [mailto:[email-masked]] 
Sent: Friday, March 09, 2007 9:58 AM
To: Singh Ajoy-ASINGH1; [email-masked]; Basavaraj Patil; Alexandru Petrescu; Hidetoshi Yokota
Cc: [email-masked]
Subject: RE: [elm] Re: SDOs and NETLMM WG

Hi, Lalit, 

-Kuntal

Regards,
Ajoy 

 
Regards
Lalit

Regards,
Ajoy 

-----Original Message-----
From: Basavaraj Patil [mailto:[email-masked]]
Sent: Thursday, March 08, 2007 3:22 PM
To: Singh Ajoy-ASINGH1; Chowdhury, Kuntal; Alexandru Petrescu; Hidetoshi Yokota
Cc: [email-masked]
Subject: Re: [netlmm] Re: SDOs and NETLMM WG

Ajoy et al,

Ajoy-> Sure

-Raj

solution.

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 09 Mar 2007 17:14:58 +0100

Chowdhury, Kuntal wrote:
> 
> ________________________________________ From: Singh Ajoy-ASINGH1
> [mailto:[email-masked]] Sent: Friday, March 09, 2007 10:51 AM 
> To: [email-masked]; Basavaraj Patil; Chowdhury,
> Kuntal; Alexandru Petrescu; Hidetoshi Yokota Cc: [email-masked] 
> respect to timeline. We should be able to meet the quality as well as
> timeline. We just need some more co-ordination between two drafts. I
> myself is very interested to get the work done in timely manner. But
> let us make the solution good enough so that various SDOs will find
> it both usable and compelling.  One way to focus on this solution
> will be to standardize IPv6 only support and focus on IPv4 support in
> seperate document.
> 
> KC> I don't think we should take the IPv4 support out of the base
> spec. It is very important that the base spec supports IPv4 and IPv6
> (addressing and transport) so that a comprehensive solution is
> available ASAP. The draft-sgundave has this support, and I don't
> believe we need to take this out.

The question is _how_ to support IPv4 support.

The current draft-sgundave PMIPv6 talks mainly in terms of DS-MIPv6. 
DS-MIPv6 is an extension to MIPv6 protocol, under development in the 
MIP6 WG.

There are other possible ways of supporting IPv4 for PMIPv6, some of 
them published: PMIPv4, DS-MIPv4, or even 6to4, TEREDO and ISATAP.

A problem statement is necessary on which we agree _how_ we support IPv4 
with PMIP in netlmm space.  Such a problem statement draft is written, 
I've referred to it.  Ignoring it and jumping straight to DS-MIPv6 is 
not good.

Also, I think one is aware that IPv6 requirements in some of the SDOs 
don't talk DS-MIPv6 but talk ISATAP TEREDO and 6to4.

In this context, I think a unilateral decision by draft-sgundave PMIPv6 
solution's authors to use DS-MIPv6 is a bit too hurry.

So, the time to figure out how to use IPv4, just leave IPv4 out, 
document is shorter, progresses faster.

Alex

> 
> -Kuntal
> 
> 
> Regards, Ajoy
> 
> ________________________________________ From:
> [email-masked]
> [mailto:[email-masked]] Sent: Friday, March 09,
> 2007 8:59 AM To: Singh Ajoy-ASINGH1; Basavaraj Patil; Chowdhury,
> Kuntal; Alexandru Petrescu; Hidetoshi Yokota Cc: [email-masked] 
> Timeline for availability of IETF PMIP protocol is extremely
> important. Your comment about quality of protocol is agreed as long
> as it meets the timeline. Group could agree on base protocol and come
> up enhancement list to be worked on as part of the netLMM WG item. If
> IETF PMIP protocol is not available at the right time, some SDOs may
> choose other non-IETF protocol, instead
> 
> Regards Lalit ________________________________________ From: Singh
> Ajoy-ASINGH1 [mailto:[email-masked]] Sent: Thu 3/8/2007 2:17 PM
>  To: Basavaraj Patil; Chowdhury, Kuntal; Alexandru Petrescu;
> Hidetoshi Yokota Cc: [email-masked] Subject: RE: [netlmm] Re: SDOs
> and NETLMM WG Hi, Raj,
> 
> Regards, Ajoy
> -----Original Message----- From: Basavaraj Patil
> [mailto:[email-masked]] Sent: Thursday, March 08, 2007
> 3:22 PM To: Singh Ajoy-ASINGH1; Chowdhury, Kuntal; Alexandru
> Petrescu; Hidetoshi Yokota Cc: [email-masked] Subject: Re: [netlmm]
> Re: SDOs and NETLMM WG
> 
> 
> Ajoy et al,
> 
> This discussion on which SDOs have expressed interest in PMIP6 and
> what is the timeline for it being available is not really productive.
> 
> 
>  current state where we debate endlessly on issues that do not result
> in the work moving forward).
> 
> Ajoy-> Absolutely. We need to review technical contents of various
> docs and make objective assessment. I think we have been making good
> progress. We have been updating draft based upon mailing list
> consensus and discussion.
> 
> Netlmm. How the SDOs use the specification is not our concern. If the
> SDOs have some specific requirements for a netlmm protocol, they can
> just as well make them known in the netlmm WG. There really is no
> value in finding out what any of the SDOs opinion is about any of
> these drafts, because the netlmm WG is not going to make a choice
> based on what another external SDO prefers or thinks.
> 
> various SDOs. If we do not make such assumption, we will end-up
> defining incompatible protocol. Incompatible protocol is not going to
> help anyone.
> 
> People from the SDOs are just as welcome to express their views in
> the netlmm WG where the discussion is open.
> 
> Ajoy-> Sure
> 
> Regarding the timeline for when this work can be completed, I think
> we can stop speculating about it and instead let the chairs make a 
> determination. The charters goals will no doubt need to be revised
> because the current milestones are not aligned with the changes that
> have occurred since IETF67.
> 
> Ajoy-> Sure, I care about quality of protocol. We should not
> compromise quality for timeline.
> 
> -Raj
> 
> 
>> I agree that SDOs are interested in PMIPv6 protocol. However, it is
>> not clear to me that enough discussion has taken place in SDOs
>> about details of both proposals being discussed in IETF. As far as
>> I am aware, WIMAX Forum is targeting to discuss both drafts in
>> 
>> next planery call.
>> 
>> Regards, Ajoy
>> 
>> 
>> -----Original Message----- From: Chowdhury, Kuntal
>> [mailto:[email-masked]] Sent: Thursday, March 08,
>> 2007 10:13 AM To: Alexandru Petrescu; Hidetoshi Yokota Cc: Singh
>> Ajoy-ASINGH1; [email-masked] Subject: RE: [netlmm] Re: SDOs and
>> NETLMM WG
>> 
>> this requirement. 3GPP SAE (TS 23.402/TR 23.882) has dependencies
>> on PMIP6. See 3GPP dependency list for more info.
>> 
>> This is certainly not a 1-3 year project. If PMIP6 spec does not
>> come out of IETF in 2007, every SDOs publication schedule will be
>> impacted. So, moving fast on the base draft is the most important
>> task for the netlmm WG, IMHO.
>> 
>> -Kuntal
>> 
>> 
>>> -----Original Message----- From: Alexandru Petrescu
>>> [mailto:[email-masked]] Sent: Thursday, March 08,
>>> 2007 8:26 AM To: Hidetoshi Yokota Cc: Singh Ajoy-ASINGH1;
>>> [email-masked] Subject: [netlmm] Re: SDOs and NETLMM WG
>>> 
>>> Hidetoshi Yokota wrote:
>>>>> Currently, only 3GPP2 TSG-X has made a statement relayed
>>>>> through our liaison.  That statement talks about need to do
>>>>> proxy mobile ip based solution.  It says nothing about the
>>>>> timeliness needed.  See the PostScriptum with the relevant
>>>>> mail.
>>>> by stating the timeline, then they would probably do so. But I
>>>> don't think IETF works that way... (I may be wrong, though)
>>>>> At the same time, the NETLMM WG has not made any statement
>>>>> back to 3GPP through our liaison.
>>>>> 
>>>>> If I'm to interpret the request from 3GPP technically I
>>>>> consider the draft-singh much more appropriated to 3GPP needs
>>>>> (has PMIP client relocation) than draft-sgundave (has not).
>>>> This type of relocation would also be beneficial for 3GPP2, but
>>>> my take is that this can be regarded as an extension to the
>>>> base protocol.
>>> It can.  The minimal conditions between the two is to refer to
>>> each other.  HEre's one example:
>>> 
>>> draft-sgundave:
>>>> When the mobile node attaches to an access link connected to
>>>> the mobile access gateway, the mobile node presents its
>>>> identity, MN- Identifier, as part of the access access
>>>> authentication procedure. After a successful access
>>>> authentication, the mobile access gateway obtains the mobile
>>>> node's profile from the policy store, such as
>> from
>>>> a AAA infrastructure.  The mobile access gatway would have all
>>>> the information for it to emulate the mobile node's home
>>>> network on the access link.  The mobile access gateway also
>>>> starts sending periodic Router Advertisements to the mobile
>>>> node advertising its home
>> network
>>>> prefix.
>>> 
>>> draft-singh:
>>>> 2. After receiving the prefix as part of the router
>>>> advertisement from MAG1, the MN attempts to acquire another IP
>>>> address, called the Proxy Home Address (pHoA) associated with
>>>> the advertised prefix. The MN issues a DHCP request and a DHCP
>>>> server assigns a pHoA consistent with the advertised prefix.
>>> System. For more information please visit
>>> http://www.messagelabs.com/email 
>>> _______________________________________________ netlmm mailing
>>> list [email-masked] 
>> _______________________________________________ netlmm mailing list
>>  [email-masked] https://www1.ietf.org/mailman/listinfo/netlmm
> 
> 
> _______________________________________________ netlmm mailing list 
> [email-masked] https://www1.ietf.org/mailman/listinfo/netlmm
> 

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________

---

From: Sri Gundavelli <[email-masked]>
Date: Fri, 9 Mar 2007 08:26:32 -0800 (PST)

Alex,

On Fri, 9 Mar 2007, Alexandru Petrescu wrote:

> The current draft-sgundave PMIPv6 talks mainly in terms of DS-MIPv6. DS-MIPv6 
> is an extension to MIPv6 protocol, under development in the MIP6 WG.
>

IPv4 HoA or transport support is a straight forward thing. We dont
have to complicate things and bring generic transition solutions, such
as ISATAP or TEREDO. MIP6 working group already chose DSMIP6 and we
leverage that work and have created normative reference. We dont have
to redo the whole spin to define this simple extension. If your
primary objective is to create room for 10 different drafts, sure
we can go that route and can work on the base problems for the next
3 years. We wanted the base to be complete. Any operator deploying
IPv6 address mobility will certainly look for  IPv4 addressing
support and we offer that. If there are technical issues, please
speak out and we will fix it. But, lets not split this doc and
create work items for 10 parties, just for the sake of doing that.
There are other problems such as context transfer, Shared-link
support etc, that working group can focus on. This doc is fairly
complete, lets improve it, fix things and take it forward.

Sri

> There are other possible ways of supporting IPv4 for PMIPv6, some of them 
> published: PMIPv4, DS-MIPv4, or even 6to4, TEREDO and ISATAP.
>
> A problem statement is necessary on which we agree _how_ we support IPv4 with 
> PMIP in netlmm space.  Such a problem statement draft is written, I've 
> referred to it.  Ignoring it and jumping straight to DS-MIPv6 is not good.
>
> Also, I think one is aware that IPv6 requirements in some of the SDOs don't 
> talk DS-MIPv6 but talk ISATAP TEREDO and 6to4.
>
> So, the time to figure out how to use IPv4, just leave IPv4 out, document is 
> shorter, progresses faster.
>
> Alex
>
>>
>>  -Kuntal
>>
>>
>>  Regards, Ajoy
>>
>>  Kuntal; Alexandru Petrescu; Hidetoshi Yokota Cc: [email-masked] Subject:
>>  RE: [netlmm] Re: SDOs and NETLMM WG Ajoy and others
>>
>>  How the SDOs use the specification is not our concern. If the
>>  Ajoy-> I am not sure if I agree with this. If the customer of our protocol
>>  is various SDOs, we will have to care about their
>>  requirements.
>>
>>  On 3/8/07 1:56 PM, "ext Singh Ajoy-ASINGH1" <[email-masked]> wrote:
>> 
>> > >  list [email-masked] https://www1.ietf.org/mailman/listinfo/netlmm
>>  proprietary, confidential, and privileged or subject to the work product
>>  doctrine and thus protected from disclosure.  If the reader of this
>>  message is not the intended recipient, or an employee or agent responsible
>>  for delivering this message to the intended recipient, you are hereby
>>  notified that any dissemination, distribution or copying of this
>>  communication is strictly prohibited.
>>  immediately by replying to this message and deleting it and all copies and
>>  backups thereof.  Thank you.
>>
>> 
>
>

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Fri, 9 Mar 2007 11:26:35 -0500

Alex,

Yes, there are a number of ways IPv4 MNs and IPv4 access networks can be
supported with MIP6. Some of these are even tried out in the field as
well. However, I think we should stick to one default method for
supporting v4 using MIP6 (and PMIP6). IETF MIP6 WG picked the DSMIP6
approach. I think it is a very good approach for us to take as well as
the *default* approach for v4 support with PMIP6.

-Kuntal

-----Original Message-----
From: Alexandru Petrescu [mailto:[email-masked]] 
Sent: Friday, March 09, 2007 11:15 AM
To: Chowdhury, Kuntal
Cc: Singh Ajoy-ASINGH1; [email-masked]; Basavaraj
Patil; Alexandru Petrescu; Hidetoshi Yokota; [email-masked]
Subject: Re: [elm] Re: SDOs and NETLMM WG

Alex

---

From: "Junghoon Jee" <[email-masked]>
Date: Sat, 10 Mar 2007 01:35:43 +0900

Hi all,
>From the current charter says like below:

"The scope of the work is initially limited to IPv6"
"Out of scope for the first design are: ~snip~, IPv4 support"

Just FYI.

Junghoon

2007/3/10, Sri Gundavelli <[email-masked]>:
> DS-MIPv6
> them
> with
> don't
> >>  Kuntal; Alexandru Petrescu; Hidetoshi Yokota Cc: [email-masked]:
> protocol
> product

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 09 Mar 2007 17:48:18 +0100

Sri Gundavelli wrote:
>>>  spec. It is very important that the base spec supports IPv4 and 
>>> IPv6 (addressing and transport) so that a comprehensive solution 
>>> is available ASAP. The draft-sgundave has this support, and I 
>>> don't believe we need to take this out.
>> 
>> The current draft-sgundave PMIPv6 talks mainly in terms of 
>> DS-MIPv6. DS-MIPv6 is an extension to MIPv6 protocol, under 
>> development in the MIP6 WG.
>> 
> 
> have to complicate things and bring generic transition solutions, 
> such as ISATAP or TEREDO.

Sri, one doesn't 'complicate' anything by using ISATAP or TEREDO, 
because these are Standards Track edited RFCs documents with widely 
available implementations.  At least TEREDO is widely deployed today.

6to4 is also widely deployed.

MIP6 and 6to4 is something that can and has been done straight away,
without any need for interoperability or for documenting at IETF.  At 
many sites.

STUN for NAT Traversal is widely deployed on mobile phones.

I think SDO may think that 6to4/TEREDO/ISATAP/STUN is too complicated 
but I can refer SDO to relevant RFCs and to deployed software (all 
windows xp and vista do TEREDO, one 15% coverage Internet operator does 
STUN in their rich handset offer, etc).

Besides, it seems contradictory for one not to want TEREDO/6to4/ISATAP,
but SDO wanting it (it so happens) and at the same time claim that SDO
needs what NETLMM WG proposes.

> MIP6 working group already chose DSMIP6 and we leverage that work and
>  have created normative reference.

That creates a dependency outside this working group.  If this working
group works under SDO pressure it doesn't mean that other WG at IETF does.

Do you agree it's better without going with another dependency of
another under-development document?

> We dont have to redo the whole spin to define this simple extension.
>  If your primary objective is to create room for 10 different drafts,
>  sure we can go that route and can work on the base problems for the
>  next 3 years.

I agree what I'm suggesting with thin document may take longer than what
some SDOs may expect.  I won't be specific in dates, but looks so.

However, every other SDO surely doesn't think that NETLMM WG is going to
solve all SDOs needs in terms of IPv4, IPv6 and all other communication.

> We wanted the base to be complete. Any operator deploying IPv6 
> address mobility will certainly look for  IPv4 addressing support and
>  we offer that.

Not only you offer that.  Deployers of IPv6 networks already have IPv4
in place.  We offer a solution to that and it's not called DS-MIPv6 and
uses other existing transitioning mechanism RFCs.

Besides, a deployer who plans to deploy an IPv6-only network can not be
accommodated by DS-MIPv6, I've explained why earlier: a DS-MIPv6 HA MUST
  run both IPv4 and IPv6, while a solution of MIPv6+6to4 allows the HA to
be IPv6 only.

What do you think?

> If there are technical issues, please speak out and we will fix it.

Check the one above.  What do you think?  How can you fix that in the 
PMIPv6 spec?  It can also be solved in DS-MIPv6 spec (a dependency) or 
by not using DS-MIPv6 but 6to4.

> But, lets not split this doc and create work items for 10 parties,
> just for the sake of doing that. There are other problems such as
> context transfer, Shared-link support etc, that working group can
> focus on. This doc is fairly complete, lets improve it, fix things
> and take it forward.

I'm not asking to split.  There's not enough matter in this document for 
10 drafts.  I'm asking to leave place and to stop taking in features 
that nobody asked to take these features in.

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 09 Mar 2007 17:50:28 +0100

> the *default* approach for v4 support with PMIP6.

I don't think it is the default approach.  We have a problem statement 
for that.  LEt's discuss that problem statement before choosing to put 
IPv4 in draft-sgundave.

DS-MIPv6 is the default approach in MIP6 WG, that's all.  This is a 
different Working Group.

IETF has many Working Groups with many transitioning IPv4-IPv6 
mechanisms developped, continuosly enhanced and published as RFC since 
long, and widespread software deployment.

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 09 Mar 2007 18:00:02 +0100

Chowdhury, Kuntal wrote:
> Ajoy,
> 
> The point I am making is that, we don't have to define IPv4 support
> in a separate draft simply because similar approach was taken in the
> past. DSMIP6 extensions are available for us to use in the PMIP6 base
> protocol so that it becomes a comprehensive solution document. I do
> not believe taking out IPv4 support from the base PMIP6 spec is going
> to speed up the process.

I think it will: taking out IPv4 from PMIPv6 document will speed up the 
process.  IPv4 in PMIPv6 creates a dependency on the DS-MIPv6 document 
developped in another Working Group (not in this Working Group) and we 
can't control that.

You seem to assume DS-MIPv6 document will be progressed quickly.  Until 
now, DS-MIPv6 was not progressed as quickly as one would expect, in MIP6 WG.

Alex

---

From: Basavaraj Patil <[email-masked]>
Date: Fri, 09 Mar 2007 11:17:24 -0600

Alex,

There was/is a good reason why in the case of DS-MIP6 the use of
Teredo/ISATAP/6to4 were not used. You have proposed these for consideration
in the design of DS-MIP6 as well and are well aware of the reasoning that
went into why none of these were chosen.
PMIP6 is essentially an off-shoot of MIP6 (albeit host involvement) and
hence the use of the same design principle that went into DS-MIP6 for IPv54
support can and are being applied here as well.

No doubt that the IETF has developed many different transition mechanisms
and you can pick and choose which makes sense. In the case of MIP6 and PMIP6
the entities that are at play are the MN, PMA and the HA (some or all of
these being DS). The preference would be to enable IPv4 support as well as
transition mechanism within the context of these elements. So while you can
argue about using a standardized transition mechanism, I do not see any of
these being a good fit for the MIP6 and PMIP6 scenario.

-Raj

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 09 Mar 2007 18:42:33 +0100

Basavaraj Patil wrote:
> Teredo/ISATAP/6to4 were not used. You have proposed these for
> consideration in the design of DS-MIP6 as well and are well aware of
> the reasoning that went into why none of these were chosen. PMIP6 is
> essentially an off-shoot of MIP6 (albeit host involvement) and hence
> the use of the same design principle that went into DS-MIP6 for IPv54
> No doubt that the IETF has developed many different transition
> mechanisms and you can pick and choose which makes sense. In the case
> of MIP6 and PMIP6 the entities that are at play are the MN, PMA and
> the HA (some or all of these being DS). The preference would be to
> enable IPv4 support as well as transition mechanism within the
> context of these elements.

If IPv4 support and transition mechanisms are enabled on these elements
then DS-MIPv6 is not needed.  Right?

> So while you can argue about using a standardized transition
> mechanism, I do not see any of these being a good fit for the MIP6
> and PMIP6 scenario.

But one can't argue that adding IPv4 support in PMIPv6 draft when the 
Charter of this WG says IPv4 is out of scope.  Right?

You argue - completely differently than this WG Charter - that IPv4 is 
needed in the first design PMIPv6 draft, and moreover, solely in the 
form of DS-MIPv6.  Please read the WG Charter.

So I'd suggest to discuss modifying the NETLMM WG Charter to include 
IPv4 and to start the problem statement as WG item.

The more argument is done in favoring IPv4 in PMIPv6 base (w/o Charter 
and w/o problem statement) the more time it may take.

This WG can't work based solely on SDO requirements, especially for Stds 
Track documents.  It must have a Charter.

I'd suggest again that if speed of progress is so important then the 
tool is the status of document (EXPERIMENTAL, INFORMATIONAL, BCP, etc) 
and/or complete PMIPv6 definition in that particular SDO.

I can go as far as suggesting that, instead of so many differing 
comments about what SDO want or don't want, we speak with a single voice 
per SDO, and that is called a Liaison.  And barring that, no progress on 
any single SDO-related document.

Alex

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 09 Mar 2007 10:17:35 -0800

Singh Ajoy-ASINGH1 wrote:
> One way to focus on this 

It turns out that supporting an IPv4 network between
the MAG and the LMA is extremely important. So it must
be there in the base protocol document. BTW, we are
re-using the IPv4 transport extensions from  DS-MIPv6.
We are not doing anything new.

Vijay

---

From: Basavaraj Patil <[email-masked]>
Date: Fri, 09 Mar 2007 12:21:47 -0600

Alex,

> then DS-MIPv6 is not needed.  Right?

If I have a DS MN and a DS HA, I would implement DS-MIP6 as the preferred
transition mechanism for these DS MIP6 MNs. Its just more pracical.

Whether enabling other solutions are possible and workable etc. are purely
an academic exercise and you can argue all day and night about it.

> form of DS-MIPv6.  Please read the WG Charter.

I know what the charter says... And IMO the charter needs to be revised to
reflect reality and requirement.

PMIP6 W/O support for IPv4 is handicapped from the very beginning and its
applicability to near-term deployments becomes very limited.

> IPv4 and to start the problem statement as WG item.

I agree.. I think this is a fair statement.

> and w/o problem statement) the more time it may take.

Charter, scope, problem statement can all be dealt with... But seriously
what is your point about why IPv4 should not be a part of the protocol. And
more to the point, do you have any comments about the proposed solution in
the I-D for IPv4 support and issues with it if any... Other than suggesting
that we should consider ISATAP and Teredo etc.

> any single SDO-related document.

??????

-Raj

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 09 Mar 2007 19:22:29 +0100

Vijay Devarapalli wrote:
>> One way to focus on this solution will be to standardize IPv6 only 
>> support and focus on IPv4 support in seperate document.
> 
> It turns out that supporting an IPv4 network between the MAG and the 
> LMA is extremely important.

Is this a Liaison Statement?

Just asking.  I also think that IPv4 network between MAG and LMA is
important in certain networks.

> So it must be there in the base protocol document.

If one proposes a document to a WG it's the WG that decides, right?

> BTW, we are re-using the IPv4 transport extensions from  DS-MIPv6. We
> are not doing anything new.

Why don't you re-use TEREDO?  That's an RFC, deployed, software
available, et caetera.  What's it missing?

DS-MIPv6 is not yet an RFC, it underwent several iterations since some 
time now, and even its attached Problem Statement was updated recently. 
  Talk about speed of progress?

Alex

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 09 Mar 2007 10:26:24 -0800

>  Talk about speed of progress?

Alex, this is nonsense. You are spreading a lot of FUD. DS-MIPv6 will be 
done much before PMIPv6 even gets to a WG last call.

Vijay

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 09 Mar 2007 19:37:50 +0100

Basavaraj Patil wrote:
> Alex,
> 
> 
> On 3/9/07 11:42 AM, "ext Alexandru Petrescu"
> <[email-masked]> wrote:
> 
>> Basavaraj Patil wrote:
>>> Alex,
>>> 
>>> consideration in the design of DS-MIP6 as well and are well aware
>>> of the reasoning that went into why none of these were chosen.
>>> PMIP6 is essentially an off-shoot of MIP6 (albeit host
>>> involvement) and hence the use of the same design principle that
>>> went into DS-MIP6 for IPv54 support can and are being applied
>>> here as well.
>>> 
>>> mechanisms and you can pick and choose which makes sense. In the
>>> case of MIP6 and PMIP6 the entities that are at play are the MN,
>>> PMA and the HA (some or all of these being DS). The preference
>>> would be to enable IPv4 support as well as transition mechanism
>>> within the context of these elements.
>> If IPv4 support and transition mechanisms are enabled on these
>> elements then DS-MIPv6 is not needed.  Right?
> 
> If I have a DS MN and a DS HA, I would implement DS-MIP6 as the
> preferred transition mechanism for these DS MIP6 MNs. Its just more
> pracical.

If you have a DS MN and a DS HA is that you already have a Mobile IPv4
and Mobile IPv6 implemented, right?  What's wrong with that?

> Whether enabling other solutions are possible and workable etc. are
> purely an academic exercise and you can argue all day and night about
> it.

I'm not talking academic exercises, I'm talking what's being deployed.

>>> mechanism, I do not see any of these being a good fit for the
>>> MIP6 and PMIP6 scenario.
>> But one can't argue that adding IPv4 support in PMIPv6 draft when
>> the Charter of this WG says IPv4 is out of scope.  Right?
>> 
>> You argue - completely differently than this WG Charter - that IPv4
>> is needed in the first design PMIPv6 draft, and moreover, solely in
>> the form of DS-MIPv6.  Please read the WG Charter.
> 
> I know what the charter says... And IMO the charter needs to be
> revised to reflect reality and requirement.

Let's discuss that first _before_ rushing adding publicly discussed
features in certain drafts.  It's a problem statement draft.

> PMIP6 W/O support for IPv4 is handicapped from the very beginning and
> its applicability to near-term deployments becomes very limited.

I agree IPv4 together with IPv6 are needed.  But from this to adding
features in drafts in this way is a long way.

When requesting support from the WG it's that the WG will read every
minor detail of this draft, going to countless revisions and minor
typos.  People do that regularly.  That is time-consuming and much
effort is put in.  One can't just add a feature and expect the WG to
debug it and improve it.  Sorry to say that.

>> So I'd suggest to discuss modifying the NETLMM WG Charter to
>> include IPv4 and to start the problem statement as WG item.
> 

Maybe we can make a separate thread on this topic?  I agree with you too.

>> The more argument is done in favoring IPv4 in PMIPv6 base (w/o
>> Charter and w/o problem statement) the more time it may take.
> 
> Charter, scope, problem statement can all be dealt with... But
> seriously what is your point about why IPv4 should not be a part of
> the protocol. And more to the point, do you have any comments about
> the proposed solution in the I-D for IPv4 support and issues with it
> if any... Other than suggesting that we should consider ISATAP and
> Teredo etc.

I've already fed back comments on the IPv4 part, right when the document
came out.  They were ignored.

I've supported an IPv4 Problem Statement.  There's a draft on that.

What's your issue with TEREDO?  What technical issue you have with it?
Please describe it so I can address it.

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 09 Mar 2007 19:38:51 +0100

Vijay Devarapalli wrote:
>> time now, and even its attached Problem Statement was updated 
>> recently.  Talk about speed of progress?
> 

I'm sorry.  What's your confidence based on?

Alex

---

From: Basavaraj Patil <[email-masked]>
Date: Fri, 09 Mar 2007 12:40:21 -0600

DS-MIP6 has come pretty far in terms of issue resolution and maturity. I
believe there is only one remaining issue to be dealt with. And it should be
in WG LC fairly soon. The PS for DS-MIP6 has completed WGLC, AD review and
is as per ID-tracker: waiting on a revised ID.

-Raj

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 09 Mar 2007 19:45:15 +0100

> is as per ID-tracker: waiting on a revised ID.

Thanks for the information.  I will comment on DS-MIPv6 if/when it comes 
from IESG to WG with issues to be solved, in the MIP6 WG.

Alex

---

From: "Singh Ajoy-ASINGH1" <[email-masked]>
Date: Fri, 9 Mar 2007 15:56:33 -0500

Kuntal, 

I think there have serious discussion on this topic and so I am not going to respond to all the emails. 
However, I will like to add that from logistic point of view,   
it may not be good idea to include IPv4 support in base draft. Note that I am NOT against defining IPv4 support 
in parallel with base PMIPv6 draft, however I will prefer to keep IPv4 support in separate document provided 
charter issues are resolved. Note that once we include IPv4 support in base draft, it will become mandatory for someone 
implementing PMIPv6 to implement IPv4 support as well even though there is no need to support transition scenario 
in a specific deployment scenario. This will become standard compliance issue. 

Regards,
Ajoy 

-----Original Message-----
From: Chowdhury, Kuntal [mailto:[email-masked]] 
Sent: Friday, March 09, 2007 10:08 AM
To: Singh Ajoy-ASINGH1; [email-masked]; Basavaraj Patil; Alexandru Petrescu; Hidetoshi Yokota
Cc: [email-masked]
Subject: RE: [elm] Re: SDOs and NETLMM WG

Ajoy,

-Kuntal

-----Original Message-----
From: Singh Ajoy-ASINGH1 [mailto:[email-masked]]
Sent: Friday, March 09, 2007 11:03 AM
To: Chowdhury, Kuntal; [email-masked]; Basavaraj Patil; Alexandru Petrescu; Hidetoshi Yokota
Cc: [email-masked]
Subject: RE: [elm] Re: SDOs and NETLMM WG

Kuntal,

draft-singh has IPv4 support as well. The point is not about which draft has what kind of support. 
Rather does transition scenario belong to base draft. If we can learn anything from past IETF work, we should know that traditionally IETF has not included transition scenario in base draft. 
Let us look at base MIPv6 spec. It does not define transition scenario. Dual stack support is defined as extension. 

Regards,
Ajoy  

-----Original Message-----
From: Chowdhury, Kuntal [mailto:[email-masked]]
Sent: Friday, March 09, 2007 9:58 AM
To: Singh Ajoy-ASINGH1; [email-masked]; Basavaraj Patil; Alexandru Petrescu; Hidetoshi Yokota
Cc: [email-masked]
Subject: RE: [elm] Re: SDOs and NETLMM WG

Hi, Lalit, 

-Kuntal

Regards,
Ajoy 

 
Regards
Lalit

Regards,
Ajoy 

-----Original Message-----
From: Basavaraj Patil [mailto:[email-masked]]
Sent: Thursday, March 08, 2007 3:22 PM
To: Singh Ajoy-ASINGH1; Chowdhury, Kuntal; Alexandru Petrescu; Hidetoshi Yokota
Cc: [email-masked]
Subject: Re: [netlmm] Re: SDOs and NETLMM WG

Ajoy et al,

Ajoy-> Sure

-Raj

solution.

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 09 Mar 2007 13:45:38 -0800

Hi Ajoy,

> Let us look at base MIPv6 spec. It does not define transition scenario. Dual stack support is defined as extension. 

We are mostly re-using DS-MIPv6 concepts for IPv4 support.
There aren't any new extensions to PMIPv6 for supporting
IPv4.

Vijay

---

From: Alexandru Petrescu <[email-masked]>
Date: Sat, 10 Mar 2007 00:40:18 +0100

Vijay Devarapalli wrote:
>> Even draft-singh has IPv4 support as well. The point is not about 
>> which draft has what kind of support. Rather does transition scenario 
>> should belong to base draft. If we can learn anything from past IETF 
>> work, we should know that traditionally IETF has not included 
>> transition scenario in base draft. Let us look at base MIPv6 spec. It 
>> does not define transition scenario. Dual stack support is defined as 
>> extension. 
> 

Vijay, which WG asked you to use IPv4 support?  Most certainly _not_ 
this WG.  Check the Charter, please.

Alex