Subject: [netlmm] HNP length

From: "DE JUAN HUARTE FEDERICO" <[email-masked]>
Date: Wed, 12 Sep 2007 15:51:15 +0200

Hi Sri,

unless I missed it, the PMIP6 v3 I-D is silent about the HNP length. Is
it intentional?

I'm trying to find out if the HNP can be longer than 64 bits
More specifically (avoiding variable length prefixes) is it possible to
assign 128-bit HNP (in per-MN HNP model)?

The motivation of my question is that I keep on getting contradictory
answers in this respect: apparently legacy v6 implementations would not
support prefixes longer than 64 bits

Thanks

federico

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Sri Gundavelli" <[email-masked]>
Date: Wed, 12 Sep 2007 17:50:24 -0700

Hi Federico,

> if the HNP can be longer than 64 bits.
 
Yes, that was intentional. The parameter for storing the prefix should
implicitly
contain the prefix length. Thats the integral property of a prefix and so
did not
define a seperate parameter for it in the conceptual data structures.

> The motivation of my question is that I keep on getting contradictory
answers in this 
> respect: apparently legacy v6 implementations would not support prefixes
longer than 64 bits
 
As per 3587 or as per 3177 recommendations,  interface id length is 64 bits
long, for the
current 001 allocation. Also, the EUI-64 format for the identifier
generation requires 64 bits.
So, not sure, if the prefix length can be  greater than 64 bits, atleast for
now. But, the draft
does not assume any prefix length or mandate on the prefix lengths.
 
Sri

  _____  

From: DE JUAN HUARTE FEDERICO
[mailto:[email-masked]] 
Sent: Wednesday, September 12, 2007 6:51 AM
To: Sri Gundavelli
Cc: [email-masked]
Subject: HNP length

Hi Sri, 

unless I missed it, the PMIP6 v3 I-D is silent about the HNP length. Is it
intentional? 

Thanks 

federico