Subject: [netlmm] LMA as a time keeper

From: Bruno Mongazon-Cazavet <[email-masked]>
Date: Thu, 13 Sep 2007 17:28:47 +0200

An idea regarding PBU ordering problem:

-The LMA is the time keeper
-When a MAG boots, it sends a dummy PBU to the LMA to request current 
time (time synchronization). LMA provides current time in the PBU-Ack. 
MAG set its time to LMA time received in PBU-Ack (a latency can be added 
for network transit).
-All MAG linked to the same LMA will get synchronized with LMA time this way
-the timestamp option is then used in real PBU/PBU-ACK, because all MAG 
are synchronized they can be ordered by LMA
-only related LMA's and MAG are synchronized this way.

Stupid?

Bruno.

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Jong-Hyouk Lee" <[email-masked]>
Date: Fri, 14 Sep 2007 16:15:21 +0900

Dear Bruno.

The introduced way seems to be simple and enough to end this issue. I take
sides with this.

Cheers.

-- 
Internet Management Technology Lab, Sungkyunkwan University.
Jong-Hyouk Lee.

#email: jonghyouk (at) gmail (dot) com
#webpage: http://www.hurryon.org
_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "John.zhao" <[email-masked]>
Date: Fri, 14 Sep 2007 15:45:15 +0800

Hi,all

         To this method , I doubt whether something need to be clarified at
the first:

1)       If we have assumed that all of the MAG can maintenance the same
clock with the LMA after it get the time from that LMA?

2)       What is the precision requirement for this timestamp used here?

3)       If can every MAG only connect to one LMA?

Best Rgds,

Thanks,

John.zhao

  _____  

发件人: Jong-Hyouk Lee [mailto:[email-masked]] 
发送时间: 2007年9月14日 15:15
收件人: Bruno Mongazon-Cazavet
抄送: [email-masked]
主题: Re: [netlmm] LMA as a time keeper

Dear Bruno.

Cheers.

On 9/14/07, Bruno Mongazon-Cazavet
<[email-masked]> wrote: 

Stupid?

Bruno.

---

From: "Jong-Hyouk Lee" <[email-masked]>
Date: Fri, 14 Sep 2007 17:24:48 +0900

Hi, all.

To get the time synchronization by the introduced method, every MAG knows
which LMA is the time sync LMA in case of multiple LMAs in the domain. It
means that every MAG only not connect to one LMA. Also, all LMA should
share the same time information by other way, e.g., NTP.

Cheers.

On 9/14/07, John.zhao <[email-masked]> wrote:
>
>  Hi,all
>
>
>
>          To this method , I doubt whether something need to be clarified
> at the first:
>
>   ------------------------------
>
> *发件人:* Jong-Hyouk Lee [mailto:[email-masked]]
> *发送时间:* 2007年9月14日 15:15
> *收件人:* Bruno Mongazon-Cazavet
> *抄送:* [email-masked]
> *主题:* Re: [netlmm] LMA as a time keeper
>
>
>
> Dear Bruno.
>
>
>
> On 9/14/07, *Bruno Mongazon-Cazavet* <
> [email-masked]> wrote:
>

---

From: Bruno Mongazon-Cazavet <[email-masked]>
Date: Fri, 14 Sep 2007 11:00:21 +0200

John.zhao wrote:

Hi,all

To this method , I
doubt whether something need to be clarified at the first:

1)
If
we have assumed that all of the MAG can maintenance the same
clock with the LMA after it get the time from that LMA?

[BM] MAG can either:

a) set its system time (machine time) as the LMA time. In such a case,
the time will be maintained by the system

b) keep this time as an internal MAG time. In such a case it needs to
maintain it  on its own with the help of timing functions of the
system.

2)
What
is the precision requirement for this timestamp used here?

[BM] second or millisecond i guess

3)
If
can every MAG only connect to one LMA?

[BM] good point. According to the draft LMA can connect to multiple
MAG. In such a case, each LMA reference time shall be kept and used
separately by the LMA. Which in turn might imply that time is maintain
as an internal MAG time, that is option b) in above question.

Best regards, Bruno.

Best
Rgds,

Thanks,

John.zhao

发件人: Jong-Hyouk
Lee
[mailto:[email-masked]]

发送时间: 2007年9月14日
15:15

收件人: Bruno
Mongazon-Cazavet

抄送:
[email-masked]

主题: Re:
[netlmm] LMA as a time keeper

Dear Bruno.

The introduced way seems to
be simple and
enough to end this issue. I take sides with this.

Cheers.

On 9/14/07,
Bruno Mongazon-Cazavet
<[email-masked]>
wrote:

An idea regarding PBU ordering
problem:

for network transit).

-All MAG linked to the same LMA will get synchronized with LMA time
this way

Stupid?

Bruno.

netlmm mailing list

[email-masked]

--

Jong-Hyouk Lee.

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 14 Sep 2007 11:20:47 +0200

Hi Bruno, just to add some thoughts... I'm not trying in no way to
discard it, just discussion.

Bruno Mongazon-Cazavet wrote:
>> 1)       If we have assumed that all of the MAG can maintenance the
>>  same clock with the LMA after it get the time from that LMA?
>> 
> [BM] MAG can either: a) set its system time (machine time) as the LMA
> time. In such a case, the time will be maintained by the system

Can a PC maintain the time correctly when its battery is no longer
working correctly.

> [BM] second or millisecond i guess

This should be dictated by the ordering requirement.  I guess we want
the precision to be directly related to how many handovers per second
can a mobile do, and the P-BUs sent.

For example, in WiFi, a typical link-layer handover is in the order of
500ms; for this, we don't need a time precision in the order of
milliseconds, but hundreds of milliseconds.  (at the same time, some
very performant wifi link-layers can do in the order of 4ms.)

WiFi is but one technology.

I expect WiMax to have handover latencies in the order of seconds.

> separately by the LMA. Which in turn might imply that time is
> maintain as an internal MAG time, that is option b) in above
> question.

In a deployment, LMA is probably the anchor point for mobility, the sort
of controlling point and thus it makes sense to have LMA to keep time
for everybody.

But for anything else than mobility maybe other entities are such
controlling points.  I'm thinking of DHCP Server or LDAP Server or AAA
Server, because they control the existence proper of mobiles.  It is
probably important that these machines are the time keepers.

Alex

> Best regards, Bruno.
>> 
>> 
>> 
>> Best Rgds,
>> 
>> Thanks,
>> 
>> 
>> 
>> John.zhao
>> 
>> 
>> 
>> ------------------------------------------------------------------------
>> 
>> 
>> *发件人:* Jong-Hyouk Lee [mailto:[email-masked]] *发送时间:* 2007年9月
>> 14日 15:15 *收件人:* Bruno Mongazon-Cazavet *抄送:* [email-masked] *主题:*
>> Re: [netlmm] LMA as a time keeper
>> 
>> 
>> 
>> Dear Bruno.
>> 
>> 
>> 
>> The introduced way seems to be simple and enough to end this issue.
>> I take sides with this.
>> 
>> 
>> 
>> Cheers.
>> 
>> 
>> 
>> On 9/14/07, *Bruno Mongazon-Cazavet* 
>> <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>> 
>> -The LMA is the time keeper -When a MAG boots, it sends a dummy PBU
>> to the LMA to request current time (time synchronization). LMA
>> provides current time in the PBU-Ack. MAG set its time to LMA time
>> received in PBU-Ack (a latency can be added for network transit). 
>>  this way -the timestamp option is then used in real PBU/PBU-ACK,
>> because all MAG are synchronized they can be ordered by LMA -only
>> related LMA's and MAG are synchronized this way.
>> 
>> Stupid?
>> 
>> Bruno.
>> 
>> _______________________________________________ netlmm mailing list
>>  [email-masked] <mailto:[email-masked]> 
>> <https://www1.ietf.org/mailman/listinfo/netlmm>
>> 
>> 
>> 
>> 
>> -- Internet Management Technology Lab, Sungkyunkwan University. 
>> Jong-Hyouk Lee.
>> 
>> #email: jonghyouk (at) gmail (dot) com #webpage:
>> http://www.hurryon.org
>> 
> 
> 
> ------------------------------------------------------------------------
> 
> 
> _______________________________________________ netlmm mailing list 
> [email-masked] https://www1.ietf.org/mailman/listinfo/netlmm

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________

---

From: "SEITE Pierrick RD-RESA-REN" <[email-masked]>
Date: Fri, 14 Sep 2007 13:47:57 +0200

Hi Bruno,
 
If I correctly understood MAG get synchronized with LMA only when booting, right? But in operational system MAGs will not often reboot, so how can you take into account MAGs desynchronization due to clocks independent drift when MAGs run for a long time?
 
BR,
Pierrick    

________________________________

De : Bruno Mongazon-Cazavet [mailto:[email-masked]] 
Envoyé : vendredi 14 septembre 2007 11:00
À : [email-masked]
Cc : [email-masked]
Objet : Re: [netlmm] LMA as a time keeper
 
John.zhao wrote: 
Hi,all
 
         To this method , I doubt whether something need to be clarified at the first:
If we have assumed that all of the MAG can maintenance the same clock with the LMA after it get the time from that LMA?
[BM] MAG can either:
a) set its system time (machine time) as the LMA time. In such a case, the time will be maintained by the system
b) keep this time as an internal MAG time. In such a case it needs to maintain it  on its own with the help of timing functions of the system. 

What is the precision requirement for this timestamp used here?
[BM] second or millisecond i guess

If can every MAG only connect to one LMA?
[BM] good point. According to the draft LMA can connect to multiple MAG. In such a case, each LMA reference time shall be kept and used separately by the LMA. Which in turn might imply that time is maintain as an internal MAG time, that is option b) in above question.

Best regards, Bruno.

Best Rgds,
Thanks,
 
John.zhao
 
________________________________

Dear Bruno.
 
The introduced way seems to be simple and enough to end this issue. I take sides with this.
 
Cheers.

On 9/14/07, Bruno Mongazon-Cazavet <[email-masked]> wrote: 
An idea regarding PBU ordering problem:

Stupid?

Bruno.

---

From: Bruno Mongazon-Cazavet <[email-masked]>
Date: Fri, 14 Sep 2007 13:52:53 +0200

Jong-Hyouk Lee wrote:

Hi, all.

To get the time synchronization by the introduced method, every
MAG knows which LMA is the time sync LMA in case of multiple LMAs in
the domain. It means that every MAG only not connect to one LMA. Also,
all LMA should share the same time information by other way,
e.g., NTP.

[BM] To be check but i think that it is not necessary that all LMA be
time synchronized.

Basically, each LMA needs to be capable to re-order PBU from the MAGs
it is connected to. If all MAGs share the same time for this LMA, then
MAG can make re-ordering. This implies that when a MAG first connects
to a LMA, it gets its time first.

Cheers.

Hi,all

To this method , I doubt whether something need to be clarified at the
first:

1)       If
we have assumed that all of the MAG can maintenance the same clock with
the LMA after it get the time from that LMA?

2)       What

3)       If

Best Rgds,

Thanks,

John.zhao

发件人: Jong-Hyouk
Lee [mailto:[email-masked]]

发送时间: 2007年9
月14日
15:15

收件人:
Bruno
Mongazon-Cazavet

抄送:
[email-masked]

主题: Re:

Dear
Bruno.

The introduced way seems to
be simple and enough to end this issue. I take sides with this.

Cheers.

On 9/14/07, Bruno Mongazon-Cazavet <
[email-masked]> wrote:

for network transit).

Stupid?

Bruno.

netlmm mailing list

[email-masked]

--

Jong-Hyouk Lee.

--

Jong-Hyouk Lee.

---

From: Bruno Mongazon-Cazavet <[email-masked]>
Date: Fri, 14 Sep 2007 14:07:34 +0200

Alexandru Petrescu wrote:

[BM] No problem. Just trying to share some ideas on the mailing list
and find out a solution.

[BM] Don't know about PC behavior. I think a MAG equipment will rather
be a fixed robust system that provides power redundancy with accurate
timing functions.

2) What is the precision requirement for this timestamp used
here?

[BM] yes precision is related to handover frequency.

[BM] Good point. The time unit can be carried together with the time
value in PBU/PBU-Ack, as a millisecond multiple.

[BM] Yes, that's why i am suggesting this idea.

[BM] Yes but it's not MIP-builtin'. A matter of choice.

Alex

Best regards, Bruno.

Best Rgds,

Thanks,

John.zhao

Dear Bruno.

Cheers.

Stupid?

Bruno.

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 14 Sep 2007 14:35:18 +0200

Bruno Mongazon-Cazavet wrote:
> [BM] No problem. Just trying to share some ideas on the mailing list and 
> find out a solution.

I think many deployed systems have a PC architecture, with a long term 
battery for the BIOS.  When that battery dies the Uninteruptible Power 
Supply is of no use.  The UPS powers the main power unit, not the BIOS.

I think I've encountered at least twice a situation where the whole 
operating system gets mangled simply because the time kept by the PC 
system (and its BIOS battery) was too long time in service and needed 
BIOS battery replacement.

Alex
[...]

---

From: "Jong-Hyouk Lee" <[email-masked]>
Date: Fri, 14 Sep 2007 23:45:36 +0900

Hi. Bruno.

We should think about multiple LMAs environments and why that needs. If an
LMA has exceeded its system resource or its capacity, then the LMA is failed
or crashed. For such cases, the failed or crashed LMA's information (about
MAGs) has to be sent another LMA in the same domain (It is similar concept
to switching HA in MIP6). If we consider this, we should consider that all
LMAs make a time synchronization.

As references, there are already mechanisms for reachability check between
LMA and MAG (draft-devarapalli-netlmm-pimpv6-heartbeat-00)or LMAs
(draft-jhlee-netlmm-heartbeatlma-00)in PMIP6. I believe that the base
document should be opened for expansions.

Cheers.

On 9/14/07, Bruno Mongazon-Cazavet <[email-masked]>
wrote:
> [BM] To be check but i think that it is not necessary that all LMA be time
> synchronized.
> Basically, each LMA needs to be capable to re-order PBU from the MAGs it
> is connected to. If all MAGs share the same time for this LMA, then MAG can
> make re-ordering. This implies that when a MAG first connects to a LMA, it
> gets its time first.
>
>
> Cheers.
>
>
> > *发送时间:* 2007年9 月14日 15:15
> > *收件人: *Bruno Mongazon-Cazavet
> > *抄送:* [email-masked]
> > On 9/14/07, *Bruno Mongazon-Cazavet* <[email-masked]>
> > wrote:
> >