Subject: [netlmm] RE: New Version Notification for draft-ietf-netlmm-proxymip6-07

From: "Sri Gundavelli" <[email-masked]>
Date: Sun, 4 Nov 2007 17:36:21 -0800

Attached is the pointer to the -07 version of the Proxy Mobile IPv6
document. We captured all the comments from all the reviews received
on -05 and -06 versions of the document. If we missed any comments
that we agreed to fix, it will be fixed after the LC. 

http://www.ietf.org/internet-drafts/draft-ietf-netlmm-proxymip6-07.txt 

Thanks
Sri

> -----Original Message-----
> From: IETF I-D Submission Tool [mailto:[email-masked]] 
> Sent: Sunday, November 04, 2007 5:23 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; 
> [email-masked]; [email-masked]
> Subject: New Version Notification for draft-ietf-netlmm-proxymip6-07 
> 
> 
> A new version of I-D, draft-ietf-netlmm-proxymip6-07.txt has 
> been successfuly submitted by Sri Gundavelli and posted to 
> the IETF repository.
> 
> Filename:	 draft-ietf-netlmm-proxymip6
> Revision:	 07
> Title:		 Proxy Mobile IPv6
> Creation_date:	 2007-11-04
> WG ID:		 netlmm
> Number_of_pages: 72
> 
> Abstract:
> Network-based mobility management enables IP mobility for a host
> without requiring its participation in any mobility related
> signaling.  The Network is responsible for managing mobility on
> behalf of the host.  The design principle in the case of a network-
> based mobility management protocol relies on the network being in
> control of the mobility management.  The mobility entities in the
> network are responsible for tracking the movements of the host and
> initiating the required mobility signaling on its behalf.  This
> specification describes a network-based mobility management protocol
> and is referred to as Proxy Mobile IPv6.
>                                                               
>                     
> 
> 
> The IETF Secretariat.

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: IETF I-D Submission Tool <[email-masked]>
Date: Sun, 04 Nov 2007 20:23:21 -0500

A new version of I-D, draft-ietf-netlmm-proxymip6-07.txt has been successfuly submitted by Sri Gundavelli and posted to the IETF repository.

Abstract:

The IETF Secretariat.

---

From: "Kalin Getov" <[email-masked]>
Date: Mon, 05 Nov 2007 11:51:05 +0100

Hi Sri,

thanks for the new version of the draft. Just a comment to the description of the multihoming support. You split it to two cases - IID option present or not. In the case where IID is not present in the request the last item from the list accepts that the IID may be present or assumes that it is also, it is a kind of mismatch IMO... . It is the same with the last item from the IID-present case, maybe a minimal correction is needed.

In section 6.9.1 - one of the items says:

 "The Handoff Indicator flag in the Access Technology Type option
      MUST be set to value 3 (Handoff between mobile access gateways for
      the same interface), if the mobile access gateway definitively
      knows the mobile node's current attachment is due to a handoff of
      the mobility session between two interfaces of the mobile node."

I assume the correct one is -  "if the mobile access gateway definitively
      knows the mobile node's current attachment is due to a handoff of
      the mobility session between two different MAGs."

or something like this.

One question, how the MAG would know what value to set in the Handoff Indicator field? Especially for values 2 and 3 (HO between interfaces and between MAGs), could you please give an example, or a hint for a technology that is able of supplying such info to the AR, thanks a lot...

Greetings,
Kalin

-- 
******************************************
Best Regards
Kalin Getov

[email-masked]
******************************************

Psssst! Schon vom neuen GMX MultiMessenger gehört?
Der kann`s mit allen: http://www.gmx.net/de/go/multimessenger

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 05 Nov 2007 09:59:34 -0800

Hi Kalin,

> One question, how the MAG would know what value to set in the Handoff Indicator field? Especially for values 2 and 3 (HO between interfaces and between MAGs), could you please give an example, or a…

For both values 2 and 3, the MAG would need additional information
to figure out if it is a handover. This would be system specific.
For example, when the MAG performs access authentication it could
be told that it was previously attached to the Proxy Mobile IPv6
domain by the AAA server or some other entity (like the old MAG
itself).

The MAG could also be told by the mobile node itself via link layer
extensions, but that is out of scope.

There could be other mechanisms.

Vijay