Subject: [netlmm] MultiHoming Section

From: "Sri Gundavelli" <[email-masked]>
Date: Mon, 17 Dec 2007 09:58:15 -0800

Please provide your input on this one open issue. We discussed
this in the Vancouver meeting. Please respond before Thursday 
(20th Dec).

Issue:
=======
Currently, the LMA processing rules related to Multihoming are
covered in a separate section (Section 5.4). As part of the
LC comments, there is a suggestion to merge this section with
the LMA Signaling Considerations section (Section 5.3). There
are two opinions on this. Please review and state your opinion.
Lets try to resolve this quickly and correctly, just a one 
liner, "Yes" or "No" to the below question would be more than
enough.

Comment
=======
- This breaks the hierarchy. It should be merged with the LMA
  signaling considerations section.

Specific Comments, just to ensure the view is correctly represented:

- "The same section should cover all LMA procedures as the
  multihoming-related options are always included in the PBUs."

- "Section 5.4, overall. I understand that it was easier for the editor
to add a separate section for the multihoming support and related LMA
operations. However I think this is not the correct approach to describe
the protocol operations. The reason is that in the PBU the Access
Technology type option is mandatory and therefore the section 5.3 does
not described the exact procedure followed by LMA when receiving a PBU.
I think we should merge section 5.3 and 5.4 in order to clearly indicate
the procedures followed by the LMA when it receives a PBU"

- In favor, George, Gerardo.

Response:
=========
- This provides a logical separation, provides better readability.

- This does not imply, an implementation cannot ignore multihoming
  considerations. The rules are clearly chained. A LMA implementation
  must apply the multihoming rules when processing a PBU request.

- There are simply too many processing rules, keeping them in one
  section, in a flat hierarchy, pages and pages of processing rules
  will be difficult to follow for a first time reader.

- Just as the timestamp section, the multihoming section is also
  kept in a separate section. Its easier to follow this way.

- In favor, PMIP6 Authors and Ahmad Muhanna.

Your response:
==============

(YES) Merge the Multihoming section with the LMA signaling considerations
      section (Merge sections 5.3 and 5.4)  

(NO) Keep both the sections separate. Just as it is in -07 version of
     the draft.

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Sri Gundavelli <[email-masked]>
Date: Mon, 17 Dec 2007 10:05:01 -0800 (PST)

One Typo ..

> - This does not imply, an implementation cannot ignore multihoming

Read:

"This does not imply, an implementation can ignore multihoming"

---

From: "Jong-Hyouk Lee" <[email-masked]>
Date: Tue, 18 Dec 2007 11:27:34 +0900

Dear colleagues.

We all know that this issue is getting a obstacle for the next steps. We've
hacked around with this issue enough. I'd like to give "NO". As Sri
mentioned, the separated sections should be easier to follow, especially,
for the first time readers. That's all.

Cheers.

-- 
Internet Management Technology Lab, Sungkyunkwan University.
Jong-Hyouk Lee.

#email: jonghyouk (at) gmail (dot) com
#webpage: http://cv.hurryon.org
_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Giaretta, Gerardo" <[email-masked]>
Date: Tue, 18 Dec 2007 08:27:39 -0800

Hi Sri, all,

I think the multihoming processing is not comparable with the timestamp
option processing. The multihoming options have big impacts on the LMA
operation and the current version of the draft is not clear enough on
the checks a LMA must do, imho.

I disagree having a separate section is not helping readability. I would
be in favor of having a separate section in case the multihoming support
was optional; however this is not the case. The reader will spend a huge
amount of time to "read together" section 5.3 and 5.4 in order to
understand what a LMA should and must do whenever it receives a PBU.

Gerardo

> -----Original Message-----
> From: Sri Gundavelli [mailto:[email-masked]]
> Sent: Monday, December 17, 2007 10:05 AM
> To: [email-masked]
> Subject: Re: [netlmm] MultiHoming Section
> 
> 
> One Typo ..
> 
>

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Tue, 18 Dec 2007 23:49:28 -0600

Hi Gerardo,

I believe this is not a real issue but more of having a different taste
for the presentation of technical text/information. IMO, there is not a
single document which would satisfy the taste of all people, there will
always be different tastes out there. IMO, since you did not point any
technical issue, we should not hold this draft from moving forward for
such a difference in technical text presentation taste:-)

Regards,
Ahmad

> From: Giaretta, Gerardo [mailto:[email-masked]] 
> Sent: Tuesday, December 18, 2007 10:28 AM
> To: Sri Gundavelli; [email-masked]
> Subject: RE: [netlmm] MultiHoming Section
> 
> Hi Sri, all,
> 
> I think the multihoming processing is not comparable with the 
> timestamp option processing. The multihoming options have big 
> impacts on the LMA operation and the current version of the 
> draft is not clear enough on the checks a LMA must do, imho.
> 
> I disagree having a separate section is not helping 
> readability. I would be in favor of having a separate section 
> in case the multihoming support was optional; however this is 
> not the case. The reader will spend a huge amount of time to 
> "read together" section 5.3 and 5.4 in order to understand 
> what a LMA should and must do whenever it receives a PBU.
> 
> Gerardo
> 
> > > Please provide your input on this one open issue. We 
> discussed this 
> > > in the Vancouver meeting. Please respond before Thursday 
> (20th Dec).
> > >
> > >
> > > Issue:
> > > =======
> > > covered in a separate section (Section 5.4). As part of the LC 
> > > comments, there is a suggestion to merge this section 
> with the LMA 
> > > Signaling Considerations section (Section 5.3). There are two 
> > > opinions on this. Please review and state your opinion.
> > > Lets try to resolve this quickly and correctly, just a one liner, 
> > > "Yes" or "No" to the below question would be more than enough.
> > >
> > >
> > >
> > > Comment
> > > =======

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Wed, 19 Dec 2007 23:11:19 -0800

Sri, all,

<chair hat on>

Section 5.4 is good and captures the rules introduced to handle the case
of multihomed hosts attaching to the PMIP domain itself quite well.
Thanks to the authors for the efforts taken to capture those details.  

The processing rules have fundamentally changed as a result of
accommodating a regular multihomed host in the PMIP domain.  Hence,
irrespective of whether a host attaching to the PMIP domain is
multihomed or not, the same processing rules apply. For that reason, I
think this requires more than a Yes or No consideration. 

Presently, section 5.3 sends the impression that it provides the
signaling considerations and processing rules.  However, upon reading
section 5.4, it is clear that the rules in 5.4 are essential and the
rules described in 5.3 alone are not sufficient.  One of the concerns I
have is that this may be a bit misleading and that this leaves it as an
exercise for the reader to put everything together.  

If the group prefers to keep section 5.4 separate, I think some forward
references from section 5.3 would be good to clarify where the
processing rules from 5.4 apply.  Without that, section 5.3 is providing
an incomplete picture of the processing rules. 

So, I suggest that we either have a section that provides the complete
signaling considerations and processing rules in an integrated manner or
provide appropriate references (e.g., references to 5.4 in 5.3) to
provide a complete picture. 

</chair hat on>

Thanks,
Vidya 

> Sent: Monday, December 17, 2007 9:58 AM
> To: [email-masked]
> Subject: [netlmm] MultiHoming Section
> 
> discussed this in the Vancouver meeting. Please respond 
> before Thursday (20th Dec).
> 
> 
> Issue:
> =======

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 19 Dec 2007 23:21:03 -0800 (PST)

Hi Vidya,

> an incomplete picture of the processing rules.

Yes. Definetly, the rules specified for multi-homing, timestamp
considerations are all chained. Section 5.3 has clear forward
references to these sections and as a mandatory consideration.
Will review this again to ensure, this is consistent and clearly
specified.

Thanks
Sri