Subject: [netlmm] Editorial: draft-ietf-netlmm-proxymip6-08

From: Julien Laganier <[email-masked]>
Date: Thu, 17 Jan 2008 16:24:56 +0100

Hello Sri,

I have an editorial comment on two figures from the draft:

>                IPv6 header (src=Proxy-CoA, dst=LMAA)
>                     Mobility header
>                         -BU /*P & A flags are set*/
>                        Mobility Options
>                           - Home Network Prefix option
>                           - Link-local Address option (Optional)
>                           - Timestamp Option (optional)
>                           - Mobile Node Identifier option
>                           - Access Technology Type option (Mandatory)
>                           - Mobile Node Interface Identifier option
>                             (Optional)
>
>               Figure 8: Proxy Binding Update message format

and just below:

>    o  The Home Network Prefix option MUST be present.  The prefix
>    value MAY be set 0::/0 or to a specific prefix value.

so I suggest to suffix the "Home Network Prefix option" line in Figure 8 
with " (Mandatory)". Also be consistent between lower case or upper 
case, e.g. Optional vs. optional.

Same goes here:

>                IPv6 header (src=LMAA, dst=Proxy-CoA)
>                     Mobility header
>                         -BA /*P flag is set*/
>                        Mobility Options
>                           - Home Network Prefix Option
>                           - Link-local Address Option (optional)
>                           - Timestamp Option (optional)
>                           - Mobile Node Identifier Option (Mandatory)
>                           - Access Technology Type option (Mandatory)
>                           - Mobile Node Interface Identifier option
>                             (Optional)
>
>             Figure 6: Proxy Binding Acknowledgement message format

which is followed by:

>    o  The Home Network Prefix option MUST be present in the Proxy
>       Binding Acknowledgement message.

Finally, I found weird the fact the message format for PBU comes after 
the one for PBAck, so maybe section 5 and 6 could be swapped.

Best,

--julien

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 17 Jan 2008 09:03:56 -0800 (PST)

Hi Julien,

> case, e.g. Optional vs. optional.

Sure.

> the one for PBAck, so maybe section 5 and 6 could be swapped.

Well, if we swap, we will be talking the PBA response and with out
talking about how the HA sent it. As it is now, we talk about the
LMA first, as it is the anchor point and then about the gateways.

Regards
Sri