Subject: Re: [netlmm] Home Network Prefix in draft-ietf-netlmm-pmip6-ipv4-support-02

From: Behcet Sarikaya <[email-masked]>
Date: Sat, 19 Jan 2008 13:46:03 -0800 (PST)

Hi Ryuji,
  I think that netlmm protocol is very clear in supporting per-MN links as opposed to shared links. In order to have per-MN link, HNP MUST be assigned and the local link will be on this HNP. HNP is an IPv6 prefix.
  I don't understand the text you have below from this point of view? Can you clarify?

Regards,

Behcet

----- Original Message ----
From: RYUJI WAKIKAWA <[email-masked]>
To: Sri Gundavelli <[email-masked]>
Cc: Julien Laganier <[email-masked]>; [email-masked]; Vijay Devarapalli <[email-masked]>; [email-masked]
Sent: Thursday, January 17, 2008 10:49:56 PM
Subject: Re: [netlmm] Home Network Prefix in draft-ietf-netlmm-pmip6-ipv4-support-02

Hi all

On 2008/01/18, at 10:35, Sri Gundavelli wrote:

>
>
>> -----Original Message-----
>> From: Vijay Devarapalli [mailto:[email-masked]]
>> Sent: Thursday, January 17, 2008 11:25 AM
>> To: Sri Gundavelli
>> Cc: Julien Laganier; [email-masked];
>> [email-masked]
>> Subject: Re: [netlmm] Home Network Prefix in
>> draft-ietf-netlmm-pmip6-ipv4-support-02
>>
>> Sri Gundavelli wrote:
>>> Hi Julien,
>>>
>>>
>>> On Thu, 17 Jan 2008, Julien Laganier wrote:
>>>
>>>>>
>>>>> There is no misalignment here. We need IPv6 HNP for requesting
>>>>> a IPv6 prefix and for the base draft that is mandatory. However,
>>>>> for IPv4 document, for requesting IPv4 address, the IPv4 HoA
>>>>> option is mandatory and the request for IPv6 is optional. In
>>>>> other words, this IPv6 HNP prefix mandatory requirement is
>>>>> modified for the IPv4 support. This is for supporting legacy
 nodes
>>>>> as there is no need for IPv6 HNP.
>>>>
>>>> Ok, now I understand the intent. But I don't think the
>> wording is okay
>>>> since the intent is not spelled out.
>>>>
>>>> If I implement spec 1 and spec 2, spec 1 says MAY do this
>> and spec 2
>>>> says MUST do this, I end up implementing the thing anyway,
>> i.e. MUST
>>>> win.
>>>>
>>>> I think we should word it with something along those lines:
>>>>
>>>>>                           [...] When IPv4 support for PMIPv6
>>>>> is present, the requirement on presence of the IPv6 home network
>>>>> prefix is relaxed, i.e., the PBU MAY NOT contain a Home Network
>>>>> Prefix option. However, the mobile access gateway MAY
>>>>> also include the IPv6 Home Network Prefix option in the same
>>>>> message for requesting IPv6 home address support in addition to
>>>>> IPv4 home address support for the mobile node.
>>>>
>>>
>>> Actually, Ryuji and myself thought we will add the correct
>>> wording in the IPv4 spec w.r.t the relaxing the requirement
>>> of IPv6 HNP and only when the IPv4 HoA option is present.
>>> So, we need to ensure the correct wording is there in the
>>> IPv4 support document. The other way is as you suggested
>>> above, but this requires references to the IPv4 HoA option.
>>> When some one implements the base spec, the HNP is mandatory
>>> and when some one implements both the specs, the modified
>>> behavior is per the IPv4 document. Do you see any issues with
>>> this ?
>>
>> Or you could make it more explicit the IPv4 support document
>> that the PMIPv6 spec is expected to also support an IPv4-only
>> mobile node. So the MAG might be requesting only for an IPv4
>> home address in some cases.
>>
>
> Sure. The text in IPv4 spec should be clear about this.

We've already explained the IPv4-only MN support in several sections.

Ex.
In Section1.

    o  IPv4 Home Address Mobility Support: A mobile node that has IPv4
       stack enabled will be able to obtain an IPv4 address and be able
       to use that address from any of the access networks in that
 Proxy
       Mobile IPv6 domain.  The mobile node is not required to be
       allocated or assigned an IPv6 address for enabling IPv4 home
       address support.

In section 3
    The support for IPv4 addressing is orthogonal to the IPv6
 addressing
    support.  Unlike as specified in [ID-DSMIP6], the mobile node is
 not
    required to have an IPv6 home address for obtaining IPv4 home  
address
    mobility.  A mobile node attached to an access link in a Proxy  
Mobile
    IPv6 domain will be able to obtain just an IPv4 address  
configuration
    or both IPv4 and IPv6 address configurations on the connected
    interface.  The policy on the mobile access gateway will determine
  
if
    the mobile node is entitled for both the protocols or a single
    protocol and based on what is enabled, only those protocols will be
    enabled on the access link.  Further, when the mobile node after
    obtaining the IPv4 or IPv4/IPv6 address configuration on the access
    link, performs an inter-technology handoff, the network will ensure
    the mobile node will be able to use the same IPv4/IPv6 address
    configuration on the new interface.

However, the text is not clear whether MAG can request only for IPv4  
HoA or not.
We will update the spec and explicitly explain this.

thanks,
ryuji

>
>
> Sri
>
>
>
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 22 Jan 2008 12:05:44 -0800 (PST)

Hi Sri,
  I share Julien's concerns. In fact I was the first to raise this issue several months ago 
The added concern I have is that an extension should not have requirement on all other extensions. This is the situation we have now without Julien's suggested modification.

Kind regards,

Behcet

----- Original Message ----
From: Sri Gundavelli <[email-masked]>
To: Julien Laganier <[email-masked]>; [email-masked]
Cc: [email-masked]
Sent: Tuesday, January 22, 2008 11:34:51 AM
Subject: RE: [netlmm] Home Network Prefix in draft-ietf-netlmm-pmip6-ipv4-support-02

Hi Julien,

> > modified for the IPv4 support. This is for supporting legacy nodes
> Right, there's no need, but getting an IPv6 HNP does not 
> hinder legacy 
> IPv4 nodes to access the IPv4 Internet in any way. They will get RA's
 
> and will not process them, that's it. There's no need to provide the 
> the PMIP *version6* protocol not to allocate an IPv6 prefix 
> where we're 
> trying to support legacy IPv4 nodes. This paragraph of the draft 
> disturbs me:
> 

(IPv4 Support document discussion)

True, the prefix can always be allocated. But, if IPv6 support is not
enabled for the terminal, it may not be worth locking up one prefix
for each interface. Secondly, the cost of carrying the option in all
messages (all thought its minor). The issue is not about the terminal's
ability to handle an IPv6 RA, the RA can always be denied or the
 terminal
will ignore the packet. But, can we not optimize it by not allocating
 one
IPv6 prefix for each interface, not having to create a route on both
the ends, create the required tunnel interface for supporting the
IPv6 payload (this may be implementation dependent). So, why allocate
 it
when we dont need it. That was the thought process.

> >   stack enabled will be able to obtain an IPv4 address and be
> >   able to use that address from any of the access networks in that
> >   Proxy Mobile IPv6 domain.  The mobile node is not required to be
> >   allocated or assigned an IPv6 address for enabling IPv4 
> home address
> >   support.
> 
> The IETF designed a new Internet Protocol, IPv6, that IIRC has been 
> called "our future". 
> 

I agree, but we also DSMIP6 with a complete IPv4 transport. I see your
point that we should always keep IPv6. But, if its not used for sure,
its a baggage.

> By allowing a PMIPv6 domain to not allocate an IPv6 address 
> you make it 
> possible for an IPv6 enabled node to not get access to the IPv6 
> Internet -- what if my network provider believes I am a "legacy" node
 
> with v4 support only but I actually do have IPv6, and get 
> allocated no 
> v6 prefix. I thought v6 prefixes were available in sufficient 
> quantities such that we don't need to worry about using one 
> of them for 
> one mobile node. 
> 
> I think we should discuss more about that. What's the usecase for 
> allowing a network not to offer a v6 prefix to a PMIPv6 MN. 
> And should 
> we, in the IETF, design a protocol allowing that?
> 

Good that we started discussions on the IPv4 support document. Lets
do that.

Sri

> Cheers,
> --julien