Subject: Re: [netlmm] NETLMM Re-Chartering Topics - Seeking Input

From: "Koodli, Rajeev" <[email-masked]>
Date: Fri, 6 Jun 2008 20:13:07 -0400

Hi Vidya,

Here is my list:

o  Advanced multihoming: Supporting various multihoming scenarios,
including a single prefix across interfaces model [ECR]

o  Inter-MAG handover optimization: Handling packets in flight upon
abrupt tunnel switch; inter-MAG tunnels, etc. [Note: This particular
work item may be handled by MIPSHOP eventually; however, please include
this in prioritization and indicate your interest in contribution] [CR]

o  Interaccess handover support: Solutions for handoffs across
interfaces involving different access networks [CR]

Thanks,

-Rajeev

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Narayanan, Vidya
> Sent: Friday, June 06, 2008 9:09 AM
> To: [email-masked]
> Subject: [netlmm] NETLMM Re-Chartering Topics - Seeking Input
> 
> All,
> Jonne and I are working on the rechartering process.  There is
> sufficient consensus from the last meeting and subsequently on the
> mailing list on the following topics:
> 
> 1) Mobile IPv6 and PMIPv6 interactions
> 2) GRE keying option to support separation of different flows in one
> PMIPv6 tunnel
> 3) AAA support for PMIP (RADIUS and Diameter)
> 4) Automated Local Mobility Anchor (LMA) discovery
> 5) Management Information Base (MIB) for PMIPv6
> 
> Additionally, there have been a number of topics proposed on the
mailing
> list.  As we said at the last meeting, we are trying to scope the
> charter for the next 12 months or so.   The above items are likely to
> take that level of resources from the working group.  We can probably
> take one more item on the list as a task for the WG.  However, there
is
> no clear consensus on what that item might be.  This is an attempt to
> get input from the working group on the relative priorities and
expected
> participation on the various topics proposed so far.
> 
> A collection of the work items proposed have been included below.
> Please respond to this email with your prioritized list of items.
> Please also indicate what level of participation you will provide for
> each item that you choose, along the following lines:
> 
> [E] Willing to serve as editor of the chosen draft
> 
> [C] Willing to co-author or contribute reasonably good amount of text
> corresponding to the work item
> 
> [R] Review the intermediate versions of drafts corresponding to the
work
> item
> 
> For instance, your response may be of the form:
> 
> [R] Path Management and Failure Detection for PMIPv6
> [ECR] Inter-MAG handover optimization
> 
> Here is the list of the remaining proposed work items, in no
particular
> order of priority:
> 
> o  Inter-MAG handover optimization: Handling packets in flight upon
> abrupt tunnel switch; inter-MAG tunnels, etc. [Note: This particular
> work item may be handled by MIPSHOP eventually; however, please
include
> this in prioritization and indicate your interest in contribution]
> 
> o  Path Management and Failure Detection for PMIPv6: Heartbeats to
> detect in-path failures
> 
> o  NEMO Support for PMIPv6: Supporting mobile routers and networks
with
> PMIPv6
> 
> o  Route Optimization for PMIPv6: Improving latency by intra-MAG,
> inter-MAG and/or inter-LMA route optimization solutions
> 
> o  Advanced multihoming: Supporting various multihoming scenarios,
> including a single prefix across interfaces model
> 
> o  Interaccess handover support: Solutions for handoffs across
> interfaces involving different access networks
> 
> o  Shared link support: Supporting the shared link model in PMIPv6
> 
> Please provide this input by June 16th, 2008.
> 
> Thanks,
> Vidya and Jonne
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netlmm
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Mohana Jeyatharan" <[email-masked]>
Date: Mon, 9 Jun 2008 11:21:53 +0800

Dear Vidya and Jonne,

This is the prioritized list we propose:
o  Interaccess handover support: Solutions for handoffs across
interfaces involving different access networks [ECR]

o  NEMO Support for PMIPv6: Supporting mobile routers and networks with
PMIPv6 [R]

o  Shared link support: Supporting the shared link model in PMIPv6 [R]

o  Route Optimization for PMIPv6: Improving latency by intra-MAG,
inter-MAG and/or inter-LMA route optimization solutions [R]

o  Path Management and Failure Detection for PMIPv6: Heartbeats to
detect in-path failures [R]

o  Interaccess handover support: Solutions for handoffs across
interfaces involving different access networks  Inter-MAG handover
optimization: Handling packets in flight upon abrupt tunnel switch;
inter-MAG tunnels, etc. [Note: This particular work item may be handled
by MIPSHOP eventually; however, please include this in prioritization
and indicate your interest in contribution] [R]
 
BR,
Mohana

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Narayanan, Vidya
> Sent: Saturday, June 07, 2008 12:09 AM
> To: [email-masked]
> Jonne and I are working on the rechartering process.  There 
> is sufficient consensus from the last meeting and 
> subsequently on the mailing list on the following topics: 
> 
> Additionally, there have been a number of topics proposed on 
> the mailing list.  As we said at the last meeting, we are 
> trying to scope the
> take that level of resources from the working group.  We can 
> probably take one more item on the list as a task for the WG. 
>  However, there is no clear consensus on what that item might 
> be.  This is an attempt to get input from the working group 
> on the relative priorities and expected participation on the 
> various topics proposed so far.  
> 
> Please also indicate what level of participation you will 
> provide for each item that you choose, along the following lines: 
> 
> [C] Willing to co-author or contribute reasonably good amount 
> of text corresponding to the work item
> 
> [R] Review the intermediate versions of drafts corresponding 
> to the work item 
> 
> [R] Path Management and Failure Detection for PMIPv6 [ECR] 
> Inter-MAG handover optimization
> 
> particular order of priority: 
> 
> o  Inter-MAG handover optimization: Handling packets in 
> flight upon abrupt tunnel switch; inter-MAG tunnels, etc. 
> [Note: This particular work item may be handled by MIPSHOP 
> eventually; however, please include this in prioritization 
> and indicate your interest in contribution]
> 
> o  Path Management and Failure Detection for PMIPv6: 
> Heartbeats to detect in-path failures
> 
> o  NEMO Support for PMIPv6: Supporting mobile routers and 
> networks with
> PMIPv6 
> 
> o  Route Optimization for PMIPv6: Improving latency by 
> intra-MAG, inter-MAG and/or inter-LMA route optimization solutions
> 
> o  Advanced multihoming: Supporting various multihoming 
> scenarios, including a single prefix across interfaces model
> 
> o  Interaccess handover support: Solutions for handoffs 
> across interfaces involving different access networks 
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 9 Jun 2008 08:59:03 -0700 (PDT)

Hi Vidya,
  As I mentioned, multiple prefixes (instead of one) support that was added to PMIPv6 starting with draft-ietf-netlmm-proxymip6-13 on May 12, 2008 requires us to look into prefix management at the LMA. There is a draft which has received comments. So my proposal fits well into your request of a work item for the next 12 months or so.

Regards,

Behcet

----- Original Message ----
From: "Narayanan, Vidya" <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: [email-masked]
Sent: Friday, June 6, 2008 7:08:49 PM
Subject: RE: [netlmm] NETLMM Re-Chartering Topics - Seeking Input

Hi Behcet,
Was this proposed earlier and did we miss it, or is this a new proposal?

Vidya 

________________________________

    From: Behcet Sarikaya [mailto:[email-masked]] 
    Sent: Friday, June 06, 2008 9:33 AM
    To: Narayanan, Vidya
    Cc: [email-masked]
    Subject: Re: [netlmm] NETLMM Re-Chartering Topics - Seeking
Input

    Hi Vidya,
      PMIPv6 latest versions are requiring multiple prefixes to be
assigned to MNs. I think this makes prefix management at LMA a strong
requirement. So our proposal is
    o Prefix Delegation Support for PMIPv6
    The work could be based on newer versions of the draft
http://tools.ietf.org/html/draft-sarikaya-netlmm-prefix-delegation-01
    [E] Willing to serve as editor of the chosen draft or
    [C] Willing to co-author or contribute reasonably good amount of
text
    corresponding to the work item
    for me, I solicit others to contribute as [E] or [C].
      This work can be concluded within 12 months easily.
    
    Regards,
    
    Behcet
    
    ----- Original Message ----
    From: "Narayanan, Vidya" <[email-masked]>
    To: [email-masked]
    Sent: Friday, June 6, 2008 11:09:11 AM
    Subject: [netlmm] NETLMM Re-Chartering Topics - Seeking Input
    
    All,
    Jonne and I are working on the rechartering process.  There is
    sufficient consensus from the last meeting and subsequently on
the
    mailing list on the following topics: 
    
    2) GRE keying option to support separation of different flows in
one
    
    Additionally, there have been a number of topics proposed on the
mailing
    list.  As we said at the last meeting, we are trying to scope
the
    charter for the next 12 months or so.  The above items are
likely to
    take that level of resources from the working group.  We can
probably
    take one more item on the list as a task for the WG.  However,
there is
    no clear consensus on what that item might be.  This is an
attempt to
    get input from the working group on the relative priorities and
expected
    participation on the various topics proposed so far.  
    
    A collection of the work items proposed have been included
below.
    Please respond to this email with your prioritized list of
items.
    Please also indicate what level of participation you will
provide for
    each item that you choose, along the following lines: 

    [C] Willing to co-author or contribute reasonably good amount of
text
    corresponding to the work item
    
    [R] Review the intermediate versions of drafts corresponding to
the work
    item 

    
    
    o  Inter-MAG handover optimization: Handling packets in flight
upon
    abrupt tunnel switch; inter-MAG tunnels, etc. [Note: This
particular
    work item may be handled by MIPSHOP eventually; however, please
include
    this in prioritization and indicate your interest in
contribution]
    
    o  Path Management and Failure Detection for PMIPv6: Heartbeats
to
    detect in-path failures

intra-MAG,
    
scenarios,

    o  Shared link support: Supporting the shared link model in
PMIPv6

    Thanks,
    Vidya and Jonne

---

From: "Koodli, Rajeev" <[email-masked]>
Date: Mon, 9 Jun 2008 18:08:04 -0400

Behalf
> Of Conny Larsson
> Sent: Sunday, June 08, 2008 7:40 AM
> To: Narayanan, Vidya
> Cc: [email-masked]
> Subject: Re: [netlmm] NETLMM Re-Chartering Topics - Seeking Input
> 
> Hi Vidya,
> 
> Here is my list:
> 
> inter-MAG and/or inter-LMA route optimization solutions [CR]

[RKo:>] Add me as well, [CR].

Thanks,

-Rajeev

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 10 Jun 2008 08:34:41 -0700 (PDT)

Hi Gerardo,
  It seems like CT4 which develops Stage 3 documents has not noticed the new features in PMIPv6 since draft version 13, if they did I am sure they would consider work on prefixes.

Regards,

Behcet

----- Original Message ----
From: "Giaretta, Gerardo" <[email-masked]>
To: "Narayanan, Vidya" <[email-masked]>; [email-masked]
Sent: Sunday, June 8, 2008 6:02:39 PM
Subject: Re: [netlmm] NETLMM Re-Chartering Topics - Seeking Input

Hi Vidya and Jonne,

As far as I can understand, there is a 3GPP dependency for Release 8 EPS

> o  Path Management and Failure Detection for PMIPv6: Heartbeats to

It may be not official but it seems to me that 3GPP CT4 WG is adopting
Vijay's draft or anyway needs this functionality. 

For this reason I think this item should be considered as the remaining
item of the charter. I am fine to review the work on this.

> detect in-path failures [R]

Thanks
Gerardo

Behalf
mailing
is
expected
work
particular
include
with

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 10 Jun 2008 12:15:16 -0700 (PDT)

The draft we submitted recently discussed these issues:
http://tools.ietf.org/id/draft-sarikaya-netlmm-itho-00.txt
Comments are welcomed.

Behcet

----- Original Message ----
From: Basavaraj Patil <[email-masked]>
To: "ext Narayanan, Vidya" <[email-masked]>; [email-masked]
Sent: Tuesday, June 10, 2008 11:47:23 AM
Subject: Re: [netlmm] NETLMM Re-Chartering Topics - Seeking Input

Jonne/Vidya,

The current charter scope does not allow any changes to the MN itself.
However I think this is an issue that we need t revisit. I think the rule on
"No chhanges to MN" needs to be relaxed in the charter.
This will better enable features such as inter-tech HO among others.
I hope you will consider this when you do the charter revision.

-Raj 

On 6/6/08 11:09 AM, "ext Narayanan, Vidya" <[email-masked]> wrote:

> Additionally, there have been a number of topics proposed on the mailing
> take one more item on the list as a task for the WG.  However, there is
> get input from the working group on the relative priorities and expected
> [R] Review the intermediate versions of drafts corresponding to the work
> item 
> 
> Here is the list of the remaining proposed work items, in no particular
> order of priority:
>

---

From: Frank Xia <[email-masked]>
Date: Tue, 10 Jun 2008 14:49:06 -0500

Sorry for forgetting  CCing this email to the WG.

----- Original Message ----- 
From: "Frank Xia" <[email-masked]>
To: "Vijay Devarapalli" <[email-masked]>
Sent: Tuesday, June 10, 2008 2:06 PM
Subject: Fw: [netlmm] NETLMM Re-Chartering Topics - Seeking Input

> Hi Vijay
>
> Probably I should make the scenario more clear.
>
> IP traffic local breakout (3GPP terms) means MN's traffic
> is anchored by visited LMA not home LMA.
>
> In this scenario, the MAG(or NAS)  contacts Home AAA for
> authentication while HAAA can't assign any LMA for the MN
> because HAAA has no any information about visited networks.
>
> BR
> Frank
>
> ----- Original Message ----- 
> From: "Vijay Devarapalli" <[email-masked]>
> To: "Frank Xia" <[email-masked]>; "Basavaraj Patil" 
> <[email-masked]>; "ext Narayanan, Vidya" <[email-masked]>; 
> <[email-masked]>
> Sent: Tuesday, June 10, 2008 1:41 PM
> Frank,
>> Local breakout of IP traffic via the visited PLMN is supposed
>> be supported,
>> when network policies and user subscription allow it.
>>
>> In this case,  HPLMN can't not assign any LMA for MN during
>> the authentication procedure.   So, MAG acting as DHCP client
>> asks for  LMA information by resuing the option defined
>> in the document http://tools.ietf.org/id/draft-ietf-mip6-hiopt-17.txt
>
> The MAG would be the NAS. As a NAS, it would get the LMA information
> from the AAA server. There is no need for any DHCP extensions here, only
> RADIUS and Diameter extensions.
>
> Vijay
>
>>
>> BR
>> Frank
>>
>> ----- Original Message ----- 
>> From: "Basavaraj Patil" <[email-masked]>
>> To: "ext Frank Xia" <[email-masked]>; "ext Narayanan, Vidya"
>> <[email-masked]>; <[email-masked]>
>> Sent: Tuesday, June 10, 2008 1:04 PM
>> > Frank,
>> > I don't know if you can equate LMA discovery with HA
>> discovery in the case
>> > of MIP6 primarily because the MN is not involved in the
>> case of PMIP6.
>> > The MN is unaware of PMIP6 elements (MAG/LMA) as per the
>> current spec. So
>> > what would the DHCP options be?
>> >
>> > -Raj
>> >
>> >
>> > On 6/10/08 12:01 PM, "ext Frank Xia" <[email-masked]> wrote:
>> >
>> >> Hi Raj
>> >>
>> >>  AAA is not sufficient enough for HA discovery
>> >> in MIP6, and DHCP solution is thus proposed.
>> >>
>> >> Vijay and I had many discussion in the mailing list
>> >> about dynamic LMA discovery  mechanisms which
>> >> are out of the scope of basic specification.
>> >>
>> >> IMHO, DHCP soultion is expected to be one part of it.
>> >>
>> >> BR
>> >> Frank
>> >>
>> >>
>> >> ----- Original Message -----
>> >> From: "Basavaraj Patil" <[email-masked]>
>> >> To: "ext Narayanan, Vidya" <[email-masked]>; <[email-masked]>
>> >> Sent: Tuesday, June 10, 2008 11:44 AM
>> >>> Just wondering about specifically what is the discovery
>> component needed
>> >>> for
>> >>> PMIP6? Is it not sufficient that the policy store
>> indicates the LMA to
>> >>> be
>> >>> assigned for an MN to the MAG?
>> >>> Or are we considering the ability for an MN to indicate
>> via some means
>> >>> an
>> >>> LMA to which it requires a prefix from?
>> >>>
>> >>> -Raj
>> >>>
>> >>>>
>> >>>> Thanks,
>> >>>> Vidya and Jonne