Subject: [netlmm] LMA assignment in the visited link (was RE: NETLMM Re-Chartering Topics - Seeking Input)

From: "Vijay Devarapalli" <[email-masked]>
Date: Tue, 10 Jun 2008 19:31:30 -0400

Hi Frank,

(changed the subject..) 

> -----Original Message-----
> From: Frank Xia [mailto:[email-masked]] 
> Sent: Tuesday, June 10, 2008 12:06 PM
> To: Vijay Devarapalli
> Subject: Fw: [netlmm] NETLMM Re-Chartering Topics - Seeking Input
> 
> Hi Vijay
> 
> Probably I should make the scenario more clear.
> 
> IP traffic local breakout (3GPP terms) means MN's traffic
> is anchored by visited LMA not home LMA.
> 
> In this scenario, the MAG(or NAS)  contacts Home AAA for
> authentication while HAAA can't assign any LMA for the MN
> because HAAA has no any information about visited networks.

In this particular scenario the AAA server in the local network will
assign the LMA. The MAG would still be the NAS. No DHCP extensions
required.

Vijay

> 
> BR
> Frank
> 
> ----- Original Message ----- 
> From: "Vijay Devarapalli" <[email-masked]>
> To: "Frank Xia" <[email-masked]>; "Basavaraj Patil" 
> <[email-masked]>; "ext Narayanan, Vidya" 
> <[email-masked]>; 
> <[email-masked]>
> Sent: Tuesday, June 10, 2008 1:41 PM
> Subject: RE: [netlmm] NETLMM Re-Chartering Topics - Seeking Input
> 
> 
> Frank,
> 
> > Local breakout of IP traffic via the visited PLMN is supposed
> > be supported,
> > when network policies and user subscription allow it.
> >
> > In this case,  HPLMN can't not assign any LMA for MN during
> > the authentication procedure.   So, MAG acting as DHCP client
> > asks for  LMA information by resuing the option defined
> > in the document 
> http://tools.ietf.org/id/draft-ietf-mip6-hiopt-17.txt
> 
> The MAG would be the NAS. As a NAS, it would get the LMA information
> from the AAA server. There is no need for any DHCP extensions 
> here, only
> RADIUS and Diameter extensions.
> 
> Vijay
> 
> >
> > BR
> > Frank
> >
> > ----- Original Message ----- 
> > From: "Basavaraj Patil" <[email-masked]>
> > To: "ext Frank Xia" <[email-masked]>; "ext Narayanan, Vidya"
> > <[email-masked]>; <[email-masked]>
> > Sent: Tuesday, June 10, 2008 1:04 PM
> > Subject: Re: [netlmm] NETLMM Re-Chartering Topics - Seeking Input
> >
> >
> > >
> > > Frank,
> > >
> > > I don't know if you can equate LMA discovery with HA
> > discovery in the case
> > > of MIP6 primarily because the MN is not involved in the
> > case of PMIP6.
> > > The MN is unaware of PMIP6 elements (MAG/LMA) as per the
> > current spec. So
> > > what would the DHCP options be?
> > >
> > > -Raj
> > >
> > >
> > > On 6/10/08 12:01 PM, "ext Frank Xia" 
> <[email-masked]> wrote:
> > >
> > >> Hi Raj
> > >>
> > >>  AAA is not sufficient enough for HA discovery
> > >> in MIP6, and DHCP solution is thus proposed.
> > >>
> > >> Vijay and I had many discussion in the mailing list
> > >> about dynamic LMA discovery  mechanisms which
> > >> are out of the scope of basic specification.
> > >>
> > >> IMHO, DHCP soultion is expected to be one part of it.
> > >>
> > >> BR
> > >> Frank
> > >>
> > >>
> > >> ----- Original Message -----
> > >> From: "Basavaraj Patil" <[email-masked]>
> > >> To: "ext Narayanan, Vidya" <[email-masked]>; 
> <[email-masked]>
> > >> Sent: Tuesday, June 10, 2008 11:44 AM
> > >> Subject: Re: [netlmm] NETLMM Re-Chartering Topics - Seeking Input
> > >>
> > >>
> > >>>
> > >>> Hi Vidya,
> > >>>
> > >>> On 6/6/08 11:09 AM, "ext Narayanan, Vidya"
> > <[email-masked]> wrote:
> > >>>
> > >>>> 4) Automated Local Mobility Anchor (LMA) discovery
> > >>>
> > >>> Just wondering about specifically what is the discovery
> > component needed
> > >>> for
> > >>> PMIP6? Is it not sufficient that the policy store
> > indicates the LMA to
> > >>> be
> > >>> assigned for an MN to the MAG?
> > >>> Or are we considering the ability for an MN to indicate
> > via some means
> > >>> an
> > >>> LMA to which it requires a prefix from?
> > >>>
> > >>> -Raj
> > >>>
> > >>>>
> > >>>> Thanks,
> > >>>> Vidya and Jonne
> > >>>> _______________________________________________
> > >>>> netlmm mailing list
> > >>>> [email-masked]
> > >>>> https://www.ietf.org/mailman/listinfo/netlmm
> > >>>
> > >>> _______________________________________________
> > >>> netlmm mailing list
> > >>> [email-masked]
> > >>> https://www.ietf.org/mailman/listinfo/netlmm
> > >>>
> > >>
> > >>
> > >
> > >
> >
> >
> > _______________________________________________
> > netlmm mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/netlmm
> >
> 
> 
> 
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Frank Xia" <[email-masked]>
Date: Tue, 10 Jun 2008 18:46:22 -0500

Hi Vijay

Please see my reply...

BR
Frank

----- Original Message ----- 
From: "Vijay Devarapalli" <[email-masked]>
To: "Frank Xia" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, June 10, 2008 6:31 PM
Subject: LMA assignment in the visited link (was RE: [netlmm] NETLMM 
Re-Chartering Topics - Seeking Input)

Hi Frank,

(changed the subject..)

In this particular scenario the AAA server in the local network will
assign the LMA. The MAG would still be the NAS. No DHCP extensions
required.
Frank=>Typically,  a home AAA server  NOT  a visited AAA server
authenticates the MN even when the MN is in the visited networks.
Of course, the visited AAA server can be an AAA proxy or AAA relay,
but the visited AAA server can't change(modify/add)  any  authorization
information.  So it is impossible for the visited AAA server to deliver
LMA information.

Vijay

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Tue, 10 Jun 2008 20:03:56 -0400

> information.  So it is impossible for the visited AAA server 

The mobile node would still be authenticated by the Home AAA server, but
LMA assignment will be delegated to the AAA server in the visited
network for the scenario you brought up.

Vijay

---

From: "Frank Xia" <[email-masked]>
Date: Tue, 10 Jun 2008 19:25:25 -0500

Hi Vijay

Please see my explaination...

BR
Frank

----- Original Message ----- 
From: "Vijay Devarapalli" <[email-masked]>
To: "Frank Xia" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, June 10, 2008 7:03 PM
Subject: RE: LMA assignment in the visited link (was RE: [netlmm] NETLMM 

Frank=>The authentication messages exchange occurs  between  the MN
and the home AAA server.   The visited AAA server only routes
the message.  It is impossible for the visited AAA to populate
LMA information  into the exchanging messges.
Do you want to introduce other message exchanges between
 the MN and the visited AAA server?

Vijay

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Tue, 10 Jun 2008 21:38:05 -0400

Frank,
 
> the MN and the visited AAA server?

You were the on who brought up the 3GPP Local Breakout scenario. I was
trying to explain to you how 3GPP has defined LMA assignment for this
scenario. If the LMA is being assigned by the AAA server, the home AAA
server can delegate the assignment of the LMA to the visited AAA server.
The visited AAA server then allocates the LMA. Now you are calling this
solution "impossible". :)

There is *no* DHCP involved here. 

I suggest you either talk to 3GPP delegates in your company on how the
LMA assignment is done in the visited network or read section 4.5.1 of
TS 23.402.

Vijay

---

From: "Frank Xia" <[email-masked]>
Date: Tue, 10 Jun 2008 21:59:43 -0500

Hi Vijay

Just as I explained before,  whether the visited
AAA is able to assign the visited LMA  or not
is not essential. The essence of the problem is
if the following scenario is valid.

During bootstraping in a visited network, the
MN is allowed to access visited LMA based on
the user's profile and operators' agreement.
The visited network has PMIPv6 and MIPv6
hybrid deployments, and all the visited LMA information
(availability, performance, loading and so on)
is dynamically managed by DHCP servers

How does the MAG find an available  LMA from
the central DHCP servers?

I also encourage other colleagues to comment.

BR
Frank

----- Original Message ----- 
From: "Vijay Devarapalli" <[email-masked]>
To: "Frank Xia" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, June 10, 2008 8:38 PM
Subject: RE: LMA assignment in the visited link (was RE: [netlmm] NETLMM 

Frank,

Vijay