Subject: Re: [netlmm] Scope of revised charter: MN impact

From: "Mohana Jeyatharan" <[email-masked]>
Date: Mon, 23 Jun 2008 09:09:37 +0800

Hello Charlie,

Please see reply in-line. Many of your points are so valid. However, I
have tried to reply to you...

> -----Original Message-----
> From: Charles E. Perkins [mailto:[email-masked]] 
> Sent: Saturday, June 21, 2008 12:54 AM
> To: Mohana Jeyatharan
> Cc: Giaretta, Gerardo; [email-masked]
> Subject: Re: [netlmm] Scope of revised charter: MN impact
> 
> 
> Hello Mohana,
> 
> I have questions about your answers to Gerardo...
> 
> Mohana Jeyatharan wrote:
> 
> > [Mohana] The current charter says that MN should not be involved in 
> > mobility management signaling.  It does not restrict the MN from 
> > participating in some support signaling.
> 
> Do you mean that it is O.K. for a MN to support mobility 
> management, but that it is not O.K. for a MN to be involved 
> with mobility management?
> 
> I think such a distinction would be almost impossible to 
> apply or evaluate in practice.
> 
[Mohana] My true feeling is mobility support signaling is basic location
update signaling. Handoff optimization , multihoming related siganling
are support signaling and they are not directly related to mobility
management signaling.
First of all, why is that a node that has MIP stack choose to operate in
PMIP mode. It does not want to engage in frequent signaling. But, if
such a node says I am not going to engage in any signaling then 
it cannot have better services. But, all I am saying is that to achieve
some benefits in PMIP some signaling should be performed and definitely
it should not be high. For example, the MN wants to inform its hand-off
state to MAG or some thing like that. This can be tied in Mn-AR
inetrface by some flag or something to existing messages. These are not
completely
New signaling. Basically it is like optimization of existing messages to
get better services.
> >   I am not sure why
> > you categorize inter-tech handover optimization signaling, or 
> > multihoming Related signaling in PMIP to mobility management 
> > signaling.
> 
> I would certainly characterize handover signaling as related 
> to mobility management.  It's almost a tautology!!
> 
> > I think mobility Management signaling is mainly to create routing 
> > state.
> 
> As opposed to... what?  Forwarding state?  Bridging state?  
> Location state?  or... ??
> 
> > Also, having some infrequent AR interaction is very different to 
> > updating your location at an HA (this is mobility management 
> > signaling).
> 
> How infrequent?  Does the relatively long MIPv6 maximum 
> binding lifetime (3 days, I think) lead to overly frequent signaling?
> Compared to, say, what?
> 
[Mohana] What I meant is that when you use CMIP then every time you
change your network
you need to update the HA. But, in PMIP you don't need to do that. What
ever optimization
Signaling should not be done often. Thus all optimization signaling may
be performed
Once and perhaps transferred via context transfer or should not be as
frequent as location update signaling.
Definitely I agree on this. If one is going to perform lot of signaling
in PMIP mode, then there is no point in using PMIP, in that case it is
better to switch to CMIP mode.
> >
> > [Mohana] I am not sure why you are not satisfied with the problem 
> > statement.
> > We are not changing the charter goal. Definitely there is no 
> > modifciation to unmodified host
> >   
> 
> This, I can go along with :-)
> 
> > All what we are saying is that for hosts that want some better 
> > services in PMIP should be able to perform some signaling to the 
> > network to achieve this.
> >   
> 
> I can also go along with this :-)
> 
> > This is not
> > Mobility management signaling and thus I don't see why it 
> breaks the 
> > charter goals.
> >   
[Mohana] Charlie, My understanding of mobility management signaling was
merely location updates. I categorized the rest as some signaling to
achieve other services. Better handoff.....
Any way, now we are into re-chartering. The old charter is mobility
mangement for unmodified hosts. I don't see why the old charter golas
should be carried so strictly to the new charter. The new charter can
perhaps work on MN's that want better service in PMIP. Future nodes or
mobile terminals will definitely want better services.

Thanks.

BR,
Mohana
> This is the part that has me stumped.
> 
> 
> Regards,
> Charlie P.
> 
> 
> 
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "BLUME, Oliver" <[email-masked]>
Date: Mon, 23 Jun 2008 10:59:09 +0200

Hi,

I followed this thread on allowing additional signalling involving the MN in PMIP. Please allow me to add my 2ct:

[Mohana] What I meant is that when you use CMIP then every time you change your network you need to update the HA. But, in PMIP you don't need to do that. What ever optimization Signaling should not be done often. Thus all optimization signaling may be performed Once and perhaps transferred via context transfer or should not be as frequent as location update signaling.
[Charles E. Perkins] Definitely I agree on this. If one is going to perform lot of signaling in PMIP mode, then there is no point in using PMIP, in that case it is better to switch to CMIP mode.

I strongly support allowing some signalling between MN and MAG, if the MN wants improved performance and supports according enhancements of PMIP. But IMHO, distinguishing between mobility and support signalling is somewhat arbitrary, only justified to formally respect the charta.  Actually, signalling for optimization cannot be done only once, but needs to be done for every handover: An indication to the MAG that this is a handoff rather than a new mobility session (MAG to set HI=2) needs to be repeated for every handoff unless there is context transfer within the PMIP domain and the MN has committed not to start multiple sessions...

I would propose to rather think about a discrimination between signalling MN-HA/LMA vs. signalling MN-MAG. Signalling of the MN should be restricted to local communication with the MAG and exclude mobility signalling with the MIPv6 mobility anchor. The MN should not be aware of the LMA (i.e. MN does not have to know the serving LMA and it does not know any LMA state ). But MN is aware of the MAG from the default router parameter in the RA and might be allowed in the PMIP (re-)charta to exchange signalling point-to-point with the MAG.

BR,

Oliver

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Mohana Jeyatharan
Gesendet: Montag, 23. Juni 2008 03:10
An: Charles E. Perkins
Cc: [email-masked]
Betreff: Re: [netlmm] Scope of revised charter: MN impact

Hello Charlie,

Please see reply in-line. Many of your points are so valid. However, I have tried to reply to you...

> Do you mean that it is O.K. for a MN to support mobility management, 
> but that it is not O.K. for a MN to be involved with mobility 
> management?
> 
> I think such a distinction would be almost impossible to apply or 
> evaluate in practice.
> 
[Mohana] My true feeling is mobility support signaling is basic location update signaling. Handoff optimization , multihoming related siganling are support signaling and they are not directly related to mobility management signaling.
First of all, why is that a node that has MIP stack choose to operate in PMIP mode. It does not want to engage in frequent signaling. But, if such a node says I am not going to engage in any signaling then it cannot have better services. But, all I am saying is that to achieve some benefits in PMIP some signaling should be performed and definitely it should not be high. For example, the MN wants to inform its hand-off state to MAG or some thing like that. This can be tied in Mn-AR inetrface by some flag or something to existing messages. These are not completely New signaling. Basically it is like optimization of existing messages to get better services.
> I would certainly characterize handover signaling as related to 
> mobility management.  It's almost a tautology!!
> 
> How infrequent?  Does the relatively long MIPv6 maximum binding 
> lifetime (3 days, I think) lead to overly frequent signaling?
> Compared to, say, what?
> 
[Mohana] What I meant is that when you use CMIP then every time you change your network you need to update the HA. But, in PMIP you don't need to do that. What ever optimization Signaling should not be done often. Thus all optimization signaling may be performed Once and perhaps transferred via context transfer or should not be as frequent as location update signaling.
Definitely I agree on this. If one is going to perform lot of signaling in PMIP mode, then there is no point in using PMIP, in that case it is better to switch to CMIP mode.
> > Mobility management signaling and thus I don't see why it
[Mohana] Charlie, My understanding of mobility management signaling was merely location updates. I categorized the rest as some signaling to achieve other services. Better handoff.....
Any way, now we are into re-chartering. The old charter is mobility mangement for unmodified hosts. I don't see why the old charter golas should be carried so strictly to the new charter. The new charter can perhaps work on MN's that want better service in PMIP. Future nodes or mobile terminals will definitely want better services.

Thanks.

BR,
Mohana

---

From: Niklas Neumann <[email-masked]>
Date: Mon, 23 Jun 2008 15:52:34 +0200

Hello Mohana,

reading the discussion I largely agree with Gerardo. It boils down to
the question what the difference is between PMIP + "extensions" and MIP.
Even if the "generic support functions" whatever they may be are only
optional to optimize things, why not just use MIP (or for what its worth
some MIP light) inside the PMIP domain then? Sure, there are some open 
issues where MIP can be optimized but isn't that in the scope of other 
WGs (e.g. MIPSHOP or MEXT)?

I understand that there are limitations to a network-based mobility
approach. But they are inherent in the "network-based" part.
That being said, I do believe that there is room for some generic
improvements on the IP layer to support mobility (e.g. multihoming and
mobility). In my opinion the question is how tight you want to bind them
to PMIP instead of making them more generic.

Best regards
   Niklas

-- 
Niklas Neumann - University of Goettingen, Institute of Informatics
http://user.informatik.uni-goettingen.de/~nneuman1/
Tel: +49 551 39-14419
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: Jun AWANO <[email-masked]>
Date: Wed, 25 Jun 2008 09:59:16 +0900

Hi Oliver,

I totally agree with you.
I also think signaling between MN-MAG is useful to enhance PMIP mobility.
MN can inform MAG of some information like MN's intention or exchange it 
with MAG by using signaling.
And it is better that the signaling is not depending on specific access 
technologies and systems, I think.

As you said, there are some differences between CMIP and PMIP even if
MN use such signalings as frequent as CMIP binding update.
MN doesn't necessarily need to have network side information like LMA's 
address.
And MN doesn't need to encap and decap data packets.

BR,
Jun

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 27 Jun 2008 11:28:15 -0700

Hello Oliver,

You attributed to me something which isn't totally accurate,
so I hope it is O.K. if I try to clarify what I had wanted to say.

> [Charles E. Perkins] Definitely I agree on this. If one is going to perform lot of signaling in PMIP mode, then there is no point in using PMIP, in that case it is better to switch to CMIP mode.

But I didn't really say this, or at least did not mean to say it.

Instead, I think that if the mobile device is going to be
modified to support some signaling to the network, then we
ought to find out why the proposed modifications are better
than CMIP for the purpose.  If they're better, that's great.
If they're just hacks to avoid doing CMIP, then maybe that's
not so great after all.

Of course I'd like to see the mobile device be the master
of its own fate, to the greatest extent possible.  Why not?

Regards,
Charlie P.

---

From: "BLUME, Oliver" <[email-masked]>
Date: Mon, 30 Jun 2008 11:31:29 +0200

Hello Charles,

Thanks for your reply. 

I copied the statement from the thread, but obviously erroneously assigned the second part of Mohana's statement to you (i.e. I missed that after the linebreak the [Mohana] was still valid).  I appologize for the confusion!

I see your point to compare optimised PMIP to what CMIP already does. I don't think there is an answer to this, yet. Currently, the discussion is looking at the gaps basic PMIP has for smooth mobility. It is an open question whether the required modification would eat up the benefit of PMIP. 

What I wanted to add to the discussion is the consideration whom the mobile node has to address for additional signalling. Rather than discriminating mobility signalling and supporting signalling it might be better to seperate between signalling MN-HA/LMA vs. signalling MN-MAG. Enhanced PMIP might allow the MN to signal to MAG (and part of this signalling could be done below IP layer in the link layer protocol or in the point-to-point communication). In that sense, the MN would not be involved in IP mobility signalling with the LMA, as the charta states.

Sorry again for the confusion by addressing you. Let's see if Mohana wants to add a comment.

Regards,

Oliver  

-----Ursprüngliche Nachricht-----
Von: Charles E. Perkins [mailto:[email-masked]] 
Gesendet: Freitag, 27. Juni 2008 20:28
An: BLUME, Oliver
Cc: [email-masked]
Betreff: Re: [netlmm] Scope of revised charter: MN impact

Hello Oliver,

You attributed to me something which isn't totally accurate, so I hope it is O.K. if I try to clarify what I had wanted to say.

Instead, I think that if the mobile device is going to be modified to support some signaling to the network, then we ought to find out why the proposed modifications are better than CMIP for the purpose.  If they're better, that's great.
If they're just hacks to avoid doing CMIP, then maybe that's not so great after all.

Of course I'd like to see the mobile device be the master of its own fate, to the greatest extent possible.  Why not?

Regards,
Charlie P.