Subject: Re: [netlmm] [MEXT] [netext] NEXTEXT2: first draft of the bof description

From: "Stuart W. Card" <[email-masked]>
Date: Mon, 29 Jun 2009 21:18:30 -0400

Charles E. Perkins wrote:
> Isn't make-before-break a function performed
> at the link layer?
>
> It certainly isn't PHY, and I wouldn't think it
> qualifies as MAC (i.e., it doesn't control the
> device's access to the medium). 
Different approaches to make-before-break can be implemented in 
different layers.

For several years, our team has done it at Layer 3, because we have had 
the luxury
of multiple radios that can operate concurrently. We simply make a MIP 
registration
on every radio that policy says we are allowed to use at the moment and 
that can
hear a base station, and insert concurrent multipath routes into our 
routing table.

Traffic naturally gets divided among paths, which we weight according to 
their
recent performance, so as a link fades, less and less traffic is routed 
over that
path, and eventually we drop it from the routing table (generally when 
we can
no longer successfully renew our MIP registration over it).

This is fairly trivial if the load balancing is flow-by-flow. If it is 
packet-by-packet,
then most TCP implementations will blow up, so we use the SCPS-TP variant.

My point is not that everyone should use SCPS-TP over Concurrent Multipath
Routing, but that make-before-break is a cat that can be skinned many ways,
depending upon what you are making and breaking: a physical channel;
a logical link; an end-to-end path; etc.

-- 
Stuart W. Card, Chief Scientist & VP, Critical Technologies Inc.
* Creativity * Diversity * Expertise * Flexibility * Integrity *
Suite 400 Technology Center, 4th Floor 1001 Broad St, Utica NY 13501
315-793-0248 x141 FAX -9710 <[email-masked]> www.critical.com

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 30 Jun 2009 09:02:30 +0700

[email-masked] writes:

> Hi Frank,
> 
> Make-before-break is inherently supported in certain technologies such
> as
> CDMA/WCDMA (which has soft HO features built in). The same is not
> possible
> for example in TDMA (GSM) or OFDMA (802.16e and WiFi). 802.16e does
> have a
> contorted mechansim for achieving the same but that's besides the
> point.
> So IMO it is a capability of the Phy/Mac.
> However it is possible to emulate soft-handovers and achieve
> make-before-break in certain cases. For example it is possible to be
> simultaneously connected to HSPA and WiFi and accomplish a make-before-
> break
> HO. I guess the definition of the term depends on an access tchnology
> or the
> combination of access technologies in the context of a use-case.

I'm inclined to agree with you, though isn't the implementation of
make-before-break capability possible using any PHY & dual radios?  The
problem being the price of parts...

...

---

From: "Davis, Terry L" <[email-masked]>
Date: Tue, 30 Jun 2009 06:45:06 -0700

Glen

Right, cost, weight, and drag, in our case.  If you are using links to geos, it definitely takes two antenna's to do make before break.  

However a single antenna, as Connexion by Boeing used, can move from one geo and lock onto another and have layer 3 routing flowing in well under 30 seconds; a short enough time that almost none of the TCP timers trigger.  The user sees a short "loss of QOS" if they are actively typing or talking which appears to be no more than a web server not responding for a few seconds or your VoIP losing a few seconds of conversation.

As far as aviation goes, you will see both types of handoff's made with a make before break probably more common with air-to-ground links than satellite.

Coordination capabilities between layer 2 and layer 3 for the handoffs though are critical.

Take care
Terry

PS: Until the IPSec, PKI, and IKEv2 interoperability between vendors (I mean dozens of different vendors!) progresses such that it actually can be dynamically done, deciding which security associations belong to which link providers and auto-configuring the links, I would expect that establishing link authentication and security will remain a primary challenge to mobility services.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Glen Zorn
> Sent: Monday, June 29, 2009 7:03 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: [MEXT] [netext] [netlmm] NEXTEXT2: first draft of thebof
> description
> 
> _______________________________________________
> MEXT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mext