Subject: Re: [Netmod-ver-dt] Netmod Ver DT - Meeting Agenda 24th May

From: wangzitao <[email-masked]>
Date: Thu, 24 May 2018 15:26:06 +0000

Dear All, 

Sorry for late joining in and missing a lot of interesting discussions. 
I had a quick review of Benoit’s problem statements, it seems well and is a good start.
And I also proposed some inputs of problem statements/requirements which come from some model designers and customers’ feedbacks. Please see following:

#1 Updating a model may cause a chain reaction, a lot of modules which dependent on it need to update.
	- How to quickly complete the update, close the issue?
#2 It need some method to reflect the changes to help to improve the module designer’s efficiency.
	- May need some tools to present the change log.
	- May need some guidance for user onboarding, teaching them how to use these tools.
#3 It also may need some document writing specifications / YANG coding conventions to help reader quickly retrieve the change log. E.g. 
	- In document’s some section to present the update details;
	- Or in model’s description statement to embed external links, like https://www.yangcatalog.org, to retrieve the change log.

Any comments?

Best Regards!
-Michael

-----邮件原件-----
发件人: Netmod-ver-dt [mailto:[email-masked]] 代表 Robert Wilton
发送时间: 2018年5月24日 21:56
收件人: [email-masked]
主题: Re: [Netmod-ver-dt] Netmod Ver DT - Meeting Agenda 24th May

I've also created an EtherPad for collaborate meeting notes/minutes.

http://etherpad.tools.ietf.org:9000/p/netmod-ver-dt

Thanks,
Rob

On 24/05/2018 14:06, Robert Wilton wrote:
> Hi,
>
> The proposed agenda for today's meeting is as follows:
>
> 1) Agenda bashing (if required) (5 mins)
> - I will take minutes.  Should we also record meetings?
>
> 2) Cover initial scope and timelines for the DT (5 mins):
> - I would like to focus just on the Problem Statement and Solution 
> Requirements, deferring discussion on the actual solution until we 
> have got these broadly agreed.
> - It would be nice to aim for an initial draft covering problem 
> statement and requirements before IETF 102.  Is this feasible?
>
> 3) Discussion on Problem Statement and Solution Requirements (45 mins)
> - Benoit has proposed using the problem statement from the clacla 
> draft as a starting point.  Does anyone disagree, or propose a 
> different starting point for the problem statement?
>  - Discussion/refinement on the problem statement and requirements.
>
> 5) Wrap up, next steps. (5 mins)
> - What frequency of meetings?  Weekly running up to IETF?
>
> Thanks,
> Rob
>

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: Robert Wilton <[email-masked]>
Date: Thu, 24 May 2018 17:12:49 +0100

Hi Michael,

Some comments inline ...

> 	- How to quickly complete the update, close the issue?
Yes, this one came up in discussions, and I agree that it is an issue to 
be solved.  I think that this is similar to the problem described in 2.4 
YANG Module Transition Strategy of the clacla draft.  Do you think that 
changing the text would make this clearer and if so please can you send 
some proposed text.

> #2 It need some method to reflect the changes to help to improve the module designer’s efficiency.
I agree that module designers/users need to be able to understand the 
change history between different versions/revisions of a YANG module.  
Tooling can certainly help here, but it can't capture everything.  Is 
this requirement similar to the one captured in section 2.7 of the 
clacla draft: "No way to easily decide whether a change in Backwards 
Compatible"?

> 	- In document’s some section to present the update details;
I would expect to see a summary of the changes in the revision history.  
Are you thinking of something more detailed?

> 	- Or in model’s description statement to embed external links, like https://www.yangcatalog.org, to retrieve the change log.
Not sure on this one.

Thanks,
Rob