Subject: Re: [Netmod-ver-dt] Do submodules have a semantic version associated with them?

From: wangzitao <[email-masked]>
Date: Tue, 27 Nov 2018 02:58:30 +0000

Hi Guys,

IHMO, in most cases, the submodel be used as a smaller block of a whole model and it cannot work alone. 
But is there any case that one submodel can be included by multiple main models? 
If yes, I believe that the submodel should have an independent SemVer, because if the submodel have NBC/BC changes, different main models may not perceive it and update their SemVer at same time.

Best Regards!
-Michael

-----邮件原件-----
发件人: Netmod-ver-dt [mailto:[email-masked]] 代表 Reshad Rahman (rrahman)
发送时间: 2018年11月27日 9:13
收件人: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>; Ebben Aries <[email-masked]>; Joe Clarke (jclarke) <[email-masked]>
抄送: Robert Wilton -X (rwilton - ENSOFT LIMITED at Cisco) <[email-masked]>; [email-masked]
主题: Re: [Netmod-ver-dt] Do submodules have a semantic version associated with them?

    We *could* consider that the main module must indicate a BC change if any submodule has a BC change, and an NBC change if any submodule has an NBC change though. Although not sure that is necessary.
<RR> Pretty sure it's necessary. Otherwise if a submodule has NBC change and the module version hasn't changed, we need to look at versions of all submodules to figure out whether NBC change took place in the module? A submodule is just a way to split a module in smaller pieces, and can't exist on its own.

On 2018-11-26, 6:20 PM, "Netmod-ver-dt on behalf of Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked] on behalf of [email-masked]> wrote:

    Hi guys,
    
    OC acts with a lot fewer constraints than vendors.
    
    I don't agree with enforcing that submodules have the same SemVer as the main module. There is no such rule for YANG version today.
    
    When a data model is organized into submodules that allows someone to indicate what parts of the overall model changed (BC or NBC or not at all) with more granularity than just the entire superset module.
    
    We *could* consider that the main module must indicate a BC change if any submodule has a BC change, and an NBC change if any submodule has an NBC change though. Although not sure that is necessary.
    
    Jason
    
    > -----Original Message-----
    > From: Netmod-ver-dt <[email-masked]> On Behalf Of
    > Ebben Aries
    > Sent: Monday, November 26, 2018 12:18 PM
    > To: Joe Clarke <[email-masked]>
    > Cc: Robert Wilton <[email-masked]>; [email-masked]
    > Subject: Re: [Netmod-ver-dt] Do submodules have a semantic version
    > associated with them?
    > 
    > On Nov 26 14:55 PM, Joe Clarke wrote:
    > > On 11/26/18 13:06, Robert Wilton wrote:
    > > > Do submodules have a semantic version associated with them?  It seems
    > > > that it would be useful information.
    > > >
    > > > If they are allowed a semantic version, then do we force that they have
    > > > exactly the same version as the module including them? This would seem
    > > > like a good idea to keep everything together.
    > >
    > > While they should retain their revisions, I think they should probably
    > > share the semver of the main module.  They should not have their own
    > > version.
    > >
    > > The YANG version is for the whole module+submodules taken together.
    > >
    > 
    > +1 - This came up a few yr back within OpenConfig and if you look at how
    > the models are grouped w/ heavy use of submodules per domain, you'll see
    > precisely this approach.  They are treated as a model grouping and the
    > semver increments across all simultaneously.
    > 
    > Though it doesn't appear any such wording was ever published on
    > http://openconfig.net/docs/semver/
    > 
    > /ebben
    > 
    > _______________________________________________
    > Netmod-ver-dt mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/netmod-ver-dt
    
    _______________________________________________
    Netmod-ver-dt mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/netmod-ver-dt

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 26 Nov 2018 19:04:06 -0800

> On Nov 26, 2018, at 6:58 PM, wangzitao <[email-masked]> wrote:
> 
> Hi Guys,
> 

A submodule can belong to one main module only. Note, the ‘belongs-to’ statement in submodules.

>> http://openconfig.net/docs/semver/

Mahesh Jethanandani
[email-masked]