Subject: Re: [Netmod-ver-dt] Proposed updates to reqs draft

From: wangzitao <[email-masked]>
Date: Thu, 22 Nov 2018 03:18:43 +0000

Dear all,

Please find my comments with <MW>

Best Regards!
-Michael

-----邮件原件-----
发件人: Netmod-ver-dt [mailto:[email-masked]] 代表 Joe Clarke
发送时间: 2018年11月21日 23:36
收件人: Balázs Lengyel <[email-masked]>; [email-masked]
主题: Re: [Netmod-ver-dt] Proposed updates to reqs draft

On 11/21/18 10:32, Balázs Lengyel wrote:
> Hello,
> 
> After these changes IMHO Req. 4.4 is included in REQ 1.4 so I propose 
> removing 4.4

 Yeah, I see what you mean.  I'd be okay with that.  What do others think?
<MW>: I agree with Balazs, it seems that there are some repetitions. 

> 
> 
> I have doubts about the bug fix definition: one man's bug is another's 
> feature.
This is why I left out any examples and tried to tie it to a defect (which many if not all would recognize as something that was broken).

<MW>: For bug fix, do we need to mention that the bug fix may cause non-backward compatible change and backward compatible change? 

> Let's see. Later if we run into problems, we could remove the word bug 
> from the requirements, but keep it in some introductory text to 
> underline the main reason: why NBC changes are needed for older 
> releases.

At this point, I want to minimize changes to try and get to adoption.  I think we're very close.  Once the WG owns this, then we can further shape things.  But I'd like to think we can keep the core requirements stable so we can make steady progress on a solution.

Joe

> 
> regards Balazs
> 
> 
> On 2018. 11. 21. 15:58, Joe Clarke wrote:
>> I have started to make changes to the reqs draft based on feedback 
>> from IETF 103.  My commit message:
>>
>> Address items that arose at IETF 103.
>>
>> * Acknowledge the inspiration of OpenConfig for semver [1]
>>
>> * Refine the wording of requirement 1.4 to remove the notion of
>>    versioning YANG modules by product software releases [1]
>>
>> * Add a basic definition of "bug fix"
>>
>> * Refine wording of requirement 3.2
>>
>> Text contributed by:    Rob Wilton [1]
>>
>> Diff to txt:
>>
>> https://tools.ietf.org/rfcdiff?url1=draft-verdt-netmod-yang-versionin
>> g-reqs-01&url2=https://namale.marcuscom.com:8443/~jclarke/draft-verdt
>> -netmod-yang-versioning-reqs.txt
>>
>>
>> Comments thus far?
>>
>> Joe
>>
>> _______________________________________________
>> Netmod-ver-dt mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/netmod-ver-dt
> 
> 
> _______________________________________________
> Netmod-ver-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod-ver-dt
> 

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: wangzitao <[email-masked]>
Date: Sat, 24 Nov 2018 01:55:53 +0000

+1. Michael

发件人: Netmod-ver-dt [mailto:[email-masked]] 代表 Reshad Rahman (rrahman)
发送时间: 2018年11月23日 20:21
收件人: Balázs Lengyel <[email-masked]>; Robert Wilton -X (rwilton - ENSOFT LIMITED at Cisco) <[email-masked]>; Joe Clarke (jclarke) <[email-masked]>; Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>; Mahesh Jethanandani <[email-masked]>; Juergen Schoenwaelder <[email-masked]>
抄送: [email-masked]
主题: Re: [Netmod-ver-dt] Proposed updates to reqs draft

Sounds good to me.

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> on behalf of Balázs Lengyel <[email-masked]<mailto:[email-masked]>>
Date: Friday, November 23, 2018 at 6:49 AM
To: "Robert Wilton -X (rwilton - ENSOFT LIMITED at Cisco)" <[email-masked]<mailto:[email-masked]>>, "Joe Clarke (jclarke)" <[email-masked]<mailto:[email-masked]>>, "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]<mailto:[email-masked]>>, Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>>, Juergen Schoenwaelder <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netmod-ver-dt] Proposed updates to reqs draft

+1, go for adoption. Balazs
On 2018. 11. 23. 11:42, Robert Wilton wrote:
I have removed req 4.4 and the bug fix definition.  That leaves us with
this proposed change set:

https://tools.ietf.org/rfcdiff?url1=draft-verdt-netmod-yang-versioning-reqs-01&url2=https://namale.marcuscom.com:8443/~jclarke/draft-verdt-netmod-yang-versioning-reqs.txt

LGTM.

My vote is that we give this to chairs, and then see what comes back during the adoption poll, to find out if we need to spend time debating the definition of what a bug fix is.

--

Balazs Lengyel                       Ericsson Hungary Ltd.

Senior Specialist

Mobile: +36-70-330-7909              email: [email-masked]<mailto:[email-masked]>