Subject: [Netmod-ver-dt] Is this a bug correction, is this an NBC change ?

From: Balázs Lengyel <[email-masked]>
Date: Tue, 13 Nov 2018 12:30:55 +0000

Hello,

In one of our internal ericsson YANG modules (YAMs) we just
corrected a spelling mistake:

- enum "x733-ouput-device-error" {     - in
2.0.0

+ enum
"x733-output-device-error" {    - in 3.0.0

According to RFC 7950 this is not allowed.

This is an NBC change and clearly a bug correction. However if the
customer has stored alarm data that contains the value or a filter
in the NMS based on the enum name this might very well become a
problem.

According to the verdt solution either this is an NBC change
meaning that we have to change the major number (3.0.0) or it is a
bug correction that needs a change to the patch level (2.0.1). So
which?

We might not answer the question now, but at some point we will
need to.

regards Balazs

--
Balazs Lengyel Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909 email: [email-masked]

---

From: Robert Wilton <[email-masked]>
Date: Tue, 13 Nov 2018 13:06:27 +0000

Hi Balazs,

On 13/11/2018 12:30, Balázs Lengyel wrote:
>
> Hello,
>
> In one of our internal ericsson YANG modules (YAMs) we just corrected 
> a spelling mistake:
>
> - enum "x733-ouput-device-error" {     - in 2.0.0
> + enum "x733-output-device-error" {    - in 3.0.0
>
> customer has stored alarm data that contains the value or a filter in 
> the NMS based on the enum name this might very well become a problem.
>
> According to the verdt solution either this is an NBC change meaning 
> that we have to change the major number (3.0.0) or it is a bug 
> correction that needs a change to the patch level (2.0.1). So which?
>
I would argue that it is, and should be, an NBC change, so that it is 
either 3.0.0 or 2.0.1(M).

Thanks,
Rob

> We might not answer the question now, but at some point we will need to.
>
> regards Balazs
>
> -- 
> Mobile: +36-70-330-7909              email:[email-masked]  
>
> _______________________________________________
> Netmod-ver-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 22 Nov 2018 15:10:55 +0000

Agree. I don't think we should care or distinguish between "bug" or "enhancement". We should just define what is NBC and what isn't. This is NBC.

We have the same type of change we need to do in SR OS occasionally, and it is even slightly worse because we include enum 'value' statements and both of those items below would have the same enum value (which means we couldn't even mark the old one as obsolete and have both in the model).

Jason

From: Netmod-ver-dt <[email-masked]> On Behalf Of Robert Wilton
Sent: Tuesday, November 13, 2018 8:06 AM
To: Balázs Lengyel <[email-masked]>; [email-masked]
Cc: Enda Murphy <[email-masked]>
Subject: Re: [Netmod-ver-dt] Is this a bug correction, is this an NBC change ?

Hi Balazs,

Hello,

In one of our internal ericsson YANG modules (YAMs) we just corrected a spelling mistake:
- enum "x733-ouput-device-error" {     - in 2.0.0
+ enum "x733-output-device-error" {    - in 3.0.0

According to RFC 7950 this is not allowed.
This is an NBC change and clearly a bug correction. However if the customer has stored alarm data that contains the value or a filter in the NMS based on the enum name this might very well become a problem.

According to the verdt solution either this is an NBC change meaning that we have to change the major number (3.0.0) or it is a bug correction that needs a change to the patch level (2.0.1). So which?

I would argue that it is, and should be, an NBC change, so that it is either 3.0.0 or 2.0.1(M).

Thanks,
Rob

regards Balazs

--

Senior Specialist

Mobile: +36-70-330-7909              email: [email-masked]<mailto:[email-masked]>

[email-masked]<mailto:[email-masked]>