Subject: [Netmod-ver-dt] YANG Ver DT meeting 15th Nov

From: Robert Wilton <[email-masked]>
Date: Thu, 15 Nov 2018 10:37:08 +0000

Hi All,

I propose that we continue the DT meetings (including today) at the same 
time slot, if everyone who wants to participate can still make this time.

I know that Juergen still can't make this time slot for the next few 
weeks, but I'm hopefully that his schedule will change after that so 
that can participate.  If not then we may need to re-poll to see if we 
can find a different time that is acceptable to everyone.

The agenda today:
  - Agree the plan of what we should focus on running up to the end of 
the year, and towards IETF 104.
  - Perhaps try to split up the work to individuals.  I think that we 
need to have some more concrete solutions text proposed for particular 
aspects of the versioning problem.

Thanks,
Rob

http://etherpad.tools.ietf.org:9000/p/netmod-ver-dt

Meeting details:

JOIN WEBEX MEETING
https://cisco.webex.com/ciscosales/j.php?MTID=m196086ddc16716f4da6338e481c01246
Meeting number (access code): 200 574 017
Meeting password: UdTbwvpT (83829878 from phones)

JOIN FROM A VIDEO SYSTEM OR APPLICATION
Dial sip:[email-masked]
You can also dial 173.243.2.68 and enter your meeting number.
 From the Cisco internal network, dial *267* and the 9-digit meeting 
number.  If you are the host, enter your PIN when prompted.

JOIN BY PHONE
+1-866-432-9903 Call-in toll-free number (US/Canada)
+1-408-525-6800 Call-in toll number (US/Canada)

Global call-in numbers:
https://cisco.webex.com/ciscosales/globalcallin.php?serviceType=MC&ED=435913767&tollFree=1

Toll-free dialing restrictions:
https://www.webex.com/pdf/tollfree_restrictions.pdf

Can't join the meeting?
https://collaborationhelp.cisco.com/article/WBX000029055

Thanks,
Rob

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Thu, 15 Nov 2018 11:40:35 +0000

I’m still in Thailand on PTO.  I have been loosely following the threads on netmod.  I will own the mods to the reqs draft.  I won’t make today’s call.  And next Thursday is thanksgiving in the US.

That said, I feel that 3.2 should stay.  The solution could be recommendations that the approach to solve this is to use augmentations, deviations, if-feature, whatever.  There is strong opinion we need something here.

My recommendation would be to fix what we know is broken in the reqs draft and ask for adoption.  The workgroup and chairs can help refine the final text.  But we need that to happen fast so we can converge on a viable solution.

Joe

PGP Key : http://www.marcuscom.com/pgp.asc

> On Nov 15, 2018, at 17:37, Robert Wilton -X (rwilton - ENSOFT LIMITED at Cisco) <[email-masked]> wrote:
> 
> Hi All,
> 
> I propose that we continue the DT meetings (including today) at the same time slot, if everyone who wants to participate can still make this time.
> 
> I know that Juergen still can't make this time slot for the next few weeks, but I'm hopefully that his schedule will change after that so that can participate.  If not then we may need to re-poll to see if we can find a different time that is acceptable to everyone.
> 
> The agenda today:
>  - Agree the plan of what we should focus on running up to the end of the year, and towards IETF 104.
>  - Perhaps try to split up the work to individuals.  I think that we need to have some more concrete solutions text proposed for particular aspects of the versioning problem.
> 
> Thanks,
> Rob
> 
> 
> From the Cisco internal network, dial *267* and the 9-digit meeting number.  If you are the host, enter your PIN when prompted.
> 
> 
> JOIN BY PHONE

---

From: Robert Wilton <[email-masked]>
Date: Thu, 15 Nov 2018 12:49:18 +0000

Hi Joe,

> I’m still in Thailand on PTO.  I have been loosely following the threads on netmod.  I will own the mods to the reqs draft.  I won’t make today’s call.  And next Thursday is thanksgiving in the US.

OK, that sounds good.

> That said, I feel that 3.2 should stay.  The solution could be recommendations that the approach to solve this is to use augmentations, deviations, if-feature, whatever.  There is strong opinion we…

I think that we should reword 3.2 into something that folks are happier 
with, but with a broadly equivalent meaning.

OLD:

        3.2  The solution MUST provide a mechanism to allow servers to
             simultaneously support clients using different revisions of
             modules.  A client's choice of particular revision of one or
             more modules may restrict the particular revision of other
             modules that may be used in the same request or session.

NEW:

        3.2  The solution MUST define a mechanism to allow servers to
             simultaneously support clients using different revisions of
             modules.  The mechanism SHOULD be optional for servers
             to implement.  The solution MAY be constrained to only
             support the client choosing between server defined sets of
             modules, where a particular session (or request) is
             constrained to using a single set of modules.

Although this requirement now sounds like it is heavily angling towards 
a particular solution.

> My recommendation would be to fix what we know is broken in the reqs draft and ask for adoption.  The workgroup and chairs can help refine the final text.  But we need that to happen fast so we can…

Agreed.

Enjoy the rest of your holiday :-)

Thanks,
Rob

---

From: Robert Wilton <[email-masked]>
Date: Thu, 15 Nov 2018 15:16:13 +0000

Only Balazs and I were there today.  We've cancelled, and will meet in 2 
weeks time, i.e. 29th November.

Thanks,
Rob

On 15/11/2018 10:37, Robert Wilton wrote:
> Hi All,
>
> I propose that we continue the DT meetings (including today) at the 
> same time slot, if everyone who wants to participate can still make 
> this time.
>