Subject: "recommended" attributes

From: "Noveck, Dave" <[email-masked]>
Date: Mon, 23 Jul 2001 11:01:35 -0700

It seems to me that recommended attributes started out
as just that: attributes that we recommended that 
servers implement but which we recognized that not
all servers might be able to implement.  The idea
was that it was better for servers to honestly tells us
that no support was available, than to try to pretend
(badly) that support was available.

At some point, we started to add attributes of which
that could not be said (e.g mime-type).  The newly-
proposed attributes also do not seem to be things that
we are not intending to really recommend, but instead
are optional attributes, that some servers might
implement and some clients might look at.

I'm not dead set against such optional attributes,
but we have to recognize that their inclusion 
complicates nfs inter-operability testing (not the 
part that consists of running the connectathon 
tests, however :-).  Since we can add recommended/
optional attributes in a minor version, I think we
should go slow about adding these now.  Let's not add
attributes because they exist in some filesystem
and might at some point be needed.  If a real need
for an attribute arises, we can add it at that point.

---

From: Spencer Shepler <[email-masked]>
Date: Mon, 23 Jul 2001 18:01:29 -0500

I agree on both counts (original intent and plan of action).

As owner of the ever growing (and tardy) issues list for RFC3010, 
it seems that we should limit ourselves to what is "broken" or
needs clarification.  Minor versioning will allow the introduction
of additional attribute definitions and other functionality.
It would be good to get some operational experience with NFSv4
before jumping into adding addition options...

-- 

- Spencer -