Subject: delegation and OPEN_CONFIRM

From: "Kendrick M. Smith" <[email-masked]>
Date: Fri, 6 Jul 2001 12:06:26 -0400 (EDT)

Suppose
  (1) the RESULT_CONFIRM flag is set in an OPEN response
  (2) a delegation is also returned in the OPEN response
  (3) the client never OPEN_CONFIRM's the OPEN.
After a suitable timeout, the server will reap the unconfirmed OPEN.
My assumption: the delegation is reaped also.  In other words, a
delegation is not "confirmed" until the OPEN is.  What does everyone
else think about this issue?

- k

---

From: "Noveck, Dave" <[email-masked]>
Date: Fri, 6 Jul 2001 12:44:43 -0700

I agree in general but there are some cases that can come
up that we need to think about carefully.

What happens if there is a conflicting open from another 
client, in the period while the delegation is unconfirmed?
If the client recongizes the delegation (does not return
BAD_STATEID) does that confirm the delegation (and the
open?) or do we proceed down the path of recalling
a delegation while it is unconfirmed.

What happens if the client spontaneously returns the 
delegation?  

What happens if the client specified the delegation in
an open with claim type DLG_CUR?  Does this confirm the
delegation, or is it invalid?

-----Original Message-----
From: Kendrick M. Smith [mailto:[email-masked]]
Sent: Friday, July 06, 2001 12:06 PM
To: [email-masked]
Subject: delegation and OPEN_CONFIRM

Suppose

- k