Subject: 2.4.18 delegation

From: Srivatsan Vijayasarathy <[email-masked]>
Date: 26 Jun 2002 12:55:10 -0400

I recently downloaded and installed the NFSv4 patches for Linux 2.4.18
from the CITI website. I encountered two problems: 

1. When delegation is disabled, the code works fine, but the kernel
throws BAD DPUT errors for all operations. 

2. When I enable delegation (by commenting the code block in
fs/nfsd4/callback.c), kernel dumps when I try to open a file. 

Has delegation been completely implemented? 

~Srivatsan 
--- 
Srivatsan Vijayasarathy 
Summer Intern, 
Red Hat Inc., 
Raleigh, NC.

---

From: "William A.(Andy) Adamson" <[email-masked]>
Date: Thu, 27 Jun 2002 11:42:32 -0400

hi srivatsan

thanks for the bug report. i believe i found the answer to #2, the rpc_message 
struct xdr_encode and xdr_decode were not initialized. please add these two 
lines of code to .../fs/nfsd4/callback.c

"callback.c" line 476 of 510 --93%-- col 2-9
        msg.rpc_proc = CB_COMPOUND;
        msg.rpc_argp = &cb->arg;
        msg.rpc_resp = &cb->res;
        msg.rpc_cred = NULL;
add >   msg.xdr_encode = NULL;
add >   msg.xdr_decode = NULL;
        rpc_call_setup(&cb->task, &msg, 0);

        cb->arg.cb_opnum = OP_CB_RECALL;

 i was able to 'vi' files which is a smoke test.

as far as the BAD DPUT errors - we need to chase them down. it's either the 
case that the corresponding dget did not go through the debug rig, or it's a 
real error.

-->Andy