Subject: Re: [nfsv4] NFS4ERR_CLID_INUSE when SetClientID changes authenticationmechanisms

From: Jim Rees <[email-masked]>
Date: Tue, 14 Dec 2004 16:06:02 -0500

I'm pretty sure the BSD clients will fail if the server doesn't allow
setclientid.  I don't even see how the server can do that.  What error would
it return exactly?

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "J. Bruce Fields" <[email-masked]>
Date: Wed, 15 Dec 2004 13:05:55 -0500

> setclientid.  I don't even see how the server can do that.  What error would

Hah, I don't know.

Could it get away with just keeping no state for untrusted clients, and
treating setclientid (and open, close, etc.) as no-ops?

--b.