Subject: [nfsv4] Correct behaviour on OPEN failure?

From: Trond Myklebust <[email-masked]>
Date: Fri, 30 Sep 2005 08:15:17 -0400

Hi,

When going over RFC3530 one more time, it appeared to me that the
IMPLEMENTATION discussion for OPEN_CONFIRM on page 181 suggests that
clients need not bump the sequence id for an unconfirmed OPEN if the
latter fails. AFAICS, the sequence id is not established until at least
one OPEN is successful and either

  - The server declares it does not need confirmation on that OPEN
or
  - the OPEN_CONFIRM is successful too.

What strategies are the non-Linux clients out there using in the event
of OPEN failure?

Cheers,
  Trond

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "Noveck, Dave" <[email-masked]>
Date: Fri, 30 Sep 2005 11:14:35 -0400

That's the way I read the spec.

-----Original Message-----
From: Trond Myklebust [mailto:[email-masked]]
Sent: Friday, September 30, 2005 8:15 AM
To: [email-masked]
Subject: [nfsv4] Correct behaviour on OPEN failure?

Hi,

Cheers,
  Trond