Subject: [nfsv4] exporting with multiple pNFS layout types

From: "William A.(Andy) Adamson" <[email-masked]>
Date: Mon, 19 Dec 2005 12:27:04 -0500

do we really expect a file system to be exported with multiple layout types? 
if so, how does a client choose which layout type to use?

-->Andy

from draft-ietf-nfsv4-pnfs-00.txt:

7.1  pnfs_layouttype4<> FS_LAYOUT_TYPES

   This attribute applies to a file system and indicates what layout
   types are supported by the file system.  We expect this attribute to
   be queried when a client encounters a new fsid.  This attribute is
   used by the client to determine if it has applicable layout drivers.

7.2  pnfs_layouttype4<> FILE_LAYOUT_TYPES

   This attribute indicates the particular layout type(s) used for a
   file.  This is for informational purposes only.  The client needs to
   use the LAYOUTGET operation in order to get enough information (e.g.,
   specific device information) in order to perform I/O.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Brent Welch <[email-masked]>
Date: Fri, 23 Dec 2005 14:06:22 -0800

>>>"William A.(Andy) Adamson" said:
 > 
 > 
      
 > if so, how does a client choose which layout type to use?

The client specifies the type in the "layout_type" parameter to LAYOUTGET
As noted by others, the client can query available types from attributes.

     struct LAYOUTGET4args {
             /* CURRENT_FH: file */
             clientid4               clientid;
             pnfs_layouttype4        layout_type;
             pnfs_layoutiomode4      iomode;
             offset4                 offset;
             length4                 length;
             length4                 minlength;
             count4                  maxcount;
     };

--
Brent Welch
Software Architect, Panasas Inc
Accelerating Time to Results(tm) with Clustered Storage

www.panasas.com
[email-masked]