Subject: RE: [nfsv4] exporting with multiple pNFS layout types

From: "Everhart, Craig" <[email-masked]>
Date: Mon, 19 Dec 2005 13:03:25 -0500

Yes.  This way the client can observe how it's connected to the universe
and contemplate which connection methods it can exploit.

		Craig 

> -----Original Message-----
> From: William A.(Andy) Adamson [mailto:[email-masked]] 
> Sent: Monday, December 19, 2005 12:27 PM
> To: [email-masked]
> Subject: [nfsv4] exporting with multiple pNFS layout types
> 
> 
> do we really expect a file system to be exported with 
> multiple layout types? 
> if so, how does a client choose which layout type to use?
> 
> -->Andy
> 
> 
> from draft-ietf-nfsv4-pnfs-00.txt:
> 
> 7.1  pnfs_layouttype4<> FS_LAYOUT_TYPES
> 
>    This attribute applies to a file system and indicates what layout
>    types are supported by the file system.  We expect this 
> attribute to
>    be queried when a client encounters a new fsid.  This attribute is
>    used by the client to determine if it has applicable 
> layout drivers.
> 
> 
> 7.2  pnfs_layouttype4<> FILE_LAYOUT_TYPES
> 
>    This attribute indicates the particular layout type(s) used for a
>    file.  This is for informational purposes only.  The 
> client needs to
>    use the LAYOUTGET operation in order to get enough 
> information (e.g.,
>    specific device information) in order to perform I/O.
> 
> 
> 
> 
> 
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nfsv4
> 

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "Noveck, Dave" <[email-masked]>
Date: Mon, 19 Dec 2005 13:42:16 -0500

I believe that it is quite possible that this will happen.  

I would expect the client first to choose a layout type that it
supports.  That is definitely preferable to choosing one it doesn't
support :-).   That would be one of the prime drivers for servers
to support multiple types.  If you can't cover available clients
with a single layout type, then it may very well be worth it to 
support more than one.

If the set of types supported by the client and the server conatins
more than one element, I would expect that client configuration 
options would be the principal way of choosing.  If a site has 
invested in iWARP adapters or IB, I woudl expect its clients to 
be set up with the preference to use it those the file variant
of pNFS in preference to anything else.  Conversely, if it is has 
invested in a big FC SAN infrastructure, then I would expect 
clients to be set up to use that, provided the administrator
is OK with the "differently secured"  model in which the client
OS's have a greater degree of responsibiltiy in this regard.

-----Original Message-----
From: William A.(Andy) Adamson [mailto:[email-masked]] 
Sent: Monday, December 19, 2005 12:27 PM
To: [email-masked]
Subject: [nfsv4] exporting with multiple pNFS layout types

do we really expect a file system to be exported with multiple layout
types? 
if so, how does a client choose which layout type to use?

-->Andy

   This attribute applies to a file system and indicates what layout
   types are supported by the file system.  We expect this attribute to
   be queried when a client encounters a new fsid.  This attribute is
   used by the client to determine if it has applicable layout drivers.

   This attribute indicates the particular layout type(s) used for a
   file.  This is for informational purposes only.  The client needs to
   use the LAYOUTGET operation in order to get enough information (e.g.,
   specific device information) in order to perform I/O.