Subject: [nfsv4] nfsv41.x naming inconsistency

From: Fredric Isaman <[email-masked]>
Date: Tue, 27 Feb 2007 14:47:45 -0500 (EST)

nfsv41.x has very consistent naming conventions, which are quite useful 
for auto-code generation.  However, I came across an apparent oversight 
within the definitions of nfs_argop4 and nfs_resop4.  I suppose it is best 
explained with this suggested patch.

 	Fred

---

--- nfsv41.x	2007-02-27 13:46:35.000000000 -0500
+++ new_nfsv41.x	2007-02-27 13:48:17.000000000 -0500
@@ -2248,7 +2248,7 @@
   /* Operations new to NFSv4.1 */
   case OP_BACKCHANNEL_CTL:	BACKCHANNEL_CTL4args opbackchannel_ctl;
   case OP_BIND_CONN_TO_SESSION:	BIND_CONN_TO_SESSION4args opbind_conn_to_session;
- case OP_EXCHANGE_ID:		EXCHANGE_ID4args opcreate_clientid;
+ case OP_EXCHANGE_ID:		EXCHANGE_ID4args opexchange_id;
   case OP_CREATE_SESSION:	CREATE_SESSION4args opcreate_session;
   case OP_DESTROY_SESSION:	DESTROY_SESSION4args opdestroy_session;
   case OP_FREE_STATEID:		FREE_STATEID4args opfree_stateid;
@@ -2309,7 +2309,7 @@
   /* Operations new to NFSv4.1 */
   case OP_BACKCHANNEL_CTL:	BACKCHANNEL_CTL4res opbackchannel_ctl;
   case OP_BIND_CONN_TO_SESSION:	BIND_CONN_TO_SESSION4res opbind_conn_to_session;
- case OP_EXCHANGE_ID:		EXCHANGE_ID4res opcreate_clientid;
+ case OP_EXCHANGE_ID:		EXCHANGE_ID4res opexchange_id;
   case OP_CREATE_SESSION:	CREATE_SESSION4res opcreate_session;
   case OP_DESTROY_SESSION:	DESTROY_SESSION4res opdestroy_session;
   case OP_FREE_STATEID:		FREE_STATEID4res opfree_stateid;

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Mike Eisler <[email-masked]>
Date: Tue, 27 Feb 2007 12:18:57 -0800 (PST)

> explained with this suggested patch.

Thanks. This will be fixed in draft-09.