Subject: [nfsv4] [LATE] Draft Minutes from March 18, 2007 NFS V4 Prague Meeting

From: Brian Pawlowski <[email-masked]>
Date: Fri, 20 Apr 2007 10:02:48 -0700 (PDT)

Many thanks to Trond for capturing the detailed minutes!
All delays due to me:-( Apologies.

And Mike Eisler for the spec update and review plan description!

Comments?  Will send to IETF later today.

-----------------------------------------------------------

[nfsv4]

NFS Version 4 Working Group, IETF 68th, Prague
March 18, 2007
Co-chairs: Spencer Shepler (absent) and Brian Pawlowski

[Minutes from Trond Myklebust, minor adds by beepy]

====== Connectathon testing

 - beepy: need for more testing in June determined during wrap-up session
 at Connectathon
 - Trond: [censored vendors list]
      New company announced an alpha NFSv4 client 
      Interoperability testing went fine
 - Andy: Global name service was tested. Linux + EMC
      Suggests this become a feature for future Cthons
      v4.0 only tested. Good enough for referrals.
      v4.1 adds features that are needed for migration/replication
 - Benny: kerberos testing?
 - Andy: Went well. still issues with privacy testing on Linux.
 - beepy: Austin should be the last testing event. Anything not tested in
      Austin, may need to be pared back.
      Audrey will work with Lisa on testing content.
 - Area directors: Proposed draft (v4.1) does not need to have 2
   interoperating implementations. However we DO need implementation
   report for 4.0
   beepy: how do we deal with features that are not implemented?
   AD: you may drop them.
   Andy: SPKM3 implemented and interop tested, but no interop of SPKM3/LIPKEY
   done yet (Hummingbird have LIPKEY, Linux does not)
  - beepy to move forward on pruning draft.

====== SPKM3

 - A BOF was held in order to figure out what could fill that space.
 - 4 proposals
   SPKM3
   DTLS (Nico)
   Mike
   .... (?) by Microsoft PKUTU
 - SPKM3 was dropped because hard to implement
 - Andy: GRID wants this
 - beepy: We're not reopening v4.0 draft in order to change it if
 we can avoid
 - AD: have an informal meeting with Sam about this in order to make
   progress.
 - Need to define follow up actions

====== pNFS
 - Overall progress made on pNFS, and it is stabilizing, but we
 can do better on testing of the specification
 - Marc: Did not go well because Sessions was thrown in at the last minute
 - Solaris had more implemented than Linux, and had to turn off features in
 order to interoperate.
 - Testing with sessions turned off, worked very well.

====== RDMA last call
 - No outstanding comments
 - 3 IANA issues pending, but not in way of last call - last call note
 will call out
 - Spencer to work with IANA on the outstanding registry issues
 - [post meeting - Spencer starting working group last call - sorry
   for delay!]

====== June interop testing
 - Lisa Weeks to organise it
 - Should be last testing for the v4.1 spec
 - Andy: many features are missing (eg. directory delegations)
 - beepy: we drop features that are not being considered
 -        only issue is to ensure we don't screw up royally
          no interop implementation are theoretically needed
 - beepy: June meeting may be an official interim ietf meeting
          in order to pare functionality.

====== Review of changes to v4.1 (Mike Eisler)

 - Draft 10 was added in order to clean up v9
 - functionality changes v8 -> v9
 - Added a destroy_clientid operation for consistency (destroy_session already
 existed). Also helps server
   Must delete sessions before calling destroy_clientid
   mandatory to implement on servers
 - Server Owners and trunking needed explaining
   beefed up text
 - Long standing issue with SECINFO/_NO_NAME dealing with RESTORE_FH fixed.
 - Max slot id concept thrown out because confusing:
     replaced by "highest slotid" concept
 - ClientID can be created for specific pNFS and non-pNFS roles.

 - Files layout type is now ONLY v4.1. v4.0 or v3 data servers are not
   supported by the document.
 - Opaque types have been changed to a standard format: layouttype4 + opaque
   blob.
 - All new data types have '4' in their name
   (Benny asked could we have 4.1? Problem is that we're carrying this forward
   for 4.2, 4.3....)
 - Discretionary acls vs security acls added
   mode_set_masked attribute added. (Bruce's text thrown in)
   ACL issues all closed.
 - Cleared up stateid definition
 - State loss detection cleaned up
 - Changed callback path testing to CB_COMPOUND/SEQUENCE
 - Introduced pNFS as an OPTIONAL feature vs. a proposal
   NFS servers that don't want to implement pNFS, can still act as a data
   server.
 - Discourage EXCLUSIVE4 OPEN/creates if persistent sessions are used
   since it is unnecessary (SHOULD).
   - Ban EXCLUSIVE4 if the pNFS layout_hint attribute is supported (MUST)
   Clients should use GUARDED open/create
 - beepy: Zzzzzzzzzzzzzzzzzzzzz

 - Issue with mapping device ids and address mappings. They are _leased_
   and subject to revocation.
 - MDS recovery clarifications
   - Client has to keep a copy of modified data in memory even after a
     COMMIT, but before a LAYOUTCOMMIT; or
   - Server cannot fail a LAYOUTCOMMIT in reclaim mode
     - Should not be an issue for NFSv4.1 storage devices
 - Storage device recovery clarifications
   - write data to the metadata server when recovering
   - Some feedback from reviewers that multipathing might permit client
     to write to secondary path for storage device
 - Recently defined pNFS terms: unit, pattern, stripe, stripe width
 - Renamed some data types to reflect their meaning
   nfsv4_file_layout_device4 -> nfsv4_1_file_layout_ds_addr4
 - More detailed example of a device (data server) list
 - Clarified stripe4_sparse vs stripe4_dense
 - Added EXCHANGE_ID and DESTROY_CLIENTID to list of ops an NFSv4.1 data
   server must support.
 - DESTROY_SESSION can fail if there are outstanding requests on the
   callback channel
 - Added error code for STRIPE4_DENSE: NFS4ERR_PNFS_IO_HOLE
 - Change GET_DIR_DELEGATION results so that the operation can fail
   without stopping compound processing. Same done for WANT_DELEGATION
 - Many fields of new data types changed to include a suffix that
   abbreviates data type name
 - Added optional "previous entry" to notifications of an addition to the
   directory.
 - Re-clarified that delegation stateid from metadata server is appropriate
   for I/O to data server
 - More field nameing consistency issues
 - Added directory filehandle to CB_NOTIFY arguments
 - Put NFS filehandle in consistent places

        ====== What will change in 11

 - Error codes
 - Some pNFS feedback from Garth G and Rahul I
 - Locking and delegations sections to be reworked by Dave
 - Sets of issues in Issues Trackers
 - Formal review issues

        ====== Formal review process

 - Want to ensure review on certain sections of spec
 - 3 areas targeted
   pNFS
   Sessions
   ACLs
 - Process and steps
   Kickoff meeting: editors act as moderators
   - reviewers give feedback on whether the sections make sense
   Volunteers sought for
    - Reader
    - scribe
    - reviewers
    - moderators
  - Scribe records 'defects' reported by reviewers
 - Initially trying 3 sections/chapters
 - Timeline is end of april
 - Focus is on new things & modified things
 - Audrey has sent out formal invitations for reviewers
   - Volunteers sought
   - if too many people, they should organise themselves into teams
     Audrey will not do.

====== beepy: What do we do about charter
  AD: charter will be pushed out after last call

====== New Milestones
  - Feb 2007 WG Last call for RPC and NFS RDMA drafts -> March
    - (this week?)
  - March 2007 WG last call for rfc1831bis (RPC version 2) status?
    -
  - April 2007 NFSv4.1 prototype, testing and interop report -> delayed to
    June

====== Questions, issues?

  - How to deal with quotas in pNFS?
     return error in LAYOUTGET vs LAYOUTCOMMIT
     for files, can still return error in WRITE
  - Benny wants to add a wishlist for 4.2
     Benny gets to maintain it

  - Audrey will provide hitlist for June testing
  - Inspection will provide issues to test
  - Andy & beepy will confer on status of SPKM3
  - Has anybody gone through v4.0 and looked at MUST vs implementation
    reality
  - Issue of can a compliant v4.1 client/server not support v4.0
    Breaks v4.0 minor versioning rules
    - ...but minor version is allowed to change v4 minor versioning rules.
    AD: please update v4.0 minor versioning rules
        maybe separate small rfc motivating change etc.
  - beepy: What in v4.0 is
     - Ready for draft?
     - inconsistent with reality?
     - ready to be dropped?
  - For the record, Nico does not understand why we minor version.

  - Benny: multiple filehandles per file. Client implementations do not
    support it very well.
    Trond+Benny: Please throw out the text that describes an algorithm
       for how to deal with multiple filehandles per file.
    beepy: Take it to the mailing list and make a proposal

====== Miscellany

  - Nico promised to sign the blue sheet.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "J. Bruce Fields" <[email-masked]>
Date: Fri, 20 Apr 2007 13:21:37 -0400

On Fri, Apr 20, 2007 at 10:02:48AM -0700, Brian Pawlowski wrote:
>    Andy: SPKM3 implemented and interop tested,

...

>  - SPKM3 was dropped because hard to implement

Hm.

(OK, I don't really care, I'm just amused.)

--b.

---

From: Brian Pawlowski <[email-masked]>
Date: Fri, 20 Apr 2007 11:03:30 -0700 (PDT)

Hmmmmm... I was reviewing Trond's notes:-)

There was follow up discussions on SPKM3 that need reflection
perhaps on the alias more nuanced and accurate than below.

Will edit the final minutes for IETF - thanks for the catch:-)