Subject: [nfsv4] CB_NULL versus CB_SEQUENCE to check for callback ability

From: "Mike Eisler" <[email-masked]>
Date: Thu, 20 Mar 2008 04:27:13 -0700 (PDT)

The spec currently says:

    The client must be able to respond to the server's callback
    requests.  The server will use the CB_NULL procedure for a test of
    callback ability.

I think it should say:

       The client must be able to respond to the
       server's callback requests.  If a backchannel
       has been established, the server will send
       a CB_COMPOUND request, containing a single
       operation, CB_SEQUENCE, for a test of backchannel
       availability.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: "Noveck, Dave" <[email-masked]>
Date: Thu, 20 Mar 2008 08:02:30 -0400

I agree.

-----Original Message-----
From: Mike Eisler [mailto:[email-masked]] 
Sent: Thursday, March 20, 2008 7:27 AM
To: [email-masked]
Subject: [nfsv4] CB_NULL versus CB_SEQUENCE to check for callback
ability

The spec currently says:

I think it should say:

---

From: Benny Halevy <[email-masked]>
Date: Thu, 20 Mar 2008 15:07:32 +0200

>        has been established, the server will send

I'd s/will/SHOULD/

>        operation, CB_SEQUENCE, for a test of backchannel

I'd also add:
The server MAY also use the CB_NULL procedure to test the client's
callback ability; in particular, while serving CREATE_SESSION
(see <xref ... />) with the CREATE_SESSION4_FLAG_CONN_BACK_CHAN
flag set in csa_flags.

Benny

---

From: Robert Gordon <[email-masked]>
Date: Thu, 20 Mar 2008 10:46:53 -0600

>        operation, CB_SEQUENCE, for a test of backchannel

Yes, I agree that seems more in keeping.

Robert.