Subject: [nfsv4] open delegations and OPENs and CLOSEs

From: "Mike Eisler" <[email-masked]>
Date: Thu, 20 Mar 2008 04:32:53 -0700 (PDT)

The spec currently says:

 When a client has an open delegation, it does not send OPENs or
 CLOSEs to the server but updates the appropriate status internally.

I think it should be:

      When a client has an open delegation, it does not need to send OPENs or
      CLOSEs to the server. Instead the client may update the appropriate
      status internally.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: "Noveck, Dave" <[email-masked]>
Date: Thu, 20 Mar 2008 08:05:28 -0400

Agree.  You might add at the end something like, "The client does need
to perform such operations (if they are still then applicable) before
returning the delegation to the server."

-----Original Message-----
From: Mike Eisler [mailto:[email-masked]] 
Sent: Thursday, March 20, 2008 7:33 AM
To: [email-masked]
Subject: [nfsv4] open delegations and OPENs and CLOSEs

The spec currently says:

I think it should be:

      When a client has an open delegation, it does not need to send
OPENs or
      CLOSEs to the server. Instead the client may update the
appropriate
      status internally.

---

From: Benny Halevy <[email-masked]>
Date: Thu, 20 Mar 2008 15:11:20 +0200

Should it also say something about matching OPEN modes?

Benny

---

From: Trond Myklebust <[email-masked]>
Date: Thu, 20 Mar 2008 09:22:44 -0400

>       CLOSEs to the server. Instead the client may update the appropriate

If it holds open stateids, it may still need to send CLOSEs, but it
won't have to issue new OPENs until it returns the delegation.

---

From: "Noveck, Dave" <[email-masked]>
Date: Thu, 20 Mar 2008 09:38:56 -0400

> If it holds open stateids, it may still need to send CLOSEs

It may choose to but there is no protocol requirement, is there?  The
delegation assures that nobody with a conflict whating for you to do a
CLOSE, or rather that you will get notified when there is.

-----Original Message-----
From: Trond Myklebust [mailto:[email-masked]] 
Sent: Thursday, March 20, 2008 9:23 AM
To: Mike Eisler
Cc: [email-masked]
Subject: Re: [nfsv4] open delegations and OPENs and CLOSEs

OPENs or
appropriate

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 20 Mar 2008 09:19:03 -0500

> CLOSE, or rather that you will get notified when there is.

The client would presumably CLOSE the file at some point
in the future -- unless the application keeps the file open
indefinitely. :-)

Spencer

---

From: "Noveck, Dave" <[email-masked]>
Date: Thu, 20 Mar 2008 10:25:05 -0400

Unless the client or the server reboots, but we know that with the
software we write, that could never happen, except deliberately to force
testing of recovery paths of course :-)

-----Original Message-----
From: Spencer Shepler [mailto:[email-masked]] 
Sent: Thursday, March 20, 2008 10:19 AM
To: Noveck, Dave
Cc: Trond Myklebust; Mike Eisler; [email-masked]
Subject: Re: [nfsv4] open delegations and OPENs and CLOSEs

Spencer