Subject: [nfsv4] I-D Action:draft-ietf-nfsv4-pnfs-obj-06.txt

From: [email-masked]
Date: Mon, 17 Mar 2008 19:15:01 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network File System Version 4 Working Group of the IETF.

	Title           : Object-based pNFS Operations
	Author(s)       : B. Halevy, et al.
	Filename        : draft-ietf-nfsv4-pnfs-obj-06.txt
	Pages           : 38
	Date            : 2008-03-17

This Internet-Draft provides a description of the object-based pNFS
extension for NFSv4.  This is a companion to the main pnfs
specification in the NFSv4 Minor Version 1 Internet Draft, which is
currently draft-ietf-nfsv4-minorversion1-21.txt.Requirements Language

The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT",
"SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in this
document are to be interpreted as described in RFC 2119 [1].

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-nfsv4-pnfs-obj-06.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Benny Halevy <[email-masked]>
Date: Tue, 18 Mar 2008 08:31:55 +0200

The main changes in this version of the pnfs-obj Internet Draft
are as follows:

Wire protocol changes:

* Device information data structure revisited.
  - SCSI target identification can be provided as either
    - iSCSI Name (currently supporting the iqn, eui, or naa formats), or
    - SCSI Device Identifier (VPD Page 83h)
  - Netaddr is optional and can be provided as a hint along with the iSCSI Name
    to accelerate discovery/login
  - References to the relevant standards were added or updated.
  - In particular, references to iSNS recommend using it to look up the target,
    especially when targets are multi-attached.

 enum pnfs_obj_addr_type4 {
-    OBJ_TARGET_NETADDR  = 1,
-    OBJ_TARGET_IQN      = 2,
-    OBJ_TARGET_WWN      = 3
+    OBJ_TARGET_ANON             = 1,
+    OBJ_TARGET_SCSI_NAME        = 2,
+    OBJ_TARGET_SCSI_DEVICE_ID   = 3
 };

 struct pnfs_osd_deviceaddr4 {
-    union target switch (pnfs_osd_addr_type4 type) {
-        case OBJ_TARGET_NETADDR:
-            pnfs_netaddr4       netaddr;
-
-        case OBJ_TARGET_IQN:
-            string              iqn&lt;&gt;;
-
-        case OBJ_TARGET_WWN:
-            string              wwn&lt;&gt;;
+    union targetid switch (pnfs_osd_addr_type4 type) {
+        case OBJ_TARGET_SCSI_NAME:
+            string              scsi_name&lt;&gt;;
+
+        case OBJ_TARGET_SCSI_DEVICE_ID:
+            opaque              scsi_device_id&lt;&gt;;
 
         default:
             void;
     };
+    union netaddr switch (bool netaddr_available) {
+        case TRUE:
+            netaddr4       netaddr;
+        case FALSE:
+            void;
+    };
     uint64_t                lun;
     opaque                  systemid&lt;&gt;;
     pnfs_osd_object_cred4   root_obj_cred;

* Added the lou_ioerr field to pnfs_osd_layoutupdate4
  (sent on LAYOUTCOMMIT) used to flag the server that I/O errors
  were seen so it can wait, if needed, with flushing any updated
  attributes to the OSDs until it receives a corresponding error
  report on LAYOUTRETURN.

 struct pnfs_osd_layoutupdate4 {
-    pnfs_osd_deltaspaceused4    delta_space_used;
+    pnfs_osd_deltaspaceused4    lou_delta_space_used;
+    bool                        lou_ioerr;
 };

Editorial changes:

* Added "Recovering from Client I/O Errors" section.

* Xref's scrubbed.

Benny
-- 
Benny Halevy
Software Architect
Tel/Fax: +972-3-647-8340
Mobile: +972-54-802-8340
US:      +1-412-203-3187
[email-masked]
 
Panasas, Inc.
The Leader in Parallel Storage
www.panasas.com

[email-masked] wrote:On Mar. 18, 2008, 4:15 +0200, [email-masked] wrote:
> ------------------------------------------------------------------------
>