Subject: [nfsv4] byte-range or record

From: "Mike Eisler" <[email-masked]>
Date: Wed, 19 Mar 2008 00:10:08 -0700 (PDT)

(re-send, the first attempt didn't appear to go through)

"byte-range" lock

   or

"record" lock

Let's have one term. Which do people prefer?

I suggest replied privately to me.

When I stop getting responses, I will collect them all, send them
in one message, and declare the rough consensus.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: "Mike Eisler" <[email-masked]>
Date: Wed, 19 Mar 2008 18:46:34 -0700 (PDT)

These folks all told me they want "byte-range".

Robert Gordon
Lisa Week
Marc Eshel
William A. (Andy) Adamson
Spencer Shepler
Trond Myklebust
wurzl_mario AT emc DOT com
Jim Rees
Noveck, Dave

No one expressed a preference for "record".

The consensus opinion was the "record" has no meaning in NFS, which
presents files a streams of bytes, not records.

---

From: "Mike Eisler" <[email-masked]>
Date: Wed, 19 Mar 2008 18:47:42 -0700 (PDT)

> wurzl_mario AT emc DOT com

plus:

Benny Halevy

---

From: "J. Bruce Fields" <[email-masked]>
Date: Wed, 19 Mar 2008 22:10:22 -0400

> > presents files a streams of bytes, not records.

I prefer "byte-range" too, but every reference I checked uses
"record"--SuS 3, the X/Open NLM spec, the linux man pages, and rfc 3530.
(The only use of "byte-range" I noticed in any of those was a single
parenthetical remark in the definition of "lock" in 3530).

That's not a vote for "record", but for consistency with those other
sources I guess we need to mention the term "record lock" at least in
any definition section.  And perhaps at the beginning of any locking
section as well, for good measure.

--b.

---

From: Benny Halevy <[email-masked]>
Date: Thu, 20 Mar 2008 11:22:26 +0200

> section as well, for good measure.

Yes. We can mention "(a.k.a. record lock)" in the definitions section.

The reason I like byte-range locks better is that record locks are essentially
just one (common) application of byte-range locks for database-like apps that
keep records in files (for whatever definition of "record" :).

Benny

---

From: "Mike Eisler" <[email-masked]>
Date: Sat, 22 Mar 2008 13:07:36 -0700 (PDT)

> Yes. We can mention "(a.k.a. record lock)" in the definitions section.

http://eisler.com/nfsv4-wg/2008-03-22-byte-range.html

has the proposed changes for changing "record" to "byte-range". I've
noted in the definition of "Lock" that UNIX calls these record locks.

---

From: "Mike Eisler" <[email-masked]>
Date: Mon, 31 Mar 2008 16:10:46 -0700 (PDT)

I have received no objections to this and will check in the changes.