Subject: [nfsv4] pnfs-obj Internet Draft last call

From: Benny Halevy <[email-masked]>
Date: Mon, 31 Mar 2008 13:56:52 +0300

Last call for http://tools.ietf.org/html/draft-ietf-nfsv4-pnfs-obj
is about to end tomorrow.  I have the following minor change to
make for version -07 of the I-D.  Thanks to Dan Messinger for
the eagle eyed catch.

Benny

--- draft-ietf-nfsv4-pnfs-obj-06.xml    2008-03-17 23:21:48.000000000 +0200
+++ draft-ietf-nfsv4-pnfs-obj-07.xml    2008-03-31 09:40:01.000000000 +0300
@@ -47,7 +47,7 @@
 <rfc
     category="std"
     ipr="full3978"
-    docName="draft-ietf-nfsv4-pnfs-obj-06">
+    docName="draft-ietf-nfsv4-pnfs-obj-07">

 <front>
     <title abbrev="pnfs objects">Object-based pNFS Operations</title>
@@ -231,7 +231,7 @@
   </t>
   <figure>
    <artwork>
-enum pnfs_obj_addr_type4 {
+enum pnfs_osd_addr_type4 {
     OBJ_TARGET_ANON             = 1,
     OBJ_TARGET_SCSI_NAME        = 2,
     OBJ_TARGET_SCSI_DEVICE_ID   = 3
@@ -1712,7 +1712,7 @@
  </t>
  <figure>
   <artwork>
-sh extract.sh &lt; spec.txt &gt; pnfs_obj_prot.x
+sh extract.sh &lt; spec.txt &gt; pnfs_osd_prot.x
   </artwork>
  </figure>
  <t>
@@ -1729,7 +1729,7 @@
 ////*
 /// * Device information
 /// */
-///enum pnfs_obj_addr_type4 {
+///enum pnfs_osd_addr_type4 {
 ///    OBJ_TARGET_ANON             = 1,
 ///    OBJ_TARGET_SCSI_NAME        = 2,
 ///    OBJ_TARGET_SCSI_DEVICE_ID   = 3

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: "Mike Eisler" <[email-masked]>
Date: Mon, 31 Mar 2008 19:59:39 -0700 (PDT)

> make for version -07 of the I-D.  Thanks to Dan Messinger for

Since you are making changes, I suggest
doing what the files and blocks XDR descriptions do
and have comments preceding the data types that
are to be plugged into the opaque fields of the
generic spec.

E.g., blocks has:

   ////* block layout specific type for loh_body */
   ///struct pnfs_block_layouthint4 {
   ///    uint64_t maximum_io_time;       /* maximum i/o time in seconds
   ///                                       */
   ///};
   ///

---

From: "Mike Eisler" <[email-masked]>
Date: Mon, 31 Mar 2008 20:05:28 -0700 (PDT)

> is about to end tomorrow.

Also, the field names of each data type ought to be prefixed with an
abbreviation of the data type. For example, there is a field named
"errno". It is going to be very painful for source code browsers
to distinguish that field name from the global errno variable
of user level programs that use POSIX interfaces.

---

From: Benny Halevy <[email-masked]>
Date: Tue, 01 Apr 2008 10:54:00 +0300

> are to be plugged into the opaque fields of the

I've actually done that by copying the definition down
to the (authoritative) "XDR Description of the Objects layout type"
section, where the data types are prefixed with a comment.
However, I see that in the blocks I-D the data types are defined
onces, with preceding comments which may make it a little less
comprehensible to the human reader but reduces the odds for
disagreement between the definitions.  I'll just go with the
latter approach...

Benny

---

From: Benny Halevy <[email-masked]>
Date: Tue, 01 Apr 2008 10:55:00 +0300

> of user level programs that use POSIX interfaces.

OK. Will do.

Benny