Subject: [nfsv4] Error code 10056 getting used twice? (minorversion1-23)

From: "Erasani, Pranoop" <[email-masked]>
Date: Thu, 7 Aug 2008 00:14:21 -0700

The protocol error definitions section says this:
 
    | NFS4ERR_DELEG_ALREADY_WANTED      | 10056  | Section 15.1.14.1
<http://tools.ietf.org/html/draft-ietf-nfsv4-minorversion1-23#section-15
.1.14.1>  |
 
It does not contain a definition for NFS4ERR_DELEG_REVOKED though. And,
the detailed description sections talk differently.
 
15.1.5.3.  NFS4ERR_DELEG_REVOKED (Error Code 10056)

   A stateid designates recallable locking state of any type that has
   been revoked due to the failure of the client to return the lock,
   when it was recalled.
 
15.1.14.1.  NFS4ERR_DELEG_ALREADY_WANTED (Error Code 10056)

   The client has requested a delegation when it had already registered
   that it wants that same delegation.

- Pranoop
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 7 Aug 2008 08:36:29 -0500

On Aug 7, 2008, at 2:14 AM, Erasani, Pranoop wrote:

>     | NFS4ERR_DELEG_ALREADY_WANTED      | 10056  | Section 15.1.14.1 |
>
> It does not contain a definition for NFS4ERR_DELEG_REVOKED though.  
> And, the detailed description sections talk differently.
>

Thanks for pointing this out, Pranoop.

The problem will be fixed in version 25 (no timetable at this point).

Turns out that the error definition is missing from the dotx and I have
added this definition:
     NFS4ERR_DELEG_REVOKED  = 10087

and the definition section is now:

15.1.5.3.  NFS4ERR_DELEG_REVOKED (Error Code 10087)

Spencer