Subject: [nfsv4] FedFS Meeting Minutes, 01/29/2009

From: James Lentini <[email-masked]>
Date: Thu, 29 Jan 2009 15:12:17 -0500 (EST)

FedFS Meeting Minutes, 01/29/2009
---------------------------------

Attendees
---------

Dan Ellard (BBN)
Craig Everhart (NetApp)
James Lentini (NetApp)
Renu Tewari (IBM/ARC)

Minutes
-------

+ IETF Note Well Agreement

  This is a reminder that our discussions are governed by the 
  IETF Note Well Agreement. See:

    http://www.ietf.org/NOTEWELL.html

  We will start each weeks meeting with this announcement.

+ Review Action Items

  [AI] James Lentini will check for IANA considerations in the NSDB draft

  We will need to update the requirements section. RFC 4520 has the details. 
  RFC 5020 looks like a good example of how the requirements should be noted.

  X.500 OID's are registered with IANA.

  FedFS uses OIDs with the 1.3.6.1.4.1.31103 prefix.
  The ownership hierarchy for these OIDs is:

  1.3.6.1               Internet
         .4.1           IANA
             .31103     Dan Ellard

+ Upcoming events

  - Connectathon

	Talk schedule announced:
	http://www.connectathon.org/talks09/index.html

	The FedFS activities are scheduled for Monday.

	James and Renu are planning to attend. Rob plans to 
	send out slides before hand.

  - FAST '09 BOF

	Dan Ellard reserved a meeting time for the BOF: 
	Wednesday, Feb. 25, 8-9 PM following the NFSv4.1/pNFS BOF.

+ NFSv4 Working Group Schedule

	The current schedule for our drafts is:

	May '09 for Requirements
        Oct '09 for the others

	We have discussed creating a root fileset document. Our goal is to 
	produce a draft on this subject by May. 

	[AI] James Lentini write Spencer Shepler about scheduling a FedFS 
	     talk at the March NFSv4 WG meeting.

	Renu might attend the NFSv4 WG meeting. Dan might attend if the 
	dates line up.

	We are ready for feedback on the requirements document now. We 
	will use the upcoming events (Connectathon, FAST, March IETF,...) 
	to solicit feedback and encourage reviews of the document.

	With Connectathon and FAST there is a good shot at getting 
	most of the core FedFS group in the same room. It would be 
	nice to have some face-to-face time for this.

	Should we emphasize replication and migration more? We 
	discussed this issue for a while. We all agreed that 
	FedFS enables these features.

+ NSDB Protocol Document Feedback

	March 3, 2009 is cutoff date for I-D version 0 submission.
	March 9, 2009 is cutoff date for I-D version 1+ submissions.
	IETF Meeting is on March 22-27, 2009 in San Francisco.

	Our goal is to republish NSDB and Admin draft before March meeting.
	Please send feedback on these documents now.
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 29 Jan 2009 14:22:18 -0600

> FedFS Meeting Minutes, 01/29/2009

...

> 	nice to have some face-to-face time for this.

I understand scheduling travel and calendars can be difficult but
please target the IETF meeting for the face to face time if possible
such that other interested parties can participate in the context
of the IETF.  If not, then this should be considered a design meeting
and potential times should be posted here such that everyone has
an opportunity to participate along with the traditional email followup.

Spencer

---

From: James Lentini <[email-masked]>
Date: Thu, 29 Jan 2009 15:24:56 -0500 (EST)

> an opportunity to participate along with the traditional email followup.

Agreed.