Subject: Re: [nfsv4] Request for expert review of FedFS LDAP object identifier descriptors

From: Kurt Zeilenga <[email-masked]>
Date: Thu, 30 Jul 2009 11:04:25 -0700

On Jul 25, 2009, at 10:03 AM, James Lentini wrote:

>
> [NOTE: me message earlier in the week bounced. This is a retry.]
>
> Hello,
>
> In accordance with BCP 64 (RFC 4520), we request an expert review of
> the FedFS LDAP object identifier descriptors defined in the draft
>
> http://tools.ietf.org/id/draft-ietf-nfsv4-federated-fs-protocol-02.txt
>
> This draft is a work item in the NFSv4 Working Group and forms part of
> the specification of FedFS. FedFS is a set of protocols for creating a
> federated filesystem namespace.
>
> Please let us know if you have any questions about this request.

I recommend that all of the descriptors specified in this draft be  
named with a common prefix, such as fedfs or fedfs-.
This was the approach used for PCIM and PCELS schema.

One approach would be to request the family of descriptors, e.g. fedfs- 
*, be registered for descriptors specified in the I-D.

Use a prefix makes the limited applicability of these descriptors more  
obvious.  I am opposed to registering descriptors such as 'annotation'  
and 'descr' as these descriptors suggest a more general applicability  
than use for FedFS.

I note that I have only reviewed the above referenced I-D as needed to  
access the appropriate of the requested descriptors for the specified  
purpose.

-- Kurt

>
> -james
>
> --
> James Lentini | NetApp | 781-768-5359 | [email-masked]
>
>
> -------------------------------------------------------------------
>
>   Subject:  Request for LDAP Descriptor Registration
>   Person & email address to contact for further information:  See
>      "Author/Change Controller"
>   Specification:  draft-ietf-nfsv4-federated-fs-protocol
>   Author/Change Controller:
>
>   James Lentini
>   NetApp
>   1601 Trapelo Rd, Suite 16
>   Waltham, MA  02451
>   US
>   Phone: +1 781-768-5359
>   Email: [email-masked]
>
>   Craig Everhart
>   NetApp
>   7301 Kit Creek Rd
>   Research Triangle Park, NC  27709
>   US
>   Phone: +1 919-476-5320
>   Email: [email-masked]
>
>   Daniel Ellard
>   BBN Technologies
>   10 Moulton Street
>   Cambridge, MA  02138
>   US
>   Phone: +1 617-873-8000
>   Email: [email-masked]
>
>   Renu Tewari
>   IBM Almaden
>   650 Harry Rd
>   San Jose, CA  95120
>   US
>   Email: [email-masked]
>
>   Manoj Naik
>   IBM Almaden
>   650 Harry Rd
>   San Jose, CA  95120
>   US
>   Email: [email-masked]
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.1
>   Descriptor (short name):  fedfsUuid
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.2
>   Descriptor (short name):  fedfsNetAddr
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.3
>   Descriptor (short name):  fsnUuid
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.4
>   Descriptor (short name):  nsdbName
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.5
>   Descriptor (short name):  fslUuid
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.6
>   Descriptor (short name):  fslHost
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.7
>   Descriptor (short name):  fslTTL
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.8
>   Descriptor (short name):  fslNfsPath
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.9
>   Descriptor (short name):  fslNfsMajorVer
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.10
>   Descriptor (short name):  fslNfsMinorVer
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.11
>   Descriptor (short name):  fslNfsCurrency
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.12
>   Descriptor (short name):  fslNfsInfo
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.13
>   Descriptor (short name):  fslNfsFlags
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.14
>   Descriptor (short name):  fslNfsValidFor
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.15
>   Descriptor (short name):  annotation
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.16
>   Descriptor (short name):  descr
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.1001
>   Descriptor (short name):  fedfsFsn
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.1002
>   Descriptor (short name):  fedfsFsl
>
>   Object Identifier:  1.3.6.1.4.1.31103.1.1003
>   Descriptor (short name):  fedfsNfsFsl
>
>   Comments:
>
>   These identifiers are described in detail in:
>   http://tools.ietf.org/id/draft-ietf-nfsv4-federated-fs-protocol-02.txt
>

---

From: James Lentini <[email-masked]>
Date: Thu, 20 Aug 2009 16:36:25 -0400 (EDT)

Hello,

In accordance with BCP 64 (RFC 4520), we request an expert review of 
the FedFS LDAP object identifier descriptors defined in

 NSDB Protocol for Federated Filesystems
 http://www.ietf.org/id/draft-ietf-nfsv4-federated-fs-protocol-03.txt

As suggested in the previous review, we have updated our FedFS LDAP 
schema to use the common prefix "fedfs" for all object identifier 
descriptors.

Once again we look forward to your comments and feedback on this 
request.

-james

   James Lentini
   NetApp
 
   Craig Everhart
   NetApp
   7301 Kit Creek Rd
 
   Daniel Ellard
   BBN Technologies
   10 Moulton Street
   Cambridge, MA  02138
   US
   Phone: +1 617-873-8000
   Email: [email-masked]
 
   Renu Tewari
   IBM Almaden
   650 Harry Rd
   San Jose, CA  95120
   US
 
   Manoj Naik
   IBM Almaden
   650 Harry Rd
   San Jose, CA  95120
   US

   Object Identifier:  1.3.6.1.4.1.31103.1.3
   Descriptor (short name):  fedfsFsnUuid

   Object Identifier:  1.3.6.1.4.1.31103.1.4
   Descriptor (short name):  fedfsNsdbName

   Object Identifier:  1.3.6.1.4.1.31103.1.5
   Descriptor (short name):  fedfsFslUuid

   Object Identifier:  1.3.6.1.4.1.31103.1.6
   Descriptor (short name):  fedfsFslHost

   Object Identifier:  1.3.6.1.4.1.31103.1.7
   Descriptor (short name):  fedfsFslTTL

   Object Identifier:  1.3.6.1.4.1.31103.1.8
   Descriptor (short name):  fedfsNfsPath

   Object Identifier:  1.3.6.1.4.1.31103.1.9
   Descriptor (short name):  fedfsNfsMajorVer

   Object Identifier:  1.3.6.1.4.1.31103.1.10
   Descriptor (short name):  fedfsNfsMinorVer

   Object Identifier:  1.3.6.1.4.1.31103.1.11
   Descriptor (short name):  fedfsNfsCurrency

   Object Identifier:  1.3.6.1.4.1.31103.1.12
   Descriptor (short name):  fedfsNfsInfo

   Object Identifier:  1.3.6.1.4.1.31103.1.13
   Descriptor (short name):  fedfsNfsFlags

   Object Identifier:  1.3.6.1.4.1.31103.1.14
   Descriptor (short name):  fedfsNfsValidFor

   Object Identifier:  1.3.6.1.4.1.31103.1.15
   Descriptor (short name):  fedfsAnnotation

   Object Identifier:  1.3.6.1.4.1.31103.1.16
   Descriptor (short name):  fedfsDescr