Subject: [nfsv4] NFSv4.2: Optional attribute to retrieve MS branchcache content description

From: "Govind, Subin" <[email-masked]>
Date: Thu, 20 Aug 2009 22:17:29 +0530

Hi,
 
We should have an optional attribute that will help NFS clients retrieve
the Microsoft branch cache file content decription. I propose this as a
possible item for NFS 4.2.
 
Using the decription, NFS clients will be able to open a file and
request other openers (possibly CIFS) who have same file cached.
Content servers that have both CIFS and NFS will benefit most from this

-Subin

---

From: "Erasani, Pranoop" <[email-masked]>
Date: Thu, 20 Aug 2009 12:51:34 -0700

Subin,
 
What information would be part of the branch cache file content
description?
 
- Pranoop

________________________________

	From: Govind, Subin 
	Sent: Thursday, August 20, 2009 9:47 AM
	To: [email-masked]
	Subject: [nfsv4] NFSv4.2: Optional attribute to retrieve MS
branchcachecontent description

	Hi,
	 
	We should have an optional attribute that will help NFS clients
retrieve the Microsoft branch cache file content decription. I propose
this as a possible item for NFS 4.2.
	 
	Using the decription, NFS clients will be able to open a file
and request other openers (possibly CIFS) who have same file cached.
	Content servers that have both CIFS and NFS will benefit most
from this     
	 
	-Subin

---

From: "Govind, Subin" <[email-masked]>
Date: Fri, 21 Aug 2009 08:23:53 +0530

Pranoop,
 
At a very high level --
 
Its basically a collection of hashes and encryption keys. The hashes are
uses to test for integrity of data that a client can fetch from its
peer.
 
Data is broken up into chunks of 32 MB and each chunk is searched using
a key that can be computed from the hashes in the content decription.
 
The encryption key used to decrypt the data that the client gets from
other peers on its network.
 
Please refer to
http://msdn.microsoft.com/en-us/library/dd303704%28PROT.10%29.aspx for
detailed info.
 
Thanks
Subin

From: Erasani, Pranoop 
Sent: Friday, August 21, 2009 1:22 AM
To: Govind, Subin; [email-masked]
Subject: RE: [nfsv4] NFSv4.2: Optional attribute to retrieve MS
branchcachecontent description

Subin,

- Pranoop

	From: Govind, Subin 

	Hi,

	 
	-Subin

---

From: Trond Myklebust <[email-masked]>
Date: Fri, 21 Aug 2009 07:37:15 -0400

On Fri, 2009-08-21 at 08:23 +0530, Govind, Subin wrote:
> Pranoop,
>  
> At a very high level --
>  
> Its basically a collection of hashes and encryption keys. The hashes
> are uses to test for integrity of data that a client can fetch
> from its peer.
>  
> Data is broken up into chunks of 32 MB and each chunk is searched
> using a key that can be computed from the hashes in the content
> decription.
>  
> Please refer to http://msdn.microsoft.com/en-us/library/dd303704%
> 28PROT.10%29.aspx for detailed info.
>  
> Thanks
> Subin
>  
>  
>  
> 
> 
> ______________________________________________________________________
> From: Erasani, Pranoop 
>         ______________________________________________________________
>         From: Govind, Subin 
>         We should have an optional attribute that will help NFS
>         clients retrieve the Microsoft branch cache file content
>         decription. I propose this as a possible item for NFS 4.2.
>          

Peer-to-peer nfs has already been proposed for the NFSv4.2 agenda, but
the plan was to reuse the pnfs mechanism. See

http://tools.ietf.org/id/draft-myklebust-nfsv4-pnfs-backend-protocol-00.txt

Trond

---

From: "Govind, Subin" <[email-masked]>
Date: Mon, 24 Aug 2009 11:14:19 +0530

There are quite a few differences between the two methods of data
caching.

It looks more like the draft on pnfs backend protocol is aimed at
increasing parallelism of data access.

On the other hand, branchcache is aimed at reducing WAN link load.

Furthermore Win7 is coming out with branchcache in a big way and it
would be a great advantage for NFS clients if they can interoperate with
Windows clients using branchcache.

I think it still makes sense to support both.

Thanks
Subin

-----Original Message-----
From: Trond Myklebust [mailto:[email-masked]] 
Sent: Friday, August 21, 2009 5:07 PM
To: Govind, Subin
Cc: Erasani, Pranoop; [email-masked]
Subject: Re: [nfsv4] NFSv4.2: Optional attribute to retrieve MS

On Fri, 2009-08-21 at 08:23 +0530, Govind, Subin wrote:
> are uses to test for integrity of data that a client can fetch from 
> its peer.
>  

http://tools.ietf.org/id/draft-myklebust-nfsv4-pnfs-backend-protocol-00.
txt

Trond

---

From: Trond Myklebust <[email-masked]>
Date: Mon, 24 Aug 2009 08:27:40 -0400

> increasing parallelism of data access.

No. Its purpose is to increase scalability of the whole system by
sharing cached data between NFS clients.

> Windows clients using branchcache.

Has Microsoft released those protocols in a form that allows use in an
IETF standard?

Cheers
  Trond

---

From: "Govind, Subin" <[email-masked]>
Date: Wed, 26 Aug 2009 21:39:48 +0530

-----Original Message-----
From: Trond Myklebust [mailto:[email-masked]] 
Sent: Monday, August 24, 2009 5:58 PM
To: Govind, Subin
Cc: Erasani, Pranoop; [email-masked]
Subject: RE: [nfsv4] NFSv4.2: Optional attribute to retrieve MS

> would be a great advantage for NFS clients if they can interoperate 
> with Windows clients using branchcache.

>>> Has Microsoft released those protocols in a form that allows use in
an IETF standard?

The terms of the open license are complicated. Will update when I get
more info. I think we should drop this from the possible work items. :-(