Subject: [nfsv4] Lustre pNFS layout

From: Rick Macklem <[email-masked]>
Date: Tue, 12 Jun 2012 19:08:33 -0400 (EDT)

Sorin suggested I post to let everyone know that I think
a Lustre pNFS layout could be useful for the FreeBSD client
down the road. At this time, I can't say how quickly I
will get around to implementing one, but I will definitely
need a spec to work from, so I hope that Sorin will be able
to do this.

rick

---

From: "Myklebust, Trond" <[email-masked]>
Date: Tue, 12 Jun 2012 23:36:03 +0000

> need a spec to work from, so I hope that Sorin will be able

On my side, I'm totally uninterested in a seeing a pNFS layout
implementation for the Linux client.

There is already a Lustre client out there that caters to that
community. Why possible interest would a pNFS client hold for anyone who
is already drinking the Lustre Kool-Aid?

Cheers
  Trond

-- 
Trond Myklebust
Linux NFS client maintainer

NetApp
[email-masked]
www.netapp.com

---

From: Rick Macklem <[email-masked]>
Date: Wed, 13 Jun 2012 18:59:40 -0400 (EDT)

> is already drinking the Lustre Kool-Aid?
First off, I realize this isn`t technical, but it does seem that
the working group will need to consider proposals for new layouts
from time to time, so it seems that it might be relevent

---

From: Rick Macklem <[email-masked]>
Date: Wed, 13 Jun 2012 19:20:43 -0400 (EDT)

> is already drinking the Lustre Kool-Aid?
Oops, I somehow hit "send" instead of "cancel" the last time;-)
Anyhow, what I was saying was that, although non-technical, I
thought this might be relevant, since the working group would
need to consider new layout types from time to time.

I think I understand where Trond is coming from. In my "perfect
client world", there would only be a couple of layout types that
all servers supported, since that would minimize the implementation
challenges. But, obviously, that isn't the case...
I would like to implement the client side of layouts that will be
most widely deployed in environments that use FreeBSD clients, but
I have no idea what those might be. I had a vague hunch that Lustre
servers might be/become popular, but I really don't know. (Since
there isn't a Lustre client for FreeBSD, the pNFS client might
be attractive in that case?)

I also need a server to test against before I can realistically
develop a layout client. The Linux single server seemed sufficient
for the file layout. Since there isn't a ODS2 stack for FreeBSD
(and I doubt I could get access to a Panasas server), the objects
layout is a "no go". I thought the same would be true of the
block/volume layout, although it sounds like gaining access to
a server might be possible for that case.

In summary, it seems to me that a new layout type is justified when none
of the existing layouts will work, but it would be nice if it
could be "more generic" than something "specific to one cluster
file system".

Finally, I'll note that I have zero knowledge/experience with
Lustre at this time and, since the block/volume spec exists and
it sounds like I may be able to get access to a server to test
against, I will probably be working on that one. (In part, my
goal for doing a second layout type, is to generalize the
interfaces so that they support multiple layout types.)

rick

---

From: Sachin Bhamare <[email-masked]>
Date: Wed, 13 Jun 2012 16:38:10 -0700

On 6/13/12 4:20 PM, Rick Macklem wrote:
> layout is a "no go". 

You can always use 'exofs' (with simulated/real OSDs) as a server for
object layout testing. Please let me or Boaz (CC'd) know if you need
help in setting things up. More info at
http://www.open-osd.org/bin/view/Main/WebHome

I thought the same would be true of the
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 14 Jun 2012 14:27:51 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Rick Macklem
> Sent: Wednesday, June 13, 2012 4:00 PM
> To: Trond Myklebust
> Cc: nfsv4
> Subject: Re: [nfsv4] Lustre pNFS layout
> 
> Trond Myklebust wrote:
> > > Sorin suggested I post to let everyone know that I think a Lustre
> > > pNFS layout could be useful for the FreeBSD client down the road. At
> > > this time, I can't say how quickly I will get around to implementing
> > > one, but I will definitely need a spec to work from, so I hope that
> > > Sorin will be able to do this.
> >
> > community. Why possible interest would a pNFS client hold for anyone
> > who is already drinking the Lustre Kool-Aid?
> >
> First off, I realize this isn`t technical, but it does seem that the working group
> will need to consider proposals for new layouts from time to time, so it
> seems that it might be relevant

The place to start is a internet draft with a proposal.  Individual drafts can be submitted
at any time and is a great way to have a solid discussion about the options.

Spencer

---

From: <[email-masked]>
Date: Thu, 14 Jun 2012 10:59:55 -0400

This was my only proposal to put a draft out for discussion. And I am currently working on this. I am trying to get it out for Vancouver but I had a lot of travel and may miss the deadline. Thank you for the support.

/Sorin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Spencer Shepler
Sent: Thursday, June 14, 2012 10:28 AM
To: nfsv4
Subject: Re: [nfsv4] Lustre pNFS layout

Spencer