Subject: [nfsv4] PNFS questions

From: Michael Maymann <[email-masked]>
Date: Thu, 13 Mar 2014 20:02:55 +0100

Hi list,

I'm setting up a new BIO-HPC facility and are looking for a fault tolerant,
scalable, fast and priceeffective storage solution.

I have been looking at Coraid, Panasas and Lustre, but would like to
investigate my options also of building my own PNFS solution. Clients are
all Debian based.

Can anyone recommend:
1. If PNFS is ready for production or if I should stick with a commercial
vendor or build a Lustre solution ?
2. PNFS Metadata server SW prefferably for Debian ?
3. PNFS Diskshelfs to be used ?
4. If AOE (ATA Over Ethernet) would make any sense together with PNFS ?
5. PNFS GUI SW prefferably for Debian ?

Thanks in advance :-) !

BR.
~Maymann

---

From: Benny Halevy <[email-masked]>
Date: Fri, 14 Mar 2014 01:56:44 +0200

Michael, the IETF mailing list is really not the right place to ask about
commercial solutions in general or linux solutions in particular.
Cc'ing the linux-nfs mailing list. Comments in line below.

On Thu, Mar 13, 2014 at 9:02 PM, Michael Maymann <[email-masked]>wrote:

> Hi list,
>
> I'm setting up a new BIO-HPC facility and are looking for a fault
> tolerant, scalable, fast and priceeffective storage solution.
>

There is no pNFS server implementation in upstream linux yet.
We maintain a development out-of-kernel tree in git://
linux-nfs.org/~bhalevy/linux-pnfs.git
but it is not production ready.

> 2. PNFS Metadata server SW prefferably for Debian ?

ditto #1

>  3. PNFS Diskshelfs to be used ?

In pNFS terminology, these are Data Servers.

>  4. If AOE (ATA Over Ethernet) would make any sense together with PNFS ?

Maybe using the Block layout and AoE as the block storage transport
protocol.

>  5. PNFS GUI SW prefferably for Debian ?

ditto #1

> Thanks in advance :-) !
>
> BR.
> ~Maymann
>
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>
>