Subject: Re: [nfsv4] Fw: New Version Notification for draft-naik-nfsv4-xattrs-00.txt

From: "Haynes, Tom" <[email-masked]>
Date: Tue, 4 Mar 2014 23:57:50 +0000

Hi Manoj,

Please find enclosed my review of your draft.

Tom

From: Manoj Naik <[email-masked]<mailto:[email-masked]>>
Date: Friday, February 7, 2014 at 8:38 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [nfsv4] Fw: New Version Notification for draft-naik-nfsv4-xattrs-00.txt

I have just submitted a draft proposal to support extended attributes in NFS. We've tried to include most of the views expressed on the mailing list in the past on this topic, and hoping the discussion can continue here, at Connectathon and at London.

This first draft extends the existing attribute bitmap to include xattrs. This is easier to define and implement, but does not allow some operations like reading or writing individual xattrs.

Other options mentioned (but not detailed) are:
- define new operations - such as GETXATTR and SETXATTR - solely for xattrs. Cleaner, but has some consistency issues with GETATTR/SETATTR
with respect to attribute caching semantics.
- define new operations - such as GETATTR_PLUS and SETATTR_PLUS (similar to extensions to READ/WRITE proposed for 4.2) - that support all the features of GETATTR/SETATTR, but include extensions to fully support xattrs.

Please provide feedback.

Manoj Naik
IBM Almaden

[email-masked]<mailto:[email-masked]> wrote on 02/07/2014 12:16:01 AM:

> From: [email-masked]<mailto:[email-masked]>
> To: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
> Date: 02/07/2014 12:16 AM
> Subject: New Version Notification for draft-naik-nfsv4-xattrs-00.txt
>
>
> A new version of I-D, draft-naik-nfsv4-xattrs-00.txt
> has been successfully submitted by Manoj Naik and posted to the
> IETF repository.
>
> Name:      draft-naik-nfsv4-xattrs
> Revision:   00
> Title:      Support for File System Extended Attributes in NFSv4
> Document date:   2014-02-06
> Group:      Individual Submission
> Pages:      10
> URL:            http://www.ietf.org/internet-drafts/draft-naik-
> nfsv4-xattrs-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-naik-nfsv4-xattrs/
> Htmlized:       http://tools.ietf.org/html/draft-naik-nfsv4-xattrs-00
>
>
> Abstract:
>    This document proposes extensions to existing NFSv4 operations to
>    allow file extended attributes (here forth also referred to as
>    xattrs) to be manipulated in the protocol. An xattr is a file system
>    feature that allows opaque metadata, not interpreted by the file
>    system, to be associated with files and directories and are supported
>    by many modern file systems. New file attributes are proposed to
>    allow clients to query the server for xattr support, and get and set
>    xattrs on file system objects.
>
>
>
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>

---

From: Marc Eshel <[email-masked]>
Date: Fri, 7 Mar 2014 12:05:42 -0800

After presenting this draft both at the Connectathon and IETF 89 it looks 
like there is consensus on option 2 in the draft. We will now work on a 
new draft adding more details to this option, unless there is anyone out 
there that read the draft and thinks that it is not the best option.
Thanks, Marc. 

From:   "Haynes, Tom" <[email-masked]>
To:     Manoj Naik/Almaden/IBM@IBMUS, "[email-masked]" <[email-masked]>, 
Date:   03/04/2014 03:58 PM
Subject:        Re: [nfsv4] Fw: New Version Notification for 
draft-naik-nfsv4-xattrs-00.txt
Sent by:        "nfsv4" <[email-masked]>

Hi Manoj,

Tom

From: Manoj Naik <[email-masked]>
Date: Friday, February 7, 2014 at 8:38 AM
To: "[email-masked]" <[email-masked]>
Subject: [nfsv4] Fw: New Version Notification for 
draft-naik-nfsv4-xattrs-00.txt

I have just submitted a draft proposal to support extended attributes in 
NFS. We've tried to include most of the views expressed on the mailing 
list in the past on this topic, and hoping the discussion can continue 
here, at Connectathon and at London. 

This first draft extends the existing attribute bitmap to include xattrs. 
This is easier to define and implement, but does not allow some operations 
like reading or writing individual xattrs.

Other options mentioned (but not detailed) are:
- define new operations - such as GETXATTR and SETXATTR - solely for 
xattrs. Cleaner, but has some consistency issues with GETATTR/SETATTR 
with respect to attribute caching semantics.
- define new operations - such as GETATTR_PLUS and SETATTR_PLUS (similar 
to extensions to READ/WRITE proposed for 4.2) - that support all the 
features of GETATTR/SETATTR, but include extensions to fully support 
xattrs.

Please provide feedback.

Manoj Naik 
IBM Almaden 

[email-masked] wrote on 02/07/2014 12:16:01 AM:

> From: [email-masked] 
> To: [email-masked], [email-masked] 
> Status:         
https://datatracker.ietf.org/doc/draft-naik-nfsv4-xattrs/
> [attachment "draft-naik-nfsv4-xattrs-00.txt" deleted by Marc 
Eshel/Almaden/IBM] _______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: "Haynes, Tom" <[email-masked]>
Date: Tue, 11 Mar 2014 01:15:26 +0000

Marc,

I also have some questions on this paragraph:

   While it should be possible to write guidance about how a client can
   use the named attribute mechanism to act like xattrs, such as carving
   out some namespace and specifying locking primitives, this is
   problematic.  A client application trying to use xattrs through named
   attributes with a server that supported xattrs directly would get a
   lower level of service, and could fail to cooperate on a local
   application running on the server unless a shim layer was also
   implemented on the server side. File systems that already implement
   xattrs and named attributes natively would need additional guidance
   such as reserving named attribute namespace specifically for
   implementation purposes.

  1.  Why do xattrs need locking primitives?
  2.  I see no mention of them in your proposed solutions.
  3.  The shim layer raises the question, again, if the server is expected to be able to act on the xattrs?
     *   This needs a discussion about server requirements. Look at how the Labeled NFS dealt with how servers could or could not interact with labels.
  4.  Why is there a need to reserve portions of the namespace?
     *   This implies a need to do so for xattrs.
     *   Which in turn negates later discussion about no need to reserve name space.

I’d really like to see the set of requirements laid bare about xattrs. I.e., each implementation may have different conventions for formatting the name, but all of these questions about atomicity, locking, caching, server-side use, etc need to be addressed.

Thanks,
Tom

From: Marc Eshel <[email-masked]<mailto:[email-masked]>>
Date: Friday, March 7, 2014 at 8:05 PM
To: Thomas Haynes <[email-masked]<mailto:[email-masked]>>
Cc: Manoj Naik <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nfsv4] Fw: New Version Notification for draft-naik-nfsv4-xattrs-00.txt

After presenting this draft both at the Connectathon and IETF 89 it looks like there is consensus on option 2 in the draft. We will now work on a new draft adding more details to this option, unless there is anyone out there that read the draft and thinks that it is not the best option.
Thanks, Marc.

From:        "Haynes, Tom" <[email-masked]<mailto:[email-masked]>>
To:        Manoj Naik/Almaden/IBM@IBMUS, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>,
Date:        03/04/2014 03:58 PM
Subject:        Re: [nfsv4] Fw: New Version Notification for draft-naik-nfsv4-xattrs-00.txt
Sent by:        "nfsv4" <[email-masked]<mailto:[email-masked]>>
________________________________

Hi Manoj,

Tom

Please provide feedback.

Manoj Naik
IBM Almaden

[email-masked]<mailto:[email-masked]> wrote on 02/07/2014 12:16:01 AM:

> [attachment "draft-naik-nfsv4-xattrs-00.txt" deleted by Marc Eshel/Almaden/IBM] _______________________________________________
nfsv4 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nfsv4