Subject: [nfsv4] NFSv4.2 SEEK

From: Anna Schumaker <[email-masked]>
Date: Fri, 23 May 2014 11:17:31 -0400

Hey Tom!

I'm looking at SEEK on draft #27, and I have a few questions:

1) I don't see a data_content4 defined anywhere, did this get lost somewhere along the lines?
2) POSIX considers the end of a file to be one giant hole.  Will NFS treat files the same way?

Thanks!
Anna

---

From: Tom Haynes <[email-masked]>
Date: Fri, 23 May 2014 09:50:06 -0700

> 1) I don't see a data_content4 defined anywhere, did this get lost somewhere along the lines?

Check the XDR document.

But I will push out a patch for the main document!

> 2) POSIX considers the end of a file to be one giant hole.  Will NFS treat files the same way?

That isn’t POSIX is it? sleek(2) states:

       SEEK_HOLE
              Adjust  the  file  offset to the next hole in the file greater than or equal to offset.  If offset points
              into the middle of a hole, then the file offset is set to offset.  If there is no hole past offset,  then
              the  file  offset  is  adjusted to the end of the file (i.e., there is an implicit hole at the end of any
              file).

But SEEK_HOLE is non-posix.

But yes, your point is well taken - Solaris also assumes a virtual hole there.

Let me send out some more text for that as well.

Thanks!

> Thanks!
> Anna
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Anna Schumaker <[email-masked]>
Date: Fri, 23 May 2014 13:33:50 -0400

> But SEEK_HOLE is non-posix.

Good point!  I forgot that SEEK_HOLE and SEEK_DATA aren't POSIX, but it's still good to ask about matching other implementations :)

> Let me send out some more text for that as well.

Thank you!

Anna