Subject: Re: [nfsv4] IETF 90 - Toronto; NFSv4 WG meeting?

From: Tom Haynes <[email-masked]>
Date: Fri, 2 May 2014 11:29:47 -0400

Hi Spencer,

I’d like some time to talk about NFSv4.2. Hopefully by then we will have been through
WG Last Call and can talk about sending it out to the IESG.

I’d like some time to talk about both:

draft-haynes-nfsv4-layout-types-02	Considerations for a New pNFS Layout Type

and

draft-bhalevy-nfsv4-flex-files-02	Parallel NFS (pNFS) Flexible Files Layout

Thanks,
Tom

On Apr 30, 2014, at 4:10 PM, Spencer Shepler <[email-masked]> wrote:

>  
> Query to see what our agenda items are for Toronto in July.
>  
> Please respond by next Monday (5/5) with your agenda items and we can decide if we need to meet face-to-face.
>  
> Spencer
>  
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Chuck Lever <[email-masked]>
Date: Fri, 2 May 2014 11:51:12 -0400

> Please respond by next Monday (5/5) with your agenda items and we can decide if we need to meet face-to-face.

I can report on FedFS documents now via e-mail.

The FedFS ADMIN and NSDB docs are still holding in the RFC Editor queue.

There are two FedFS-related personal drafts, one is:

  http://datatracker.ietf.org/doc/draft-cel-nfsv4-federated-fs-security-addendum/

That doc hasn’t changed recently, but I’d like to add a section that
discusses how to access an NSDB via SASL GSSAPI with Kerberos. I’m
interested to know if there are others who can review or comment.

One of Andy’s multi-domain drafts, related to FedFS, recently expired.
Setting up cross-realm trust would be required to access NSDBs in a
foreign realm with SASL GSSAPI.

The second personal draft is:

  http://datatracker.ietf.org/doc/draft-cel-nfsv4-federated-fs-nce/

These changes are in Linux’s fedfs-utils 0.10, released in February 2014.
Oracle is exploring a second prototype for interoperability testing.

When the ADMIN and NSDB docs become RFCs, it might make sense to have
these two personal drafts become WG documents.

--
Chuck Lever
chuck[dot]lever[at]oracle[dot]com

---

From: Andy Adamson <[email-masked]>
Date: Mon, 5 May 2014 09:51:03 -0400

I'd like some time to report on rpcsecgssv3 progress, and on the
inter-ssc copy demo I've been working on.

There will be an draft-ietf-nfsv4-rpcsec-gssv3 update as well as a
draft-adamson-nfsv4-multi-domain-federated-fs-reqs refresh/update.

-->Andy

---

From: "Matt W. Benjamin" <[email-masked]>
Date: Mon, 5 May 2014 09:52:25 -0400 (EDT)

Hi,

We will have a metastripe draft update.

Matt

-- 
Matt Benjamin
The Linux Box
206 South Fifth Ave. Suite 150
Ann Arbor, MI  48104

http://linuxbox.com

tel.  734-761-4689 
fax.  734-769-8938 
cel.  734-216-5309

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 7 May 2014 16:03:23 +0000

I have submitted a meeting request for Toronto and the draft agenda is as follows.  Please submit updates or additional item as necessary.

NFSv4 Working Group
Toronto
Time: TBD
Room: TBD
Date: TBD
[version 0.1]

Note Well

Agenda Bashing

NFSv4.2 Updates and Issues (Haynes)

Considerations for a New pNFS Layout Type (Haynes)
draft-haynes-nfsv4-layout-types-02

Parallel NFS (pNFS) Flexible Files Layout (Haynes)
draft-bhalevy-nfsv4-flex-files-02

RPCSEC_GSSv3 I-D Update (Adamson)
draft-ietf-nfsv4-rpcsec-gssv3

Multi Domain FedFS (Adamson)
draft-adamson-nfsv4-multi-domain-federated-fs-reqs

Inter SSC Copy Demo (Adamson)

Xattr Protocol Extensions (Eshel)

pNFS Metadata Striping (Benjamin)
     draft-mbenjamin-nfsv4-pnfs-metastripe

---

From: Tom Haynes <[email-masked]>
Date: Fri, 9 May 2014 16:26:13 -0700

I’m looking at the last published draft and section 4.2.4:

>    For SETATTR operation, if the
>    associated xattrvalue4 has a length of zero, the corresponding xattr
>    is to be deleted, if it exists.
And I’m also looking at Robert Love’s Linux System Programming,
specifically Chapter 8:

> A key is either defined or undefined. If a key is defined, its value may be
> empty or nonempty. That is, there is a difference between an undefined
> key and a key with no assigned value. As we shall see, this means a
> special interface is required for removing keys as assigning an empty value
> is insufficient.

This implies for at least Linux, it is possible to set/have an xattr with
no value at all. How does the proposal address that case?

---

From: Manoj Naik <[email-masked]>
Date: Fri, 9 May 2014 18:11:04 -0700

Good point. This is one of the issues with trying to plug xattrs into the 
existing GETATTR/SETATTR operations (should have been added to others 
mentioned in section 5. Note that Linux also has a separate operation to 
remove xattrs). One of the alternatives is to define new operations 
(GETXATTR/SETXATTR) that gives better flexibility and was briefly 
mentioned in section 5.1 - and appears to be better suited based on the 
discussion at IETF 89. 

We'll have a revision of the document with the comments (including your 
earlier ones) soon.

Manoj.

"nfsv4" <[email-masked]> wrote on 05/09/2014 04:26:13 PM:

> From: Tom Haynes <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Date: 05/09/2014 04:26 PM
> Subject: [nfsv4] Xattr was Re:  IETF 90 - Toronto; NFSv4 WG meeting?
> Sent by: "nfsv4" <[email-masked]>
> 
> I?m looking at the last published draft and section 4.2.4:
> 
> And I?m also looking at Robert Love?s Linux System Programming,
> specifically Chapter 8:
>

---

From: "Matt W. Benjamin" <[email-masked]>
Date: Sat, 10 May 2014 11:48:35 -0400 (EDT)

Hi,

Will the new draft focus on GETXATTR/SETXATTR and related ops?

Thanks,

Matt

----- "Manoj Naik" <[email-masked]> wrote:

> Good point. This is one of the issues with trying to plug xattrs into
> the existing GETATTR/SETATTR operations (should have been added to
> others mentioned in section 5. Note that Linux also has a separate
> operation to remove xattrs). One of the alternatives is to define new
> operations (GETXATTR/SETXATTR) that gives better flexibility and was
> briefly mentioned in section 5.1 - and appears to be better suited
> based on the discussion at IETF 89.
> 
> We'll have a revision of the document with the comments (including
> your earlier ones) soon.
> 
> Manoj.
> 

http://linuxbox.com

tel.  734-761-4689 
fax.  734-769-8938 
cel.  734-216-5309

---

From: Manoj Naik <[email-masked]>
Date: Sat, 10 May 2014 19:21:38 -0700

Yes, that's the plan.

Manoj.

"Matt W. Benjamin" <[email-masked]> wrote on 05/10/2014 08:48:35 AM:

> From: "Matt W. Benjamin" <[email-masked]>
> To: Manoj Naik/Almaden/IBM@IBMUS
> Cc: [email-masked], Tom Haynes <[email-masked]>
> Date: 05/10/2014 08:49 AM
> Subject: Re: [nfsv4] Xattr was Re:  IETF 90 - Toronto; NFSv4 WG meeting?
> 
> Hi,
>