Subject: Re: [nfsv4] RFC 7204 on Requirements for Labeled NFS

From: "faibish, sorin" <[email-masked]>
Date: Sun, 4 May 2014 13:52:35 -0400

Tom,

Per your request I reviewed the draft and it reflects most of the discussions we had regarding labeled NFS. There is only one additional used case that we discussed and needs to be added to the draft; server side copy which it is similar to the use case 5.5.2 but there are few differences that need to be emphasized. I recall we had several discussions regarding server side copy when the target server was not MAC-aware and the source server was MAC aware. If you think it is covered by 5.5.2 use case I still think we need to mention it. Also maybe you can also mention the support of David Black and myself in the acknowledgement section. Thanks

./Sorin

Sent from my iPad

> On Apr 17, 2014, at 4:04 PM, "[email-masked]" <[email-masked]> wrote:
> 
> A new Request for Comments is now available in online RFC libraries.
> 
> 
>        RFC 7204
> 
>        Title:      Requirements for Labeled NFS 
>        Author:     T. Haynes
>        Status:     Informational
>        Stream:     IETF
>        Date:       April 2014
>        Mailbox:    [email-masked]
>        Pages:      18
>        Characters: 39350
>        Updates/Obsoletes/SeeAlso:   None
> 
>        I-D Tag:    draft-ietf-nfsv4-labreqs-05.txt
> 
>        URL:        http://www.rfc-editor.org/rfc/rfc7204.txt
> 
> This memo outlines high-level requirements for the integration of
> flexible Mandatory Access Control (MAC) functionality into the
> Network File System (NFS) version 4.2 (NFSv4.2).  It describes the
> level of protections that should be provided over protocol components
> and the basic structure of the proposed system.  The intent here is
> not to present the protocol changes but to describe the environment
> in which they reside.
> 
> This document is a product of the Network File System Version 4 Working Group of the IETF.
> 
> 
> INFORMATIONAL: This memo provides information for the Internet community.
> It does not specify an Internet standard of any kind. Distribution of
> this memo is unlimited.
> 
> This announcement is sent to the IETF-Announce and rfc-dist lists.
> To subscribe or unsubscribe, see
>  http://www.ietf.org/mailman/listinfo/ietf-announce
>  http://mailman.rfc-editor.org/mailman/listinfo/rfc-dist
> 
> For searching the RFC series, see http://www.rfc-editor.org/search
> For downloading RFCs, see http://www.rfc-editor.org/rfc.html
> 
> Requests for special distribution should be addressed to either the
> author of the RFC in question, or to [email-masked].  Unless
> specifically noted otherwise on the RFC itself, all RFCs are for
> unlimited distribution.
> 
> 
> The RFC Editor Team
> Association Management Solutions, LLC
> 
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: spencer shepler <[email-masked]>
Date: Sun, 4 May 2014 20:48:11 -0700

Belated but I wanted to express my personal thanks to all those involved
for moving this work forward to an RFC.

The discussion started quite awhile ago but the result is worthwhile and
will set up things well as we move other pieces of our labeled work and
NFSV4.2 forward.

Spencer