Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-minorversion2-dot-x-26.txt

From: [email-masked]
Date: Mon, 19 May 2014 15:16:42 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Network File System Version 4 Working Group of the IETF.

        Title           : NFSv4 Minor Version 2 Protocol External Data Representation Standard (XDR) Description
        Author          : Thomas Haynes
	Filename        : draft-ietf-nfsv4-minorversion2-dot-x-26.txt
	Pages           : 80
	Date            : 2014-05-19

Abstract:
   This Internet-Draft provides the XDR description for NFSv4 minor
   version two.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-nfsv4-minorversion2-dot-x/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-nfsv4-minorversion2-dot-x-26

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-nfsv4-minorversion2-dot-x-26

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Tom Haynes <[email-masked]>
Date: Mon, 19 May 2014 15:19:24 -0700

Grr, one of those days.

My Linux VM can do the ‘make testx'. My MacBook can not. Guess which one can easily upload to IETF? :-)

On May 19, 2014, at 3:16 PM, [email-masked] wrote:

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Trond Myklebust <[email-masked]>
Date: Mon, 19 May 2014 19:27:57 -0400

15.9.1.  ARGUMENT

   struct OFFLOAD_CANCEL4args {
           /* CURRENT_FH: source file */
           stateid4        oca_stateid;
   };

If applied to the destination server, surely the CURRENT_FH is not the
source file? Please clarify in the text...

You might also want to note that the generic asynchronous use cases of
OFFLOAD_CANCEL (of which there are only one so far: WRITE_SAME)
matches the syntax for intra-server COPY.

---

From: Tom Haynes <[email-masked]>
Date: Thu, 22 May 2014 14:23:07 -0700

> matches the syntax for intra-server COPY.

kitty:NFSv4.2 loghyr$ git diff
diff --git a/dotx.d/offload_cancel_args.x b/dotx.d/offload_cancel_args.x
index 9a44760..cd97691 100644
--- a/dotx.d/offload_cancel_args.x
+++ b/dotx.d/offload_cancel_args.x
@@ -1,5 +1,5 @@
 struct OFFLOAD_CANCEL4args {
-        /* CURRENT_FH: source file */
+        /* CURRENT_FH: file to cancel */
        stateid4        oca_stateid;
 };
 
diff --git a/nfsv42_middle_op_offload_cancel.xml b/nfsv42_middle_op_offload_cancel.xml
index fd85ec7..281c41d 100644
--- a/nfsv42_middle_op_offload_cancel.xml
+++ b/nfsv42_middle_op_offload_cancel.xml
@@ -16,7 +16,8 @@
       operation, which is identifed both by CURRENT_FH and the
       oca_stateid. I.e., there can be multiple offloaded operations acting
       on the file, the stateid will identify to the server exactly which
-      one is to be stopped.
+      one is to be stopped.  Currently there are only two operations
+      which can decide to be asynchronous: COPY and WRITE_SAME.
     </t>
 
     <t>