Subject: [nfsv4] [PATCH] Revert change of FATTR4_SEC_LABEL value

From: "J. Bruce Fields" <[email-masked]>
Date: Wed, 4 Jun 2014 12:00:09 -0400

From: "J. Bruce Fields" <[email-masked]>

e04719ce7034 "Remove FATTR4_CHANGE_SEC_LABEL" shifted down the values of
three other attributes when it removed FATTR4_CHANGE_SEC_LABEL.

In particular, it redefined FATTR4_SEC_LABEL, which already has
implementations.

Let's leave these alone instead and just leave a hole.

Note that nobody appears to have ever actually implemented
FATTR4_CHANGE_SEC_LABEL, so it would be safe to fill in the hole later
if we want.

Signed-off-by: J. Bruce Fields <[email-masked]>
---
 dotx.d/head.x |    7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/dotx.d/head.x b/dotx.d/head.x
index d5c2457..2b899a1 100644
--- a/dotx.d/head.x
+++ b/dotx.d/head.x
@@ -599,9 +599,10 @@ const FATTR4_RETENTEVT_SET	= 72;
 const FATTR4_RETENTION_HOLD	= 73;
 const FATTR4_MODE_SET_MASKED	= 74;
 const FATTR4_FS_CHARSET_CAP	= 76;
-const FATTR4_SPACE_FREED	= 77;
-const FATTR4_CHANGE_ATTR_TYPE	= 78;
-const FATTR4_SEC_LABEL		= 79;
+/* 77 is currently unused */
+const FATTR4_SPACE_FREED	= 78;
+const FATTR4_CHANGE_ATTR_TYPE	= 79;
+const FATTR4_SEC_LABEL		= 80;
 
 /*
  * File attribute container
-- 
1.7.9.5

---

From: Tom Haynes <[email-masked]>
Date: Wed, 4 Jun 2014 11:06:51 -0700

Applied!