Subject: [nfsv4] Flexfile rfc v3

From: "Mkrtchyan, Tigran" <[email-masked]>
Date: Sun, 22 Jun 2014 22:50:47 +0200 (CEST)

Hi Benny et al.

I started to read flexfile spec, and noticed that dot-x file includes nfsv42.x. I am sure, it doesn't belong there.

Regards,
   Tigran.

---

From: "Mkrtchyan, Tigran" <[email-masked]>
Date: Sun, 22 Jun 2014 23:16:25 +0200 (CEST)

Ah, you use some data types from 4.2.   But it looks like overkill to depend on 4.2 for that.

Other point: it's unclear to me, will client write to all mirrors the same block or not?

Tigran

On Jun 22, 2014 10:51 PM, "Mkrtchyan, Tigran" <[email-masked]> wrote:
>
> Hi Benny et al.
>
> I started to read flexfile spec, and noticed that dot-x file includes nfsv42.x. I am sure, Hi Benny et al.

Regards,
   Tigran.
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Benny Halevy <[email-masked]>
Date: Mon, 23 Jun 2014 09:57:47 +0300

> Ah, you use some data types from 4.2.   But it looks like overkill to depend on 4.2 for that.

Making forward progress.

> Other point: it's unclear to me, will client write to all mirrors the same block or not?

I guess we thought it goes without saying.
What is the other option you're seeing?

Benny

---

From: "Mkrtchyan, Tigran" <[email-masked]>
Date: Mon, 23 Jun 2014 09:07:16 +0200 (CEST)

----- Original Message -----
> From: "Benny Halevy" <[email-masked]>
> To: "Tigran Mkrtchyan" <[email-masked]>
> Cc: "[email-masked] [email-masked]" <[email-masked]>
> Sent: Monday, June 23, 2014 8:57:47 AM
> Subject: Re: [nfsv4] Flexfile rfc v3
> 

Of course, the word 'mirror' implicitly describes this behavior.
Personally, I love to see word 'MUST' in the sepc to avoid any kind of
misinterpretations.

But let me re-read the draft.

Thanks,
   Tigran.

> > I started to read flexfile spec, and noticed that dot-x file includes
> > nfsv42.x. I am sure, it doesn't belong there.
> > 
> > Regards,
> >    Tigran.

---

From: Benny Halevy <[email-masked]>
Date: Mon, 23 Jun 2014 10:19:47 +0300

On Mon, Jun 23, 2014 at 10:07 AM, Mkrtchyan, Tigran <
[email-masked]> wrote:

> > > Other point: it's unclear to me, will client write to all mirrors the
> same
> > > block or not?
> >

That's a good point.
It might not be obvious from the text that the client  MUST mirror the data
to all mirrors for any WRITE.
And the corresponding client responsibility for COMMITing all mirrors after
UNSTABLE or DATA_SYNC WRITEs.

> But let me re-read the draft.

Thanks Tigran!
Suggestions for clarifying text are welcomed as well if you have the cycles.

Benny

>
> Thanks,
>    Tigran.
>
> >
> > Benny
> >
> > >
> > > Tigran
> > >
> > > On Jun 22, 2014 10:51 PM, "Mkrtchyan, Tigran" <
> [email-masked]>
> > > wrote:
> > >>
> > >> Hi Benny et al.
> > >>
> > >> nfsv42.x. I am sure, Hi Benny et al.
> > >

---

From: Tom Haynes <[email-masked]>
Date: Mon, 23 Jun 2014 10:33:19 -0700

> Ah, you use some data types from 4.2.   But it looks like overkill to depend on 4.2 for that.

Look at what the ‘make testx’ does to check that the XDR is valid.

Overkill, yeah, but I’d rather catch an error earlier than later.

Also, as the 4.2 data types may change yet, I’d also like to catch problems
introduced by that.