Subject: [nfsv4] NVMe and pNFS SCSI layout - two comments

From: "Black, David" <[email-masked]>
Date: Sun, 10 Jul 2016 19:09:31 +0000

Two quick comments: 

(1) Section 2.1 on Volume Identification could use some tightening.
As a straw proposal I'd suggest (on the NVMe side):
	- MUST use one of EUI64 or NGUID identification
	- SHOULD use NGUID identification, as it's a larger ID.
	- MUST NOT use serial number for identification with the pNFS SCSI layout.

(2)  Should add a discussion on registering with all controllers as an analog to registering all SCSI I_T
Nexuses - the NVMe Host Identifier simplifies this by comparison to SCSI, but this is an area where
relying strictly on SCSI translation may not suffice.

Thanks, --David

> -----Original Message-----
> From: nfsv4 [mailto:[email-masked]] On Behalf Of Christoph Hellwig
> Sent: Friday, July 08, 2016 9:19 AM
> To: Chuck Lever; [email-masked]
> Subject: [nfsv4] [[email-masked]: New Version Notification for draft-
> hellwig-nfsv4-scsi-layout-nvme-00.txt]
> 
> 
> As promised to Chuck and a few others a while ago here is the
> draft on how to use the SCSI to NVMe mapping for using the
> SCSI layout with NVMe storage devices.
> 
> ----- Forwarded message from [email-masked] -----
> 
> Date: Fri, 08 Jul 2016 06:16:54 -0700
> From: [email-masked]
> Subject: New Version Notification for
> 	draft-hellwig-nfsv4-scsi-layout-nvme-00.txt
> To: Christoph Hellwig <[email-masked]>
> 
> 
> A new version of I-D, draft-hellwig-nfsv4-scsi-layout-nvme-00.txt
> has been successfully submitted by Christoph Hellwig and posted to the
> IETF repository.
> 
> Name:		draft-hellwig-nfsv4-scsi-layout-nvme
> Revision:	00
> Title:		Using the Parallel NFS (pNFS) SCSI Layout with NVMe
> Document date:	2016-07-08
> Group:		Individual Submission
> Pages:		4
> URL:            https://www.ietf.org/internet-drafts/draft-hellwig-nfsv4-scsi-layout-
> nvme-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-hellwig-nfsv4-scsi-layout-
> nvme/
> Htmlized:       https://tools.ietf.org/html/draft-hellwig-nfsv4-scsi-layout-nvme-00
> 
> 
> Abstract:
>    This document explains how to use the Parallel Network File System
>    (pNFS) SCSI Layout Type with transports using the NVMe or NVMe over
>    Fabrics protocol.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> ----- End forwarded message -----
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Christoph Hellwig <[email-masked]>
Date: Mon, 18 Jul 2016 06:17:42 +0200

> 	- MUST NOT use serial number for identification with the pNFS SCSI layout.

That's probably a good idea given ho painful the serial number idenfitication
is.

> relying strictly on SCSI translation may not suffice.

Ok, I'll look into this.  So far I've not even started into the multipathing
issues, so this might take a bit more time.