Subject: [nfsv4] [Technical Errata Reported] RFC7530 (4742)

From: RFC Errata System <[email-masked]>
Date: Fri, 15 Jul 2016 02:05:12 -0700 (PDT)

The following errata report has been submitted for RFC7530,
"Network File System (NFS) Version 4 Protocol".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7530&eid=4742

--------------------------------------
Type: Technical
Reported by: Manju Karthik <[email-masked]>

Section: section-6.2.

Original Text
-------------
https://tools.ietf.org/html/rfc7530#section-6.2.1

   The client can use the OPEN or ACCESS
   operations to check access without modifying or reading data or
   metadata.

Corrected Text
--------------
   The client can use the OPEN or ACCESS
   operations to check access without modifying or reading data.

Notes
-----
Whenever client does OPEN/ACCESS call, there is an inadvertent change in the Last Access time of the file. Hence we think that the Metadata is modified due to OPEN/ACCESS call.  Hence the Suggestion is to change the text as above.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7530 (draft-ietf-nfsv4-rfc3530bis-35)
--------------------------------------
Title               : Network File System (NFS) Version 4 Protocol
Publication Date    : March 2015
Author(s)           : T. Haynes, Ed., D. Noveck, Ed.
Category            : PROPOSED STANDARD
Source              : Network File System Version 4
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: David Noveck <[email-masked]>
Date: Fri, 15 Jul 2016 09:43:59 -0400

The suggested correction should not be applied.

While the suggested correction would result in text that is
literally true, it would undercut the whole point of the passage,
which is that you can find out whether access is possible without
explicitly reading access control attributes.

With regard to modification of access time attribute, it is possible
that some file systems will modify this when doing an OPEN.  Others
may modify it when doing an ACCESS.  However, in any case, this is
implementation-specific behavior.

Two elements in the original text that make a clear correction difficult to
effect:

   - Reference to data (since data is not really the subject here)
   - Mention of "modifying" which isn't the subject either.

A possible replacement that eliminates the abovementioned troublesome
elements could cure the potential problem with access time would be the
following:

The client can use the OPEN or ACCESS operations to check access

without explicitly accessing file attributes.

On Fri, Jul 15, 2016 at 5:05 AM, RFC Errata System <
[email-masked]> wrote:

> Whenever client does OPEN/ACCESS call, there is an inadvertent change in
> the Last Access time of the file. Hence we think that the Metadata is
> modified due to OPEN/ACCESS call.  Hence the Suggestion is to change the
> text as above.
>
> Instructions:
> -------------
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>