Subject: [nfsv4] netconfig in the age of RDMA

From: William Allen Simpson <[email-masked]>
Date: Thu, 8 Mar 2018 17:52:19 -0500

I'm looking for sage advice on the purpose of etc/netconfig?

I've been having problems with the usual default, as it
seems to willy-nilly change IPv6 to IPv4.  And otherwise
give preference to IPv4, no matter how DNS is configured.

It has no RDMA capability.

But it does have, in addition to the expected TCP and UDP,
many other unknown capabilities: "netpath", "visible",
"circuit_v", "datagram_v", "circuit_n", "datagram_n" --
and an awful lot of obsolete COTS and CLTS references.

Is this of any use in this century, or can it be tossed?

---

From: Tom Haynes <[email-masked]>
Date: Thu, 8 Mar 2018 14:57:48 -0800

Wrong mailing list? /etc/netconfig sounds like something you
should ask about on the Linux NFS mailing list.

> On Mar 8, 2018, at 2:52 PM, William Allen Simpson <[email-masked]> wrote:
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: William Allen Simpson <[email-masked]>
Date: Thu, 8 Mar 2018 18:18:56 -0500

> should ask about on the Linux NFS mailing list.
Other than the fact that it's from BSD and SunOS.  And it's
supported by libntirpc.

It's still being processed for NFSV4.  Uselessly.

Any other sage advice?