Subject: [nfsv4] nfsv4 xattr support

From: "van der Linden, Frank" <[email-masked]>
Date: Thu, 8 Aug 2019 22:50:20 +0000

[sorry, couldn't reply to the earlier thread, I wasn't on this list at the time]

I saw that there was interest in an implementation of RFC8276.

I am actually working on one. So far I have the Linux kernel client side working (caching needs a bit of work), and I have modified Mark Eshel's original ganesha code, plus added the VFS clue to it. They talk to each other just fine.

I'm doing the Linux kernel server side right now, and can then send it out for comments to the linux-nfs mailing list. That is all out of scope for this list, so any follow ups on that should go there (and I should have sent a message to that list earlier), but I saw the earlier thread and decided to reply. 

General question: is there an archive somewhere that documents the reasoning behind how the document evolved? E.g. from draft 2 to draft 3, the cookie verifier was removed for LISTXATTR. Again, probably out of scope to discuss the details here, but a pointer would be welcome.

Thanks,

Frank

---

From: [email-masked] (J. Bruce Fields)
Date: Tue, 13 Aug 2019 13:55:57 -0400

On Thu, Aug 08, 2019 at 10:50:20PM +0000, van der Linden, Frank wrote:
> I am actually working on one. So far I have the Linux kernel client
> side working (caching needs a bit of work), and I have modified Mark
> Eshel's original ganesha code, plus added the VFS clue to it. They
> talk to each other just fine.
> 
> I'm doing the Linux kernel server side right now, and can then send it
> out for comments to the linux-nfs mailing list. That is all out of
> scope for this list, so any follow ups on that should go there (and I
> should have sent a message to that list earlier), but I saw the
> earlier thread and decided to reply. 

Great, we'll look forward to seeing that.

> General question: is there an archive somewhere that documents the
> reasoning behind how the document evolved? E.g. from draft 2 to draft
> 3, the cookie verifier was removed for LISTXATTR. Again, probably out
> of scope to discuss the details here, but a pointer would be welcome.

I'd probably just search the mail archives and then ask the authors.

--b.