Subject: Re: [nfsv4] Extended Attributes NFSv4

From: David Noveck <[email-masked]>
Date: Fri, 2 Aug 2019 12:41:49 -0400

> The NFSv4 WG rejected the idea of using extended attributes that were
specified in the rfc 8276.

I don't'  think the working group considered and rejected the idea using
extended attributes,   Making a decision like that is way to organized for
an IETF working group, espec.

Tha
> It seems nobody implemented xattr per the rfc. If you have any plans for
that please let the NFSv4 WG know sending this email to the nfsv4 list I
added here. Thanks

On Tue, Jul 30, 2019 at 11:47 AM <[email-masked]> wrote:

> Victor,
>
>
>
> Just to keep you expectations low, the NFSv4 WG rejected the idea of using
> extended attributes that were specified in the rfc 8276. It seems nobody
> implemented xattr per the rfc. If you have any plans for that please let
> the NFSv4 WG know sending this email to the nfsv4 list I added here. Thanks
>
>
>
> ./Sorin
>
>
>
>
>
> *From:* Victor A Asencio Casiano <[email-masked]>
> *Sent:* Tuesday, July 30, 2019 10:43 AM
> *To:* faibish, sorin; Shilane, Philip; Black, David
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Extended Attributes NFSv4
>
>
>
> [EXTERNAL EMAIL]
>
> Good morning, I’m currently interested in adding extended attributes to
> NFSv4 and I would like if you can send me in the right direction. RFC 8276
> and your draft (Support for Data Reduction Extended Attributes in nfsv4
> Version 2) are the only serious documents that I found about this topic. I
> would like to know if Extended Attributes have been already implemented
> somewhere that I can test it out, or If someone try to implement this
> before or any source code that I can reach out or any draft code? Besides
> the code portions that appears on RFC 8276.
>
>
>
> Thanks for your help.
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: Matt Benjamin <[email-masked]>
Date: Fri, 2 Aug 2019 12:43:43 -0400

I was not aware that this had been rejected?

Matt

On Fri, Aug 2, 2019 at 12:42 PM David Noveck <[email-masked]> wrote:
>
> > The NFSv4 WG rejected the idea of using extended attributes that were specified in the rfc 8276.
>
> I don't'  think the working group considered and rejected the idea using extended attributes,   Making a decision like that is way to organized for an IETF working group, espec.
>
> Tha
> > It seems nobody implemented xattr per the rfc. If you have any plans for that please let the NFSv4 WG know sending this email to the nfsv4 list I added here. Thanks
>
>> Just to keep you expectations low, the NFSv4 WG rejected the idea of using extended attributes that were specified in the rfc 8276. It seems nobody implemented xattr per the rfc. If you have any plans for that please let the NFSv4 WG know sending this email to the nfsv4 list I added here. Thanks
>>
>>
>>
>> ./Sorin
>>
>>
>>
>>
>>
>> From: Victor A Asencio Casiano <[email-masked]>
>> Sent: Tuesday, July 30, 2019 10:43 AM
>> To: faibish, sorin; Shilane, Philip; Black, David
>> Cc: [email-masked]; [email-masked]
>> Subject: Extended Attributes NFSv4
>>
>>
>>
>> [EXTERNAL EMAIL]
>>
>> Good morning, I’m currently interested in adding extended attributes to NFSv4 and I would like if you can send me in the right direction. RFC 8276 and your draft (Support for Data Reduction Extended Attributes in nfsv4 Version 2) are the only serious documents that I found about this topic. I would like to know if Extended Attributes have been already implemented somewhere that I can test it out, or If someone try to implement this before or any source code that I can reach out or any draft code? Besides the code portions that appears on RFC 8276.
>>
>>
>>
>> Thanks for your help.
>>

-- 

Matt Benjamin
Red Hat, Inc.
315 West Huron Street, Suite 140A
Ann Arbor, Michigan 48103

http://www.redhat.com/en/technologies/storage

tel.  734-821-5101
fax.  734-769-8938
cel.  734-216-5309

---

From: "Marc Eshel" <[email-masked]>
Date: Fri, 2 Aug 2019 09:49:41 -0700

There is an implementation in NFS Ganesha for the server side, and a 
prototype for the NFS Linux client side.
Marc.

From:   David Noveck <[email-masked]>
To:     "faibish, sorin" <[email-masked]>
Cc:     [email-masked], [email-masked], NFSv4 
<[email-masked]>
Date:   08/02/2019 09:42 AM
Subject:        [EXTERNAL] Re: [nfsv4] Extended Attributes NFSv4
Sent by:        "nfsv4" <[email-masked]>

Tha  

Just to keep you expectations low, the NFSv4 WG rejected the idea of using 
extended attributes that were specified in the rfc 8276. It seems nobody 
implemented xattr per the rfc. If you have any plans for that please let 
the NFSv4 WG know sending this email to the nfsv4 list I added here. 
Thanks
 
./Sorin

[EXTERNAL EMAIL] 
 
Thanks for your help. 
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4
_______________________________________________
nfsv4 mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_nfsv4&d=DwICAg&c=jf_iaSHvJObTbx-siA1ZOg&r=NhjWjQMiZ2Z3jl9k1z_vFQ&m=ciCsJOkQAIJqC9dtwkItM5iA0MolxyyZs-81_AsYLOo&s=XgAi3TaMnwCf6mDBCts78JCVpt4A0AeDkaNQpFg-nUo&e=

---

From: David Noveck <[email-masked]>
Date: Fri, 2 Aug 2019 12:59:39 -0400

I don't  think the working group considered and rejected the idea using
extended attributes,   Making a decision like that is way too organized for
an IETF working group, especally given that we had ten minutes to devote to
the topic.

Nevertheless, many members seemed to feel Sorin's attributes were not a
good fit for the xattrs in rfc 8276, and, while I can't speak for the
group, I'd like to explain while I felt that way.

rfc8276 defines a mechanism to provide for user xattrs, i.e. those that are
totally opaque to the server and which the server essentially treats pretty
much as user data.    In many cases we do have items which are system
xattrs in Linux (e.g. IMA metadata).  Thse are typically handled as
ordinary optional attributes.    This works OK since the set of OPTIONAL
attributes can be easily extended, as described in RFC 8178.

> It seems nobody implemented xattr per the rfc.

It appears that implementation has lagged.  I'm not sure why.   In any
case, I don't feel that the decision about whether xattrs should be used
for the data reduction attributes should turn on the pace of
implementationof the xattr feature.

> If you have any plans for that please let the NFSv4 WG know sending this
email to the nfsv4 list I added here.

I certainly would like to know about such plans.   It is hard to invest in
server-side implementations of a feature when there are no client-side
implementations in the horizon.

---

From: David Noveck <[email-masked]>
Date: Fri, 2 Aug 2019 13:00:49 -0400

Cool!

---

From: Chuck Lever <[email-masked]>
Date: Fri, 2 Aug 2019 14:16:07 -0400

Hi Matt-

I don't recall us rejecting RFC 8276 in general. My sense of the
room was we were not sensing good alignment between user extended
attributes as specified in RFC 8276 and their use for conveying
data reduction metadata, as proposed in

https://datatracker.ietf.org/doc/draft-faibish-data-reduction-xattrs-pvt/ .

By the way, Sorin, you should rename this document, when you submit
the next revision, to include "nfsv4" in the name so it appears on
the NFSv4 WG page where it is easy to find. Something like

draft-faibish-nfsv4-data-reduction-attributes

would work.

> On Aug 2, 2019, at 12:43 PM, Matt Benjamin <[email-masked]> wrote:
> 

--
Chuck Lever
[email-masked]

---

From: Rick Macklem <[email-masked]>
Date: Sat, 3 Aug 2019 02:33:47 +0000

David Noveck or Sorin Faibish (sorry, I lost track of which;-) wrote:
[stuff snipped]
>> If you have any plans for that please let the NFSv4 WG know sending this email to >the nfsv4 list I added here.
>
>I certainly would like to know about such plans.   It is hard to invest in server-side >implementations of a feature when there are no client-side implementations in the >horizon.
Just fyi, I do plan on implementing RFC-8276 extended attribute support for FreeBSD.
Hopefully ready for the FreeBSD-13 release. (ie. next year, maybe?)
(I have no code at this time.)

I'll let others try and decide if using these extended attributes are appropriate for
Sorin's problem.

rick

---

From: <[email-masked]>
Date: Mon, 5 Aug 2019 18:06:42 +0000

Chuck,

-----Original Message-----
From: Chuck Lever <[email-masked]> 
Sent: Friday, August 2, 2019 2:16 PM
To: Matt Benjamin; faibish, sorin
Cc: David Noveck; Shilane, Philip; [email-masked]; NFSv4
Subject: Re: [nfsv4] Extended Attributes NFSv4

[EXTERNAL EMAIL] 

Hi Matt-

I don't recall us rejecting RFC 8276 in general. My sense of the room was we were not sensing good alignment between user extended attributes as specified in RFC 8276 and their use for conveying data reduction metadata, as proposed in

By the way, Sorin, you should rename this document, when you submit the next revision, to include "nfsv4" in the name so it appears on the NFSv4 WG page where it is easy to find. Something like

draft-faibish-nfsv4-data-reduction-attributes
[sf] I followed your recommendation and changed the name of my draft. I posted the revise draft.

would work.

>>> It seems nobody implemented xattr per the rfc. If you have any plans 
>>> for that please let the NFSv4 WG know sending this email to the 
>>> nfsv4 list I added here. Thanks
>> 
>>> Just to keep you expectations low, the NFSv4 WG rejected the idea of 
>>> using extended attributes that were specified in the rfc 8276. It 
>>> seems nobody implemented xattr per the rfc. If you have any plans 
>>> for that please let the NFSv4 WG know sending this email to the 
>>> nfsv4 list I added here. Thanks
>>> 
>>> 
>>> 
>>> ./Sorin
>>> 
>>> 
>>> 
>>> 
>>> 

--
Chuck Lever
[email-masked]

---

From: Chuck Lever <[email-masked]>
Date: Mon, 5 Aug 2019 15:00:35 -0400

Thanks, Sorin.

> On Aug 5, 2019, at 2:06 PM, [email-masked] wrote:
> 
> Chuck,
> 
> 
> 

--
Chuck Lever
[email-masked]

---

From: "Marc Eshel" <[email-masked]>
Date: Thu, 15 Aug 2019 17:45:53 -0700

Hi Victor,

The implementation I added was for the GPFS FSAL, there is some common 
code and if your FSAL claims support for xattr with the ATTR4_XATTR option 
in the fsal_SUPPORTED_ATTRIBUTES it will get the getxattrs, setxattrs,... 
xattr operation. Most of the logic is in the 39a5ef370d path.

The NFS client side was prototyped by Manoj and it was tested against the 
Ganesha/GPFS implementation. I will send it to you on a separate email but 
it is old and the Linux kernel had big changes since.

Marc.

From:   Victor A Asencio Casiano <[email-masked]>
To:     Marc Eshel <[email-masked]>
Cc:     David Noveck <[email-masked]>, [email-masked], NFSv4 
<[email-masked]>, nfsv4 <[email-masked]>, [email-masked]
Date:   08/15/2019 09:14 AM
Subject:        [EXTERNAL] Re: [nfsv4] Extended Attributes NFSv4

Hi Marc, can you give more details of how this is implemented/works on 
Ganesha, and if the current 2.8 version support it? The client prototype 
is in a public domain ? 

Thank you all for the replies and help. 

On Fri, Aug 2, 2019, 12:49 PM Marc Eshel <[email-masked]> wrote:
There is an implementation in NFS Ganesha for the server side, and a 
prototype for the NFS Linux client side.
Marc.

Tha  

./Sorin

[EXTERNAL EMAIL] 

Thanks for your help.

---

From: Victor A Asencio Casiano <[email-masked]>
Date: Thu, 15 Aug 2019 12:13:18 -0400

Hi Marc, can you give more details of how this is implemented/works on
Ganesha, and if the current 2.8 version support it? The client prototype is
in a public domain ?