Subject: [Nfvrg] RG adoption of draft-lee-nfvrg-resource-management-service-chain

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Fri, 10 Apr 2015 12:03:39 +0000

Hi,

This message is to open a two-week adoption call for draft-lee-nfvrg-resource-management-service-chain.

Please indicate in your comments “support” or “no support” and discuss how this draft will contribute to a better understanding of the application of SFC principles to NFV, as well as probable feedback to the SFC WG.

The current draft is available at:

http://datatracker.ietf.org/doc/draft-lee-nfvrg-resource-management-service-chain/

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Sumandra Majee <[email-masked]>
Date: Fri, 10 Apr 2015 19:12:28 +0000

To the Authors,

So what is this draft is proposing?
  A) SFC control plane should use resource attributes when selecting a specific service graph?
  B) Scheduling of VNF on an infrastructure given the resource constraints of all VNFs?  Yes it is an important issue for increased utilization.

If it is A) then I don't view fault detection and and mitigation strictly as resource management issue. I don't think SFC control plane is the right place for VNF scheduling.

Cheers

Sumandra

From: DIEGO LOPEZ GARCIA <[email-masked]<mailto:[email-masked]>>
Date: Friday, April 10, 2015 at 7:03 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Nfvrg] RG adoption of draft-lee-nfvrg-resource-management-service-chain

Hi,

Please indicate in your comments "support" or "no support" and discuss how this draft will contribute to a better understanding of the application of SFC principles to NFV, as well as probable feedback to the SFC WG.

Be goode,

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

---

From: 이승익 <[email-masked]>
Date: Sat, 11 Apr 2015 17:53:03 +0000

Sumandra,

Thanks for the comment.

The focus of the draft is more about A) at this moment but I don’t think B) is beyond the subject of the draft.

Main idea of the draft is to address NFV resource management issues by scheduling the resources when creating NFPs (or SFPs).
Here I can provide different words about what you figured out regarding approaches to resource scheduling for NFPs:

- A) selecting the existing VNF instances to form a NFP considering their resource constraints: Since the VNF instances and the underlying resources may be shared by different NFPs, how to select NFV resources (i.e., VNF instances and virtual links) for NFPs matters to global scheduling of NFV resources.  
- B) scaling/instantiating/placing VNFs to form a NFP considering their resource constraints

A) is our initial focal point of the draft but we’re still under study on B).
And we’re also preparing an input to SFC WG based on the study on A) for SFC control plane, but B) is beyond the scope of SFC as you mentioned. 

Let me improve the draft if it misleads or does not mention enough the rationale described above. 
Any suggestions are welcomed and appreciated.

Regards,
Seungik.

> 2015. 4. 11., 오전 4:12, Sumandra Majee <[email-masked]> 작성:
> 
> To the Authors,
> 
> If it is A) then I don’t view fault detection and and mitigation strictly as resource management issue. I don’t think SFC control plane is the right place for VNF scheduling.
> 
> Cheers
> 
> Sumandra
>   
> 
> From: DIEGO LOPEZ GARCIA <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> _______________________________________________
> Nfvrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nfvrg

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Wed, 15 Apr 2015 15:31:31 +0000

Hi,

This is a reminder of the open two-week adoption call for draft-lee-nfvrg-resource-management-service-chain. The feedback received so far was focused on commenting the contents of the current draft (what is extremely useful) but we need that you indicate explicitly your “support” or “no support”, and your view on how this draft will contribute to a better understanding of the application of SFC principles to NFV, as well as probable feedback to the SFC WG.

Be goode,

Dr Diego R. Lopez
Telefonica I+D

---

From: "Browne, Rory" <[email-masked]>
Date: Thu, 16 Apr 2015 08:43:24 +0000

We support this draft and feel that resource signaling into SFC will have multiple use cases

BR Rory

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Wednesday, April 15, 2015 4:32 PM
To: [email-masked]
Subject: [Nfvrg] Reminder of the RG adoption of draft-lee-nfvrg-resource-management-service-chain

Hi,

This is a reminder of the open two-week adoption call for draft-lee-nfvrg-resource-management-service-chain. The feedback received so far was focused on commenting the contents of the current draft (what is extremely useful) but we need that you indicate explicitly your "support" or "no support", and your view on how this draft will contribute to a better understanding of the application of SFC principles to NFV, as well as probable feedback to the SFC WG.

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
--------------------------------------------------------------
Intel Shannon Limited
Registered in Ireland
Registered Office: Collinstown Industrial Park, Leixlip, County Kildare
Registered Number: 308263
Business address: Dromore House, East Park, Shannon, Co. Clare

This e-mail and any attachments may contain confidential material for the sole use of the intended recipient(s). Any review or distribution by others is strictly prohibited. If you are not the intended recipient, please contact the sender and delete all copies.

---

From: <[email-masked]>
Date: Thu, 16 Apr 2015 09:13:30 +0000

I'm confused about the terminology used in this document.

"Using these virtualized network functions (VNFs), the network service can be    described by a service chain (or VNF forwarding graph; VNF-FG) which defines an ordered sequence of VNFs for the composed service.  The VNF-FG can be instantiated by creating or selecting VNF instances and virtual links (VLs) among them, which results in a network forwarding path (NFP)."

The above text does not seem consistent with the ETSI NFV framework. According to the ETSI NFV Framework specifications, a VNF-FG has two facets: a network connectivity topology (NCT) and one or more network forwarding paths (NFP) that are built on top of the NCT.  The concept of ordered sequence does not exist at the NCT level and only appears at the NFP level. Moreover, NFPs exist before instantiation of the Network Service or VNF-FG, as soon as the VNF-FG descriptor is on-boarded.

I would suggest the following alternative wording:

"Using these virtualized network functions (VNFs), one or more VNF forwarding graph (VNF-FG) can be associated to the network service, each of which describes a network connectivity topology, by referencing VNFs and Virtual Links that connect them. One or more network forwarding paths (NFPs) can be built on top of such a topology, each defining an ordered sequence of VNFs and Virtual Links to be traversed by traffic flows matching certain criteria.

Bruno

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Wednesday, April 15, 2015 4:32 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Nfvrg] Reminder of the RG adoption of draft-lee-nfvrg-resource-management-service-chain

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: 이승익 <[email-masked]>
Date: Fri, 17 Apr 2015 02:50:02 +0000

Bruno,

Thank you so much for the suggestion. Your suggestion looks quite clearer to me.
Let me revise the draft based on it and try to have the draft text more consistent with the ETSI NFV framework.

Looking forward to having your further comments.

Regards,
Seungik.

From: Nfvrg [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, April 16, 2015 6:14 PM
To: Browne, Rory; DIEGO LOPEZ GARCIA; [email-masked]
Subject: Re: [Nfvrg] Reminder of the RG adoption of draft-lee-nfvrg-resource-management-service-chain

I’m confused about the terminology used in this document.

“Using these virtualized network functions (VNFs), the network service can be    described by a service chain (or VNF forwarding graph; VNF-FG) which defines an ordered sequence of VNFs for the composed service.  The VNF-FG can be instantiated by creating or selecting VNF instances and virtual links (VLs) among them, which results in a network forwarding path (NFP).”

“Using these virtualized network functions (VNFs), one or more VNF forwarding graph (VNF-FG) can be associated to the network service, each of which describes a network connectivity topology, by referencing VNFs and Virtual Links that connect them. One or more network forwarding paths (NFPs) can be built on top of such a topology, each defining an ordered sequence of VNFs and Virtual Links to be traversed by traffic flows matching certain criteria.

Bruno

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Thank you.

---

From: <[email-masked]>
Date: Tue, 21 Apr 2015 16:34:28 +0000

With these changes I support this draft going forward as means to study requirements and solutions for dynamic updates of NFV Forwarding Graphs and NFPs, in the context of dynamic service function chaining.
BC

De : 이승익 [mailto:[email-masked]]
Envoyé : vendredi 17 avril 2015 04:50
À : CHATRAS Bruno IMT/OLN
Cc : Browne, Rory; DIEGO LOPEZ GARCIA; [email-masked]
Objet : RE: Reminder of the RG adoption of draft-lee-nfvrg-resource-management-service-chain

Bruno,

Regards,
Seungik.

From: Nfvrg [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Thursday, April 16, 2015 6:14 PM
To: Browne, Rory; DIEGO LOPEZ GARCIA; [email-masked]<mailto:[email-masked]>
Subject: Re: [Nfvrg] Reminder of the RG adoption of draft-lee-nfvrg-resource-management-service-chain

Bruno

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Thank you.