Subject: Re: [Nfvrg] [Fwd: I-D Action: draft-irtf-nfvrg-gaps-network-virtualization-01.txt]

From: "Saumya Dikshit (sadikshi)" <[email-masked]>
Date: Wed, 28 Sep 2016 07:49:40 +0000

Dear Carlos,

Apology for the late response.
Please find inline the proposed text and feel free to edit to align it
with 
the existing content.

Thanks,
Saumya.

On 7/25/16, 2:21 PM, "Carlos Jesús Bernardos Cano" <[email-masked]> wrote:

>Hi Saumya,
>
>Thanks. Please see inline below.
>
>On Thu, 2016-07-21 at 20:05 +0000, Saumya Dikshit (sadikshi) wrote:
>> Hi Carlos,
>> 
>> Thanks for the response. Please see inline
>> 
>> On 7/21/16, 3:11 PM, "Carlos Jesús Bernardos Cano" <[email-masked]>
>> wrote:
>> 
>> > 
>> > Dear Saumya,
>> > 
>> > Thanks for your comments. Please see some first comments/questions
>> > inm
>> > line below.
>> > 
>> > On Mon, 2016-07-18 at 08:50 +0000, Saumya Dikshit (sadikshi) wrote:
>> > > 
>> > > Hello Authors,
>> > > 
>> > > Informative presentation in ietf-96 !!!
>> > > 
>> > > Apology if this been asked/resolved earlier in the mailing list:
>> > > Couple of  queries
>> > > 1. about NFV requirements for for serviceability across overlay-
>> > > underlay
>> > > deployment, wherein error-detection/handling/recovery from
>> > > underlays
>> > > to be
>> > > made opaque and not transparent to ensure faster serviceability
>> > > of
>> > > network.
>> > I'm not sure I got this comment right. Can you please elaborate it
>> > a
>> > bit more?
>> <Saumya> my statement is in context of datacenter network.
>> Since NFV¹s may mostly find themselves on the server (client) side of
>> a
>> data-center network,
>> Which typically consists of Vxlan like Overlays on top of an IP/Ipv6
>> underlay. Both underlay and overlay
>> can potentially fall under different operator domains. Hence for
>> faster
>> serviceability it¹s required to
>> gather information from all hierarchy of networks(overlay(s) and
>> underlay.
>> I suggest that it;s worth mentioning
>> explicitly as an NFV requirement and if required run it through other
>> groups like NVO3 and rtgwg for firming up.
>
>[Carlos] OK, I see now. I agree this is worth being mentioned. We'll
>add something in the next revision of the draft.
[Saumya] The following text can be inserted after third paragraph in
Section 4.6.  Service Composition:
"The service composition SHOULD also act as an enabler to gather
information across all hierarchies (underlays and overlays) of network
deployments which may span across multiple operators, for faster
serviceablity thus facilitating in accomplishing aforementioned goals of
'load
   balancing and improve reliability’”.
>
>> > 
>> > 
>> > > 
>> > > 2. Any specific use-case, wherein, you want it to be made NON-
>> > > agnostic to
>> > > routing extensions like BGP-EVPN or specific requirements to
>> > > integrated it
>> > > to BGP-EVPN extensions.
>> > So far no. Do you have anything in mind?
>> <Saumya> The answer is to inculcate Network as service elements in
>> NFV.
>> And as I mentioned in the above bullet, need of the hour for these
>> elements to function robustly is to gather information as much
>> information
>> possible about end-to-end network.
>
>[Carlos] OK, we'll also add something in the next version of the draft.
>If you have specific text suggestions for this or the above, those will
>be very welcome.
[Saumya] Following text can be added in Section 4.4.  Multiple Domains:
“For specific use case of ’Network as a Service’, it becomes even more
important
to ensure, that Cross Domain Orchestration also takes care of hierarchy of
networks and their
association, with respect to provisioning tunnels and overlays."
>
>Thanks,
>
>Carlos
>
>> > 
>> > 
>> > Thanks,
>> > 
>> > Carlos
>> > 
>> > > 
>> > > 
>> > > 
>> > > Thanks
>> > > Saumya.
>> > > 
>> > > On 7/8/16, 6:54 PM, "Nfvrg on behalf of Carlos Jesús Bernardos
>> > > Cano"
>> > > <[email-masked] on behalf of [email-masked]> wrote:
>> > > 
>> > > > 
>> > > > 
>> > > > Hi,
>> > > > 
>> > > > We have just updated our draft. We have performed significant
>> > > > changes
>> > > > to adapt the content as we discussed in the past meetings and
>> > > > make
>> > > > it
>> > > > more "challenges and gap oriented", instead of organizing the
>> > > > content
>> > > > along the WGs.
>> > > > 
>> > > > We plan to continue adding challenges and relating them to the
>> > > > work
>> > > > that might be done in IETF/IRTF. We believe this structure adds
>> > > > value
>> > > > to the draft.
>> > > > 
>> > > > Comments are welcome,
>> > > > 
>> > > > Carlos (on behalf of all the authors of the draft)

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Wed, 28 Sep 2016 11:57:45 +0200

Dear Saumya,

Thanks a lot for your proposed text!

Kind Regards,

Carlos