Subject: [NGO] NEE Agenda at IETF 69

From: "Sharon Chisholm" <[email-masked]>
Date: Tue, 19 Jun 2007 13:12:59 -0400

Hi

The Nee BOF (Netconf Extensions and Evolution) currently has two hours
scheduled. I've spoken with a number of you offline about work you have
done which fits into the proposed agenda, but I'd like to make a more
open request for people to send me requests for a spot on the agenda.
Note that Dave Partain has agreed to co-chair the BOF with me.

Just as a reminder, this is the description I included in the BOF
request:

"The NETCONF working group has successfully defined an effective and
functional protocol, but there still remain some gaps in required
functionality. This BOF will look at necessary extensions to the NETCONF
protocol with the aim to charter a working group to address them.
Extensions will focus on generally agreed to functionality that has just
not yet been defined such as fine grain locking, advertising XML Schema
(content) support, access control, etc. It will also include an XML
Schema (content) definition to enable monitoring of the Netconf
protocol. Note that the charter does not wish to dictate which Netconf
layer problems should be solved at (content, operations, etc)."

Sharon Chisholm
Nortel 
Ottawa, Ontario
Canada

_______________________________________________
NGO mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ngo

---

From: Phil Shafer <[email-masked]>
Date: Tue, 19 Jun 2007 13:58:52 -0400

"Sharon Chisholm" writes:
>functionality.

Dumb ietf question: if this is netconf-related work, why not mung
the charter of the existing working group?  Or is that what the BOF
will decide?

>Note that the charter does not wish to dictate which Netconf

Will the list of problems need to be articulated before this becomes
(or adds to) a working group?

Thanks,
 Phil

---

From: "Sharon Chisholm" <[email-masked]>
Date: Tue, 19 Jun 2007 14:21:47 -0400

Hi

Doing this work in the existing working group is technically an option
that hasn't been ruled out. Historically the IETF prefers at some point
to shut down the original working group and charter a new one for
extensions since it triggers to the outside world that the base
technology is ready for general adoption. Either way, having the
discussions in a BOF allows us to explore different options for
executing.

I have been tasked to come up with a formal charter proposal for the
working group which would be discussed at the BOF. I expect it to
include a very specific list of tasks, which in theory could be expanded
at later date if we successfully deliver on the initial set. 

Sharon

-----Original Message-----
From: Phil Shafer [mailto:[email-masked]] 
Sent: Tuesday, June 19, 2007 1:59 PM
To: Chisholm, Sharon (CAR:ZZ00)
Cc: [email-masked]
Subject: Re: [NGO] NEE Agenda at IETF 69

>functional protocol, but there still remain some gaps in required 

Dumb ietf question: if this is netconf-related work, why not mung the
charter of the existing working group?  Or is that what the BOF will
decide?

>Note that the charter does not wish to dictate which Netconf layer 
>problems should be solved at (content, operations, etc)."

Will the list of problems need to be articulated before this becomes (or
adds to) a working group?

Thanks,
 Phil

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 20 Jun 2007 09:35:44 +0200

Sharon, David,

Could you please add
http://www.ietf.org/internet-drafts/draft-badra-tls-netconf-03.txt to
the agenda of the NEE BOF so that it can be discussed together with the
other proposals for NETCONF extensions, and the community can provide
feedback about its priority in the context of other work that needs to
be done. 

Thanks and Regards,

Dan

> From: Sharon Chisholm [mailto:[email-masked]] 
> Sent: Tuesday, June 19, 2007 8:13 PM
> To: [email-masked]
> Subject: [NGO] NEE Agenda at IETF 69
> 
> Hi
> 
> The Nee BOF (Netconf Extensions and Evolution) currently has 
> two hours scheduled. I've spoken with a number of you offline 
> about work you have done which fits into the proposed agenda, 
> but I'd like to make a more open request for people to send 
> me requests for a spot on the agenda.
> "The NETCONF working group has successfully defined an 
> effective and functional protocol, but there still remain 
> some gaps in required functionality. This BOF will look at 
> necessary extensions to the NETCONF protocol with the aim to 
> charter a working group to address them.
> Extensions will focus on generally agreed to functionality 
> that has just not yet been defined such as fine grain 
> locking, advertising XML Schema
> (content) support, access control, etc. It will also include 
> an XML Schema (content) definition to enable monitoring of 
> the Netconf protocol. Note that the charter does not wish to 
> dictate which Netconf layer problems should be solved at 
> (content, operations, etc)."
> 
> Sharon Chisholm
> Nortel
> Ottawa, Ontario
> Canada
>

---

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 20 Jun 2007 08:53:09 -0700

Hi,

Plea for simplicity - creating progressively more
mailing lists for NetConf related work just makes
it harder to follow.  Keeping all of the NetConf
discussions forever on a single mailing list (even
if successor IETF working groups are chartered)
would make monitoring and participation much easier.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-----Original Message-----
From: Sharon Chisholm [mailto:[email-masked]]
Sent: Tuesday, June 19, 2007 1:22 PM
To: Phil Shafer
Cc: [email-masked]
Subject: RE: [NGO] NEE Agenda at IETF 69

Hi

Sharon

-----Original Message-----
From: Phil Shafer [mailto:[email-masked]] 
Sent: Tuesday, June 19, 2007 1:59 PM
To: Chisholm, Sharon (CAR:ZZ00)
Cc: [email-masked]
Subject: Re: [NGO] NEE Agenda at IETF 69

Thanks,
 Phil

No virus found in this outgoing message.
Checked by AVG Free Edition. 
Version: 7.5.472 / Virus Database: 269.9.1/854 - Release Date: 6/19/2007 1:12 PM