Subject: [NNTP] Re: nntp and rfc 3977

From: "Clive D.W. Feather" <[email-masked]>
Date: Fri, 20 Jun 2008 14:27:41 +0100

I've just received this message. I've suggested to Nathan that he subscribe
to the list.

----- Forwarded message from nathan wagner <[email-masked]> -----

From: nathan wagner <[email-masked]>
To: [email-masked]
Date: Fri, 20 Jun 2008 00:14:58 -0500
Subject: nntp and rfc 3977
User-Agent: Thunderbird 2.0.0.14 (Macintosh/20080421)
X-CNFS-Analysis: v=1.0 c=1 a=oJe5nrretZYsIjrd2poaDw==:17 a=BacyRZpF28Vy_dmUlyUA:9 a=Pi6a-WNfgP7BF9e0a2bqa-N5yu4A:4 a=gi0PWCVxevcA:10

I wanted to run a news server again, but the thought
of configuring INN again made my teeth itch.  So I
wrote my own server, using 3977 as my guide.  I think
it conforms, though I haven't gone over it with
a comb checking against all the "MUST"s in the rfc.

At any rate, 3977 is currently a proposed standard.
It would be nice to get that moving along to draft
status and further.  If nothing else, I would have
a bigger club to wield against the slrn maintainer.

Since multiple implementations are wanted to move
from proposed to draft, I thought I should let someone
know that I have a completely independent implementation
of 3977.  Where to go from here?

As a complete aside, I have some ideas on automatic
feed management, which shouldn't need too many
changes in the protocol, and none that would be
incompatible with it as it stands.

-- 
nathan wagner
[email-masked]

----- End forwarded message -----

-- 
Clive D.W. Feather  | Work:  <[email-masked]>   | Tel:    +44 20 8495 6138
Internet Expert     | Home:  <[email-masked]>  | Fax:    +44 870 051 9937
Demon Internet      | WWW: http://www.davros.org | Mobile: +44 7973 377646
THUS plc            |                            |

---

From: Ade Lovett <[email-masked]>
Date: Sun, 22 Jun 2008 18:58:26 -0700

> I've just received this message. I've suggested to Nathan that he  

With all due respect to the INN and diablo folks, I certainly think  
the time has come to consider a new 3977-specific reference  
implementation, with the emphasis being the protocol, rather than  
tuned for optimal performance under insane workloads.

I believe this would serve two purposes:

1.  The "proving" of the protocol itself
2.  Providing a straightforward package which newsreader authors can  
test against, ensuring correct client-server interaction.

Thoughts?

-aDe