Subject: [Nsis-imp] some problems with NSIS_0.3.0

From: "廖佩贞" <[email-masked]>
Date: Mon, 29 May 2006 18:48:10 +0800

Hi all,
     I am a student of Beijing University of Post and
Telecommunication.Ihave followed the technology of NSIS discussed in
this maillist for a long
time.Now there's some problems in the software platform named NSIS_0.3.0.
1.When we tested the QoS-NSLP using the command "# bin/qos_server" "#
bin/qos_client",it can't establish a successful connection.We can't get any
message from the screen except some information parsed the command .Is there
anyone who have tested the QOS-NSLP? No problem? I wonder if there's any
mistakes in the soude code?
2.Will there be any improvements in the software ,and a new version that
implement some QoSMs?

Thanks very much!

liaopeizhen
_______________________________________________
NSIS-imp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis-imp

---

From: Bernd Schloer <[email-masked]>
Date: Mon, 29 May 2006 21:37:29 +0200

Hi Liaopeizhen,

1. refer to the documentation in ./manual
2. change the configuration (bin/nsis.conf) according to your IP-addresses
    for example:
    Qni: 10.10.1.1/16
    Qne: 10.10.1.2/24 and 10.10.2.1/24
    Qnr: 10.10.2.2/16
3. activate forwarding on the Qne:
    echo "1"> /proc/sys/net/ipv4/ip_forward
4. run as root the NSIS daemon on all nodes (e.g. Qni, Qne, Qnr) using
    # bin/nsis
5. start the qos_server in a second console on all nodes
    # bin/qos_server
6. run the qos-client on one node, which is your Qni, in a third console
    # bin/qos_client MESSAGETYPE DEST-IP FLAGS GENERICFLAGS [OBJ1] [OBJ2]...

    MESSAGETYPE: RESERVE, QUERY, TEARDOWN, NOTIFY
    DEST-IP: enter the IP-address of your destination (Qnr)
    FLAGS and GENERICFLAGS: Message type dependent according to the QoS-NSLP
    draft. E.g. FLAGS = 2: set ACK Flag, FLAGS = 4: set TEAR Flag.
    OBJ: RII, REP, BSI, POD

    example to make a reservation:
    # bin/qos_client RESERVE <DEST-IP> 2 0 RII

    to tear down the session:
    # bin/qos_client RESERVE <DEST-IP> 4 0

If there are still problems please send me the console output.

Version 0.3.0 hasn't support for all objects and message types. Also mendatory
objects are not checked if they're present. Version 0.4.0 has improvements in
message handling, message processing and timer handling. There's also IPv6 and
basic QSPEC objects support, but so far no QOSMs. We have scheduled the release
of version 0.4.0 for this week.

Bernd

ÁÎÅåÕê wrote:
> ------------------------------------------------------------------------
>