Subject: RE: [NSIS] requirements

From: "Greis Marc (NRC/Dallas)" <[email-masked]>
Date: Fri, 7 Dec 2001 14:05:53 -0600

Hi Mike,

> In fact, I think that an accounting of the current
> set of affairs is pretty much a prerequisite to
> requirements, which seems to be item two in the
> charter (analysis). This seems backward to me.  Ie
> the question should start with "what's wrong" and
> be followed up with "what are the common
> problems and missing requirements".

I agree with your point to some extent, but I would think that first you
need to know the requirements, i.e. what you actually want to achieve,
before you can move to the "what's wrong" discussion. Something that may
look totally wrong to someone in e.g. RSVP may be perfectly ok and
acceptable to someone else, if they don't agree on the requirements. 

That's why I think we should first come up with a set of requirements to
determine what we actually want to get out of this working group, and
then we use these requirements to perform the "what's wrong/what's
right" analysis on existing protocols.

Marc

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Michael Thomas <[email-masked]>
Date: Fri, 7 Dec 2001 12:27:02 -0800 (PST)

> right" analysis on existing protocols.

I guess I'm just taking a pragmatic view of this:
by analogy if we wanted to make my Ford Exploder
go 150Mph, I don't think we'd really need to start
gathering requirement from the ground up, like
say, whether wheels were needed. OTOH, if we were
trying to make my Exploder suitable for a trip to
the moon, I think that that exercise would be very
valuable. My impression is that we are far more
likely to be in the first problem space rather
than the second. That seems to be reflected in the
charter since this WG seems to be chartered as
more of a fact gathering mission about the current
state of affairs, rather than a ground up
design/new protocols/etc.

	  Mike