Subject: RE: Definition of QI was: Re: [NSIS] WG requirements draft

From: "Geib, Ruediger" <[email-masked]>
Date: Wed, 27 Feb 2002 09:16:09 +0100

Roland,

I agree with your view completely. Let's go on with the requirements and stop a discussion of architectures. That's part of the solutions.

A requirement may be that in some cases a "QC" may act as "QI": An edge to edge QoS tunnel set up (maybe even spanning several domains). This would allow the tunnel entry point QC to do per flow edge to edge admission control once the QI requests service for the tunnel destination domain. To me this is the simplest and therefore most desireable way of per service reservation aggregation.

Regards, Rüdiger 

> Hi all,
> 
> I think we can solve this issue by not complicating the role model. 
> It is also mentioned in section 4.1 of the nsis-req draft that QoS
> Controllers interact with other QoS Controllers (as I understood). 
> Therefore, there is signaling between different QCs. I don't think 
> that we should complicate the model by explicitly defining every QC 
> also as QI, although the QC initiates a further signaling transaction 
> with another QC. I also don't think that the terms QC and QI are not 
> generic enough to also cover a distributed approach. For a more 
> complete model my suggestion (we add also a QoS Responder):
> 
>           Domain A             Domain B
>         .......................      .......................
>         .                     .      .                     .
> QI <--> . QC <==> ... <==> QC . <==> . QC <==> ... <==> QC . <--> QR
>         .......................      .......................
>      a)       b)                  c)                           a)
> 
> 1.) The QI can be an end system or signaling proxy acting on
>     behalf of an end system. 
> 2.) There can be several QoS Controllers involved in signaling. 
>     Some of the QCs may be located within one administrative
>     domain (allowing the distributed case where each router 
>     or each edge router or several BBs are involved within
>     such a domain) whereas others are located within different
>     domains. 
> 3.) Finally, we should add the QoS Responder (QR) in order to have 
>     a "symmetric" model where the corresponding end system
>     can be also involved in signaling (e.g., to let a mobile terminal 
>     decide about the priority of requests due to scarce bandwidth).
>     As with the QI the QR could be also a signaling proxy. 
>     Alternatively, the QC can act as proxy.
> 
> I think that this model covers all the different signaling cases:
> a) end <-> edge/network
> b) network internal, also covering edge to edge (intra-domain)
> c) network <-> network (inter-domain)
> and considering the whole signaling scenario by combining
> the parts
> d) end to end (QI <--> QR indirectly via a)b)c), not at 
> application level)
> 
> Won't this fit most use cases?
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Muhammad Jaseemuddin <[email-masked]>
Date: Wed, 27 Feb 2002 13:58:16 -0500

Ruediger:

 I agree that the requirement should also consider the case where QC may 
act as QI. I am not sure if I understood the example you gave. But, I 
know for example in GPRS there is a network initiated PDP context 
activation procedure, where the GGSN (QC) requests MS (QI) to initiate 
the PDP context activation procedure. This is a genuine case because a 
QC (e.g. GGSN or a an edge router) may receive packets for delivery to 
the hosts (normally a QI) for which QoS needs to be setup along the 
path. In this case essentially QI remains the actual initiaor, but it 
initiates at the request of QC.

Cheers,
- Muhammad Jaseemuddin

-- 
==================================================
Muhammad Jaseemuddin
Associate Professor
Departement of Electrical and Computer Engineering
Ryerson University
350 Victoria Street
Toronto, ON M5B 2K3
Tel: +1 416 979-5000x6073
Fax: +1 416 979-5280
Email: [email-masked]
Web: http://www.ee.ryerson.ca/~jaseem
==================================================