Subject: RE: Definition of QI was: Re: [NSIS] WG requirements draft

From: "Geib, Ruediger" <[email-masked]>
Date: Thu, 28 Feb 2002 13:23:04 +0100

Hi Roland,

I don't know details of the DARIS approach. I agree to all of your statements which may be understood without assuming knowledge of the DARIS approach (i.e. "reservation aggregate" instead of "tunnel", hierachical stacking of reservation aggregates which means nested aggregates).

Regards, Rüdiger

Rolands comments were:
.....
> I prefer the term reservation aggregate, because "tunnel" is 
> often associated with encapsulation of packets in packets.
> I know that the Q-Bone approach used this term.
.....
> I think this is a very good point according to scalability. 
> Hence, in my view the nsis protocol should allow to set up
> and manage reservation aggregates. The DARIS approach is
> a bit more general, because it also supports full
> hierachical aggregation of reservations between arbitrary
> domains. Therefore, the "fat pipes" are not restricted to reach from
> Edge network to Edge network: every domain can decide by itself to set
> up an aggregate to any other domain, and, aggregates can be nested.
..... 
> Moreover, I designed a signaling protocol that allows more efficient
> aggregation management (saving more than one RTT in delay, 
> for instance in case the aggregate capacity has to be changed).
..... 
> Yes, but not limited to pipes reaching from edge to edge network.

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Roland Bless <[email-masked]>
Date: Thu, 28 Feb 2002 13:58:56 +0100

Hi Ruediger,

> I don't know details of the DARIS approach. I agree to all of your
> statements which may be understood without assuming knowledge of the
> DARIS approach (i.e. "reservation aggregate" instead of "tunnel",
> hierachical stacking of reservation aggregates which means nested
> aggregates).

Yes, that was my intention. It is not required to know details
of the approach now. The basic principle is just to let QCs decide
when to aggregate and where the aggregate should end. It allows
nearly arbitrary nestings of aggregates (in principle, there is
a conflict case, but this case is manageable) and to integrate reservations
into new or existing aggregates as well as to shift them between aggregates.
Finally, the signaling protocol supports some kind of parallelism that
can be used to speed up signaling as mentioned earlier.

Regards,
 Roland

-- 
Roland Bless -- e-Mail: [email-masked]
Institute of Telematics, University of Karlsruhe, Germany  
Zirkel 2, D-76128 Karlsruhe -- Office: Bld. 20.20, 3rd floor, R 358
Phone: +49 721 608-6413 Fax: +49 721 388097