Subject: RE: [NSIS] What is the goal of the analysis draft?

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Thu, 5 Dec 2002 14:53:11 +0100

Hi Melinda

You are of course right when saying that the "when applicable" 
term has to be specified somewhere! 

Regarding the difference between "must support message aggregation" and 
"when applicable must support message aggregation?"
in my opinion, can be solved, by requiring a "should" in place of a "must". Thus 
the scalability requirements can be enlarged with sentences such as:
"should support state aggregation", 
"should support message aggregation", etc.
Is this acceptable to you?

Best Regards,
Georgios

-----Original Message-----
From: Melinda Shore [mailto:[email-masked]]
Sent: donderdag 5 december 2002 14:44
To: Georgios Karagiannis (ELN)
Cc: [email-masked]
Subject: Re: [NSIS] What is the goal of the analysis draft? 

> Regarding the scalability term I see your point!
> Maybe we could enlarge the scalability requirements 
> with sentences, such as:
> "when applicable must support state aggregation", 
> "when applicable must support message aggregation", etc.
> Is this acceptable to you?

I like to see crisp requirements - ones that really will be
helpful to the protocol design/selection process - and I
think that if we're going to use phrases like "when
applicable" we need to add some text (in framework or
requirements) stating what "when applicable" means.  I also
like to think about what happens if you leave the
requirement out, or what happens if you leave the mitigating
words out.  So, what's the *real* difference between "must
support message aggregation" and "when applicable must
support message aggregation?"

> Regarding section 5.5.5, I think that it emphasizes 
> the need on achieving high network utilization and therefore,
> it makes sense to have such a requirement.

I'm unconvinced those are real requirements, but will defer
to the will of the group on that.

Melinda
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Marcus Brunner <[email-masked]>
Date: Wed, 11 Dec 2002 18:02:27 +0100

IMHO state aggregation is already a solution to a problem. And I definitly 
don't want to prescribe a solution with that type of requirements draft. 
Anothger solution could be avoid state instead of aggregate it.

Marcus

--On Donnerstag, 5. Dezember 2002 14:53 +0100 "Georgios Karagiannis (ELN)" 
<[email-masked]> wrote:

> in my opinion, can be solved, by requiring a "should" in place of a
> "must". Thus  the scalability requirements can be enlarged with sentences
> such as: "should support state aggregation",

--------------------------------------
Dr. Marcus Brunner
Network Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
Phone: +49 (0) 6221 905 11 29
personal home page: http://www.brubers.org/marcus