Subject: RE: [NSIS] Updated milestones

From: [email-masked]
Date: Fri, 13 Dec 2002 15:14:58 +0100

John, 

not sure if you sent out draft of the charter before, in that case I apologize for the late reply. Otherwise, concerning: 

DEC 03    If criteria were met, submit 'Next Step QoS Signaling' as a standards track RFC  

Does this mean that a protocol should be designed (/revised design of RSVP) until dec-03 or an architect or what? The goal/milestone were a bit vague about what "Next Step QoS Signaling" refers to. 

Furthermore, there are two wg id's (Threats, Security properties) that does not have an associated goal/milestone. Not that I am fully up-to-date with NSIS activities, but is the intention to move this to informational or merge them with framework/analysis document? If the intention is to move them to informational then they should go into goal/milestone, otherwise, should they still be a wg item? 

Best regards,

Anders

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: den 13 december 2002 14:58
> To: [email-masked]
> Subject: [NSIS] Updated milestones
> 
> 
> Hi all,
> 
> I've updated the milestones for NSIS. They can be viewed here:
> 
> http://www.ietf.org/html.charters/nsis-charter.html
> 
> These milestones are still with the old charter.  My intention
> is that we work towards these goals at present.
> 
> best regards,
> John
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: [email-masked]
Date: Fri, 13 Dec 2002 16:23:51 +0200

Hi Anders,

> not sure if you sent out draft of the charter before, in that 
> case I apologize for the late reply. Otherwise, concerning: 
> 
> Does this mean that a protocol should be designed (/revised 
> design of RSVP) until dec-03 or an architect or what? The 
> goal/milestone were a bit vague about what "Next Step QoS 
> Signaling" refers to. 

This work would be the protocol work, based on RSVP - a
RSVPv2, so to speak.  So, working with the existing charter,
the plan is to try to get an initial draft out by March.

> Furthermore, there are two wg id's (Threats, Security 
> properties) that does not have an associated goal/milestone. 
> Not that I am fully up-to-date with NSIS activities, but is 
> the intention to move this to informational or merge them 
> with framework/analysis document? If the intention is to move 
> them to informational then they should go into 
> goal/milestone, otherwise, should they still be a wg item? 

Yes, of course.  The charter is undergoing some revision as we speak.

John

---

From: "Hancock, Robert" <[email-masked]>
Date: Fri, 13 Dec 2002 15:43:11 -0000

eek! another one? (compared to the 'Done' i-d and July informational, which i assume is the one we are currently working on.)

i can't currently decide how to interpret the analysis/framework 'charter criteria' mentioned in the milestones, since the existing charter implies we are going to evaluate RSVP to see if it is up to the job (and i'm not sure how/where this is taking place), and the charter presented in Atlanta doesn't mention this 'hurdle' the same way.

so, i'm not really sure how to interpret the milestones in detail without updated charter text.

cheers,

robert h.

> From: Melinda Shore [mailto:[email-masked]]
> Sent: 13 December 2002 15:29
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [NSIS] Updated milestones 
> 
> 
> What is the second MAR 03 goal ("'Next Step QoS
> Signaling'")?  Is that a framework document?
> 
> Thanks,
> 
> Melinda

---

From: [email-masked]
Date: Sun, 15 Dec 2002 09:03:28 +0200

Hi Melinda,

> Signaling'")?  Is that a framework document?

This is an update of the original charter.  It is meant as what
is the NSIS protocol.  The current plan is to get an initial
version of the protocol document out.  I would hope it contains
initial assumptions and goals of the protocol before getting
(heavily) into the protocol mechanisms.

The plan for the WG was to work on a general requirements doc,
analysis of existing solutions & a framework in order to set
the sandbox for the protocol.  The IESG put a constraint
on us, which is we need to prove that if NSIS WG chooses
to work on something not RSVP based, we would need to have 
justification. How this is decided is based upon the chair &
ADs discussing this.

However, in my opinion, it does seem that the mechanisms which
we will use will be at least based on RSVP,  and may re-use
much of the protocol mechanisms.

John

---

From: [email-masked]
Date: Tue, 17 Dec 2002 08:41:26 +0200

Hi Robert,

> i can't currently decide how to interpret the 
> analysis/framework 'charter criteria' mentioned in the 
> milestones, since the existing charter implies we are going 
> to evaluate RSVP to see if it is up to the job (and i'm not 
> sure how/where this is taking place), and the charter 
> presented in Atlanta doesn't mention this 'hurdle' the same way.

This is something for the ADs to deterime.  They originally
wanted to ensure due-dilegence when looking at new solutions.
They wanted to make sure we don't toss RSVP into the garbage
can and do something entirely new.  My current view is that
we are not doing this, so if the ADs agree, we probably don't
need to worry about the hurdle.

John