Subject: RE: [NSIS] "split layers"

From: [email-masked]
Date: Thu, 5 Dec 2002 12:59:47 +0200

Hi Rüdiger,

> > Please note that currently, we do not have a functionality
> > split determined, so I feel trying to make requirements specifically
> > discussing a fictitious split to be wrong.  That does not mean,
> > however, that I don't think that the current set could be improved,
> > so please make some suggestions, if you have any.
> 
> You want to say that first we will determine the the functionality 
> split and then we will formulate the requirements for each 
> functionality? 

No, I am actually trying to say the reverse.  The requirements should
be general requirements.  We should handle the layer split in a 
seperate document, which then specifies the more layer-specific 
requirements.  I have thought that a document which is more prescriptive
like 'the transport layer handles message fragmentation / re-assembly'
or the 'application layer handles application state creation authorization'
would be the proper way to go.

John
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Melinda Shore <[email-masked]>
Date: Thu, 05 Dec 2002 08:47:06 -0500

> requirements.

I think I disagree with that - it's certainly not going to
speed up the process, and the layer split almost certainly
imposes its own requirements, even if its as simple as "The
protocol must support the transmission of blobs of data that
are opaque to it."

Melinda