Subject: [NSIS] attempted summary of next-peer issue (was: RE: next peer issue in rsvp-sec)

From: Michael Thomas <[email-masked]>
Date: Mon, 2 Dec 2002 15:49:11 -0800 (PST)

Hancock, Robert writes:
 > Hi Kuntal, Sven, Ping, Michael, John, Melinda, Hannes, all,
 > 
 > It seems a number of issues have got combined here. Here is an attempted summary. Let me know if I missed or confused something.
 > 
 > 1. If the originator knows the route the traffic is taking up to
the next peer, it can send the signalling message to the right place
no problem - there is *no next-peer issue* in this case. (This could
be either because the originator is doing traffic engineering, or has
complete IGP knowledge, or is telepathic, or whatever.) It can send
the signalling message with an ERO object or with what the framework
(currently) calls peer-peer addressing; in any case, there is *no
problem*.

   I think this probably just points out a previously
   un(der)solved problem: if the next peer isn't
   directly adjacent how do you know which one it
   will be? Solving for this first makes the keying
   problem tractable, I'd think. The question is what
   scale you need to solve for. The current solution
   of pre-shared keys and manually set up SA's is
   not very attractive as the mesh gets larger. 

   Also: one thing that Steve's draft should *really*
   drive home as hard as possible with the clue-by-four
   is that Key Management is an extremely large pain
   in the patochkie. Non-security working groups should
   be extremely fearful of recreating them. As in, if
   at all possible beg, borrow or steal even if it makes
   for some warts; do not assume you're smarter
   than security geeks on this front.

		  Mike
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: [email-masked]
Date: Tue, 3 Dec 2002 11:44:51 +0200

Hi Mike,

>    not very attractive as the mesh gets larger. 

Agreed.
 
>    than security geeks on this front.

Most definately agreed.  We should work on the signaling
and not work on making key distribution mechanisms.

John