Subject: RE: [NSIS] layer split summary? opinions?

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Thu, 30 Jan 2003 10:28:11 +0100

Hi Ilya

Please see my comment in line!

>> I think that such transport-layer like functions should not
>> be a part of the NTLP!
>> Such functions should be accomplished as much as possible by NSLPs.
>> NTLP should mainly support the transport layer features
>> that are at the moment supported by RSVP, while transport layer features
>> that are not supported by RSVP should not be supported by
>> the NTLP.

[Ilya] I would argue that from the strictly layer separation perspective it
is beneficial to put as much common transport functionality into NTLP as
possible and do not duplicate it in various NSLPs. 

I think that we should introduce only the necessary main common
transport functionality into NTLP.
In my opinion RSVP provides the main transport functionality 
that we need in NTLP.
Features such as segmentation, congestion
control, non duplication of signaling messages, etc.
are specific and needed for some NSLP type, 
but not for all NSLP types.

Best Regards,
Georgios

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 30 Jan 2003 08:09:19 -0500

> but not for all NSLP types.

Can you identify the types that need it and the types that don't?

Are you advocating that NSLP become a full-fledged transport protocol 
for 'some' NSLP types, essentially an application-layer TCP or SCTP?