Subject: RE: [NSIS] WG Last Call on draft-ietf-nsis-req-06.txt

From: [email-masked]
Date: Mon, 13 Jan 2003 13:41:22 +0200

Hi Rüdiger,

> | > I have a first comment on draft-ietf-nsis-req-06.txt
> | > related to Section 5.1.5.
> | > 
> | > Section 5.1.6 emphasizes that the NSIS protocol must support 
> | > independence of signaling and provisioning paradigm.
> | > If that is true I do not understand why then Section 5.1.5 
> | > emphasizes that the NSIS protocol MUST 
> | > reuse existing provisioning functions and protocols!
> | 
> | What I think is meant is that NSIS protocol SHOULD NOT define 
> | new provisioning paradigms, but try to re-use existing ones.
> 
> Only SHOULD NOT? The suggested new charter says: "It is a 
> non-goal of the working group to develop new resource allocation 
> protocols. Resource reservation and traffic engineering are out 
> of scope of this working group."
> "Should not" means that NSIS is allowed to work on provisioning 
> if that is felt to be required. Could you clarify what kind of
> work on provivioning is within scope and the relation of this to 
> the charter?

I agree with you - I meant provisioning mechanisms are currently
out of scope for NSIS.  The requirement should probably say that
the work MUST be able to re-use existing mechanisms.  See my mail
(just sent) on this topic.
 
John

> should the following be correct,
> 
> "Specification of any provisioning function is out
> of scope of the NSIS WG. Any protocols developed by
> NSIS may assume existing standard-provisioning 
> functions if information about provisioning 
> mechanisms is required for the protocol design."
> 
> 5.1.5. could be removed and the above could be inserted wherever it
> fits (a charter non goal with some explanation or a requirement).
> 
> If wording of the text I proposed may be misleading, it should be 
> improved. I hope the sense gets through. "Provisioning" my be 
> replaced by "resource allocation" and/or "TE". Or is there a 
> significant difference between provisioning and resource allocation? 
> Where is it defined?
>   
> | > NSIS is a signaling protocol and it should actually not depend 
> | > on any provisioning function or protocol. Therefore, I propose 
> | > to remove Section 5.1.5.
> | 
> | I don't think it is meant that NSIS MUST depend on a provising
> | function or paradigm.
> 
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Melinda Shore <[email-masked]>
Date: Mon, 13 Jan 2003 08:24:43 -0500

> the work MUST be able to re-use existing mechanisms.  

If it's out-of-scope, what are the consequences of just
dropping it?  If there are consequences, doesn't that imply
that it's in scope?

Melinda