Subject: RE: [NSIS] state management and the nsis framework

From: [email-masked]
Date: Wed, 14 May 2003 13:19:44 +0300

Hi Georgios,

> When we only use refresh message belonging to one of the protocol levels then
> for one signaling application the number of refresh messages needed
> can be two times smaller than the number of refresh messages that have to be
> processed when we use NTLP refresh messages to refresh the NTLP states
> and independent NSLP refresh messages to refresh the NSLP states.

At present, I don't know if we have made a determination which layer
must refresh what layer. One could imagine a light-weight NTLP which
does not require refreshign, but all is handled via NSLP refreshes
or visa-versa.

It seems that you are requesting the possibility at refreshing at
both layers, correct?

John
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Wed, 14 May 2003 12:38:22 +0200

Hi John

What I am actually saying is that  both layers should be able to provide
soft state
management. The soft state management at both layers could use refresh
messages
belonging to one of the protocol levels, e.g., NTLP. If a NTLP state is not
refreshed
in time the NSLP instance is informed about it.
Otherwise the NSLP instance assumes that the NTLP state is alive.
This is similar to the concept proposed by Bob Braden,
see:
http://www.ietf.org/internet-drafts/draft-braden-2level-signal-arch-01.txt

In this way the the number of refresh messages
that have to be processed, per signaling application,
by the NTLP/NSLP aware node is minimized.

Best regards,
Georgios