Subject: RE: [NSIS] RE: Security Threats for NSIS & RSVP Security Properties documents

From: [email-masked]
Date: Fri, 23 May 2003 06:46:28 +0300

Hi Melinda,

> I continue to think this is an excellent document, but the
> layer split issues are sometimes not completely obvious and
> at some point in the not-too-distant future we're going to
> need to have a thorough discussion of where different
> protections need to be made available, and to what extent
> security concerns should drive certain layer split
> decisions.  Also, different types of applications will have
> different threat models and different needs (for example,
> the concerns in a discovery protocol will be different from
> the concerns in a reservation protocol).  Clearly those can
> only be properly discussed in the context of the application
> protocols themselves, but at any rate I think there may be a
> need to beef out the layer split and transport layer
> discussions.

Good point - Hannes, do you think that you coul daddress this
in the update?  Melinda, if you have any specifics you think should be
added, please let Hannes know.

> But generally I think the document is ready for last call
> (although there may be some formatting issues in the
> references, formfeeds, etc).

Good.

thanks,
John
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: [email-masked]
Date: Fri, 23 May 2003 13:14:09 +0300

Hi Robert,

> I think we should see this document as logically similar to the
> requirements document, i.e. covering the NSIS problem as a whole at
> some high level, rather than trying to include all protocol design
> goals as well. Otherwise it will never be finished.

I agree, but I think that all Melinda was saying was some (hopefully
brief) comments to the affect that different parts of the
functionality, which may be related to the layer split, may
have some impact upon the security threats.  This seems
reasonable to me.

John