Subject: RE: [NSIS] state management and the nsis framework

From: "Hancock, Robert" <[email-masked]>
Date: Tue, 13 May 2003 11:45:50 +0100

john,

> > > Is it sufficient for NTLP to specify the grammer but not 
> the  management
> > > of the state machine?
> > 
> > please clarify.
> 
> Messages between the boxes vs. what the boxes do.  My 
> question is, then, is
> NTLP more about the messages & parameters between entities as 
> opposed to the
> internal states of the boxes?
> 
> John
> 

so far as what is normatively standardised, i would say absolutely the first and not the second.

so far as what is useful to include in the standard to make the first easy to understand and interpret (but only for that purpose), the second is usually pretty useful.

i think it would be a bad idea to include internal state description which is 'added value' on top of what is the minimal description needed to understand the protocol operation.

what do the NTLP designers think?

r.

ps. the situation for the NSLPs is somewhat different. but we'll get to that ...
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Melinda Shore <[email-masked]>
Date: Tue, 13 May 2003 08:09:34 -0400

> so far as what is normatively standardised, i would say
> absolutely the first and not the second.  so far as what
> is useful to include in the standard to make the first
> easy to understand and interpret (but only for that
> purpose), the second is usually pretty useful.

State machines in protocol definitions tend to be
descriptive rather than normative, as you say.  They
also tend to describe protocol state rather than "box
state."  I think much of this is clear in practice.

One thing that's struck me about some of the recent state
discussions is that in some of the comments it's not clear
what the real implications are for the protocol, and it
would be helpful to me if people could be more explicit
about what they think it means for the protocol when they
make comments about state retention, etc.

I'm in the process of finishing up a first NTLP protocol
draft, which I'll iterate with Henning.  After we come to
agreement it needs to be checked out by a couple of
reviewers, after which it will be posted to internet-
drafts.

Melinda

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Tue, 13 May 2003 14:44:45 +0200

Hi Melinda

We tried to describe the real implications for the protocol in two drafts:
http://www.ietf.org/internet-drafts/draft-westberg-proposal-for-rsvpv2-nslp-
00.txt
http://www.ietf.org/internet-drafts/draft-westberg-nsis-rsvp-as-ntlp-01.txt

Best Regards,
Georgios