Subject: RE: [NSIS] state management and the nsis framework

From: "Geib, Ruediger" <[email-masked]>
Date: Thu, 15 May 2003 11:49:14 +0200

Hello Georgios,

assume A-B to be replaced by A-C-B. You've changed 
my example in your reply and I'd prefer if you'd 
answer my original question.

Regards, Rüdiger

| -----Original Message-----
| From: Georgios Karagiannis [mailto:[email-masked]]
| Sent: Thursday, May 15, 2003 10:14 AM
| To: Geib, Rüdiger
| Cc: [email-masked]
| Subject: Re: [NSIS] state management and the nsis framework
| 
| 
| Hi Ruediger
| 
| Okay, thus you are assuming that a re-routing takes place!
| 
| But if (A) and (B) are not end nodes, and the following network
| configuration is used:
| Before re-routing:
| (D = end node) <->(E)<->(F)<->(A)<->(B)<->(G)<->(H)<->(Z= end node)
| 
| After rerouting (due to failure of link (A)<->(B)) the 
| following network
| configuration can be chosen
| by the applied dynamic routing protocol:
| 
| (D = end node) <->(E)<->(F)<->(A)<->(C)<->(I)<->(H)<->(Z= end node)
| 
| 
| Consider that  the nodes (D), (E), (F), (A), (B), (G), (H), 
| (Z) and (I) can
| support both NTLP and
| NSLP protocols. Node (C) as you already proposed supports 
| only the NTLP
| protocol and not
| the NSLP protocol.
| Due to failure of the link (A)<->(B) a re-routing takes place.
| When the path coupled signaling is used, the new re-routed 
| forwarding path
| will be (mainly)
| chosen by the applied dynamic routing protocol.
| It may happen that the new re-routed path is not at all 
| passing through node
| (B).
| This means that the old NSLP state stored  in node (B) before 
| re-routing
| will remain
| there for "ever" (if of course no other soft state management 
| solution is
| applied).
| 
| Therefore, I think that in many situations, if a re-routing 
| takes place it
| will
| affect both the NTLP and NSLP state management procedures.
| Thus not only the NTLP state management.
| 
| Best Regards,
| Georgios
| 
| 
| 
| ----- Original Message -----
| From: "Geib, Ruediger" <[email-masked]>
| To: <[email-masked]>
| Sent: Thursday, May 15, 2003 8:29 AM
| Subject: RE: [NSIS] state management and the nsis framework
| 
| 
| > Hi Georgios,
| >
| > I'm assuming it to be standard Internet architecture.
| > There's a best route between A and B. A broken link
| > results in a new best route bewteen A and B.
| >
| > Regards, Rüdiger
| >
| > | I do not completely understand the depicted scenario.
| > | Are you trying to say that there are two paths between A and
| > | B that are used
| > | simultaneously:
| > | One is the direct path A-B and the other is the path A-C-B.
| > | Considering that this is not a load sharing solution,
| > | is this scenario realistic?
| > |
| > | Best Regards,
| > | Georgios
| > |
| > |
| > | ----- Original Message -----
| > | From: "Geib, Ruediger" <[email-masked]>
| > | To: <[email-masked]>
| > | Cc: <[email-masked]>
| > | Sent: Wednesday, May 14, 2003 1:43 PM
| > | Subject: RE: [NSIS] state management and the nsis framework
| > |
| > |
| > | > Hi Georgios
| > | >
| > | > | If a NTLP state is not refreshed in time the NSLP instance
| > | > | is informed about it. Otherwise the NSLP instance
| > | > | assumes that the NTLP state is alive.
| > | >
| > | >    +---C---+
| > | >   /         \
| > | >  A-----------B
| > | >
| > | > Assume A, B, C to support NTLP, whereas the NSLP of 
| interest is only
| > | > supported by A and B. Once the link A-B is broken, the NTLP A-B
| > | > isn't refreshed while the NSLP A-B could easily maintain state
| > | > via A-C-B communication.
| > | >
| > | > How does your system react in this case? It is of no 
| importance to
| > | > the NSLP B that NTLP B lost connectivity to NTLP A.
| > | >
| > | > Regards, Rüdiger
| > | >
| > | >
| > |
| >
| 
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Thu, 15 May 2003 13:57:14 +0200

Hi Ruediger

I tried to emphasize that the network configuration example
that you used, in many situations cannot be considered as a
network configuration applied in NSIS.

Now to answer to your question.
If I would assume that the network configuration in your example is a
realistic one and that it can be considered as a generic network
configuration
used in NSIS then yes, it is of no
importance to the NSLP B that NTLP B lost connectivity to NTLP A.
But in my opinion this would be the same way of thinking if one would
assume that failures never occur in the Internet
and that soft state management procedures are not needed
at all.

Best Regards,
Georgios