Subject: [NSIS] Proxies in NSIS

From: "Thanh Tra LUU" <[email-masked]>
Date: Fri, 9 May 2003 20:33:40 +0200

Hello everyone,

I have something not very clear about the proxy in the framework 2 of NSIS. I don't know how the sender can communnicate with proxy ( protocol, interface, authorization...?) when sender is not a NSIS-aware . It is possible that the proxies is not on the first router connecting the sender to network ? 

Thanks,

Nary Tra,
ENST, Paris.
Tel: (0033) (0) 1 45 81 71 06

---

From: "Freytsis, Ilya" <[email-masked]>
Date: Sun, 11 May 2003 22:20:15 -0400

Hi, Nary.
 
There are two concepts of NSIS proxies discussed in the framework:
1.	So called "on path" proxies that are somewhat similar to the concept
of RSVP proxy (see
http://www.ietf.org/internet-drafts/draft-ietf-rsvp-proxy-03.txt
<http://www.ietf.org/internet-drafts/draft-ietf-rsvp-proxy-03.txt> )
2.	Proxies for signaling applications that require/use some off-path
processing facilities
 
It is important to note that in either case the communication between the
NSIS unaware hosts (1) or off-path application facility (2) and NSIS proxy
is outside of the NSIS itself. Probably it is reasonable to expect that the
first NE along data path where the flow enters the NSIS domain will act as
an NSIS proxy. This NE is not necessarily the first router connecting the
sender to the network though.
 
Best regards,
Ilya Freytsis
 
-----Original Message-----
From: Thanh Tra LUU [mailto:[email-masked]]
Sent: Friday, May 09, 2003 2:34 PM
To: [email-masked]
Subject: [NSIS] Proxies in NSIS
 
Hello everyone,
 
I have something not very clear about the proxy in the framework 2 of NSIS.
I don't know how the sender can communnicate with proxy ( protocol,
interface, authorization...?) when sender is not a NSIS-aware . It is
possible that the proxies is not on the first router connecting the sender
to network ? 
 
Thanks,

Nary Tra,
ENST, Paris.