Subject: RE: [NSIS] state management and the nsis framework

From: [email-masked]
Date: Tue, 13 May 2003 16:33:08 +0100

Hi

Yip, I see that point. But, might there not be other cases where this
near-functionality duplication or ability to infer information occurs?
Urgh...for example, at a guess something similar might happen when mobility
occurs and the NLTP and NSLP states might need to be moved. Efficiency gains
at this point might be much more significant. If so, then your argument will
then (correctly, but not helpfully) lead you to say that one protocol is
going to be more efficient than two

Louise

-----Original Message-----
From: Georgios Karagiannis [mailto:[email-masked]]
Sent: 13 May 2003 15:51
To: Farr,AL,Louise,XVR2 BURNESAL R
Cc: [email-masked]
Subject: Re: [NSIS] state management and the nsis framework

Hi Louise

One of the issues with the two layer split is that two types of states have
to be maintained:
NTLP states and NSLP states.
The NTLP states are associated with transport features, while the NSLP
states
are associated with signaling application features.

One way of providing soft state management is by specifying completely
independent soft state management procedures for the NTLP and NSLP layers.
This means that NTLP will have to use its own NTLP refresh messages and each
NSLP protocol
that is using the NTLP layer will also have to use its own refresh messages.
This will create an unnecessary load on the network.

The other way of providing soft state management is to only use the refresh
messages
belonging to one of the protocol levels (NTLP or NSLP). In this way the load
on the
network can be severely reduced.

Best regards,
Georgios

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, May 13, 2003 4:02 PM
Subject: RE: [NSIS] state management and the nsis framework

> Hi
>
> What is the actual benefit of mixing the two protocols like this?
Generally,
> its best to keep the interface and meaning between the two elements as
> simple as possible? Efficincy gains must be minimal? Is it guarenteed that
> beacuse the NTLP/ transport is still alive  the NSLP still is?
>
> Louise
>
> -----Original Message-----
> From: Georgios Karagiannis [mailto:[email-masked]]
> Sent: 13 May 2003 14:22
> To: Hancock, Robert
> Cc: [email-masked]
> Subject: Re: [NSIS] state management and the nsis framework
>
>
> Hi Robert
>
> [reh]
> > > in terms of what is being discussed below, could you clarify
> > > if you see
> > > any difference in overall NSIS functionality between our two
> > > descriptions
> > > (and what this difference is).
> > >
> > > if there is no overall difference, could you explain why you
> > > prefer your
> > > split of responsibility between NSLP/NTLP. what you propose
> > > seems to me
> > > to assume a closer customisation of NTLP functionality to
> > > support one specific
> > > signalling application that I feel we should be aiming for.
> >                          ^^^^
> > should be:              "than"
> >
>
> [GK]
> The main difference is the following:
> * In my proposed text, the NTLP is used to provide NTLP soft state
> management,
>    meaning that NTLP refresh messages are used. The NSLP is using this
> procedure
>    for NSLP soft state management. If a NTLP state is not refreshed, then
> the NSLP instance
>    is informed about it. Moreover, for inter-domain signaling no NSLP
> refresh
>    messages are needed. Please note that a NSLP might choose to not use
the
> NTLP soft
>    state management.
>
> * If  I understood you correctly, in your proposed text you are in favour
of
> using
>    the NSLP protocol to provide the NSLP and NTLP soft state manegement.
> Meaning that
>    each NSLP will have to use its own refresh messages for providing NSLP
> and NTLP soft state
>    management.
>
> In my opinion my proposed text is presenting a NTLP/NSLP soft state
> management concept that is not specific
> for one signaling application, but that is general and can be used for all
> types of signaling applications.
> Please note that this soft state management concept is similar to the soft
> state manegement concept presented
> in the Bob Braden's draft, see:
> http://www.ietf.org/internet-drafts/draft-braden-2level-signal-arch-01.txt
>
> However, please note that these two proposals could be combined. The NSLP
> that does not use the NTLP
> soft state management concpet could provide its own by using NSLP refresh
> messages.
>
> Best regards,
> Georgios
>
>
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
>

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Wed, 14 May 2003 09:59:11 +0200

Hi Louise

There might be situations that for a specific NSLP
this duplication could be required. Therefore, in one of my last e-mails I
mentioned that the
two proposals could be combined. The NSLP that does not use the NTLP
soft state management concpet could provide its own by using NSLP refresh
messages.

What I would also like to emphasize is that when a user is roaming and a
handover take place
then both  NTLP and NSLP states have to be transferred to the new path.

Best Regards,
Georgios